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AMX Design Suite
AMX Design Suite
Overview
AMX Design Suite is an integrated development environment (IDE) based on the Eclipse platform that supports the Driver Design 
plug-in from AMX. Use Driver Design to create XDD files (aka Device Drivers) that can be used with NetLinx control systems. 
AMX Design Suite also provides the ability to upload and download XDD's to/from AMX’s online InConcert Resource Center.

AMX Design Suite System Requirements
Supported Operating Systems: Windows 7/8 (32-bit and 64-bit)
NetLinx System Requirements: NetLinx Master Firmware version 4.1 or higher

Verifying Your AMX.COM Account Login Information
In order to access the AMX InConcert Resource Center, you must have valid login credentials (Username and Password) for 
www.amx.com. AMX Design Suite connects to the AMX InConcert Resource Center, to upload and download XDD's (aka Device 
Drivers).
To verify that you have valid login credentials, visit the Login Center page at www.amx.com (FIG. 1): 

Follow the on-screen instructions to either login or create a new account.

Installing AMX Design Suite
NOTE: In Windows 7, the installer must be run with full admin rights.

1. Launch the appropriate AMX Design Suite installer (AMX Design Suite 32bit Installer.exe or AMX Design Suite 64bit 
Installer.exe), based on the PC’s operating system. This launches the AMX Design Suite Setup Wizard (FIG. 2). Click Next to 
proceed. 

2. Click Next on the Conf igure Shortcuts and Select Installation Folder dialogs to configure the installation (FIG. 3): 

FIG. 1  www.amx.com - Login Center Page

FIG. 2  Welcome to the AMX Design Suite Setup Wizard dialog
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AMX Design Suite
3. In the Ready to Install dialog, click Install (FIG. 4): 

4. Progress is indicated in the Installing AMX Design Suite dialog (FIG. 5): 

5. When the installation is complete, the Completing the AMX Design Suite Setup Wizard dialog is displayed (FIG. 6):  

FIG. 3  AMX Design Suite Setup Wizard - Configure Shortcuts and Select Installation Folder dialogs

FIG. 4  AMX Design Suite Setup Wizard - Ready to Install dialog

FIG. 5  AMX Design Suite Setup Wizard - Ready to Install dialog
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AMX Design Suite
6. Click Finish to close the Installation Wizard.

Launching AMX Design Suite
Assuming the default settings were accepted in the Conf igure Shortcuts and Select Installation Folder Setup Wizard dialogs, AMX 
Design Suite can be launched via the Desktop Icon. 

NOTE: The AMX Design Suite application must be run with full admin rights.

1. The first time Design Suite is launched, it prompts for login credentials (FIG. 7). 

2. Enter your login in formation for www.amx.com, select Remember My Password, and click Save. This invokes the Secure 
Storage dialog (FIG. 8): 

3. Click Yes to proceed to the Password Recovery Setup dialog (FIG. 9): 

FIG. 6  AMX Design Suite Setup Wizard - Completing the AMX Design Suite Setup Wizard dialog

FIG. 7  AMX Design Suite Setup Wizard - AMX.com Login Information

FIG. 8  AMX Design Suite Setup Wizard - Secure Storage

FIG. 9  AMX Design Suite Setup Wizard - Password Recovery Setup dialog
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AMX Design Suite
Use the options in this dialog to configure a set of questions and answers for future password recovery.
4. Click OK to save changes and proceed to Driver Design perspective. The Driver Design perspective shows all the views and 

editors related to the Driver Design plug-in. FIG. 10 provides an example view of the Driver Design perspective: 

NOTE: Refer to the Driver Design Instruction Manual for directions on using Driver Design to create and export Device Driver (XDD) 
f iles.

Uninstalling AMX Design Suite and Driver Design
AMX Design Suite and Driver Design should be uninstalled via Windows Add/Remove Programs.

FIG. 10  Driver Design perspective (example view)
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Updating Driver Design
Updating Driver Design
Overview
Driver Design can be updated either via Automatic Update, or manually via the Help > Check for Updates option, as described 
below:

Updating Plug-ins via Automatic Update
The Automatic Update feature in AMX Design Suite automatically alerts you when new updates for installed plug-ins are available to 
install. The Updates Available popup window is shown in FIG. 11: 

By default, when this prompt appears the available updates have already been downloaded, and only need to be installed. The 
default actions for automatic updates can be changed via the Preferences dialog (see below).
1. Click inside the popup to review the available updates, in the Available Updates dialog (FIG. 12): 

By default, all available updates are selected for installation.

NOTE: Click on any update in the list to view a brief description of the update in the Details window.

2. Click Next to proceed to the Update Details dialog. This dialog indicates the updates that are selected for installation (FIG. 13). 

FIG. 11  Automatic Update popup

FIG. 12  Available Updates dialog
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Updating Driver Design
3. Review this list and click Next to proceed to the Review Licenses dialog (FIG. 14): 

4. Click I accept the terms of the license agreement to enable the Finish button.
5. Click Finish to install the selected updates.
6. The progress of the installation is indicated in the Updating Software dialog (FIG. 15): 

7. When the installation is complete, the program will prompt you to restart AMX Design Suite (FIG. 16): 

8. Click Restart Now to restart AMX Design Suite with the updated software installed.

FIG. 13  Update Details dialog

FIG. 14  Review Licenses dialog

FIG. 15  Updating Software dialog

FIG. 16  Software Updates dialog
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Updating Driver Design
Setting Automatic Updates Preferences
The options in the Automatic Updates page of the Preferences dialog allow you to specify how often to check for updates, as well as 
the default actions for updates (FIG. 17): 

The options in this dialog are described below: 

Updating Driver Design via "Check For Updates"
1. Select Help > Check For Updates.
2. In the Available Updates dialog, any available software updates are listed in the top window, indicating basic information 

(Name, Version and ID). 
Click on an item in the list to populate the Details window with more detailed information.
Click More to open the Properties dialog to view additional details including Copyright information and the AMX License 

Agreement information for the selected item.
3. Check the updates that you wish to install in the list of available updates.
4. Click Next to proceed to the Update Details dialog, to review and confirm the selected update(s).
5. Click Next to proceed to the Review Licenses dialog. Review and accept the license, and click Finish to begin installing 

update(s).
6. The program will prompt you to restart AMX Design Suite (select Restart Now).

NOTE: AMX Design Suite can be restarted at any time via the File > Restart option.

FIG. 17  Preferences dialog - Automatic Updates page

Preferences dialog - Automatic Updates options
Automatically find new
updates and notify me:

This option enables or disables the Automatic Update feature in AMX Design Suite. This is the default setting. If 
you de-select this option, software updates will not be indicated via the Updates Available popup window (see 
FIG. 11 on page 8)

Update Schedule: • Look for updates each time AMX Design Suite is started: This is the default setting.
• Look for updates on the following schedule: Click this option to schedule looking for software updates. When 

this option is selected, the drop-down menus for Day and Time are enabled. Use these options to specify 
when to check for updates.

Download Options: • Search for updates and notify me when they are available: Click this option to receive a notification when 
updates are available to download.

• Download new updates automatically and notify me when ready to install them: This is the default setting.

When Updates are 
Found:

• Notify me once about updates: Click this option to be notified only once when software updates are available.
• Remind me about updates every (4 hours): This is the default setting. To change the frequency of these 

checks, select from the Hours drop-down menu.

Directly Show Update 
Wizard:

With this option selected, when updates are found, the Automatic Update popup (see FIG. 11 on page 8) is 
bypassed, and the Available Updates dialog is launched automatically. By default, this option is not selected.
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Updating Driver Design
Viewing AMX Design Suite Installation Details
Click Help > About AMX Design Suite to open the About AMX Design Suite dialog, which provides copyright information for AMX 
Design Suite products (FIG. 18): 

Viewing Plug-In Installation Details
Click Installation Details to open the AMX Design Suite Installation Details dialog. This tabbed dialog provides detailed product 
information for all installed plug-ins:

Installed Software
This tab provides detailed information for each installed plug-in (FIG. 19). Select an entry in the list to enable the Update, Uninstall 
and Properties command buttons at the bottom if the window. 

The Update and Uninstall options in this tab are for advanced users only. See the Updating Plug-ins via Automatic 
Update section on page 8 for details.

Click Properties to open the Properties dialog which provides read-only Copyright Information, General Information and the 
License Agreement for reference.

FIG. 18  About AMX Design Suite dialog

FIG. 19  AMX Design Suite Installation Details dialog - Installed Software tab

Click to open the AMX Design Suite Installation Details dialog
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Updating Driver Design
Installation History
The Previous Conf igurations tab lists the current configuration, and all previous configurations (FIG. 20). Select a previous 
configuration to populate the Conf iguration Contents window with details on the selection. 

When you select a previous configuration, the Delete and Revert buttons are enabled. 
Click Revert to revert to the selected configuration.
Click Delete to delete to the selected configuration.

Features
The Features tab provides detailed information on all installed features (FIG. 21). Select a feature in the top window to view 
copyright and build details in the lower window. 

When you select a feature, the License, Plug-in and Revert buttons are enabled. 
Click License to view the End-User License Agreement associated with the selected feature.
Click Plug-in Details to view details on the plug-ins associated with the selected feature.
Click Columns to open the Conf igure Columns dialog. This dialog allows you to specify which columns to display in the plug-

ins tab, and set the width for each column.

FIG. 20  AMX Design Suite Installation Details dialog - Installation History tab

FIG. 21  AMX Design Suite Installation Details dialog - Features tab
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Updating Driver Design
The Plug-ins tab provides detailed information on all installed plug-ins (FIG. 22). Select an entry in the list to enable the Legal Info, 
Show Signing Info and Columns command buttons at the bottom if the window. 

Click Legal Info to open a window providing copyright/legal information for the selected plug-in.
Click Show Signing Info to open a window proving date information and details on the selection's Signing Certificate. Click 

Hide Signing Info to close this window.
Click Columns to open the Conf igure Columns dialog. This dialog allows you to specify which columns to display in the plug-

ins tab, and set the width for each column.

Conf iguration
The Conf iguration tab provides a report containing various pieces of information about your installation, including plug-in versions, 
preference settings, and the contents of the internal log file. Use this tab to browse detailed information about the current 
installation and capture that information when reporting a problem with your setup (FIG. 23): 

Click View Error Log to open the Error Log in your default browser. The Error Log view captures all the warnings and errors 
logged by plug-ins. The underlying log file is a .log file stored in the ".metadata" subdirectory of the workspace.

Click Copy To Clipboard to copy the configuration report to clipboard memory. You may then paste this information into a 
file and attach it to a problem report.

Click Close to close the AMX Design Suite Product Installation Details dialog.

FIG. 22  AMX Design Suite Installation Details dialog - Plug-ins tab

FIG. 23  AMX Design Suite Installation Details dialog - Configuration tab
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