
Operation/Reference Guide

Development Tools

VisualArchitect
NSS-VA (v1.4.3 or higher)

Last  Revised:  8/20/2014



AMX Software License and Warranty Agreement
• LICENSE GRANT. AMX grants to Licensee the non-exclusive right to use the AMX Software in the manner described in this 

License. The AMX Software is licensed, not sold. This license does not grant Licensee the right to create derivative works of the 
AMX Software. The AMX Software consists of generally available programming and development software, product documenta-
tion, sample applications, tools and utilities, and miscellaneous technical information. Please refer to the README.TXT file on 
the compact disc or download for further information regarding the components of the AMX Software. The AMX Software is sub-
ject to restrictions on distribution described in this License Agreement. AMX Dealer, Distributor, VIP or other AMX authorized 
entity shall not, and shall not permit any other person to, disclose, display, loan, publish, transfer (whether by sale, assignment, 
exchange, gift, operation of law or otherwise), license, sublicense, copy, or otherwise disseminate the AMX Software. Licensee 
may not reverse engineer, decompile, or disassemble the AMX Software. 

• ACKNOWLEDGEMENT. You hereby acknowledge that you are an authorized AMX dealer, distributor, VIP or other AMX autho-
rized entity in good standing and have the right to enter into and be bound by the terms of this Agreement.

• INTELLECTUAL PROPERTY. The AMX Software is owned by AMX and is protected by United States copyright laws, patent 
laws, international treaty provisions, and/or state of Texas trade secret laws. Licensee may make copies of the AMX Software 
solely for backup or archival purposes. Licensee may not copy the written materials accompanying the AMX Software. 

• TERMINATION. AMX RESERVES THE RIGHT, IN ITS SOLE DISCRETION, TO TERMINATE THIS LICENSE FOR ANY REA-
SON UPON WRITTEN NOTICE TO LICENSEE. In the event that AMX terminates this License, the Licensee shall return or 
destroy all originals and copies of the AMX Software to AMX and certify in writing that all originals and copies have been 
returned or destroyed. 

• PRE-RELEASE CODE. Portions of the AMX Software may, from time to time, as identified in the AMX Software, include PRE-
RELEASE CODE and such code may not be at the level of performance, compatibility and functionality of the GA code. The 
PRE-RELEASE CODE may not operate correctly and may be substantially modified prior to final release or certain features may 
not be generally released. AMX is not obligated to make or support any PRE-RELEASE CODE. ALL PRE-RELEASE CODE IS 
PROVIDED "AS IS" WITH NO WARRANTIES.

• LIMITED WARRANTY. AMX warrants that the AMX Software (other than pre-release code) will perform substantially in accor-
dance with the accompanying written materials for a period of ninety (90) days from the date of receipt. AMX DISCLAIMS ALL 
OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH REGARD TO THE AMX SOFTWARE. THIS LIM-
ITED WARRANTY GIVES LICENSEE SPECIFIC LEGAL RIGHTS. Any supplements or updates to the AMX SOFTWARE, 
including without limitation, any (if any) service packs or hot fixes provided to Licensee after the expiration of the ninety (90) day 
Limited Warranty period are not covered by any warranty or condition, express, implied or statutory.

• LICENSEE REMEDIES. AMX's entire liability and Licensee's exclusive remedy shall be repair or replacement of the AMX Soft-
ware that does not meet AMX's Limited Warranty and which is returned to AMX in accordance with AMX's current return policy. 
This Limited Warranty is void if failure of the AMX Software has resulted from accident, abuse, or misapplication. Any replace-
ment AMX Software will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. 
Outside the United States, these remedies may not available. NO LIABILITY FOR CONSEQUENTIAL DAMAGES. IN NO 
EVENT SHALL AMX BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES 
FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER 
PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THIS AMX SOFTWARE, EVEN IF AMX HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/COUNTRIES DO NOT ALLOW 
THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITA-
TION MAY NOT APPLY TO LICENSEE.

• U.S. GOVERNMENT RESTRICTED RIGHTS. The AMX Software is provided with RESTRICTED RIGHTS. Use, duplication, or 
disclosure by the Government is subject to restrictions as set forth in subparagraph ©(1)(ii) of The Rights in Technical Data and 
Computer Software clause at DFARS 252.227-7013 or subparagraphs ©(1) and (2) of the Commercial Computer Software 
Restricted Rights at 48 CFR 52.227-19, as applicable.

• SOFTWARE AND OTHER MATERIALS FROM AMX.COM MAY BE SUBJECT TO EXPORT CONTROL. The United States 
Export Control laws prohibit the export of certain technical data and software to certain territories. No software from this Site may 
be downloaded or exported (i) into (or to a national or resident of) Cuba, Iraq, Libya, North Korea, Iran, Syria, or any other coun-
try to which the United States has embargoed goods; or (ii) anyone on the United States Treasury Department's list of Specially 
Designated Nationals or the U.S. Commerce Department's Table of Deny Orders. AMX does not authorize the downloading or 
exporting of any software or technical data from this site to any jurisdiction prohibited by the United States Export Laws.

This Agreement replaces and supersedes all previous AMX Software License Agreements and is governed by the laws of 
the State of Texas, and all disputes will be resolved in the courts in Collin County, Texas, USA. For any questions concern-
ing this Agreement, or to contact AMX for any reason, please write: AMX License and Warranty Department, 3000 Research 
Drive, Richardson, TX 75082.
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VisualArchitect (NSS-VA)
VisualArchitect (NSS-VA) 

Overview (v1.4 or higher)
VisualArchitect (VA) is a comprehensive system design platform that increases the productivity and efficiency 
of your organization. VisualArchitect simplifies generation of all the programming, touch panel files, IR codes 
and system documentation for an integrated control system.

This software is free to Authorized AMX Dealers and Independent Programmers and is available through your 
AMX sales representative (FG3002-21).

For experienced NetLinx® programmers and system designers, VA can serve as a powerful tool, greatly 
reducing the amount of time required to design and complete single-master NetLinx systems. The UI Template 
support in VA makes it easy to create attractive Touch Panel page designs, and the CodeBuilder feature helps 
to define macros with ease and speed.

More information on VisualArchitect can be found at www.amx.com/va. Here you will find the Quick Start 
Demo, Frequently Asked Questions including instructional video clips, training course list and the 
VisualArchitect Forum.

Also, take a few moments to familiarize yourself with the elements of the VA Workspace, and the elements of 
the help file. When you're ready to begin, select an option under Start a New Project, on the Welcome To 
VisualArchitect window: 

Basic System Assistant

System Design Library

New Empty System

Refer to the Creating a New VA Project section on page 21for details.

FIG. 1  New Project options (Welcome To VisualArchitect window)
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VisualArchitect (NSS-VA)
Supported Windows Platforms and PC Requirements
Supported Operating Systems

Windows XP® Professional (service pack 2 or greater)

Windows Vista® Home Basic

Supported System Languages
English (US)

French

Spanish

German

Russian

PC Requirements/Recommendations
1.00 GHz Processor (minimum requirement); 1.5GHz or faster recommended.

20 GB of free disk space (minimum requirement)

1 GB of RAM (minimum - SQL Server 2005 Express Edition requires 512MB)

Minimum (VGA) screen resolution of 800x600.

Windows-compatible mouse (or other pointing device).

You must have Power User (or Administrator) rights to install and run all required 
System files.

If the mouse wheel on your Microsoft® IntelliMouse® doesn't work with VA, try 
downloading the latest IntelliMouse drivers from Microsoft.
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Getting Started

Overview
The basic steps involved in creating a new system in VA are:

1. Creating a New VA Project/System.

Use the Basic System Assistant option to use a wizard-type approach to defining the Central 
Controller, Touch Panel, Keypads and Remotes as a starting point to creating a new project/system.

Refer to the Using The Basic System Assistant Option section on page 22 for details.

Use a System Design Library file as a starting point to creating a new project/system. System 
Design Library (.VAP) files provide several templates for pre-configured systems of various types 
(e.g. Auditoriums, Conference Rooms, Boardrooms etc.), to use as is or as a short-cut to designing 
several common types of control systems.

Refer to the Using the System Design Library Option section on page 24 for details.

Use the New Empty System option to start with a blank slate.

Refer to the Using the New Empty System Option section on page 26 for details.

2. Adding Devices to the System, and establishing device connections. Refer to the Adding Devices To The 
System Diagram section on page 100.

3. Setting Device Properties. Refer to the Device Properties section on page 68.

4. Defining Control Strings and Device Macros as necessary. Refer to the Creating Device Macros (Using 
CodeBuilder) section on page 175.

5. Define the User Interface for UI devices

Touch Panels (see the Defining the UI - Touch Panels section on page 144)

Keypads (see the Defining the UI - Keypads section on page 159)

Remote Controllers (see the Defining the UI - Remote Controllers section on page 169)

6. Saving the Project (see Saving VA Project Files  on page 28).

7. Finishing the Project

Generating And Transferring System Files - see Generating And Transferring System Files  on 
page 199.

Generating the System Report - see System Report  on page 202.

Exporting Diagram Images - see Exporting Diagram Images  on page 206.

Printing The Diagrams - see Printing The Diagrams  on page 207.

You can also start a new system design with a Central Controller selection. With no 
project open, right-click on the Central Controller that you want to use in the Central 
Controllers tab of the Toolbox, and select New System Using: from the context menu. 
This action starts a new empty system, with the selected Controller in place.
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Welcome Screen
When you launch VisualArchitect, the Welcome screen is displayed (FIG. 2): 

The Welcome screen is divided into three main sections (Start a New Project, Open a Recent Project, and 
Managers), each containing a set of shortcuts:

Welcome Screen - Start a New Project
This section contains shortcuts relating to creating a new VA project (FIG. 3): 

Basic System Assistant: Click to access the Basic System Assistant dialog. Use the Basic System 
Assistant to quickly specify a Central Controller, Touch Panel, up to two Keypads, and / or a 
remote. This option is the same as selecting File > New > Basic System Assistant.

Refer to the Using The Basic System Assistant Option section on page 22 for details.

System Design Library: System Design Library files (SDLs) represent pre-configured VA Project/
Systems designed to accommodate various installation types. SDLs are available for Dealers to 
download from www.amx.com (in the Markets section). Select a SDL that most closely meets the 
needs of your customer, keeping in mind that you will have the ability to customize the solution 
later by adding different devices and options. This option is the same as selecting File > New > 
System Design Library.

Refer to the Using the System Design Library Option section on page 24 for details.

New Empty System: Click to open a new System tab, with a NI-3100 Central Controller. This is 
the default Central Controller for new VA projects, and it can be switched to a different Central 
Controller at any time. This option is the same as selecting File > New > New Empty System (or 
the New Empty System button on the Standard Toolbar).

Refer to the Using the New Empty System Option section on page 26 for details.

FIG. 2  Welcome Screen

The Welcome screen is also displayed any time there is not a Project open.

FIG. 3  Welcome Screen - Start a New Project Options
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Welcome Screen - Open a Recent Project 
This section contains a list of recently opened VA Projects, for quick access (FIG. 4). 

Click on any project in the list to open it.

Welcome Screen - Browse for a Project
Click to launch the Open VisualArchitect Project dialog, where you can locate and select projects that are not 
listed in the recent projects list (FIG. 5). 

Welcome Screen - Managers
This section of the Welcome Screen contains shortcuts to the two managers used by VA (FIG. 6): 

Device Database Search Paths Manager: Click to access the Device Database Search Paths 
Manager dialog, where you can specify the location of folders containing new/additional devices.

The Device Database is a collection of Cafe Duet module files (.JAR), and IR files with their 
metadata (.IRL/,XMD). Each JAR and IRL/XMD file represents one or more controlled devices 
that can be added to the project as third-party devices, via the Devices tab of the Toolbox.

The Device Database is located in the VASupportFiles folder (Program Files / Common Files / 
AMXShare / VASupportFiles), the folders added to the Device Database Search Paths Manager tell 
VA which folders to include when building or updating the database. These paths will contain 
JARs, CSDs, and/or IRL/XMDs.

If you add new JAR or IRL/XMD files to the Device Database, you'll have to update the database 
via the Re-Scan Device Database Search Paths option in the Managers menu.

You can also start with the Central Controller selection - right click on any Central 
Controller in the Toolbox, and select New System Using: from the context menu.

FIG. 4  Welcome Screen - Open a Recent Project

FIG. 5  Welcome Screen - Open a Recent Project > Browse for a project

FIG. 6  Welcome Screen - Managers
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Refer to the Device Database section on page 29 for details.

User Interface Template Manager: Click to access the User Interface Template Manager dialog, 
where you can preview, load and install ready-made UI templates that can be applied to Panels in 
your project.

Refer to the UI Templates section on page 147 for details.
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The VisualArchitect Workspace

Overview
Take a few moments to familiarize yourself with the elements of the VA Workspace (FIG. 7): 

Menu Bar
The VA Menu Bar (FIG. 8) provides access to the following menus: 

File Menu

Edit Menu

System Menu

Device Menu

Touch Panel Menu

Keypad Menu

Managers Menu

View Menu

Window Menu

Help Menu

FIG. 7  The VisualArchitect Workspace

FIG. 8  Menu Bar

Menu Bar
Standard

System Tree
Properties Window

Diagram Area (System Diagram shown)Toolbar

Toolbox (devices shown)
Status Bar
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Toolbars
There are several Toolbars available in the VA Workspace, each one providing shortcuts to a different set of 
functions (FIG. 9): 

Standard Toolbar - Displayed by default

Touch Panel Toolbar - Displayed when a Panel UI tab is selected,

Keypad Toolbar - Displayed when you select a UI tab for a Keypad.

Remote Toolbar - Displayed when you select a UI tab for a R-1, R-2 or R-3 Remote.

System Tree
FIG. 10 shows the System Tree window, as it appears with the System Diagram active: 

The System Tree indicates the devices that are currently in your system, separated into two categories:

Control Equipment - This represents AMX equipment, including Central Controllers, Expansion, 
Networking, Touch Panels, Keypads, Remotes, Media devices, and Environment devices.

Devices - This represents third-party (non-AMX controlled) equipment.

Refer to the VisualArchitect online help system for detailed descriptions of all Menus, 
Toolbars and dialogs.

FIG. 9  Toolbars

Standard Toolbar

Touch Panel Toolbar

Keypad Toolbar

Remote Toolbar

Refer to the VisualArchitect online help system for detailed descriptions of all Menus, 
Toolbars and dialogs.

FIG. 10  System Tree - System Diagram active
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Beyond providing a visual summary of the devices in your system, the System Tree also provides shortcuts to 
many of the device-oriented functions of VA, via the System Tree shortcut menu. Right-click on any device in 
the System Tree to access this menu.

FIG. 11 shows the System Tree window, as it appears with a UI Diagram active: 

If you are in a UI diagram (UI tabs), the Controlled third-party device list has an additional feature:

Clear the check box next to any controlled device in the list to remove its element from the UI diagram. This 
does not remove the device from the system, it only removes it from the diagram. Reapply the check mark to 
return the device to the UI diagram.

Device Classes / Device Controllers
VA represents its Device Database in the System Tree on a class-by-class basis, based on the Duet module they 
share.

As devices that are controlled by a single Duet controller module (or device controller), and not individual 
modules per device, are added to a system, VA collects them under a common logical device controller 
(FIG. 12). 

For CodeBuilder, the device controller is the only device visible for programming purposes. The events 
available for programming in CodeBuilder are the events for the device controller, and the functions and status 

FIG. 11  System Tree - UI Diagram active

Device Controllers include the Lighting System device class.

FIG. 12  System Tree - Lighting System Device Controller
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items available for use in programming are only those from the controller. Individual controlled devices are 
not listed on the right-side of Code Builder.

In the generated NetLinx code, only the controller device is assigned a virtual address and given a 
DEFINE_MODULE statement (the second parameter to the module definition-physical address-will be 
ignored by the module).

The physical addresses of the controlled devices are passed to the controller module via PROPERTY 
commands in the module's ONLINE handler.

System Tree Context Menu
The System Tree context menu provides shortcuts to many of the device-oriented functions of VA.

Properties Window
Beneath the System Tree is the Properties window (FIG. 13): 

The Properties Window provides detailed information for any selected device or navigation element.

The Properties Window is context sensitive:

When a Device Element is selected in the System Diagram, it provides detailed information for that 
device.

When a Navigation Element is selected in a Panel UI diagram, it provides information relative to 
the selected UI element.

Refer to the VisualArchitect online help system for detailed descriptions of all Menus, 
Toolbars and dialogs.

FIG. 13  Properties Window

Device Element (NI-3100) selected Navigation Element (Nav 2) selected

Keypad Button selected Remote Button selected
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When a Keypad button is selected in a Keypad UI diagram, it provides information relative to the 
selected button.

When a Remote button is selected in a Remote UI diagram, it provides information relative to the 
selected button.

Diagram Area
The Diagram Area is the main area in the middle of the application window, where you will view 
representations of every device in your system, as well as all device connections and Navigation layouts for 
User-Interface devices (Touch Panels, Keypads and Remotes).

Note that the example in FIG. 14 indicates several tabs across the top of the Diagram Area window (showing 
the System tab): 

System Tab - The System tab displays the System Diagram which gives a visual representation of 
the devices in the system and their connections to each other and to the Central Controller. When 
you start a new system, the program automatically selects a NI-3100 NetLinx Central Controller. 
At this point, only the System tab is represented. Since every system must have a single NetLinx 
Central Controller, there will always be a single System tab.

Use the System tab to add and remove devices from the system, and establish connections between 
the devices.

UI Tab(s) - A separate UI tab is added for each User-Interface device added to the system. Use 
these tabs to design the navigation layout for each of the UI devices.

For each Touch Panel in the system, there is a Touch Panel UI tab, which displays the UI 
diagram for each panel.

For each Keypad in the system, there is a Keypad UI tab, which displays the Keypad Diagram 
for each keypad.

For each Remote in the System, there is a Remote UI tab, which displays the Remote Diagram 
for each remote.

The navigation that is established here will be reflected in the resulting Touch Panel, Keypad, and 
Remote templates generated by VA.

If a Keypad or Remote is selected in the System Diagram, the Properties window 
represents the device-level properties for that keypad or remote only, but if the 
Keypad's or Remote's UI tab is opened, the Properties window indicates button-level 
properties (in addition to device-level properties).

FIG. 14  Diagram Area (System tab shown)
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System Tab (System Diagram)
Click on the System tab in the Diagram Area to view the System Diagram - a layout of the entire system, 
including the NetLinx Central Controller, AMX devices and third-party (controlled) devices, as well as all 
device connections (FIG. 15): 

See the System Design section on page 99 for details.

Panel UI Diagrams
For every Touch Panel added to the system, a separate Panel UI tab is added to the Diagram Area. Each Panel 
UI tab consists of a Panel UI Diagram - the graphic representation of the elements in the GUI, and their 
navigation layout. This is where you can add and connect UI Elements to establish a flow from one area of the 
UI to another.

The selected UI Element’s properties are displayed in the Properties window.

An example of a simple Panel UI diagram is shown below (FIG. 16): 

FIG. 15  Example System Diagram

FIG. 16  Panel UI Diagram

Start Device Element
Mode Element

Navigation Elements
Feature Element

Sub-Feature Element

Device Elements
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Keypad UI Diagram
For every Keypad added to the system, a separate UI tab is added to the Diagram Area. Each UI tab consists of 
a Keypad UI Diagram - the graphic representation of the buttons on the keypad (FIG. 17): 

The button layout for each keypad is based on the type of keypad selected:

For Keypads that do not feature an LCD display, the UI consists of channel codes assigned to each 
button on the keypad that allow the end-user to select devices to control, and trigger various control 
functions on each device.

For Keypads that feature an LCD display, the UI also includes items displayed on the LCD display. 
These include the Mio Modero Elite SL, Elite DL and Attache.

Click on any button on the UI diagram to select it for editing, via the button properties in the Properties 
window.

Remote UI Diagrams - MIO R-1, R-2 and R-3 Remotes
For every MIO R-1, R-2 and R-3 remote added to the system, a separate UI tab is added to the Diagram Area. 
Each UI tab consists of a UI Diagram - the graphic representation of the buttons on the remote. The UI 
Diagram for these remotes is similar to Keypad UI diagrams - click on any button on the Remote UI diagram 
to select it for editing. The selected button's properties are displayed in the Properties window.

An example MIO R-1/R-2/R-3 UI diagram is shown below (FIG. 18): 

Note that when you select a UI tab for MIO R-1, R-2 and R-3 remotes, the Remote Toolbar is displayed.

Select Remote > Engraving Template Preview to open the Engraving Template Preview dialog. Use this 
dialog to preview the button engraving text as it has been specified in the properties for each button.

FIG. 17  Keypad UI Diagram (Show Button Numbers, Show Menu Actions, Show Button Names options enabled)

FIG. 18  MIO R-1, R-2 and R-3 UI Diagram

Button Number (Channel Code)

Engraved Text

Menu Action

Button Name
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Remote UI Diagrams - MIO R-4 Remotes
For every MIO R-4 Remote added to the system, a separate UI tab is added to the Diagram Area. Each UI tab 
consists of a UI Diagram - the graphic representation of the elements in the remote's Panel GUI, and their 
navigation layout. This is where you can add and connect UI Elements to establish a flow from one area of the 
UI to another. The UI Diagram for MIO R-4 remotes is similar to Touch Panel UI diagrams - click on any UI 
Element on the R-4 UI diagram to select it for editing. The selected UI Element's  properties are displayed in 
the Properties window.

An example MIO R-4 UI diagram is shown below (FIG. 19): 

Right-click on any UI element to access the UI Diagram context menu.

Use the Preview UI option to preview a selected element in a UI Diagram.

Note that each UI element in the UI Diagram represents a separate page on the panel. The figure 
below shows an example Device UI element for a DVD player (FIG. 20): 

Use the options in the Customize UI Pages dialog to add/remove buttons and edit button text on the 
panel pages.

Show/Hide/Snap To Grid
Show Grid (Ctrl +G) - By default, the Grid display on the on the System Diagram, and UI 

Diagrams is enabled. Select Show Grid from the System Diagram context menu, the UI Diagram 
context menu, the View Menu (or click the Toolbar button)  to toggle the grid display.

Snap To Grid (Ctrl +Shift + G) - When this option is enabled, device elements and connection 
lines automatically "snap" to the nearest line on the grid, for quick and easy visual alignment of 
elements. Use this feature to ensure a clean layout for your system and touch panel navigation 
layouts.

By default, the Grid display is enabled.

Select Show Grid from the System Diagram context menu, the UI Diagram context menu, the View 
Menu (or click the Toolbar button)  to toggle the snap to feature.

FIG. 19  MIO R-4 UI Diagram

FIG. 20  Example Device UI element for a DVD player (MIO R-4)
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Toolbox
The Toolbox in VA is dual-purpose:

If you are in the System tab of the Diagram Area, the Toolbox provides thumbnail images of the 
devices that you can add to your system. In this scenario, use the Toolbox to select AMX hardware 
and third-party (controlled) devices to add to the system. Controlled devices are represented in the 
Devices tab.

If you are in a UI tab of the Diagram Area, the toolbox provides access to all elements available 
within the template selected for this Touch Panel. In this scenario, use the Toolbox to select UI 
elements to incorporate in your panel navigation layout.

Toolbox - System Devices
When you are in the System tab of the Diagram Area, the Toolbox provides thumbnail images of the devices 
that you can add to your system (FIG. 21): 

In this scenario, use the Toolbox to select AMX hardware and third-party devices to add to the system.

Click on the tabs to view the different categories of devices. AMX Device categories include: Central 
Controllers, Expansion devices, Networking devices, Touch Panels, Keypads / Remotes, Media, Environment 
and Communications devices.

To add a device to the system, simply click and drag it into the System tab of the Diagram Area.

Select View > Toolbox to access the Toolbox sub-menu, where you can select to hide and show the 
AMX hardware and third-party device types that can be added to the system.

Right-click on any device thumbnail to access the Toolbox System Devices context menu. By 
default, all available device types are shown. De-select any item in the Toolbox sub-menu to 
prevent that device type from being displayed in the Toolbox.

FIG. 21  Toolbox - System Devices

The "Devices" category represents third-party (non-AMX) controlled devices in the 
system. To view a listing of third-party devices that can be added to the system, click 
on the Devices tab.
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There are many devices indicated in the database when VA is installed, and there are many more that can be 
downloaded from the InConcert Resource Center (on www.amx.com) and added to the database.

Device Groups
To  manage large numbers of devices in certain categories, the Toolbox presents similar devices in groups that 
can be expanded and collapsed to reveal or hide their individual devices. A device group is represented by 
reduced thumbnails of devices in that group with a different background color, and a button to expand the 
group.  

The group may be expanded by either clicking on the expand button (<>), or by double clicking on the group 
thumbnail itself (FIG. 22). 

Once a group has been expanded, it will show the devices it contains as full-sized thumbnails (as they are 
currently represented).  To collapse a group, click either the collapse button on the first member of the group 
(>) or the collapse button on the last member of the group (<).

Availability Icons
The Toolbox uses icons to indicate the availability status of AMX products (FIG. 23): 

VA uses a device database to populate the list of module-supported devices 
(displayed in the Devices tab of the Toolbox). The device database is installed as part 
of the VA installation routine. However, the device database can be updated via the 
Re-Scan Device Database Search Paths option in the Managers menu. In order for a 
device to be available for inclusion in your projects, it must be represented in the 
device database.

FIG. 22  Device Group - Collapsed and Expanded Views

FIG. 23  Toolbox - Availability Icons

Indicates that the product has limited availability

indicates that the product is discontinued.
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Toolbox - UI Tabs
If you are in a UI tab of the Diagram Area, the toolbox provides access to all UI elements available within the 
Template selected for this device (FIG. 24): 

In this scenario, use the Toolbox to select UI elements to incorporate in your panel navigation layout.

You must select a template for the panel (via the Template option in the Device Properties window) 
to populate the tabs in the Toolbox with UI elements.

You must install at least one template (via the User Interface Template Manager dialog) to have a 
template available to apply to your panel(s).

To add a UI element from the Toolbox to a Navigation diagram, simply click and drag it into a 
Touch Panel UI tab of the Diagram Area.

Select View > Toolbox to access the Toolbox sub-menu, where you can select to hide and show the 
various types of UI elements that can be used in the UI diagram.

Right-click on any UI element to access the Toolbox User Interface context menu.

By default, all available elements are shown. De-select any item in the Toolbox sub-menu to prevent that 
element type from being displayed in the Toolbox.

FIG. 24  Toolbox - UI Tabs
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Toolbox - Devices Tab
The Devices tab of the Toolbox displays a listing of all third-party devices natively supported by VA (via a 
Duet Module (.JAR) file), categorized by type (FIG. 25): 

Click the plus sign next to any Device Type folder to display a listing of supported Manufacturers 
for that device type.

Click the plus sign next to any Brand folder to further expand the view to show the supported 
Devices for the selected Manufacturer and device type.

The options at the top of this tab allow you to filter the Devices list by Type and/or Brand:

Type: Select a Device Type from the drop-down menu to exclude all other device types from the 
list (default = All Types).

Brand: Select a brand (manufacturer) from the drop-down menu to exclude all other brands from 
the list (default = All Brands).

Show Device Discovery: Click to include Device Discovery-capable devices in the list.

Once you have located the desired device, you can click and drag it onto the System Diagram.

Toolbox Context Menus
Right-click on any device thumbnail in the Toolbox to access the Toolbox System Devices context 

menu.

Right-click on any third-party device thumbnail in the Toolbox (Devices tab) to access the Toolbox 
Third-Party System Devices context menu.

Right-click on any UI template element thumbnail in the Toolbox to access the Toolbox User 
Interface context menu.

FIG. 25  Toolbox - Devices Tab

If the device you want to add is not included in the Devices tab, you can use the 
Device Discovery (assuming the device supports Device Discovery) and/or the 
User-Defined Device (assuming that the "User-Defined Device" is a CSD or IRL/
XMD device) options to add it to your system.

Refer to the VisualArchitect online help system for detailed descriptions of all Menus, 
Toolbars and dialogs.
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Toolbox Sub-Menu
Click View > Toolbox to open the Toolbox sub-menu. Use this sub-menu to toggle display of the various 
elements displayed in the Toolbox (FIG. 26): 

Note that some of the options in the sub-menu are disabled, depending on what type of tab is currently active 
in the Diagram Area. For example, if this sub-menu is accessed while the System Diagram is active, then the 
Device elements are enabled, but the UI elements are disabled.

Conversely, if a UI tab is selected when the sub-menu was accessed, then only the UI elements are enabled, as 
shown above.

In either case, the Devices element is enabled.

By default, all Toolbox elements are displayed.

Status Bar
The Status Bar displays application status and Tooltips when the mouse moves over Toolbar buttons.

The icons on the right side indicate standard keyboard settings: Caps Lock (CAP), Num Lock 
(NUM) and Scroll Lock (SCRL).

The Status Bar display can be toggled via the Status Bar option in the View menu.

FIG. 26  Toolbox Sub-Menu
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Working With Projects

Creating a New VA Project
When you launch VA, you are presented with the Welcome Screen. At the top of the Welcome Screen are 
options for creating a new NetLinx control system (FIG. 27): 

Basic System Assistant - If you select this option, the program allows you to select a NetLinx 
Central Controller (default = NI-3100), an AMX Touch Panel, and up to two AMX Keypads (via 
the Basic System Assistant dialog). All other devices are added to the system by dragging them 
from the Toolbox into the System Diagram.

System Design Library -  If you select this option,  the program uses a System Design Library 
(SDL) template as a starting point to creating a new project/system. System Design Library (.VAP) 
files provide several templates for pre-configured systems of various types (e.g. Auditoriums, 
Conference Rooms, Boardrooms etc.), to use as is, or as a short-cut to designing several common 
types of control systems (see Using System Design Library Files).

New Empty System - If you select this option, the program automatically adds a NI-3100 NetLinx 
Central Controller. All other devices are added to the system by dragging them from the Toolbox 
into the System Diagram. You can change the Central Controller type later via the Edit > Replace 
option (see Replacing The Central Controller).

FIG. 27  Start a New Project Options

These options are also available via the File > New sub-menu.
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Using The Basic System Assistant Option
One of the main options presented on the Welcome Screen for starting a new project is the Basic System 
Assistant option (FIG. 28): 

The Basic System Assistant helps you get started designing a new system by allowing you to define several 
key pieces of equipment as a first step. You can always add, remove or replace devices later, but the Basic 
System Assistant can help you get started.

1. Select File > New > Basic System Assistant (or select Basic System Assistant in the Welcome Screen) to 
access the Basic System Assistant dialog (FIG. 29). 

Use the options in this dialog to enter general project information and specify a NetLinx Central 
Controller and User-Interface devices.

2. Fill in the Project Information (System name, Dealer, Designer and Comments). The only required input 
here is the System name.

3. Use the fields in the lower half of the dialog to select the system devices:

NetLinx Controller

Touch Panel

Resolution

Template

Keypads A, B

Remote 

FIG. 28  Basic System Assistant option

FIG. 29  Basic System Assistant dialog
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4. Click OK to close the Basic System Assistant dialog.

5. If VA detects that there are any support devices required for the devices selected so far (like a WAP or 
Ethernet Switch for example), you will be prompted to pick a device from the appropriate device 
category. Select a device from each Choose (Device Type) dialog that is presented, and click OK to 
proceed.

6. Once all required support devices have been selected, the System Diagram is displayed, indicating all of 
the devices you selected.

7. Assuming that you haven't disabled the Auto-Connect feature (via the Edit > Auto-Connect option), VA 
will automatically establish device connections for the devices in the system.

The new system (one NetLinx Central Controller and any selected user interface devices) will be represented 
in the diagram on the System tab.

Note that there is a separate User-Interface (UI) tab for each User-Interface device (Touch Panels, Keypads 
and Remotes) currently in the system. Use these tabs to define UI Navigation for each of these devices.

At this point, you can add more devices and accessories, set device properties, define macros and UIs to 
complete the project.

Every system must have one Central Controller and at least one User-Interface 
device (Touch Panel, Keypad or Remote).
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Using the System Design Library Option
One of the main options presented on the Welcome Screen for starting a new project is the System Design 
Library option (FIG. 30): 

System Design Library files (SDLs) represent pre-configured VA Project/Systems designed to accommodate 
various installation types. SDLs are available for Dealers to download from www.amx.com (in the Markets 
section).

Select an SDL that most closely meets the needs of your customer, keeping in mind that you will have the 
ability to customize the solution later by adding different devices and options.

When you download System Design Library (.VAP) files, they must be placed in the following directory to be 
utilized by VA (if you don't already have this directory, you'll need to create it):

C:\Program Files\AMX Control Disc\System Design Library
Once you have loaded at least one SDL in the System Design Library directory, you can select it via the 
System Design Library dialog.

1. Select System Design Library from the File > New sub-menu (or on the Welcome Screen) to open the 
System Design Library dialog (FIG. 31). 

2. Fill in the Project Information (System name, Dealer, Designer and Comments). The only required input 
here is the System name.

3. Select an SDL from the Template drop-down menu.

4. Click OK to close the System Design Library dialog.

At this point, you can add more devices and accessories, set device properties, define macros, and UIs to 
complete the project.

FIG. 30  System Design Library Option

FIG. 31  System Design Library dialog
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Downloading System Design Library (SDL) Files
System Design Library (SDL) files represent pre-configured VA Project/Systems designed to accommodate 
various installation types. SDLs are available for Dealers to download and install from www.amx.com (in the 
Markets section):

1. From the Help menu, select WebUpdate System Design Libraries (SDL). If VA finds any SDL files, the 
WebUpdate System Design Libraries dialog opens.

2. Select the files you want to download by clicking the corresponding check box for each item.

3. Click Download.

4. Read the License Agreement, select I Agree and click Next to proceed.

5. The program alerts you once the SDL installation is complete (FIG. 32): 

6. Click Finish to proceed. This action invokes the WebUpdate System Design Libraries Report dialog 
(FIG. 33): 

FIG. 32  System Design Library - Installation Complete

FIG. 33  WebUpdate System Design Libraries Report dialog
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Click Print to print the Download and Installation Report.

Click OK to close this dialog.

Once installed, the SDL is available for selection via the System Design Library dialog (FIG. 34): 

Using the New Empty System Option
One of the main options presented on the Welcome Screen for starting a new project is the New Empty System 
option (FIG. 35): 

Select New Empty System on the Welcome Screen to start a new system, with no devices other than the 
(default) NI-3100 NetLinx Central Controller. This option invokes the Choose Central Controller for new 
system dialog (FIG. 36). 

Alternatively, you can select Empty System from the File > New sub-menu, or click the Toolbar button.

FIG. 34  System Design Library dialog

FIG. 35  New Empty System Option

FIG. 36  Choose Central Controller for new system dialog
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If you start with the New Empty System option, you should visit the Project Properties dialog 
(System > Project Properties) to enter basic project information for this system. Note that the 
Project Properties dialog is only available once the project has been created (indicated by the 
display of the System Diagram).

Every system must have one Central Controller and at least one User-Interface device (Touch 
Panel, Keypad or Remote).

Opening VA Project Files
Select File > Open (or click the Toolbar button) to open an existing VA Project file (.VAP), via the Open 
VisualArchitect Project dialog (FIG. 37). 

Recent Projects can also be accesses via the Recent Projects section of the Welcome Screen (see FIG. 4 on 
page 5).

Setting Project Properties
Select System > Project Properties to open the Project Properties dialog, where you can view and edit basic 
project information for the active project (FIG. 38). 

The fields in this dialog include:

System Name - Enter the name that you want to associate with this system. This name will be 
reflected in the resulting project (.VAP) file, and any system reports and diagrams generated from 
this project (default = Untitled).

FIG. 37  Open VisualArchitect Project dialog

FIG. 38  Project Properties dialog
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This System Name is used as part of the filename for export diagram images, and as part of the 
Header/Footer text in printouts of diagram images.

Dealer - Enter the name of the dealer associated with this project.

Sales Order - Enter the sales number associated with this project

File Revision - Enter a file revision number.

Designer ID - Enter the name of the designer associated with this project.

Purchase Order - Enter the sales number associated with this project.

Comments - Enter any comments that might prove useful regarding this project.

If you started your project via the Basic System Assistant dialog, some of the fields in this dialog are pre-
populated with the project data you entered there.

If you started your project via the (New) Empty System option, all fields are empty.

Saving VA Project Files
VA Project files are saved as *.VAP files.

Select File > Save (or click the Toolbar button) to save the project under its current name. The first 
time you save the project, the Save VisualArchitect Project dialog prompts you to define a File 
Name and specify a target directory for the Project (.VAP) file.

Select File > Save As to save the Project under a different name.

Compiling VA Project Files
In VA, project files are "Generated" (or complied) via options in the Generate and Transfer System Files 
dialog. See the Generating And Transferring System Files section on page 199 for details.

The only required field in this dialog is System Name.
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Device Database

Overview
The Device Database is a collection of Duet device module (.JAR) files that provide support for controlled 
devices in VA. The Device Database is included as part of the VA installation, and provides VA support for 
many popular devices. For module-supported devices, the control information is already captured in the Duet 
module associated with each device. Therefore, you only need to define macros to apply to the functions 
supported by each device/module (via CodeBuilder).

VA uses the Device Database to populate the list of controlled devices displayed in the Devices tab of the 
Toolbox.  While the Device Database provides module support for many popular devices, at some point you 
may need to include devices not inherently included. 

Devices can be added to the Device Database either by downloading the Module (JAR) file from the InConcert 
Resource Center at www.amx.com, or by using tools included with VA to create the device files required by 
the Device Database:

IR Devices - In order for IR-controlled devices to be available for inclusion in your projects, each 
device must be represented in the Device Database with both an IR Library (.IRL) and an IR 
Metadata (.XMD) file. The options in the IR Capture and Management dialog allow you to capture 
and manage IR control codes (FIG. 39). 

By default, these .IRL and .XMD files are stored in the following location:
C:\Documents and Settings\All Users\Application Data\AMX\IR Files

VA requires v1.8 or higher Duet Module files to support controlled devices.

FIG. 39  IR Capture and Management dialog
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Serial and IP Devices - In order for Serial and IP Devices to be available for inclusion in your 
projects, each device must be represented in the Device Database with a Control Strings Definition 
(.CSD) file. The options in the Control Strings Definition dialog allow you to define control strings 
and create a new .CSD file, and add the .CSD file to the Device Database (FIG. 40): 

The Device Database can be updated via options in the Managers menu, via the Device Database Search Paths 
Manager dialog. Refer to the Re-Scanning the Device Database section on page 60 for details.

Adding IR Devices To The Device Database
There are two ways to approach adding an IR-controlled device to the Device Database:

Download a VA-compatible IRL file for the device from the InConcert Resource Center at 
www.amx.com, and save the IRL file to a directory included in the Search Paths for the Device 
Database (see the InConcert Resource Center section on page 53 for details). By default, these .IRL 
and .XMD files are stored in the following location:

C:\Documents and Settings\All Users\Application Data\AMX\IR Files

Use the IR Capture and Management dialog to capture IR functions from a device's remote 
controller (using an AMX IRIS IR Capture Unit), and save the resulting IR Library (.IRL) and 
metadata (.XMD) files to a directory included in the Search Paths for the Device Database (see the 
Capturing IR Codes section on page 34 for details).

Either way, in order for any new devices to be represented in the Devices tab of the Toolbox (so that they can 
be added to your System), the Device Database must be updated to include the new file(s), via the Device 
Database Search Paths Manager dialog (see Re-Scanning the Device Database  on page 60).

FIG. 40  Control Strings Definition dialog

Some InConcert IR Devices may not have an .XMD file associated with the .IRL file. 
In these cases, you will need to generate an .XMD file (see Creating XMD Files  on 
page 37).
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Adding InConcert IR Devices To The Device Database
IRL files for many popular IR-controlled devices are available for download on the InConcert Resource 
Center at www.amx.com (see the InConcert Resource Center section on page 53 for details):

1. Go the InConcert Resource Center at www.amx.com to search and download IRL files.

Some of the devices represented in the InConcert Resource Center provide a ZIP file for download that 
contains all of the system files required to control that device, including IRL and XMD files. XMD Files 
provide metadata for captured IR-functions and are designed to provide device information for the 
designer. While .XMD files are not required to control IR devices, they are required by VA.

Duet and IRL files on the InConcert web site have a checkmark in the VA column (in the Download 
section) to indicate that they are VA compatible.

See Searching For IR Library (.IRL) Files  on page 53

See Downloading IR Library (.IRL) Files  on page 55

2. Save the downloaded IRL file(s) to a local directory.

In order for a device to be available for inclusion in your projects, it must be represented in the 
device database with an IR Library (.IRL) and an IR Metadata (.XMD) file. Both files must be 
present in the Device Database in order for the device to be listed in the Devices tab of the Toolbox.

Some InConcert IR Devices may not have an XMD file associated with the IRL. In these cases, you 
will need to generate an XMD file (see Creating XMD Files  on page 37).

3. Re-scan the Device Database to include the new IRL and XMD files (see the Re-Scanning the Device 
Database section on page 60).

At this point, the device associated with the new IRL file should be represented in the Devices tab of the 
Toolbox, in the appropriate device type folder:

The new IRL file is added to the Device Type folder that matches the Device Type selection made 
in the IR Capture and Management dialog.

Within the appropriate Device Type folder, the new file is added to a folder matching the 
Manufacturer name entered in the IR Capture and Management dialog.

Manually Adding IR Devices To The Device Database
To manually add an IR-controlled device to the Device Database:

1. Select File > IR Capture and Management to open the IR Capture and Management dialog.

2. Enter the information for the Device that you are adding in the Device window (FIG. 41). The Device 
window contains a set of text fields that allow you enter information specific to the device for which you 
are capturing IR codes (all fields are required): 

Manufacturer: Enter the device manufacturer's name.

Model: Enter the device's model name and/or number.

Hand Control Model: Enter the model name and/or number of the remote controller associated 
with this device.

Device Type: Select the Device Type that best describes this device from the drop-down menu.

3. Select the IR Functions that you want to capture, in the Functions/Properties windows.

FIG. 41  IR Capture and Management dialog - Device window
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Click the Function tab to view the functions defined in the selected IR Template and select which ones to 
include in the capture operation (FIG. 42): 

4. Review and edit the IR properties as required for this device, in the Properties tab.

Click the Properties tab to view and edit device-level IR Properties for the selected device type. The IR 
properties listed here will vary depending on the device type selection, and represent the default settings 
for that device type (FIG. 43): 

5. Use the AMX IRIS IR Capture Unit to capture the selected IR Functions for the IR remote controller.

FIG. 42  IR Capture and Management dialog - Function tab

FIG. 43  IR Capture and Management dialog - Properties tab

Click to select an IR Property
to configure

Select a configuration
option for the selected
IR Property

Description of the selected
IR Property
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The IR Capture window guides you through the process of capturing IR Codes, using an AMX IRIS IR 
Capture Unit (FIG. 44): 

See the Capturing IR Codes section on page 34 for details.

6. Select File > Save (or click the Toolbar button) to save the new .IRL file to a local directory.

In order for a device to be available for inclusion in your projects, it must be represented in the 
device database with an IR Library (.IRL) and an IR Metadata (.XMD) file. Both files must be 
present in the Device Database in order for the device to be listed in the Devices tab of the Toolbox.

Some InConcert IR Devices may not have an XMD file associated with the IRL. In these cases, you 
will need to generate an XMD file (see Creating XMD Files).

7. Click OK to close the IR Capture and Management dialog.

8. Re-scan the Device Database to include the new IRL and XMD files (see Re-Scanning the Device 
Database  on page 60).

At this point, the device associated with the new IRL file should be represented in the Devices tab of the 
Toolbox, in the appropriate device type folder:

The new IRL file is added to the Device Type folder that matches the Device Type selection made in 
the IR Capture and Management dialog.

Within the appropriate Device Type folder, the new file is added to a folder matching the 
Manufacturer name entered in the IR Capture and Management dialog.

Adding InConcert Serial and IP Devices To The Device Database
JAR files for many popular Serial and IP-controlled devices are available for download on the InConcert 
Resource Center (at www.amx.com):

1. Go the InConcert Resource Center at www.amx.com to search and download JAR files. See Searching 
For Duet Module (.JAR) Files  on page 55 and Downloading Duet Module (.JAR) Files  on page 57.

Some of the devices represented in the InConcert Resource Center provide a ZIP file for download 
that contains all of the system files required to control that device, including JAR, APW, TP4 and 
Protocol reference files.

Duet and IRL files on the InConcert web site have a checkmark in the VA column (in the Download 
section) to indicate that they are VA compatible.

2. Save the downloaded .JAR file(s) to a local directory.

3. Re-scan the Device Database to include the new .JAR files (see Re-Scanning the Device Database  on 
page 60).

At this point, the device associated with the new .JAR file should be represented in the Devices tab of the 
Toolbox, in the appropriate device type folder.

FIG. 44  IR Capture and Management dialog - IR Capture window

Number of IR functions (after this one) still to be captured

Name of the IR function currently being captured

Click to cancel this IR capture operation
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Manually Adding Serial and IP Devices To The Device Database
Serial and IP Devices rely on Control String Definition (*.CSD) files for support in VA. CSD files are created 
in the Control Strings Definition dialog. See the Control Strings Definitions section on page 39 for details.

Capturing IR Codes
VA helps you to capture IR codes for any devices that you want to include in your system that are not already 
module-supported. All devices listed by name in the Devices tab of the Toolbox are module-supported. 
Module-supported devices have their basic IR codes captured within the module, so there is no need to capture 
their IR codes.

To capture IR Codes, you'll need:

The hand control (remote controller) that is associated with the device.

An AMX IRIS IR Capture Unit, connected to your PC. Refer to the IRIS Infrared Capture Unit 
Instruction Manual (available at www.amx.com) for details.

Use the options in the IR Capture and Management dialog to capture IR codes.

The basic steps in capturing IR Code include:

1. Enter device information (including the device type).

2. Select the IR functions you wish to capture, from a listing of all function supported by the device.

3. Set IR properties for this device.

4. Capture the IR codes from the device's hand controller.

5. Save the IRL file (File > Save) to a local directory.

6. Re-Scan the Device Database to include the new IRL and XMD files.

IR Capture - 1) Entering Device Information
The first step in capturing IR codes for an IR-controlled device is to enter the device information, and select an 
IR template to use, via the Device window of the IR Capture and Management dialog:

1. In the Device window, enter the Manufacturer, Model and Hand Control Model fields manually.

2. Select the Device Type that best describes the device that you want to control from the drop-down menu 
of supported device types. The Functions tab is populated with the functions supported by the IR 
Template associated with the selected Device Type.

The next step is to select the functions that you want to capture, from the list of all supported function for this 
template type (in the Functions tab).

Once you have captured a device's IR codes, they are added to the VA database as 
an IR Capture (.IRL) file, which will be available for other future projects.

When VA generates the IRL file, it also creates an XMD file to handle metadata for 
this device. The XMD file is copied to the same location as the IRL file, and both files 
must be present in the Device Database in order for this device to be represented in 
the Devices tab of the Toolbox.
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IR Capture - 2) Selecting Functions To Capture
Once you have entered the device information for the device/hand controller that you want to capture, you can 
select the specific functions to capture (from the full set of functions included in the selected IR Template) in 
the Functions window of the IR Capture and Management dialog (FIG. 45). 

1. Look at the remote controller that you will capture the IR codes from, and note the functions that are 
indicated on the remote, based on the buttons and labels that you see. In most cases, you will want to 
capture all of the functions that are represented on the hand controller.

While many hand controllers support most or all of the functions listed in the Main Functions directory in 
the Functions window, many hand controllers do not support the full set of Main Functions. Keep in mind 
that the Main Functions listed represent those included in the selected IR Template, and are intended to 
account for the Main Functions on a majority of hand controllers, but are not expected to apply fully to all 
hand controllers. In most cases, you will select some but not all functions in the template.

Click the check boxes to select the functions that you want to capture.

Use the top-level checkbox to toggle Select All/Select None.

2. Select File > Save (or click the Save IR File Toolbar button) to save your changes.

The next step is to specify IR Properties for this device.

IR Capture - 3) Setting IR Properties
Once you have selected a Device Type, you should review the IR Properties for this device type.

IR Properties are viewed and edited in the Properties tab of the Properties window (in the IR Capture and 
Management dialog):

The IR properties listed here will vary depending on the device type selection, and represent the default 
settings for that device type. In most cases, these default settings should suffice, but in some cases you may 
need to edit some IR properties. You should consult the hand controller's documentation for device 
specifications that may indicate changing some of the default IR properties. Although the IR properties vary 
for each device type, there are some that are common to all devices:

Module - The Device Class is a read-only field that indicates the Duet SDK class that this device 
type implements.

IR Settings - These basic IR properties are common to all IR devices: 

FIG. 45  IR Capture and Management dialog - Functions window

Click to select/deselect all IR Functions

Select any IR property to display a description of that property in the text field at the 
bottom of the Properties window.

IR Mode: Click the drop-down menu to select either SET MODE IR (the default setting) or SET MODE 
SERIAL.

IR Carrier 
String:

This option indicates whether or not to use IR Carrier signals. 

The default setting is True (do use IR Carriers). Carrier signals are sometimes used in IR-
transmissions to bookend signals, to add accuracy.

Pulse 
Interval:

This option defines the length of time between IR signals, measured in .10-second 
increments.

Pulse 
Time:

This option defines the length of time that the IR signal is emitted, also measured in 
.10-second increments.
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IR Capture - 4) Capturing IR Codes From The Hand Controller
Once you have entered the device information for the device/hand controller, selected the functions that you 
want to capture, and entered IR properties for this device, you are ready to start capturing the selected 
functions, using an AMX IRIS IR Capture Unit:

1. Select IR > Capture Selected from the menu bar (or click the Toolbar button). The dialog steps you 
through the process:

The dialog displays the first function that will be captured, and indicates how many functions 
remain after the current one.

Locate the button on the remote control that matches the indicated function.

2. Press the button on the remote control corresponding to the function indicated in the IR Capture and 
Management dialog (FIG. 46): 

a.  Point the emitter on the remote directly at the IR window on the IRIS (between the SIGNAL and 
READY LEDs on the front panel).

b.  Press and hold the button on the remote - the SIGNAL (red) LED on the IRIS should flicker to 
indicate that is receiving a signal.

c.  Don't release the button on the remote until the READY (green) turns off (approximately 3 seconds). 
When the READY LED turns off, the IRIS is ready to verify the signal (by repeating the button 
press).

d.  When the VERIFY (red) and READY (green) LEDs are lit, press and hold the button again. Again, 
hold the button until the READY LED turns off.

e.  Once the function has been captured and verified by the IRIS, the LED on the SEND button (also on 
the front panel of the IRIS) illuminates to indicate that the captured function is ready to send (to the 
PC).

f.  Press the SEND button to send the captured function to the PC (so it can be added to the IRL file for 
this device). The display on the IRIS reads "So", indicating that the function is being sent to the PC.

Before you begin, make sure that the IRIS is connected to the PC running VA and 
powered up.

FIG. 46  Capturing IR

Before you begin, verify that the IRIS is ready to use (the READY (green) LED on the 
IRIS is illuminated and the numeric LED indicates "01").

For best results, place the remote control's IR emitter as close as possible to the IR 
window on the IRIS.
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The IR Capture and Management dialog should now indicate that it is waiting for you to capture the next 
selected function (and that one less function remains to be captured).

Repeat steps a-f for the remaining functions, until all of the selected functions have been captured.

A green check icon in the Functions list indicates which functions have been captured successfully.

3. Once you have captured all of the selected functions, save your work: In the IR Capture and Management 
dialog, select File > Save. This creates an IR Capture File (.IRL) in the specified directory.

4. Re-scan the Device Database (see the Re-Scanning the Device Database section on page 60).

Troubleshooting - IR Capture
Problem:
The ER/E1 message appears in the LED display on the IRIS, and it doesn't seem to capture codes.

Possible Solutions:

Verify that the IRIS is connected to the COM port selected in the IR Capture Options dialog 
(default = COM1).

Verify that the communications settings on the IRIS are correct. VA requires the IRIS to use the 
following settings:

Bits Per Second = 9600

Data Bits = 8

Parity = None

Stop Bits = 1

Flow Control = None

Verify that the batteries in the remote control are fresh. If the remote has inadequate power, it may 
appear to capture some functions, but could result in various anomalies or the inability to capture 
some functions.

Try to minimize direct exposure of the IR window to strong light sources (especially fluorescent).

Minimize or eliminate other sources of IR emission in the area that could cause interference.

Creating XMD Files
In order for an IR-Controlled device to be listed in the Devices tab of the Toolbox (to be available for inclusion 
in your projects), it must be represented in the Device Database with both an IR Library (.IRL) and an IR 
Metadata (.XMD) file. Both files must be present in the Device Database in order for the device to be listed in 
the Devices tab of the Toolbox.

If you captured your own IR functions via the IR Capture and Management dialog, VA 
automatically generates the associated .XMD file.

If you are adding an existing IR device, you must first open and save the .IRL file (in the IR 
Capture and Management dialog) to generate the required .XMD file.

Some InConcert IR Devices may not have an .XMD file associated with the .IRL file. In these cases, you will 
need to generate an .XMD file by opening the .IRL file in the IR Capture and Management dialog and re-
saving the file:

1. Select File > IR Capture and Management to open the IR Capture and Management dialog.

2. Select File > Open to locate and select the .IRL file that you want to generate an .XMD file for.

3. Review the Device information and edit if necessary. This is the information that is represented in the 
.XMD metadata file.

4. Select File > Save to save the file. This action generates the required .XMD file.

5. Click Close to close the dialog.

6. Make sure that the .XMD file resides in the same directory as the .IRL file for this device, and that the 
directory that contains both files is represented in the Search Paths for the Device Database.

You can cancel the capture process at any time by clicking on the Cancel Capture 
button.
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7. Re-Scan the Device Database to include the .IRL and .XMD files (see Re-Scanning the Device Database  
on page 60).

VA IR Templates - Channel Layouts
Select Device Type in the IR Capture and Management dialog to view a listing of IR Templates provided by 
VA.Select a Device Type to view the IR Functions available in the IR Template for the selected Device Type in 
the Functions window (FIG. 47). 

IR slots 240-255 are reserved for Custom use in VA, to allow you to capture remote-specific 
functions into Custom 1 - Custom 16. You can then write custom code in Custom .AXI to use those 
IR functions.

Refer to the VisualArchitect online help for a comprehensive listing of the channel layout of each of 
VA's IR Templates.

FIG. 47  IR Capture and Management dialog - Device Type drop-down menu and Associated IR Functions list

Device Type drop-down menu
(DSS selected)

Functions window displaying
all IR functions available for
the selected Device Type
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Control Strings Definitions
VA uses Control Strings Definition (.CSD) files to support Serial and IP controlled devices.

In order for a Serial or IP controlled device to be added to the Device Database for inclusion in your projects, 
it must be represented by a .CSD file.

To add a new Serial or IP device to the Device Database, use the options in the Control Strings Definition 
dialog to define control strings and create a new .CSD file, and add the .CSD file to the device database.

Once you have created a .CSD file for a controlled device in your system, VA incorporates the control strings 
information into the source code when the system files are generated.

Creating a New CSD File
To manually add a Serial and IP-controlled device to the Device Database, so that it appears in the Devices tab 
of the Toolbox, you will define custom control strings for the device in the Control Strings Definition dialog 
(see FIG. 40 on page 30):

1. Select File > Control Strings Definition > New to open the Control Strings Definition dialog.

2. Enter device details in the Properties window (FIG. 48). 

a.  Select the device type from the Device Type drop-down menu (for example, DVD Player / Changer). 
Note that this selection populates the Functions window with a list of functions supported for the 
selected Device Type.

b.  Enter the name of the device's Manufacturer (in the Manufacturer field - required entry).

c.  Enter the model name/number of the device (in the Model field - required entry).

d.  Review the Packet Format and Connection properties, and edit as required: To change any of these 
properties to a setting other than the default, click inside the String Value column for any item to 
select from a drop-down menu of values supported for each property.

3. Double-click on any function in the Functions window to add it to the Control String Assignments 
window (FIG. 49).

Alternatively, you can select a function and click the Add Function command button or click the toolbar 
button.

The Control String Assignments window displays the Custom Control Definitions that have been created 
for this CSD file in a two-column table:

IR-controlled devices are supported by IR Library (*irl) files, which are outside of the 
scope of the Control Strings Definition dialog. See the Adding IR Devices To The 
Device Database section on page 30 for details.

FIG. 48  Control Strings Definition dialog - Properties window
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The Function column indicates the name of each function. Some functions support variable 
parameters, as indicated by a editable field within the Function column. In some cases this field 
accepts an integer (type directly into the text field. In other cases the field provides a drop-down 
menu of supported parameters to choose from.

The String Value column contains text fields that allow you to enter the control string assignments 
for each Function. Type the control string assignment  that you want to assign to each function in 
the Control Strings Assignments window, in the String Value column.  The format and specific data 
bits that need to be entered here depend on the device’s protocol specifications. Before you start, 
consult the device’s protocol specifications to determine what aspects of the control string are 
required.

Each function should only appear in the string assignment list once.  If a function has been duplicated in 
the Control String Assignments window, it is flagged with a red (!) icon (FIG. 50): 

To remove duplicate functions, select the function that you want to remove and select Edit > Delete 
Function (or click the toolbar button).

4. Click Save & Close to save your changes. The program will alert you if there is any required information 
missing.

In order to save a CSD file, the following information must be defined:

Every Control String Assignment must have a Control String defined (in the Value column of the 
Control String Assignments window).

Every CSD file must have a manufacture defined (in the Manufacturer field of the Properties 
window).

Every CSD file must have a device model defined (in the Model field of the Properties window).

5. Assuming all required information is present, the Save As dialog prompts you to specify a filename for 
this CSD file, and a target directory. Click Save to save the file, and close the Save As and Control Strings 
Definition dialogs.

6. Re-scan the Device Database (see the Re-Scanning the Device Database section on page 60).

Once a new Control Strings Definition (*.CSD) file has been created and saved, it must be added to the Device 
Database, in order to be available as a selection in the Devices tab of the Toolbox. To add a new CSD File to 
the Device Database, you must re-scan the Device Database to include the new CSD file. See the Adding a 
New CSD File to the Device Database section on page 43 for details.

FIG. 49  Control Strings Definition dialog - Functions and Control String Assignments windows

FIG. 50  Duplicate Function

The Device Database cannot be changed while a VA Project is open. Save and close 
your project before proceeding.
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Control String Assignments window
The Control String Assignments window displays the custom control definitions that have been created for the 
active CSD file in a two-column table:

The Function column indicates the name of each function. Some functions support variable parameters, as 
indicated by a editable field within the Function column. In some cases this field accepts an integer (type 
directly into the text field. In other cases the field provides a drop-down menu of supported parameters to 
choose from.

As an example, to define a control string assignment for the Stop command (which happens to be one of 
several other options present in the setDiscTransport function):

1. Add the setDiscTransport function to the Control String Assignments window.

2. Click the down arrow next to the Function to select from a drop-down list of supported functions within 
this control string:

The String Value column contains text fields that allow you to enter the control string assignments for each 
Function. Type the control string assignment  that you want to assign to each function in the Control Strings 
Assignments window, in the String Value column.  The format and specific data bits that need to be entered 
here depend on the device’s protocol specifications. Before you start, consult the device’s protocol 
specifications to determine what aspects of the control string are required.

To continue the example of the Stop command for a DVD Player / Changer, let us assume that according to the 
device’s protocol specifications, the DVD Player / Changer has the following requirements for control strings:

Header (STX (0x02) type) is required

Terminator (ETX (0x03) type) is required

No Checksum required

According to the protocol specifications provided by the device manufacturer, the player requires two data 
bytes to be sent: Device ID, xE7.

In our case, Device ID will be set to 0 (zero), but per the manufacturer’s specifications, the Device 
ID range is x50 - x5F. Therefore, a device ID of zero is entered as 50 ("x5F" = device ID of 15).

xE7 represents the STOP command (again, according to the device manufacturer’s protocol 
specifications).

So, to invoke the STOP command, we would expect to transmit the following control string:

\x02\ x50\xE7\x03

where:

x02 = Header

x50 = Device ID (equal to zero)

xE7 = STOP

x03 = Terminator

Since the Header, Terminator and Checksum (if used) information is specified in the Properties window, it is 
only necessary to enter the actual data bits of the control string in the String Value field.

In this example, the data bits include the Device ID (x50) and the command itself (xE7), therefore, the 
following string assignment is entered into the String Value field.:

\x50\ xE7

FIG. 51 shows the Control String Assignments window, indicating the data entered in this example: 

FIG. 51  Control String Assignments window
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Control Strings - Syntax Rules
The syntax rules for control string assignments in VA are as follows:

VA allows string assignments to contain non-printable ASCII characters in the form of escape 
sequences, to enter the equivalent decimal or hexadecimal ASCII code.

VA treats all control string text as if it was enclosed in single quotes. Do not include the single 
quotes in your text.

ASCII strings can have from 0 to 255 characters.

All characters used in the context of Control String Definitions are case-sensitive.

The backslash ( \ ) character is used to denote the start of an escape sequence, which must adhere to 
one of the supported formats: 

When generated into the appropriate SEND_STRING NetLinx construct, where these sequences represent an 
ASCII character outside of the range of 32/0x20 (‘ ‘ space) to 126/0x7E (‘~’ tilde), they are output as a 
NetLinx string expression. For example the string ‘ PLAY\n’ with no header, terminator, or checksum would 
be generated as: SEND_STRING “’PLAY”,$0A”.

If the escape sequence represents a character in the allowable range mentioned above, it will simply be 
converted to its equivalent character in the output string. For example, the string ‘PLA\x59’ with no header, 
terminator, or checksum would be generated as: SEND_STRING ‘PLAY’.

Device Classes / Device Controllers
VA represents its Device Database in the System Tree on a class-by-class basis, based on the Duet module they 
share.

As devices that are controlled by a single Duet controller module (or device controller), and not individual 
modules per device, are added to a system, VA collect them under a common logical device controller.

For CodeBuilder, the device controller is the only device visible for programming purposes. The events 
available for programming in CodeBuilder are the events for the device controller, and the functions and status 
items available for use in programming are only those from the controller. Individual controlled devices are 
not listed on the right-side of Code Builder.

In the generated NetLinx code, only the controller device is assigned a virtual address and given a 
DEFINE_MODULE statement (the second parameter to the module definition-physical address-will be 
ignored by the module). The physical addresses of the controlled devices are passed to the controller module

via PROPERTY commands in the module's ONLINE handler.

Opening Control Strings Definition (*.CSD) Files
To open existing Control Strings Definition (.CSD) files for viewing/editing:

1. Select File > Control String Definition to open the Control Strings Definition dialog.

2. Select File > Open (or click the toolbar button) to invoke the Open dialog.

3. Locate and select a *.CSD file, and click Open.

Escape Sequences - Supported Formats

• \n new line (ASCII 10/0x0A)

• \r carriage return (ASCII 13/0x0D)

• \t horizontal tab (ASCII 9/0x09)

• \v vertical tab (ASCII 11/0x0B)

• \\ backslash character (ASCII 92/0x5C)

• \ nnn ASCII decimal character, where nnn is from 0 to 255 (\0 to \255)

• \ xhh ASCII hexadecimal character, where hh is from 00 to FF (\x00 to \ xFF)

Device Controllers include the Lighting System device class.
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Adding a New CSD File to the Device Database
Once a new Control Strings Definition (*.CSD) file has been created and saved (via the Control Strings 
Definition dialog), it must be added to the Device Database, in order to be available as a selection in the 
Devices tab of the Toolbox.

To add a new CSD File to the Device Database, you must re-scan the Device Database to include the new file:

1. Select Managers > Re-Scan Device Database Search Paths to open the Device Database Search Paths 
Manager dialog.

2. In the Search Paths area, click the Add Search Path (Insert) button. This adds a new (empty) search path 
to the device database.

3. Click the Browse (...) button next to the new search path to open the Browse For Folder dialog. Select the 
directory that the new CSD file was saved to, and click OK.

4. Click Update to update the Device Database to include the new file (as well as any other device files 
saved in the same directory).

5. Once the database update is complete, click the Close button to exit the Device Database Search Paths 
Manager dialog.

At this point, the device associated with the new CSD should be represented in the Devices tab of the Toolbox, 
in the appropriate device type folder:

The new CSD file is added to the Device Type folder that matches the Device Type selection made 
in the Control Strings Definition dialog.

Within the appropriate Device Type folder, the new file is added to a folder matching the 
Manufacturer name entered in the Control Strings Definition dialog.

CSD Example 1: Case Requiring a Check Sum
Below is a command to send to a DVD Player, that uses an ASCII protocol along with a checksum. The 
example that follows assumes that the device has the following RS-232 specifications:

Transmission Speed: 9600 BPS

Character Length: 8 bit

Parity Bit: None

Stop Bit:1 bit

The following table shows the layout of the command, the only thing that needs to be obtained from the 
documentation is what method is being used to calculate the check sum. In this example, it is 2's complement 
(FIG. 52). 

The Device Database cannot be changed while a VA Project is open. Save and close 
your project before proceeding.

Once the Re-Scan, or Rebuild operation has been started, it cannot be cancelled. Do 
not forcibly exit the program while a device database operation is in progress.

FIG. 52  Example Command Layout
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Step 1: Specify the Device Type
In the Properties window of the Control Strings Definition dialog, specify the Device Type: select DVD 
Player/Changer from the drop-down menu (FIG. 53): 

Step 2: Enter the Manufacturer Name
Enter the Manufacturer name (FIG. 54): 

FIG. 53  Select Device Type

FIG. 54  Enter Manufacturer Name
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Step 3: Enter the Model Name
Enter the Model name (FIG. 55): 

Step 4: Specify the Packet Format
The Header (or "Start Byte") and Terminator (or "End Byte") are okay, so no changes are needed here. The 
Checksum should be changed to None since this protocol does not support it (FIG. 56): 

FIG. 55  Enter Model Name

FIG. 56  Specify the Packet Format
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Step 5: Terminator Before Checksum Setting
The Terminator Before Checksum may need to be changed based on your protocol. By default it is set to True, 
which would mean that our bytes would come in the wrong order. We are going to set this to False so that it 
will match the order displayed above (FIG. 57): 

Step 6: Enter the Command and Parameters
Now we can enter the command and it’s parameters. In this case we need add four spaces as well. This can be 
done using the space bar, or using an escape sequence to define the decimal or hexadecimal value for the 
space.

The escape sequence is the preferred method since it helps you see that you entered the correct number of 
space.

The code generated for this scenario would look like the following:

CHANNEL_EVENT[vdvDISC2, 0]

   {

   ON:

      {

         SWITCH (CHANNEL.CHANNEL)

            {

               // setDiscTransport (PLAY): Play

               CASE PLAY:

               {

                  SEND_STRING dvDISC2,"$02,' PLYFWD ',$AA,$03"

               }

            }

         }

      }

FIG. 58 shows a screen capture of the Control Strings Definition dialog for this example: 

FIG. 57  Terminator Before Checksum Setting
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FIG. 58  Control Strings Definition dialog - CSD Example 1
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CSD Example 2: Case Not Requiring a Check Sum
Below is a command to send to a Receiver, that uses an ASCII protocol. The example that follows assumes 
that the device has the following RS-232 specifications:

Transmission Speed: 4800 BPS

Start: 1 bit

Data: 8 bit

Parity: None

Stop: 1 bit

The following table shows the layout of the command (FIG. 59): 

Step 1: Specify the Device Type
Enter the Device Type in the field: select Receiver from the drop-down menu (FIG. 60): 

FIG. 59  Example Command Layout

FIG. 60  Select Device Type
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Step 2: Enter the Manufacturer Name
Enter the Manufacturer name (FIG. 61): 

Step 3: Enter the Model Name
Enter the Model name (FIG. 62): 

FIG. 61  Enter Manufacturer Name

FIG. 62  Enter Model Name
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Step 4: Specify the Packet Format
The Header (a.k.a. "Start Byte") and Terminator (a.k.a. "End Byte") are okay, so no changes are needed here. 
The Checksum needs to be changed to 2’s Complement (FIG. 63): 

Step 5: Specify the Serial Baud Rate
The Serial Baud Rate needs to be set to the correct value - 4800 (FIG. 64): 

FIG. 63  Specify the Packet Format

FIG. 64  Specify the Serial Baud Rate
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Step 6: Enter the Command and Parameters
Now we can enter the command and it’s parameters. The code generated for this scenario would look like the 
following:

CHANNEL_EVENT[vdvRECV1, 0]

   {

      ON:

      {

         SWITCH (CHANNEL.CHANNEL)

         {

            // setVolumeRamp (UP): Ramp volume up

            CASE VOL_UP:

               {

                  SEND_STRING dvRECV1,"$02,'VOLUP1',$03"

                   OFF[CHANNEL.DEVICE, CHANNEL.CHANNEL]

               }

         }

      }

   }

FIG. 65 shows a screen capture of the Control Strings Definition dialog for this example: 

FIG. 65  Control Strings Definition dialog - CSD Example 2
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Device Database - Default Search Paths
The default Search Paths (defined in the Device Database Search Paths Manager dialog) are as follows:

For Module (.JAR) Files:

C:\Documents and Settings\All Users\Application data\AMX\Duet\Module
For IR Library (.IRL) and IR Metadata (.XMD) Files:

C:\Documents and Settings\All Users\Application data\AMX\IR Files

Select Managers > Device Database Search Paths Manager to access this dialog (FIG. 66): 

Device Database - Adding a New Search Path

1. Click the Add Search Path (Insert) button. This adds a new (empty) line to the bottom of the Search 
Paths list.

2. Click the Browse button next to this line to open the Browse For Folder dialog (FIG. 67). 

3. Locate and select the directory that you want to include as a search path for the device database.

4. Click OK to close the Browse For Folder dialog and add the selected directory to the Search Paths list.

FIG. 66  Device Database Search Paths Manager dialog

FIG. 67  Device Database Search Paths Manager dialog - Adding a New Path

Add Search Path (Insert)
Remove Search Path (Delete)

Move Up
Move Down
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Removing a Search Path

1. Select the search path that you want to remove in the Search Paths list.

2. Click the Remove Search Path button.

Re-ordering the Search Paths
Select an item in the Search Paths list, and use the up/down arrow buttons to move it up and down in the list.

If you have made any changes to the search paths, the paths must be re-scanned to update the Device Database.

InConcert Resource Center
The InConcert Resource Center is available at www.amx.com for registered AMX Dealers.

Click the Partners link at the top of the www.amx.com website to access the AMX InConcert Partners page 
(FIG. 68): 

AMX InConcert Partners offer products that simplify integration with AMX control systems by streamlining 
system programming. Use the InConcert Resource Center to search for and download device modules.

Searching For IR Library (.IRL) Files
IR library (.IRL) files for many popular remote controls are available for download from the InConcert 
Resource Center at www.amx.com. All InConcert Resource Center search boxes use implied wildcards. For 
example, entering "son" in the R.C. Manufacturer search field will return "Sonance", "Sonic Blue", "Sonic 
Foundry" and "Sony".

1. Go to www.amx.com, and log in as a registered Dealer.

2. Click on the Partners Toolbar button, to access the Partners List, and the InConcert Resource Center.

3. Click on Search Remote Controls to access the Search Remote Controls page (FIG. 69): 

4. Enter as much information as you can into these fields and click Search.

5. The results of any search operation are displayed on the selected Search page (FIG. 70): 

FIG. 68  InConcert Resource Center

FIG. 69  InConcert Resource Center - Search Remote Controls page
53VisualArchitect Operation/Reference Guide 



Device Database
6. Click on the link for the desired device to open the Remote Control Information window (FIG. 71): 

7. Use this dialog to view device specifications and download associated files, including the IRL file.

FIG. 70  InConcert Resource Center - Search Results page

FIG. 71  InConcert Resource Center - Remote Control Information window
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Downloading IR Library (.IRL) Files
IR library (.IRL) files for many popular remote controls are available for download from the InConcert 
Resource Center at www.amx.com:

1. In the Remote Control Information window, select the Assoc. IR Files link (in the left sidebar) to access 
the Associated IRL Files window (FIG. 72): 

2. Click the Download icon to download the .IRL file. The system will prompt you to specify a target 
directory for the file. 

3. Finally, update the device database to include the new entries.

Searching For Duet Module (.JAR) Files
Duet Module (*JAR) files for many popular devices are available for download from the InConcert Resource 
Center at www.amx.com. All InConcert Resource Center search boxes use implied wildcards. For example, 
entering 'son' in the Manufacturer box will return Sonance, Sonic Blue, Sonic Foundry and Sony.

1. Go to www.amx.com, and log in as a registered Dealer.

2. Click on the Partners Toolbar button, to access the Partners List, and the InConcert Resource Center.

There are several search options available:

Search Devices: Click to display the Search Devices options (this is the default view).

Search New Releases: Click to access the Search New Releases page, where you can view listings 
of new and updated module file, separated by file type.

Search Remote Controls: Click to show the Search Remote Controls options.

Voting/Request: Click to display the Voting/Request options, where you can vote for device 
modules that you would like to see developed and released by AMX, or request that a specific 
device module be developed.

3. Click on Search Devices to access the Search Devices page (FIG. 73): 

FIG. 72  InConcert Resource Center - Associated IRL Files window

VA requires Duet Module v1.8 or higher module files to support third-party 
(controlled) devices.
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4. Click the Duet Modules check box to limit the search to Duet Modules.

5. Enter as much information as needed into the remaining fields, and click Search.

6. The results of any search operation are displayed on the selected Search page (FIG. 74): 

7. Click on the link for the desired device to open the Device Model Details dialog. Use this dialog to view 
device specifications and download associated files, including the Duet Module (*JAR) file (FIG. 75): 

FIG. 73  InConcert Resource Center - Search Devices page

FIG. 74  InConcert Resource Center - Search Results page
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Downloading Duet Module (.JAR) Files
Non-IR controlled (Ethernet, Modem, Serial and TCP/IP) devices can use Duet Module (.JAR) files for 
support in VA. Duet module files for many popular devices are available for download (as ZIP files) from the 
InConcert Resource Center at www.amx.com:

1. In the Device Model Details dialog, select Download, under Model Information on the left side of the 
dialog to access the Download page for the selected device (FIG. 76): 

2. Verify that there is a check-mark in the "VA" column, which indicates that the Duet module is VA 
compatible. If so then proceed to the next step.

3. Click on the file icon next to file name to save the ZIP file to your hard drive. The system will prompt you 
to specify a target directory for the file.

4. Click Save to save the selected (ZIP) file.

5. Once you have saved one or more modules to your local drive, unzip the files to access the set of device 
files that it contains. Typically the ZIP includes several files - see Module ZIP Files  on page 58.

FIG. 75  InConcert Resource Center - Device Model Details dialog

FIG. 76  InConcert Resource Center - Download page

Checkmarks indicate that these files 
are VA-Compatible
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6. Finally, update the device database to include the new entries: 

a.  Select Managers > Device Database Search Paths Manager.

b.  In the Search Paths window, verify that the folder(s) that you unzipped the new files to are 
represented in the list. If the new files are in a folder that is not listed, press the Add Search Path 
button, to add a new entry to the list, then click the Browse button (...) to select the folder that the 
files are in (in the Browse For folder dialog).

c.  Click OK to close the Browse For Folder dialog.

d.  Click OK in the Device Database Search Paths Manager dialog.

Module ZIP Files 

Module ZIP Files

• .JAR file: This is the "Module" file required by VA to support this device. In order for devices to be 
represented in the Devices tab of the Toolbox (for inclusion in your VA projects), the Module 
(.JAR) file associated with the device must be present in the Device Database.

•  .AXI file: " Include" files can be loaded and edited in NetLinx Studio like normal AXS program files. Like 
AXS program files, the name of the include file is stored on the first line of the file as a PRO-
GRAM_NAME declaration.

To include a file in a program, use the keyword INCLUDE, followed by the filename in single 
quotes.

When the compiler reaches the INCLUDE statement, it jumps into the specified file and 
continues compiling. When it has reached the end of that file, it comes back to the line following 
the INCLUDE statement and continues compiling.

DEFINE_PROGRAM

(* Program statements can go here *)

INCLUDE 'TEST.AXI'

(* More program statements can go here *)

This file must be transferred to the Central Controller.

•  .APW file: NetLinx Studio "Workspace" files contain of the files required for a control system (including 
Source Code (AXS) Files, Include (AXI) files, Module (AXS/TKO) Files, User Interface (TPD, 
TP4 or KPD) Files, IR Library (IRL) files, and Other (TXT, DOC, BMP etc.).

This file allows you to open and edit the system files in NetLinx Studio, and is not transferred to 
any system devices.

• .AXS file: This is the Master Source Code File (and possibly other source code files associated with the 
System).

This file must be transferred to the Central Controller.

•  .TP4 file: The TPDesign4 project file defines the Touch Panel UI (panel pages, buttons and navigation).

This file must be transferred to the Touch Panel.

•  .DOC file: This document file provides details about this module and describes its implementation.

This file is for information purposes only.
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Importing a Café Duet Module into VisualArchitect
In some projects, you may find it necessary to import a previously created Café Duet module (JAR file) into 
VA instead of creating a new one. These may include third-party modules or modules designed for another 
project.

To import a previously created Café Duet module into VA:

1. Copy your module JAR files to the appropriate directory. VA searches particular directories when 
building or updating its device database, so copying the JAR files to one of those directories is highly 
recommended. If you are not sure what the paths are, select Managers > Device Database Search Paths 
Manager - the default directories as well as any others that may have been added are indicated in the 
Device Database Search Paths Manager dialog (FIG. 77): 

2. If you add a new path or change one of the existing paths, VA will automatically search all the paths and 
rebuild the device database for you. If your jar files were in one of those directories, you can skip this 
step.

When Café Duet and VA are first installed on the same PC, they will both point to the same path by 
default. Café Duet's Module Export Directory and VisualArchitect's Device Database Search Path would 
be:

C:\Documents and Settings\All Users\Application data\AMX\Duet\module

3. Once the search paths have been scanned, you will find your device listed under the appropriate device 
heading in VA. It is now available for use in your VA project.

FIG. 77   Device Database Search Paths Manager dialog

Default Device Database Directories

Because not all users install Café Duet to the same computer, or because the output 
JAR files may go to a different directory, having the correct directory path is essential. 
If you are unable to find the correct module directory using the Device Database 
Search Paths Manager, you may have to perform a manual search for the directory 
containing your module JAR file and then copy the file directly to the correct directory.

For details on using the Café Duet Integrated Development Environment for NetLinx 
application, refer to the Café Duet Operation/Reference Guide and on-line help.
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Re-Scanning the Device Database
When you re-scan the Device Database, VA scans the search paths indicated in the Device Database Search 
Paths Manager dialog, looking for changes in the files including added (new) files, removed files and changed 
files.

Notes:

The Device Database cannot be changed while a VA Project is open. Save and close your project 
before proceeding.

Because of the large amount of data contained in the Device Database, Rescan and Rebuild 
operations typically take several minutes to complete.

Modules and IRL files stored on removable media such as CDs cannot be added to the Device 
Database. These files must be copied to the local drive in order to add these devices to the database.

To re-scan the Device Database:

1. Select Managers > Re-scan Device Database Search Paths.

2. The progress bar indicates the status of the re-scan operation. When the operation is complete, the status 
bar closes.

Rebuilding the Device Database
When you rebuild the Device Database, VA clears the current database, then re-populates from the search 
paths indicated in the Search Paths window of the Device Database Search Paths Manager dialog.

Notes:

You should only have to use the Rebuild option if you are experiencing problems with devices 
in VA.

The Device Database cannot be changed while a VA Project is open. Save and close your project 
before proceeding.

Because of the large amount of data contained in the Device Database, Rescan and Rebuild 
operations typically take several minutes to complete.

Modules and IRL files stored on removable media such as CDs cannot be added to the Device 
Database. These files must be copied to the local drive in order to add these devices to the database.

To rebuild the device database:

1. Select Managers > Rebuild Device Database.

2. The progress bar indicates the status of the rebuild operation. When the operation is complete, the status 
bar closes.

Once a Rescan or Rebuild operation has been started, it cannot be cancelled. Do not 
forcibly exit the program while a Device Database update operation is in progress.
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Adding MSRP Values for Controlled Devices
VA allows you to add MSRP values for third-party devices, by manually editing the "MSRP.CSV" file that VA 
uses to provide MSRP values for AMX equipment (FIG. 78): 

To add MSRP values for third-party devices:

1. Open the "MSRP.csv" file. This file resides in:

C:\Documents and Settings\All Users\Application Data\AMX\VisualArchitect\MSRP

Note that there are two CSV files in this directory: One named "MSRP.csv", and a second one named 
"AMX MSRP.CSV":

"MSRP.csv" is the file used by VA. This is the file that you should edit.

"AMX MSRP.csv" is a backup file. Do not edit this file - it is intended for use in the case that 
the MSRP.csv file is lost or corrupted in some way.

There are two ways to edit this file: via Microsoft Excel (or a similar spreadsheet editing program), or via 
Notepad (or a similar text editor).

MSRP.csv is simply a comma-delimited text file; follow the formatting that is apparent in the file when 
adding new devices/MSRP values.

2. Scroll down to the last entry and press Enter to add a carriage return. You can start adding new devices to 
the bottom of the list (after all of the AMX devices).

3. Enter the new devices one at a time, following the required formatting (if you open the file in Excel, the 
comma delimiters are represented as three columns - A, B and C):

FG Number,Dealer Part Number,MSRP
Be sure to type the device name exactly as it appears in the Properties window.

AMX devices use the first field for FG Numbers which may not apply to third-party devices. When 
adding third-party devices, use this field for the "Model Number" of the device.

The Dealer Part Number is optional. AMX Devices do not include a Dealer Part Number. 
Therefore, all AMX devices are represented in the MSRP.csv file with an empty middle field (for 
example: "FG012-03, ,$100"). However, you can use this field to add a custom part number to 
third-party devices.

Example: Toshiba 42H82,10-123,$1500

4. When you're done editing the file, be sure to save it to the same name, file extension and location.

5. Restart VA to see the MSRP (and Dealer Part Number, if one was included) in the Properties window for 
that device. Note that you must select the device in the System Diagram in order to view its properties 
(FIG. 79): 

FIG. 78  MSRP.CSV
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FIG. 79  Properties window - MSRP Value indicated
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Working With Devices

Supported Devices
VA provides native support for many devices, including AMX devices as well as third-party devices.

Supported devices are indicated in the Toolbox: with the System Diagram selected, the Toolbox provides 
several tabs for the various device categories (FIG. 80): 

Click on any tab to view the devices contained therein.

Click and drag any device from the Toolbox onto the System Diagram to add the device to the 
System.

Refer to the VisualArchitect online help for a comprehensive listing of supported AMX devices.

Device Notes
Many devices have device notes associated with them, indicated by a blue Information Icon on the Device 
Element (in the System Diagram - see FIG. 81): 

Click on this icon to view the Device Notes, in the Device Notes dialog.

Click Print to print the device notes.

Click OK to close this dialog.

Copying Device Notes to Clipboard Memory
Right-click inside the text window to access a context menu (the options in this menu will vary depending on 
your PC configuration), and select Copy to copy the text to clipboard memory. Then, you can paste these notes 
into another file if desired.

FIG. 80  Toolbox - Device Categories

FIG. 81  Device Notes
63VisualArchitect Operation/Reference Guide 



Working With Devices
NetLinx Central Controller
Every VA project/system requires a single NetLinx Central Controller.

When you start a new project (either via the Basic System Assistant or the Empty System option), VA 
automatically selects the NI-3100 as the Central Controller. In most cases, the NI-3100 is a good selection, 
since it is capable of handling most system designs that come from VA. However, VA also provides the 
flexibility to change this selection if necessary:

If you started your project with the Basic System Assistant, you can select a different NetLinx 
Controller in the Basic System Assistant dialog.

If you started your project with the New Empty System option, the NI-3100 is automatically added 
to the system when it is initially created. You can change the Central Controller type later via the 
Edit > Replace option.

Setting The Card Frame Number
The Card Frame Number dialog allows you to specify a Card Frame Number for NXF Card Frames and 
Central Controllers equipped with card slots (NI-4000 /4100).

The Card Frame Number determines the device numbers for the for the Control Cards installed in the 
Controller or Card Frame.

To access this dialog, click on the Browse (...) button in the Card Frame Number device property for NXF 
Card Frames and Controllers equipped with card slots (FIG. 82): 

By default, VA assigns the Card Frame Number as 25 (FIG. 83): 

The formula for assigning device numbers to the Controls Card Slots is:

(Card Frame Number x 12) + Card Slot Number (1-12) = Card address

Therefore, if you use the default Card Frame Number setting of 25:

Card slots 1-12 in an NXF Card Frame are assigned slot numbers 301-312.

Card slots 1-4 in NI-4000/4100 Central Controllers are assigned slot numbers 301-304.

To change the Card Frame Number assignment, type the Card Frame Number in the Number field, and take 
note of the DIP Switch settings indicated in the dialog.

The DIP Switch on the Controller or Card Frame (rear panel) will have to be set to match the 
settings shown here.

Any time you change the DIP Switch settings on the Controller or Card Frame, cycle power for 
approximately 5 seconds to allow the system to read the new device number settings.

Replacing the Central Controller
VA requires that there is always one NetLinx Central Controller in each system.

Since you are not allowed to delete the Central Controller, you must use Replace to use a different type:

1. Select the device in the system diagram that you want to replace.

2. Select the device that you want to replace it with, in the Toolbox.

3. Select Edit > Replace (or select Replace Device from the Toolbox System Devices context menu).

You can also start a new system design with a Central Controller selection. With no 
project open, right-click on the Central Controller that you want to use in the Central 
Controllers tab of the Toolbox, and select New System Using: from the context menu. 
This action starts a new empty system, with the selected Controller in place.

FIG. 82  Card Frame Number device property

FIG. 83  Card Frame Number DIP Switch
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Alternatively, you can drag-and-drop a replacement Central Controller from the Toolbox into the System 
Diagram:

1. Position the replacement Central Controller directly on top of the existing one to replace it.

2. When the replacement Controller is positioned correctly to replace the existing one, the Replace icon is 
displayed on the cursor (FIG. 84): 

3. When the Replace Icon appears, release the Controller that you are dragging, and it will replace the 
existing Central Controller.

It is important to note that depending on the differences between the original Central Controller and the 
one that is selected to replace it, some device connections may be lost.

For example, if you replace a NI-4000 - which features eight IR/Serial ports, with a NI-700 - which has 
one IR/Serial Port, you will lose IR/Serial Ports 2-8.

If you have devices connected to any ports on the original Controller that do not exist on the 
replacement Controller, the device connections will be lost for the missing ports, but the devices 
will remain in the System. However, if the replacement Controller has the same number of port 
types as the original, no device connections will be lost.

Also note that when you replace the Central Controller, device properties relative to connection 
type may be lost.

All Central Controllers are added to the system (including replacements) with the same default Connection 
Settings: 

If any of the settings were changed before the Central Controller was replaced, they will have to be re-entered 
(since the replacement Controller will apply the default settings).

This also holds true for the System Number assignment, which will return to the default setting of 
1.

Any Comments entered will carry over after replacing the Controller.

FIG. 84  Replace icon

Central Controllers - Default Connection Settings

• Connection Type: TCP/IP

• IP Address/Host Name: (none)

• IP Port Number: 1319

• Ping For Availability: true

• Requires Authentication: false
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Working With Applications
NetLinx Central Controllers feature the ability to add AMX Applications directly to the Central Controller's 
device node in the System Diagram. 

To add an application to a NetLinx Central Controller:

1. Select the Central Controller in the System Diagram.

2. Click on the plus icon in the Applications node (FIG. 85): 

This action invokes the Select a device to add to Applications dialog (FIG. 86): 

3. Select an Application and click OK to close this dialog.

4. The selected Application is indicated in the device element in the System Diagram (FIG. 87): 

FIG. 85  Central Controller - Application Node

FIG. 86  Select a device to add to Applications dialog

FIG. 87  Central Controller with i Weather Application
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5. Click on the Application node on the device element to populate the Properties window with the 
Application's properties (FIG. 88): 

6. Edit the Application Name and add Comments as desired.

To remove an Application from a Central Controller, click on the Application node and select Delete from the 
Toolbar, the Edit menu or the System Diagram Context menu (or press the Delete key).

User Interface Devices
There are three types of User-Interface (UI) devices supported by VisualArchitect:

Touch Panels

Keypads

Remotes

Refer to the VisualArchitect online help for a comprehensive listing of supported AMX Touch Panels, 
Keypads and Remotes.

Selecting AMX User-Interface Devices
Once you have selected a NetLinx Central Controller, you can specify one or more AMX User-Interface 
devices.

Every VA project/system requires at least one AMX User-Interface device.

If you started your project with the Basic System Assistant, you can select one Touch Panel and up 
to two Keypads in the Basic System Assistant dialog. The Basic System Assistant dialog also 
provides the opportunity to select a Template to apply to the Touch Panel.

Select File > New > Basic System Assistant to launch the Basic System Assistant dialog, which 
helps to streamline the initial setup of the control system, based on Project information and AMX 
Equipment (NetLinx Central Controller and Touch Panel/Keypad) selections.

If you started your project with the New Empty System option, you will select and add User-
Interface device(s) from the Toolbox:

Select File > New > New Empty System to create a new system, without any devices except the 
(default) NI-3100 NetLinx Central Controller. At this point you can define the rest of the system as 
desired.

1. To add a Touch Panel, open the Touch Panels tab of the Toolbox, and double-click or drag-and-drop the 
desired Touch Panel into the System Diagram.

2. To add a Keypad or Remote, open the Keypads & Remotes tab of the Toolbox, and click and double-click 
or drag-and-drop the desired keypad onto the System Diagram.

FIG. 88  Properties window - Application Properties

When adding video touch panels (including any of the wired Modero panels), VA 
(v1.3 or higher) automatically adds the appropriate NXA-AVB Breakout box to the 
System Diagram at the time that the panel is added. Also, note that included 
accessories cannot be removed from the system.
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Intercom-Enabled Touch Panels
Intercom-enabled panels have additional template support in VA v1.3 or above. When an intercom-enabled 
panel is added to the system, and the Intercom feature/sub-feature from the selected template is added to the 
Touch Panel navigation, VA instantiates two NetLinx modules during code generation that handle the intercom 
communications and the intercom UI interaction.

These modules are defined once, regardless of how many intercom-enabled panels have been added 
to the system (assuming that at least one has been added).

These modules are given an array of the touch panels ports controlling intercom operation and an 
array of virtual devices to use for communication. 

These modules files will also be added to the resulting NetLinx Studio Workspace (.APW) file 
when the system code is generated.

Device Properties
When a device is selected in the System Diagram, detailed information for that device is displayed in the 
Properties window. Many of these properties are editable, and some require input, in order to successfully 
generate your control system files.

Using Quick Input
Select Quick Input from the Edit menu (or the System Diagram context menu or Panel UI Diagram context 
menu) to access the Quick Input sub-menu.

The Quick Input setting allows you to enter a particular device or UI element property, without having to select 
the property in the Properties Window.

Use the Edit > Quick Input submenu to specify which device property to assign Quick Input to. The options 
are:

Name (default setting): With this option selected, you can select a device and type to change that 
device's name.

Current Property: Highlight any device property (in the Properties window) and select Current 
Property to assign the selected property to Quick Input.

For example, select the Device Number property (in the Properties window), and select Current 
Property from the Quick Input sub-menu, then any time you select a device in the System Diagram, 
you can just type and press the Enter key to enter a device number for the selected device.

Note that VA will prompt you if the value entered is outside of the allowed range for the selected 
property.

Disabled: This option disables the Quick Input feature.

Device Properties - Central Controllers
The following parameters are required for NetLinx Central Controllers, and are set via fields in the Properties 
window (FIG. 89): 

FIG. 89  Device Properties - Central Controllers
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The fields displayed depend on the Central Controller selected in the System Diagram, and include the 
following: 

Device Properties - Accessories & Expansion Devices
The device parameters for Accessories and Expansion devices are set via fields in the Properties window 
(FIG. 90): 

The fields displayed depend on the device selected in the System Diagram, and include the following: 

Device Properties - Central Controllers

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.

• Option See page 77.

• FG Number See page 77.

• MSRP See page 77.

• System Number See page 78.

• Device Number See page 77.

• Card Frame Number See page 76.

• IP Address/Host Name See page 77.

• IP Port Number See page 77.

• Ping For Availability See page 77.

• Requires Authentication See page 78.

FIG. 90  Device Properties - Accessories & Expansion Devices

Device Properties - Accessories & Expansion Devices

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.

• Device Number See page 77.

• Color See page 76.

• Frequency See page 77.

• FG Number See page 77.

• Duet Module See page 77.

• IP Address/Host Name See page 77.

• MSRP See page 77.
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Device Properties - Networking Devices
The device parameters for Networking devices are set via fields in the Properties window (FIG. 91): 

The fields displayed depend on the Networking device selected in the System Diagram, and include the 
following: 

Device Properties - Touch Panels
The device parameters for Touch Panel devices are set via fields in the Properties window (FIG. 92): 

The fields displayed depend on the Touch Panel device selected in the System Diagram, and include the 
following: 

FIG. 91  Device Properties - Networking Devices

Device Properties - Networking Devices

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.

• FG Number See page 77.

• MSRP See page 77.

• IP Address/Host Name See page 77.

FIG. 92  Device Properties - Touch Panels

Device Properties - Touch Panels

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.
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Device Properties - Keypads & Remotes
The device parameters for Keypad & Remote Controller devices are set via fields in the Properties window 
(FIG. 93): 

The fields displayed depend on the Keypad or Remote selected in the System Diagram, and include the 
following: 

Device Properties - Touch Panels (Cont.)

• Color: See page 76.

• Option See page 77.

• FG Number See page 77.

• MSRP See page 77.

• Device Number See page 77.

• IP Address/Host Name See page 77.

• Template See page 78.

• Color Scheme See page 76.

• Unicode Font See page 78.

FIG. 93  Device Properties - Keypads & Remotes

Device Properties - Keypads & Remotes

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.

• Color: See page 76.

• Frequency R-2 remotes only

See page 77.

• FG Number See page 77.

• MSRP See page 77.

• Device Number See page 77.

• Option R-3 and R-4 remotes only (see page 77).

• IP Address/Host Name Mio Modero DMS/Pinnacle keypads and only (see page 77).

• Template Mio Modero DMS/Pinnacle keypads only (see page 78).

• Color Scheme Mio Modero DMS/Pinnacle keypads only (see page 76).

• Unicode Font Mio Modero DMS/Pinnacle keypads only (see page 78).
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Device Properties - Media Devices
The device parameters for Media devices are set via fields in the Properties window (FIG. 94): 

The fields displayed depend on the Media device selected in the System Diagram, and include the following: 

FIG. 94  Device Properties - Media Devices

Device Properties - Media Devices

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.

• FG Number See page 77.

• MSRP See page 77.

• Duet Module See page 77.

• IP Address/Host Name See page 77.

Module Initialization Properties

These additional options are available for Tango Controllers:

• Baud_Rate Click to manually enter a baud rate for the controllers serial port (default = 9600).

• DEVICEMODEL Click to manually enter a Device Model type for the selected device (default = 
DELTA).

• Model Click to manually enter a Model type for the selected device (default = DELTA).

These additional options are available for Autopatch Switchers:

• config Click to manually enter a configuration string for the selected switcher 
(default = AfV:0:36:36:ALL?
Video:1:36:36:VIDEO?
Audio:2:36:36:AUDIO?=3) - 

• features Click to manually enter XXXXX.

These additional options are available for Endeleo Distribution Matrix devices:

• A/B/C/D_Config Click to manually enter a video output type for the selected output (default = VGA).

• Password Click to manually enter a password for the selected device (default = admin).

• Port Click to manually enter a port for the selected device (default = 2008).
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Device Properties - Environment Devices
The device parameters for Environment devices are set via fields in the Properties window (FIG. 95): 

The fields displayed depend on the Media device selected in the System Diagram, and include the following: 

Device Properties - Media Devices (Cont.)

• IP Address Click to manually enter an IP Address for the selected device (default = 
192.168.0.200).

• User_Name Click to manually enter a User Name for the selected device (default = endeleo).

• A/B/C/D_AudioConfig Click to manually enter an audio output type for the selected output (default = 
ANALOG).

These additional options are available for Solecis AVS-SL-0401-838 & AVS-SL-0601-848 Switchers:

• DEVICE_ID Click to manually enter a Device ID for the selected device (default = 0).

FIG. 95  Device Properties - Environment Devices

Device Properties - Environment Devices

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.

• FG Number See page 77.

• MSRP See page 77.

• Duet Module See page 77.

Module Initialization Properties

These additional options are available for Radia RE-DM4 & DM6 Controllers:

• Identifiers Click to manually enter an identifier for the selected device (default = 0).

• DefaultRxTimeout Click to manually enter default timeout for the selected device (default = 5000)

• SystemName Click to manually enter a SystemName for the selected device (default = empty).
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Device Properties - Communications Devices
The device parameters for Communications devices are set via fields in the Properties window (FIG. 96): 

The fields displayed depend on the Communications device selected in the System Diagram, and include the 
following: 

Device Properties - Third-Party Devices
Third-party (non-AMX controlled) devices, are selected via the Devices tab of the Toolbox. There are two 
types of Third-Party devices:

Module-Supported devices - Devices that are listed by name in the Devices tab are module-
supported. These devices are supported by Duet Modules that are packaged with VA that provide 
device and control information.

Device Discovery (DD) devices - Every device category in the Devices tab of the Toolbox contains 
a listing for "Device Discovery". Device Discovery (DD) devices are automatically detected by the 
Central Controller when they are connected and powered-up.

The following properties are displayed for DD devices: 

FIG. 96  Device Properties - Communications Devices

Device Properties - Communications Devices

• Name See page 77.

• Comments See page 76.

• Category See page 76.

• Model Number See page 77.

• Device Number See page 77.

• Color MET-ECOM & MET-ECOM-D only - default = White

See page 76.

• FG Number See page 77.

• MSRP See page 77.

• IP Address/Host Name Mio Modero DMS/Pinnacle keypads only

See page 77.

Communication properties for a module-supported device should only be changed if 
it is known that the module supports that property.

Device Properties - Device Discovery (DD) Devices

• Name See page 77.

• Comments See page 76.

• Category See page 76.
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Device Number Defaults
The default device numbers for devices that have this as a default are listed below: 

Device Properties - Device Discovery (DD) Devices (Cont.)

• Manufacturer See page 77.

• Model Number See page 77.

• Connection Type See page 77.

• Duet Module See page 77.

• IP Address/Host Name See page 77.

• Preset/Media Library File Path See page 78.

• Module Initialization Properties See page 77.

Device Number Defaults

Central Controller default device number = 0

Accessories & Expansion Devices

• NXS-NMS The first NXS-NMS added to the system is assigned default device number 
5002; each one added thereafter increments it's default device number by +1 
(5003, 5004, 5005, etc).

• AXR-RF, MIO-IRRX, AXD-
IR+, AXR-IRSM+

The first IR/RF Receiver added to the system is assigned default device num-
ber 128; each one added thereafter increments it's default device number by +1 
(129, 130, 131, etc).

• AXB-VOL3 The first AXB-VOL3 added to the system is assigned default device number 96; 
each one added thereafter increments it's default device number by +1 
(97, 98, 99, etc).

Touch Panels The first touch panel added to the system is assigned device number 10001; 
each one added thereafter increments it's default device number by +1 
(10002, 10003, 10004, etc).

Keypads & Remotes

• Metreau & Mio Modero The first Metreau or Mio Modero keypad added to the system is assigned 
device number 128; each one added thereafter increments it's default device 
number by +1 (129, 130, 131, etc). Note that the MET-6N uses two device 
numbers: one for the keypad portion of the device, and one for the AMX IR 
receiver portion (i.e. 129,130).

• DMS Keypads The first DMS keypad added to the system is assigned device number 11001; 
each one added thereafter increments it's default device number by +1 
(11002, 11003, 11004, etc).

• Mio Modero Remotes 
(R-3, R-4 only)

The first R-3 or R-4 remote added to the system is assigned device number 
10001; each one added thereafter increments it's default device number by +1 
(10002, 10003, 10004, etc).

Media Devices MAX-CSE - The first MAX-CSE or MAX-CSD10 added to the system is 
assigned device number 10001; each one added thereafter increments it's 
default device number by +1 (10002, 10003, 10004, etc).

Environment Devices Radia Controllers - The first Radia Controller added to the system is assigned 
device number 96; each one added thereafter increments it's default device 
number by +1 (97, 98, 99, etc).

Communications 
Devices

The first MET-ECOM or MET-ECOM-D added to the system is assigned device 
number 10001; each one added thereafter increments it's default device 
number by +1 (10002, 10003, 10004, etc).
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Device Number Ranges - By Device Type
VA enforces the following device number ranges (entered in the Device Number field in the Device Properties 
window): 

Device Properties 

Device Number Ranges

Device Type Allowed Device # Range

AxLink General 1-255

AxLink UI 128-255

NetLinx Card Frames 301-3060 - see Setting The Card Frame Number  on page 64

NetLinx ICSNet devices 5001-5999

Landmark ICSNet devices 6001-6999

P3 Devices 7001-7999

PCLink Devices 8001-8999

ICSNet Panels DMS, IMS, future panels 10001-31999

Dynamic devices (NetLinx Devices with no 
device number assigned)

32001-32385

Virtual devices 32768-36863 - start at 33001

Dynamic Virtual Devices (used by some older 
AMX-written modules)

36865-37863

Module Virtual devices (non-echoing devices) 37865-40999

Duet Virtual Devices 41000-42000

Device Properties 

Card Frame Number The device number of the Card Frame. Available only for NXF Card Frames 
and NI-4000/4100 Controllers only (default = 25).

Note: Click the browse button to open the Card Frame Number dialog to 
change this assignment (see Setting The Card Frame Number  on page 64).

Category The VA device category of this Controller (read-only).

Note that the Category field is displayed as both a Device property and a UI 
Element property.

Color Click to access the drop-down menu, and select from a listing of color options 
available for this device.

Note that this selection is automatically reflected in the FG Number field.

Note that the Color field is displayed as both a Device property and a UI Ele-
ment property.

Color Scheme Once a Template has been selected, this field is enabled. Click to access the 
drop-down menu and select a color theme to apply to the selected template.

Note that the Color Scheme field is displayed as both a Device property and a 
UI Element property.

Comments Click to add developer's comments regarding this device.

Once comments have been added to a device, a yellow comment icon is 
added to the Device Element in the System Diagram (or the Start Element in a 
UI Diagram), and the comments are displayed when the cursor hovers over the 
element: 

Note that the Comments property is displayed as both a Device property and a 
UI Element property.
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Device Properties (Cont.)

Connection Type Click to access the drop-down menu, and select from a listing of connection 
types supported by the selected device.

The Connection Type selection determines which rows are displayed immedi-
ately beneath this one (based on that type's required parameters).

• By default, Serial devices are always added to the system with RS-232 set as 
the Connection Type.

• By default, DD devices connect to the Central Controller via Ethernet 10/
100T connection.

Device Number Central Controllers: The current Device Number setting for this Controller 
 (default = 0).

Other devices: The current Device Number setting for this device (see Device 
Number Defaults  on page 75).

Note that the Device Number field is displayed as both a Device property and a 
UI Element property.

Duet Module The file path and name of the Duet Module (*.JAR file) associated with this 
device (read-only).

FG Number The AMX "Finished Goods" number associated with this device (read-only).

Note that the FG Number field is displayed as both a Device property and a UI 
Element property.

Frequency Click to access the drop-down menu, and select from a listing of available RF 
frequencies.

Note that this selection is automatically reflected in the FG Number field.

IP Address/Host Name Enter an IP address (or Host Name if applicable) for this device.

Note that the IP Address/Host Name field is displayed as both a Device 
property and a UI Element property.

IP Port Number The IP Port Number to be used by this Controller (default = 1319).

Note: In most situations, the Port Number should not be changed.

Manufacturer This field indicates the name of the selected device's manufacturer (read-only).

Model Number The product model number of this device (read-only).

Note that the Model Number field is displayed as both a Device property and a 
UI Element property.

Module Initialization 
Properties

Some third-party control modules have specific initialization properties 
(required or optional) which can be entered here. Examples include user name 
and password for a device, optional baud rates, etc.

These properties are listed by name, with an entry space for each property, 
and will be transmitted to the module during system startup.

MSRP The AMX Manufacturer's Suggested Retail Price for this device (read-only).

Note that the MSRP field is displayed as both a Device property and a UI Ele-
ment property.

Name The (default) system name for this device (click to edit).

Option • Central Controllers: Specify an amplifier option for the DVX-2100HD Central 
Controller (DVX-2100HD only).

• Remotes: Specify a kit option (R-3 and R-4 remotes only).

Ping For Availability Click to access the drop-down menu.

Select True - ping the Controller before attempting a TCP/IP connection, or 
False - do not ping for availability (default = True).

Pinging a device is relatively fast and will determine if the device is off-line, or if 
the TCP/IP address that was entered was incorrect. If you decide not to ping 
for availability and the controller is off-line, or you have an incorrect TCP/IP 
address, the program will try for 30-45 seconds to establish a connection.

Note: If you are trying to connect to a master controller that is behind a firewall, 
you may have to disable this option. Most firewalls will not allow ping requests 
to pass through for security reasons.
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Communication Parameters
Every time you add a device of any kind to the System Diagram, you should review the Device Properties for 
the device. Device properties include communication parameters, and the communication parameters 
displayed depend on the selected device's connection/control type. These include:

Ethernet

IR

Modem (for Central Controllers)

Serial (RS-232/422/485) Connections (for Central Controllers)

TCP/IP Connections

When you select a Device Element in the System Diagram, the device properties for the selected device are 
displayed in the Properties window.

These device properties include communication parameters, and the communication parameters displayed 
depend on the selected device's control type. Each device's control type is also indicated in the Device Element 
in the System Diagram (FIG. 97): 

Device Properties (Cont.)

Preset/Media Library File 
Path

Click the Browse button (...)  to specify a file path for the Media Library (.MXD) 
file.

The Media Library represents a listing of all media (including CDs and DVDs) 
identified in the Preset Editor program - accessible via the File menu. See Pre-
set and Media Content Database Files.

This field is only displayed for devices that can playback audio/video media.

Requires Authentication Click to access the drop-down menu.

Select True - this Controller has been configured to require authentication, or 
False - authentication is not required (default = False).

If the Controller requires authentication, the correct User Name and Password 
combination will be required in order to establish a connection with the Control-
ler.

Refer to the Controller's WebConsole & Programming Guide for details on 
enabling this option on the Controller.

Note: User Names and Passwords are case-sensitive.

System Number The current System Number setting for this Central Controller (default = 1).

Template Click inside this field to access the drop-down menu and select a template to 
apply to this panel.

Note: VA only presents templates that include a resolution supported by the 
selected panel.

Click Browse to access the Select User Interface Template dialog.

Note that the Template field is displayed as both a Device property and a UI 
Element property.

Unicode Font This field is enabled only after a Template has been selected. Click to access 
the drop-down menu and select a font to use with the selected template.

Note that you can scroll through the font list by double-clicking in the text field.

Note that the Unicode Font field is displayed as both a Device property and a 
UI Element property.

Voltage Click to select a voltage setting (120VAC / 240VAC) for the selected device 
(default = 120 VAC).

Device Properties are set via fields in the Properties window.

There are several Ethernet connection types supported by VA (selectable only if 
Ethernet is selected as the Connection Type).
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Communication Parameters - Ethernet Connections
The following parameters are required for Ethernet connections, and are set via fields in the Device Properties 
window. These fields are only displayed if an Ethernet connection type is selected for the device. 

Ethernet devices that use a Duet Module have the display-only item Duet Module listed as a device property. 
This is the file path and name of the Duet Module associated with the device.

Ethernet Connection Types
When you add a Device Discovery (DD) device to the System Diagram, the Connection Type is always set to 
Ethernet 10/100T. There are several types of Ethernet 10/100T connections supported by VA, as indicated in 
the drop-down menu that is accessible by clicking on the Connection Type (Ethernet 10/100T) field in the 
Device Properties:

Ethernet 10/100T - This is the default Ethernet connection type used by DD devices. This 
connection type supports both "Standard" Ethernet" and "Fast" Ethernet.

Uses a bus or star topology that supports data transfer rates of 100 Mbps.

Uses a bus or star topology that supports data transfer rates of 10 Mbps.

FIG. 97  Device Elements - Control Types

Communication Parameters - Ethernet Connections

• IP Address/Host Name: Enter an IP Address or Host Name for this device in this field. This value is used 
for establishing connection during transfer:

• For third-party devices controlled by Duet modules, this value is used to initialize 
module communications with the device.

• For all AMX Ethernet devices (e.g., touch panels), the field is strictly 
informational.

• This value will be output into the System Report in the Device Addressing 
section under the IP Address/Host Name column.

IP Address/Host Name must either be a valid IP Address in the format 
XXX.XXX.XXX.XXX, where XXX is a number between 0 and 255, except:

• 0.X.X.X - zero address

• 127.X.X.X - loopback address

• 255.255.255.255 - broadcast address

• or a valid IP hostname starting with a letter and containing only letters, numbers, 
dashes, or dots.

VisualArchitect does not provide support for login information on IP devices that 
require a login. If the device uses a module that specifically handles login information, 
the Module Initialization Properties (User Name and Password) are displayed. Use 
these additional fields to specify required login information.
However, if you have an IP device that requires a login, the device must be added to 
the Custom.AXI file after system file generation, but prior to file transfer. This is a 
process that requires NetLinx programming experience and is not recommended for 
the novice VA user.

DD devices can also support Serial (RS-232/422/485) connections, as indicated in 
the drop-down menu.
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Ethernet 1000T - This represents a "Gigabit" Ethernet connection, which supports data rates of 1 
gigabit (1,000 megabits) per second.

Ethernet 802.11b - (also referred to as "802.11 High Rate" or "Wi-Fi") -- an extension to 802.11 
that applies to wireless LANs and provides 11 Mbps transmission (with a fallback to 5.5, 2 and 1 
Mbps) in the 2.4 GHz band. 802.11b uses only DSSS, and allows wireless functionality comparable 
to Ethernet.

DSSS = Direct Sequence Spread Spectrum. DSSS is used in wireless local-area network 
transmissions where a data signal at the sending station is combined with a higher data rate bit 
sequence, or chipping code, that divides the user data according to a spreading ratio. The chipping 
code is a redundant bit pattern for each bit that is transmitted, which increases the signal's 
resistance to interference. If one or more bits in the pattern are damaged during transmission, the 
original data can be recovered due to the redundancy of the transmission.

802.11 refers to a family of specifications developed by the IEEE for wireless LAN technology.

Ethernet 802.11g - Also applies to wireless LANs, and provides 20+ Mbps in the 2.4 GHz band.

RS-232/422/485 - Standard Serial (RS-232, RS-422 or RS-485) connection. Serial connections 
have their own communication parameters, unrelated to Ethernet communication parameters.

Communication Parameters - IR Connections
The following parameters are required for IR-controlled devices, and are set via fields in the Device Properties 
window. These fields are only displayed if IR is selected as the Connection Type for the device. 

Communication Parameters - Modem Connections
The following parameters are required for Modem connections for Central Controllers (which can be accessed 
from your PC via a modem connection), and are set via fields in the Device Properties window. Click inside 
any of these fields to access a drop-down menu of supported options. These fields are only displayed if 
Modem is selected as the Connection Type for the device. 

All four Ethernet connection types share the same communication parameters.

Communication Parameters - IR Connections

• Remote Control Model: This field displays the model number of the IR hand controller associated with this 
device. If this device supports more than one remote control, you can select from 
the drop-down menu of supported models.

• IR File: This field displays the name of the IR File associated with the selected remote 
control.

Communication Parameters - Modem Connections

• COM Port: Select an available COM (communications) port to use for communication with this device. 

The COM ports available to choose from will depend on the number of COM ports present 
on the selected device (default = COM1).

• Baud Rate: Select a baud rate for communications with this device. For most devices the choices 
range from 75 to 128,000 BPS (default = 115200).

• Data Bits: Select the number of data bits used for encoding characters. For most devices, the 
options are 5, 6, 7 or 8 (default = 8).

• Parity: Select a method of parity checking. For most devices, the options are Odd, Even, Space 
or Mark (default = None).

• Stop Bits: Select 1 or 2 (default = 1).

• Flow Control: Select a method of flow control. For most devices, the options are Xon/Xoff, RTS/CTS, 
DTR/DSR (default = None).

• Phone Number: Enter the phone number of the modem connected to the target NetLinx Central Controller.
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Communication Parameters - Serial (RS-232/422/485) Connections
The following parameters are required for Serial (RS-232/422/485) connections, for Central Controllers, 
(which can be accessed from your PC via a serial port), and are set via fields in the Device Properties window. 
Click inside any of these fields to access a drop-down menu of supported options. These fields are only 
displayed if Serial (RS-232, RS-422 or RS-485) is selected as the Connection Type for the device. 

Communication Parameters - TCP/IP Connections
The following parameters are required for TCP/IP connections, and are set via fields in the Device Properties 
window. These fields are only displayed if TCP/IP is selected as the Connection Type for the device. 

In most applications, the default communications settings should suffice and should 
only be changed by advanced users.

Communication Parameters - Modem Connections

• COM Port: Select an available COM (communications) port to use for communication with this device. 
The COM ports available to choose from will depend on the number of COM ports present on 
the selected device (default = COM1).

• Baud Rate: Select a baud rate for communications with this device. For most devices the choices range 
from 75 to 128,000 BPS (default = 115200).

• Data Bits: Select the number of data bits used for encoding characters. For most devices, the options 
are 5, 6, 7 or 8 (default = 8).

• Parity: Select a method of parity checking. For most devices, the options are Odd, Even, Space or 
Mark (default = None).

• Stop Bits: Select 1 or 2 (default = 1).

• Flow Control: Select a method of flow control. For most devices, the options are Xon/Xoff, RTS/CTS, DTR/
DSR (default = None).

By default, Serial devices are always added to the system with RS-232 set as the 
Connection Type. Change the Connection Type to match the device's requirements 
via the Connection Type field in the Device Properties window.

Communication Parameters - TCP/IP Connections

• Host Name: Enter a Host Name for this Central Controller in this field (example = " NetLinx").

• Port Number: By default, the Port Number is 1319. In most situations, the Port Number should not 
be changed.

• Ping For Availability: Click inside this field to access the drop-down menu and specify whether to ping the 
Controller before attempting a TCP/IP connection (select True or False). By default, 
this option is enabled (True).

Pinging a device is relatively fast and will determine if the device is off-line, or if the 
IP address that was entered was incorrect.

If you decide NOT to ping for availability and the controller is off-line, or you have an 
incorrect IP address, the program will try for 30-45 seconds to establish a connec-
tion.

If you are trying to connect to a Central Controller that is behind a firewall, you may 
have to disable this option (set to False). Most firewalls will not allow ping requests to 
pass through for security reasons.

In most applications, the default communications settings should suffice and should 
only be changed by advanced users.
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Device Addressing
Device:Port:System (D:P:S)
A device is any hardware component that can be connected to the NetLinx bus. Each device must be assigned 
a unique number to locate that device on the bus.

The NetLinx programming language allows numbers in the range 0-32,767.

Device 0 refers to the local Central Controller; numbers greater than 32,767 are reserved.

NetLinx requires a Device:Port:System (D:P:S) specification. This D:P:S triplet can be expressed as a series of 
constants, variables separated by colons, or a DEV structure.

For example:

STRUCTURE DEV

{

INTEGER Number // Device number

INTEGER Port // Port on device

INTEGER System // System the device belongs to

}

The D:P:S notation is used to explicitly represent a device number, port and system. For example, 128:1:0 
represents the first port on device 128 on this system. If the system and Port specifications are omitted, (e.g. 
128), system 0 (indicating this system) and port 1 (the first port) is assumed. Here's the syntax:

NUMBER:PORT:SYSTEM

where:

NUMBER: 16-bit integer represents the device number

PORT: 16-bit integer represents the port number (in the range 1 through the number of ports on the 
Controller or device)

SYSTEM: 16-bit integer represents the system number (0 = this system)

Modero® Touch Panels Device Addressing

1. Press the gray Front Setup Access button for 3 seconds to open the Setup page

2. Press the Protected Setup button (located on the upper-left of the panel page) to open the Protected Setup 
page and display an on-screen keypad.

3. Enter 1988 into the Keypad's password field and press Done when finished.

4. Press the red Device Number field to open the Device Number keypad.

5. Enter the Device Number value for the panel into the Device Number Keypad.

6. Press Done to close the keypad, assign the number, and return to the Protected Setup page.

7. Press the on-screen Reboot button to restart the panel and incorporate any changes.

Mio Modero Keypad Device Addressing

1. If connected, disconnect the power supply.

2. Locate the 8-position Device DIP switch on the rear panel.

3. Set the DIP switch according to the switch values shown below: 

The device number is set by the total value of DIP switch positions that are ON.

If you later change the device number, remove and reconnect the AxLink power connector to enter 
the new device number into memory.

Switch 1 2 3 4 5 6 7 8

Value 1 2 4 8 16 32 64 128
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Central Controller Addressing Via Telnet
Establishing a Terminal Connection:

1. Launch the Hyper Terminal application from its' default location (Start > Programs > Accessories > 
Communications).

2. Apply power to the Central Controller and allow it to boot up.

3. Connect the PC COM (RS232) port from your computer to the RS232 Program port on the Controller. 
Note the baud rate settings for the Controller.

4. Enter any text into the Name field of the Hyper Terminal Connection Description dialog window and 
click OK when done.

5. From the Connect Using field, click the down-arrow and select the PC COM port being used for 
communication by the target Controller and click OK when done.

6. From the Bits per second field, click the down-arrow and select the baud rate being used by the target 
Controller.

Configure the remaining communication parameters as follows: Data Bits: 8, Parity: None, Stop 
bits: 1, and Flow control: None (default is Hardware).

Click OK to complete the communication parameters and open a new Terminal window.

Getting and Setting the IP Address:
Within the Terminal session, type get ip and press <ENTER> to view the current IP communication 
parameters. Here is a listing of some sample information pulled from the Central Controller:

>get ip

IP Settings for 0:1:1

HostName NetLinx

Type DHCP

IP Address 192.192.199.99

Subnet Mask 255.255.255.0

Gateway IP 192.192.199.2

MAC Address 00:61:9h:91: aa:6e

1. Type set ip and press <ENTER> to either retain a DHCP Address or assign a pre-reserved IP Address.

Throughout the following setting options you can enter new values or press <ENTER> to keep current 
settings enabled.

2. When prompted to enter a Host Name you can either press <ENTER> to accept the current name 
(NetLinx) or enter a new name and press <ENTER>.

Enter Host Name: NetLinx

3. When prompted to enter an IP Type, the entry defaults to DHCP but you can assign either a DHCP or 
Static IP Address to the target Controller.

Assigning a DHCP Address:

1. Enter IP type. Type D for DHCP or S for Static IP and then Enter: DHCP

If you press <ENTER> the setting remains defaulted to pull a DHCP Address from the DHCP Server.

2. Enter IP type. Type D for DHCP or S for Static IP and then Enter: DHCP

3. When prompted to enter a Gateway IP, press <ENTER> to accept the default setting and display the 
entered information:

Enter Gateway IP: 192.168.5.2

You have entered: Host Name NetLinx

Type DHCP

Gateway IP 192.168.99.3

4. When prompted to confirm that the previous information was correctly entered, you can either accept the 
default y (yes) and press <ENTER> or change the entry to n (no) to repeat the process:

Type echo on to view the characters while entering commands. If that does not work, 
press <ENTER> key on your keyboard.
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Is this correct? Type Y or N and Enter -> y

Settings written. Device must be rebooted to enable new settings.

5. Incorporate the new settings by cycling power to the unit.

Assigning a Static IP Address:

1. Enter IP type. Type D for DHCP or S for Static IP and then Enter: Static

If you type in S or Static and press <ENTER>, you are then prompted to enter the pre-reserved IP 
Address, Gateway, and Subnet Mask information. This information can be obtained from your System 
Administrator.

Enter IP Address: 192.199.99.2

Enter Subnet Mask: 255.255.255.0

Enter Gateway IP: 192.199.99.3

2. After you have completed entering the Gateway IP Address, the previously entered information is then 
displayed.

You have entered: Host Name NetLinx

Type Static IP

IP Address 192.199.99.2

Subnet Mask 255.255.255.0

Gateway IP 192.199.99.3

3. When prompted to confirm that the previous information was correctly entered, you can either accept the 
default y (yes) and press <ENTER> or change the entry to n (no) to repeat the process:

Is this correct? Type Y or N and Enter -> y

Settings written. Device must be rebooted to enable new settings.
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NetLinx Device Addressing via the Central Controller UI
Step 1: Access the Central Controller's UI and Configuring the NetLinx Device

Once the Central Controller's IP Address has been set through either a Terminal or Telnet session:

1. Launch your web browser.

2. Enter the IP Address of the target Controller (ex: http://198.198.99.99) into the web browser's Address 
field.

3. Press the Enter key on your keyboard to begin the communication process between the target Controller 
and your computer.

Initially, the Master Security option is disabled (in the System Security page) and no user name and 
password is required for access or configuration.

Both HTTP and HTTPS Ports are enabled by default (via the Manage System > Server page).

The first active page displayed within your open browser page is Manage WebControl Connections. 
To access this page click on the Manage System link (from within the System Settings section of 
the Navigation frame). 

Step 2: Configure the Network Settings via the Device Menu

1. Click the System Settings > Manage System link from within the System Settings section of the 
Navigation frame.

2. Click on a violet Device icon from within the Online Tree to open the Device menu buttons within the 
right frame.

3. Click the Network Settings button to open the Network Settings dialog. This dialog allows a user to setup 
the network settings for the specified device. The fields are populated with the current settings (when 
initially loaded). 

4. Enter a new or updated name within the Host Name field. This entry can be 1 - 50 alphanumeric 
characters in length.

5. Select either the DHCP or Specify an IP Address check box to chose the source of the IP Address 
information being used within the remaining fields.

6. Enter or change any IP Address or DNS Address information within the remaining fields.

7. Click Update to save any changes. If your changes are successfully updated to the Central Controller, the 
following message appears. "Network Settings updated. Device must be rebooted for the setting to take 
effect".

8. Return to the System menu by clicking on the purple System icon (within the Online Tree), click the 
Reboot button, and then allow the Controller a short time to reboot itself.

Feature Description

IP Address:

Host Name Use this field to view/edit the target Central Controller's cur-
rent Host Name.

DHCP/Specify IP Address Use these radio buttons to specify an address for the target 
Controller:

• DHCP - obtained from a DHCP Server.

• Specify an IP Address - typically obtained from a System 
Administrator.

IP Address Use this field to view/edit the target Controller's current IP 
Address.

Subnet Mask Use this field to view/edit the target Controller's current 
Subnet Mask assignment.

Gateway Use this field to view/edit the target Controller's current 
Gateway assignment.

DNS Address:

Domain Suffix Use this field to view/edit the target Controller's current 
Domain Suffix.

DNS IP #1, #2, #3 Use these fields to view/edit the target Controller's current 
DNS IP addresses.
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9. Click on the Refresh macro from the browser's menu bar. If no security is currently enabled on the target 
Controller, you are directed back to the Manage WebControl Connections page. If security is enabled, 
you are directed to the initial Username/Password page to enter your access information.

Step 3: Change the System Number via the System Menu

1. Click the Manage System link (from within the System Settings section of the Navigation frame).

2. Click on the purple System icon from within the Online Tree to open the System menu buttons within the 
right frame.

3. Click the System Number button to open the Change System Number dialog. This dialog shows the 
current system number (read-only) on the target Central Controller.

4. Enter a new numeric value into the New Device Number field.

5. Click the Update button to save this new value to the device. The message; "Device number changed to 
XXX. Device must be rebooted for the change to take effect.", reminds the user that the Controller must 
first be rebooted before the new settings take effect.

Step 4: Reboot the Central Controller via the System Menu

1. Click the Manage System link (from within the System Settings section of the Navigation frame).

2. Click on the purple System icon (within the Online Tree) to open the System menu buttons within the 
right frame.

3. Click the Reboot button to remotely reboot the target Central Controller. No dialog appears while using 
this button. The Online Tree then reads "Rebooting...". After a few seconds, the Online Tree refreshes 
with the current system information (showing the newly updated system number).

If the Online Tree contents do not refresh within a few minutes, press the browser's Refresh button and 
reconnect to the Controller.

Device Accessories
VisualArchitect supports various Accessories for each supported AMX device.

For example, the accessories available for the NI-700 Central Controller include: AC-SMB (Surface-Mount 
Bracket), AC-RK (Rack Kit), PSN2.8, PSN4.4 and PSN6.5 (Power Supplies), CC-COM (Serial Programming 
Cable), etc.

To determine which accessories are compatible with any AMX device, right-click on a device in the System 
Diagram, and select Accessories from the System Diagram context menu (alternatively, with a device selected 
in the System Diagram, select Device > Accessories).

This action invokes the Accessories dialog, which provides a full listing of accessories supported by VA and 
compatible with the selected device.

Most accessories will not show up on the System Diagram, but those with control system 
connections will be displayed. For instance, the NXA-AVB/Ethernet and NXA-AVB/RGB Touch 
Panel breakout boxes would be displayed, since they utilize device connections to the Touch Panel, 
but a conduit box would not be displayed.

All accessories included in the project are represented in the System Report (in the Accessory List 
section).

Adding Accessories to an AMX Device
Right-click on any AMX device in the System Diagram, and select Device > Accessories to open the 
Accessories dialog. The Accessories dialog lists all accessories associated with the selected device. All 
Accessories included in the project are represented in the System Report (in the Accessory List section).

The Included column indicates wether or not this accessory is included with the selected device. If 
it is, this column indicates how many are included; a dash indicates none.

The Additional column indicates the quantity of an accessory that the user has chosen to purchase 
above and beyond what is included with the device.

If the selected device does not support any accessories, this option is disabled.
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1. In the Accessories dialog, select the Accessory that you want to add and click the Change Quantity 
button. This opens the Quantity dialog.

a.  The Included Quantity field indicates how many of the selected Accessory are already included with 
the device (this field reflects the Included column in the Accessories dialog).

By default, all included Accessories are assumed to be used.

Note that you can reduce the number of Included Accessories, but you cannot exceed the number 
provided by VA. To add more than is Included with the device, adjust the Additional Quantity 
number.

b.  The Additional Quantity field indicates how many additional Accessories of this type to include 
(reflecting the Additional column in the Accessories dialog).

By default, Additional Quantity is set to zero.

The number entered into Additional Quantity field is added to the number already in the Included 
Quantity field. The total number of this Accessory is represented in the System Report for this 
device (in the Accessory List section).

2. Click OK to close the Quantity dialog.

Changing the included quantity for Accessories that are represented in the System Diagram causes them to be 
added or removed from the System Diagram as needed.

Alternatively, you may delete any visible accessories directly from the System Diagram in the same manner as 
any other device. Doing so will remove the device from any Additional Quantity first, and then from the 
Included Quantity.

Prerequisite Devices
Many AMX Devices have certain prerequisite devices in order for them to be functional parts of the system. 
For example, in order to use a Mio R-4 remote controller, you must also have a ZigBee connection (NXR-
ZGW or NXR-ZRP). Another example would be that in order to use a MVP-8400 wireless touch panel, you 
must also include a Wireless Internet Connection.

See the Prerequisite Devices section on page 100 for details.

Adding a visible accessory back to the System Diagram requires changing the 
quantity via the Accessories dialog.
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Multi-Port Devices
Multi-port device addressing is supported via the Port Activation and Naming dialog.

Port Activation
Right-click on a multi-port device in the System Diagram, and select Port Activation and Naming from the 
System Diagram context menu to invoke the Port Activation and Naming dialog. This dialog is used to manage 
ports on the selected device.

1. Activate/deactivate individual ports by checking/unchecking the check box in the Active column.

Use SHIFT+click to select a range of ports to activate/deactivate.

Use CTRL + click to select two or more individual ports to activate/deactivate.

2. Select the Activate Selected or Deactivate Selected button.

Activate/deactivate all ports (accept port 1) of all components by selecting the Activate All or Activate 
None buttons.

3. Click OK to save all changes, or Cancel to cancel all changes.

Port Naming
Right-click on a multi-port device in the System Diagram, and select Port Activation and Naming from the 
System Diagram context menu to invoke the Port Activation and Naming dialog. This dialog is used to 
manage ports on the selected device.

The main window lists the ports on the selected device, separated by Component

Click the + icon to expand each Component to see all ports.

The Port Name column indicates the Port Name for each port. Click in the Port Name cell for any Port to edit 
directly in the text field (FIG. 98): 

The Port Name specified here is represented in CodeBuilder, in the Port Number drop-down (in the Event 
Window for multi-port devices. For example, if on the NXC-VOL4, "Port 4" is renamed to "Port Four", 
CodeBuilder represents the modified name as shown below (FIG. 99): 

This option is only available for devices that support two or more ports for at least one 
component.

Multi-port devices include the AXB-VOL3, NXC-VOL4, MAX Media Servers, DAS-
T0804/8, and AutoPatch Switchers.

FIG. 98  Port Naming

FIG. 99  Port Naming - Port Number
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Component Port Usage
Right-click on a multi-port device in the System Diagram, and select Port Activation and Naming from the 
System Diagram context menu to invoke the Port Activation and Naming dialog. This dialog is used to 
activate ports on the selected multi-port device.

Component port usage appears in the CodeBuilder at the functions/status level for particular component 
functionality.  

Using the AMX Autopatch Precis switcher as an example, the first four ports on the Gain component have 
been activated and named, as shown below (FIG. 100): 

As a result, any function/status from the Gain component that supports multi-port addressing will appear in 
CodeBuilder with a drop-down list box for the port option.

The port option appears after the device name and before the function/status name.

By default the first port is always defined.  

For example, with the definition above we can open CodeBuilder on the switcher and see that the first button 
event, Gain Down, has default code.  

The default code, AMX_AutoPatch Precis :  Living Room   setGainRamp  DOWN has "Living Room" 
automatically set because this function supports multiple port addressing and "Living Room" is the first port 
(FIG. 101).   

FIG. 100  Port Activation and Naming dialog
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We can change this option to any of the other ports:  Kitchen, Master Bedroom, and Patio.

If we add the function "setVolume" we would see that it also supports multiple ports with the default port 
names "Port 1" to "Port 8".  If all ports for the volume component are disabled, the port option will still appear 
with the default "Port 1" option to indicate that this function is capable of addressing more than one port, but 
has been deactivated.  

Port 1 is always active and can not be deactivated.  

Functions/status that do not support multiple ports will not have this option.

The figure below shows three more examples of multi-port usage with the status getGain (FIG. 102): 

The first shows getGain in a conditional

The second shows the result of getGain being assigned to a variable

The last shows the result of getGain being compared to a variable

All versions of getGain show that the port can be changed.

FIG. 101  CodeBuilder dialog

FIG. 102  CodeBuilder dialog
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Multi-Port Code Generation
For each device port that the user defines usage of, VA will generate a NetLinx device statement.

If a port is defined across multiple components in a device, only a single NetLinx device statement will be 
generated, and its comment will reference all components that use that port.  For example, a switcher with 
multi-port Volume and Gain components, for which the user has activated and named the first four ports, will 
be generated as follows:

dvSWT1 = 5001:1:0      // AMX_AutoPatch Precis real device, via NI-900 Serial #1

vdvSWT1 = 41001:1:0    // AMX_AutoPatch Precis virtual device, via NI-900 Serial #1

vdvSWT1_P2 = 41001:2:0 // AMX_AutoPatch Precis (Gain:Patio, Volume:Patio) virtual device

vdvSWT1_P3 = 41001:3:0 // AMX_AutoPatch Precis (Gain:Office, Volume:Office) virtual device

vdvSWT1_P4 = 41001:4:0 // AMX_AutoPatch Precis (Gain:Master Bedroom, Volume:Master Bedroom)

                          virtual device

Any reference to these ports in CodeBuilder will cause the resulting NetLinx statement to use the proper 
virtual device from those declared.  For example, using the switcher defined above, ramping the volume up for 
the Master Bedroom (port 4) will generate the following code:

// Ramp volume up

TO[vdvSWT1_P4, VOL_UP]

Device Discovery (DD)
NetLinx Masters equipped with firmware build 320 or higher support Device Discovery (DD), via the 
Dynamic Device Detector.

The Dynamic Device Detector monitors the system for newly connected devices. New devices can be detected 
via either an external discovery protocol manager, Multicast reception of a Dynamic Device Beacon, or via the 
receipt of a beacon response on an application specified list of serial devices. This Dynamic Device Detector 
process begins by detecting new devices within a NetLinx/Duet system, binding those devices to application 
instances, and then starting a Duet module to control those new devices.

Device Discovery was created to take advantage of Java's Dynamic Class Loading and the Duet Standard 
NetLinx API (SNAPI). Java loads classes as they are needed. Therefore it is feasible to load a Duet control/
protocol module on the fly as each new device is discovered. SNAPI provides a fixed interface for 
communicating with a certain type of device. The "glue code" refers to the developer defined NetLinx 
program that runs on a Central Controller and controls a system.

Take for example a VCR. The majority of control features are common to all VCRs (play, stop, pause, etc.). 
SNAPI provides the "glue code" developer the ability to write common code that will control any type of VCR 
having an associated Duet module. The underlying Duet module could be swapped in and out based on the 
actual physical device with no changes needed to the higher level "glue code".

Every device category in the Devices tab of the Toolbox contains a listing for "Device Discovery". Device 
Discovery (DD) devices are automatically detected by the Central Controller when they are connected and 
powered-up.

To view Device Discovery devices in the Toolbox, enable the Show Device Discovery option (FIG. 103):  

VA (v1.4 or higher)  will automatically convert older projects so that port usage is 
available for all function/status that map back to a component that supports multiple 
ports.

FIG. 103  Toolbox - Show Device Discovery option enabled
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By default, Device Discovery devices always connect to the Central Controller via Ethernet 10/100T 
connection, as indicated in the Connection Type field of the Properties window (FIG. 104):  

You can select another Ethernet connection type, or RS-232 as the connection type for Device Discovery 
devices.

Device Discovery (DD) Concepts
Application Device: A Duet Device (41000-42000) that is used as a control interface to a physical 

device. This is also referred to as the Duet virtual device. All control requests are made to the 
application device rather than to the physical device.

There are two types of application devices: Static Bound application devices and Dynamic 
application devices:

Static Bound application devices specify both a Duet virtual device and its associated Device SDK 
class type, as well as a NetLinx physical device port to which the application device is always 
associated (i.e. statically bound).

Dynamic application devices specify both the Duet virtual device and its associated Device SDK 
with no association to a physical port. Binding of an application device to a physical device/port 
occurs at run-time (either via auto-binding or manual binding).

Application devices that have a "bound" physical device display their physical device ID within the 
Physical Device column. If an associated Duet module has been started to communicate with the 
device, its associated property information is displayed in a mouse-over popup dialog when the 
cursor hovers over the physical device ID.

Binding: In concrete programming, the application device is forever associated with the NetLinx 
physical device. In Device Discovery, this association is dynamic. The act of associating an 
application device with a physical device is called "binding".

Device Discovery: In Device Discovery, physical devices are detected in the system at run-time. 
There are two different methods of detection: via DD or via user definition within the Central 
Controller's Web interface.

SDK Class: Each application device in the Device Discovery world is associated with a particular 
device type as defined by SNAPI. When using a VCR or a Receiver as an example, each of these 
device types would correspond with a Java Interface within the Duet Device Software 
Development Kit (SDK). When writing programs for DD, the developer specifies the device type 
of a particular application device by using one of these SDK Class names.

Polling: Dynamic physical devices can be detected by DD through both Serial and IP interfaces. 
But whereas IP connections are then able to utilize the network's higher layers of multicast to 
broadcast their existence, Serial devices speak a fixed protocol that is incompatible with DD. Serial 
devices are passive and will only broadcast their existence if polled to do so. The program 
developer must specify which NetLinx interfaces/ports (i.e. serial ports) should be polled for 
devices.

FIG. 104  Device Element - Device Discovery device

In order to use Device Discovery devices in your system, your Central Controller 
must have Internet access enabled. See Enabling Internet Access On The Central 
Controller.
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Enabling Internet Access On The Central Controller
Use the options on the Details for Additional Devices page (in the NetLinx Central Controller's WebConsole) 
 to manage 3rd party Device Discovery devices.

To access the NetLinx Central Controller's WebConsole,  enter the following URL In your web browser:

http://masters-ip/ (example: http://123.45.6.78/)

In the NetLinx Central Controller's WebConsole:

1. Select System, and open the Manage Devices tab (FIG. 105): 

2. In your web browser, enter the following URL to access the Central Controller's built-in web interface:

http://masters-ip/ (example: http://123.45.6.78/):

3. Click the Device Options link to access the Details for Additional Devices  page. This page is used as the 
entry point for the management of all Third-Party Device Discovery (DD) devices.

4. In the Configure Binding Options section of this page, click in the check boxes to enable the following 
options:

Enable Auto Bind: This selection allows an end-user to toggle the state of the automatic binding 
for Device Discovery (DD) devices (On/Off).

When auto-binding is enabled, the Central Controller automatically attempts to connect any newly 
discovered DD device with an associated application device (defined in the running NetLinx 
application). Auto-binding can only be accomplished if the Central Controller's firmware 
determines a one-to-one correlation between the newly discovered device and a single entry within 
the list of defined application devices (accessed by pressing the Manage Device Bindings button at 
the top of the page).

For example, if the application only has one VCR defined and a VCR is detected in the system, 
auto-binding can then be accomplished. If there were two VCRs defined within the application, 
auto-binding could not be completed due to the lack of a clearly defined one-to-one 
correspondence.

Refer to the NetLinx Integrated Controllers WebConsole & Programming Guide for 
details on using the WebConsole.

FIG. 105  NetLinx Central Controller's WebConsole - Manage Devices tab
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Enable Module Search on Internet: Clicking this button toggles the capability of searching the 
Internet (either AMX's site or a device specified site) for a device's compatible Duet modules. This 
capability is automatically disabled if the Central Controller does not have Internet connectivity.

Upon enabling Internet connectivity, the AMX License Agreement is displayed for acceptance. The 
AMX License Agreement must be accepted (by pressing the Accept button on the upper-right of 
the page) for the Internet Module search to be enabled.

When the Internet search for modules feature is enabled (the button then reads Disable Module 
Search via Internet), the Central Controller queries either AMX's Online database of device 
Modules and/or pulls Modules from a separate site specified by the manufacturer's device.

5. Click Accept.

Managing Device Bindings
Use the options on the Manage Device Bindings page (in the NetLinx Central Controller's WebConsole)  to 
configure application-defined Duet virtual devices with discovered physical devices.

To access the NetLinx Central Controller's WebConsole,  enter the following URL In your web browser:

http://masters-ip/ (example: http://123.45.6.78/)

In the NetLinx Central Controller's WebConsole:

1. Select System, and open the Manage Devices tab.

2. Click the Bindings link to access the Manage Device Bindings page (FIG. 106): 

3. Use the options on this page to configure application-defined Duet virtual devices with discovered 
physical devices.

The table on this page displays a list of all application-defined devices, including each device’s "Friendly 
Name", the Duet virtual device’s D:P:S assignment, the associated Duet Device SDK class (indicating the type 
of the device), and the physical device’s D:P:S assignment. This information has to be pre-coded into the 
NetLinx file currently on the Central Controller.

When the Enable Auto Bind option is not selected, no auto-binding activity takes 
place and all binding of the newly discovered devices must be accomplished 
manually via the Web control interface Manage Other Devices.

You can later disable this feature by toggling this button's state.

Refer to the NetLinx Integrated Controllers WebConsole and Programming Guide 
(available at www.amx.com) for configuration instructions, and descriptions of all 
WebConsole Pages/Options.

FIG. 106  NetLinx Central Controller's WebConsole - Manage Device Bindings tab
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Each entry in the table has one of four buttons to the right of the Physical Device D:P:S assignment:

Static Bound application devices will either be blank, or display a Release button:

Static Bound application devices that have not yet detected a physical device attached to their 
associated port have a blank button.

Once a physical device is detected and its associated Duet module has been started, a Release 
button is then displayed. Click Release to force the associated Duet module to be destroyed and the 
firmware then returns to detecting any physical devices attached to the port.

Dynamic application devices either display a Bind or Unbind button:

Dynamic application devices that have been bound display an Unbind button. When the user selects 
Unbind, any associated Duet module is then destroyed and the "link" between the application 
device and the physical device is then broken.

Dynamic application devices that have not been bound to a physical device display a Bind button. 
When this button is selected, a secondary display appears with a listing of all available unbound 
physical devices that match the application device's Device SDK class type.

The administrator/user can then select one of the available physical devices to bind with the associated 
application device. When the Save button is selected, the binding is created and a process begins within the 
target Master to find the appropriate Duet Module driver. Once a driver is found, the Duet Module is then 
started and associated with the specified application device (Duet virtual device). If the Cancel button is 
selected, the binding activity is then aborted.

Configuring Application-Defined Devices
Elements such as DUET_DEV_TYPE_DISC_DEVICE and DUET_DEV_POLLED are defined within the 
NetLinx.AXI file. The NetLinx.AXI file contains both the new API definitions, as well as the pre-defined 
constants that are used as some of the API arguments (ex: DUET_DEV_TYPE_DISC_DEVICE).

Example Code:

PROGRAM_NAME='DDD'

DEFINE_DEVICE

COM1 = 5001:1:0

COM2 = 5001:2:0

dvRECEIVER1 = 41000:1:0

dvDiscDevice = 41001:1:0

DEFINE_CONSTANT

DEFINE_TYPE

DEFINE_VARIABLE

DEFINE_START

STATIC_PORT_BINDING(dvDiscDevice, COM1, DUET_DEV_TYPE_DISC_DEVICE,

       'My DVD', DUET_DEV_POLLED)

DYNAMIC_POLLED_PORT(COM2)

DYNAMIC_APPLICATION_DEVICE(dvRECEIVER1, DUET_DEV_TYPE_RECEIVER,

          'My Receiver')

If a currently bound device needs to be replaced or a Duet Module needs to be 
swapped out, the device should be unbound and the new module/driver should then 
be bound.

If the manufacturer device does not support Dynamic Device Discovery (DDD) 
beaconing, you must use the Add New Device page to both create and manage 
those values necessary to add a dynamic physical device. This process is described 
in detail within the following section.

Physical device names are typically prefixed with "dv" and Virtual device names are 
typically prefixed with "vdv".
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(***********************************************************)

(* THE EVENTS GO BELOW *)

(***********************************************************)

DEFINE_EVENT

DATA_EVENT [dvRECEIVER1]

{

// Duet Virtual device data events go here

}

Sample code can be found within the DEFINE_START section.

This code gives the Central Controller a “heads-up” notification to look for those devices meeting the criteria 
outlined within the code.

Troubleshooting - Device Discovery (DD) Devices
There are two error messages that might be received from the Central Controller under the following project 
conditions:

The Project loaded on the Central Controller uses only Device Discovery devices (that is, there are 
0 non-Device Discovery devices in the project).

The Central Controller has not been loaded with code files that refer to non-Device Discovery 
devices.

In this situation the following errors are visible, if you have connected to the Central Controller via 
Telnet, and have messaging turned on (MSG ON):

Error Message:
DynamicDeviceDetector.retrieveUrlJar: missing filename in URL response

DynamicDeviceDetector.retrieveDriverDependencies: failed to retrieve 
dependencydevicesdkrt.jar

This message indicates that the following requires system file is missing from the Central Controller: " 
devicesdkrt.jar"

Error Message:
DynamicDeviceDetector.retrieveUrlJar: missing filename in URL response

DynamicDeviceDetector.retrieveDriverDependencies: failed to retrieve 
dependencysnapirouter.jar

This message indicates that the following requires system file is missing from the Central Controller: " 
snapirouter.jar"

Solution:

Copy the missing files to the Central Controller, via the Controller's built-in web UI:

1. In your web browser (i.e.: Internet Explorer or compatible), enter the following URL:

http://masters-ip/ (example: http://123.45.6.78/), to access the Controller's built-in web interface.

2. Open the Manage Other Devices page: click on the Manage Other Devices link (from within the System 
Settings section of the Navigation frame).

3. In the Manage Device Modules section of this page, select the Browse button (next to Select File To 
Upload).

4. Locate and select the file: devicesdkrt.jar.

By default, VA copies these files to the following directory:

Program Files\Common Files\AMXShare\Duet\Bundle

5. Select Upload File.

6. Select the Browse button (next to Select File To Upload).

7. Locate and select the file: snapirouter.jar.

8. Select Upload File.
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External Device Configuration Files
For configuring the module layout for the Hydraport HPX-1600, AMX provides the Hydraport Connection 
Preview web application. The Hydraport Connection Preview application is available on the AMX website.

Follow the on-screen directions to configure the module layout for an HPX-1600.

The Save Config option under Manage Configurations in the left window of the Hydraport Connection 
Preview page saves the current module configuration as an *.HPX file (FIG. 107): 

VA allows you to import this file as an external device configuration file for the HPX-1600.

Importing a Device Configuration (*.HPX) File

1. In the System Diagram, select the device to which you will apply the imported External Configuration 
file.

2. Select Device > Import Configuration.

3. The program will alert you that the existing external configuration will be replaced with that from the 
imported external file, and prompt you to continue with the import operation.

4. Click OK to proceed. This action invokes the Import External Config File dialog.

5. Locate and select the desired external configuration (*.HPX) file to import, and click Open.

Exporting a Device Configuration File

1. In the System Diagram, select the device from which you will export an External Configuration file.

2. Select Device > Export Configuration.

3. Specify a target directory for the HPX file, and click OK.

FIG. 107  Hydraport Connection Preview web application
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System Design

Overview
System Design is managed in the System Diagram. When you create a new VA Project (see Creating a New 
VA Project  on page 21), the System tab contains at least one Device Element: the default NetLinx Central 
Controller (NI-3100). Other devices are added to the system by clicking and dragging devices from the 
Toolbox into the System Diagram. See Adding Devices To The System Diagram  on page 100 for details.

Each device in the System is represented in the System Diagram with a separate Device Element. 
See Device Elements  on page 99 for details.

Each Device Element uses Connection Nodes (IN and OUT) to connect to other devices in the 
System Diagram. See Connection Nodes - Device Elements  on page 102 for details.

Device connections are defined by drawing Connection Lines between the Device Elements. See 
Connection Lines  on page 104 for details.

Select any Device Element in the System Diagram to view/edit the Device Properties for the 
selected Device. See the Device Properties  on page 68 for details.

System Diagram
Click on the System tab in the Diagram Area to view the System Diagram - a layout of the entire system, 
including the NetLinx Central Controller, AMX devices and third-party (controlled) devices, as well as all 
device connections (FIG. 108): 

Device Elements
Each device is represented in the System Diagram by a Device Element. To add devices to the system, simply 
select each device in the Toolbox, and drag-and-drop into the System Diagram (FIG. 109): 

Hover the cursor over any device in the System Diagram (or the Toolbox) to view basic device information 
(FIG. 110): 

FIG. 108  System Diagram

FIG. 109  Device Element (Central Controller)
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Adding Devices To The System Diagram
The first step in developing a new VA project is to define the devices in the system. This includes selecting the 
devices that you want in the system and adding them to the System Diagram, establishing device connections, 
and configuring device properties.

1. In the Toolbox, click on a device tab to display the supported devices of that type available to choose 
from.

2. Select the desired device and drag-and-drop it into the System Diagram. Each device in the System 
Diagram is represented by a Device Element.

3. Connect the Device Elements to the NetLinx Central Controller. Different device types have different 
connection requirements.

4. Review the device properties (including communication settings) for this device, and edit if necessary.

Prerequisite Devices
Many AMX Devices have certain prerequisite devices in order for them to be functional parts of the system. 
For example, in order to use a Mio R-4 remote controller, you must also have a ZigBee connection (NXR-
ZGW or NXR-ZRP). Another example would be that in order to use a MVP-8400 wireless touch panel, you 
must also include a Wireless Internet Connection.

Since in these cases, you absolutely must have the other prerequisite devices in your system in order to depict 
a fully function control system, VA assists you in making sure that all prerequisite devices are included, and 
helps you choose the correct devices according to the other devices in your system.

A given device may contain one or more groups of prerequisite (or required support) devices; each group 
having a name and a designation of either required or optional.

Upon adding a device to the System Diagram, VA establishes whether that device has any groups of support 
devices, and then checks to see if the system currently contains at least one of the devices in those groups. If 
none of the devices in a group is found in the system, VA prompts you to choose one to be added prior to the 
original device being added, via the Choose Required Support Device dialog (XXXXXXXXXX). 

FIG. 110  Device Element (Central Controller) - Basic Device Information

An example of an "optional" support device would be the ABS (AxLink Bus Strip), for 
Radia controllers. Since there is only a single AxLink connection available on NetLinx 
Central Controllers, the ABS is only required if you need to connect more than one 
AxLink device to the Controller.
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VA also prompts you to add any additional prerequisite devices that the original prerequisites may have, and so 
on. For example, from an empty system, adding an R-4 remote will require a ZigBee connection and will give 
the user the choice of an NXR-ZGW or NXR-ZRP. If you choose the NXR-ZGW gateway, VA will further 
prompt you to select the Ethernet connection required by the NXR-ZGW, giving the choices of an NXA-
ENET24, NXA-ENET24PoE, or Ethernet Backbone.

Again, canceling the dialog at any point will abort the entire operation-no devices will be added.

Removing Devices From The System Diagram
There are several ways to remove devices via the System Diagram:

Right-click on device in the System Diagram and select Delete from the System Diagram context 
menu.

Select a device in the System Diagram and select Delete from the Edit menu.

Select a device in the System Diagram and click the Delete Toolbar button.

Select a device in the System Diagram and press the Delete key.

Alternatively, you can use the Device list in the System Tree to select and delete devices from the System:

Right-click on device in the System Tree and select Delete from the System Tree context menu.

Select a device in the System Tree and select Delete from the Edit menu.

Select a device in the System Tree and click the Delete Toolbar button.

Select a device in the System Tree and press the Delete key.

The program will prompt you to verify this action before the device is removed from the system. Click the 
Don't Show Again option in the Remove Element dialog to avoid being prompted again.

You can reactivate this prompt at any time via the Help > Reset Message Boxes option.

FIG. 111  Choose Required Support Device (Wireless Ethernet Connection) dialog

In the case of both required and optional support devices, cancelling the dialog will 
cancel the entire operation, and no devices will be added to the system.

For a comprehensive listing of devices and their prerequisite devices, as well as 
listing of all supported Accessories, refer to the VisualArchitect online help.
101VisualArchitect Operation/Reference Guide 



System Design
Connection Nodes - Device Elements
Each Device Element has Connection Nodes on either side that represent the physical ports on the device. 
Connection Nodes allow each Device Element to be connected to other Device Elements in the System 
Diagram (FIG. 112). 

The nodes on the left side of the Device Element are Input (IN) Nodes, and accept incoming 
connections to the device from other devices.

The nodes on the right side of the Device Element are Output (OUT) Nodes, and provide outgoing 
connections from the device to other devices.

The number and types of Connection Nodes provided on each Device Element depends on the device type and 
the physical ports it uses.

You are not allowed to delete the Central Controller. You can change the Central 
Controller's type via the Replace option.

FIG. 112  Device Elements - Connection Nodes

Connection Nodes (OUT)

Connection Node (IN)

Connection Nodes (OUT)
Connection Nodes (IN)

Connection Nodes (IN)

Connection Nodes (OUT)
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Expand / Collapse Multi-Connection Nodes
Many Device Elements feature more than one port/Connection Node of a given type. For example, the 
NI-3100 NetLinx Central Controller features eight IR/Serial ports, eight I/O ports and eight Relay ports. 

By default, each port and associated Connection Node of a given connection type is not shown individually on 
the Device Element. Instead, they are collapsed to provide a cleaner view on the System Diagram.

In most cases, you don't need to view every port, since VA will automatically connect devices to the next 
available port of the appropriate type. However, multi-connection ports can be expanded to show each 
individual port.

To expand the port view, click the plus-sign (+) to the left of the port name. FIG. 113 shows the IR/Serial, IO 
and Relay ports on the NI-3100 first in their (default) collapsed state, and expanded: 

Click the minus sign (-) next to the top port in a set of expanded ports to collapse that set of ports.

The numbers following the port name on multi-port connections indicate the number of ports, and number of 
those ports already used (FIG. 114).

FIG. 113  Expanding the Port View

FIG. 114  Number of Ports / Available Ports

Click the plus sign (+) 
on multi-connection ports

to show individual ports

"[5/7]" indicates that 5 of the 7 RS-232/422/485 
ports are currently connected to devices

"[3/8]" indicates that 3 of the 8 IR/Serial
ports are currently connected to devices

"[0/8]" indicates that 0 of the 8 I/O
ports are currently connected to devices
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Connection Lines
Each Device Element must be connected to the NetLinx Central Controller in the System Diagram, either 
directly or via an intermediate Networking or Expansion device. 

Device connections are indicated in the System Diagram with connection lines. Connection lines connect to 
the Connection Nodes on the Device Elements.

Connection lines are colorized to represent different connection types: 

Use the Connect feature to let VA establish device connections automatically, based on the device's 
control type (select Device > Connect, or select Connect from the System Diagram context menu).

Use the Auto-Connect feature to have VA automatically draw a connection between a new device 
and the Central Controller (or intermediate device required for the device to connect to the 
Controller), when a new device is dropped into the System Diagram (select Auto-Connect from the 
System Diagram context menu).

Use the Filter Connections option (in both the View menu and the System Diagram context menu 
to filter device connection lines on the System Diagram by connection type, to present a more 
targeted view of the system connections (in the Define Filter dialog). See the Filtering Device 
Connections section on page 107 for details.

Use the Connection Style option (in both the View menu and the  System Diagram context menu 
to switch between straight lines (default) and curved lines. See the Changing the Connection Line 
Style section on page 109 for details.

Connecting Devices
Each Device Element in the System Diagram has at least one Connection Node. Connection nodes represent 
ports on the actual device, and are used to establish connections between devices and other system devices as 
well as the NetLinx Central Controller.

More typically, Device Elements will feature several Connection Nodes to accommodate the different physical 
connectors on the actual device (FIG. 115). 

The nodes on the left side of the Device Element are Input (IN) Nodes, and accept incoming 
connections to the device from other devices.

The nodes on the right side of the Device Element are Output (OUT) Nodes, and provide outgoing 
connections from the device to other devices.

See Connection Nodes - Device Elements  on page 102 for additional details.

Click-and drag on the System Diagram to connect devices. Device connections are established by drawing 
lines from an OUT Connection Node on one Device Element to a matching IN Connection Node on another 
Device Element. 

For example, the figure below shows that to connect an ABS AxLink Bus Strip to the Central Controller, the 
AxLink OUT Connection Node on the Central Controller connects to the AxLink IN Connection Node on the 
ABS (FIG. 116): 

Connection Lines - Color Scheme

• Control: green

• Power: red

• Audio: white

• Video: blue

• Audio/Video: cyan

FIG. 115  Connection Nodes on a NetLinx Central Controller

Connection Nodes (OUT)

Connection Node (IN)
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Some devices do not connect directly to the Central Controller. For example, wireless MVP touch 
panels require a (WAP) Wireless Access Point between the panel and the Central Controller. 
Similarly, Ethernet 10/100T panels require a Network Switch between the panel and the Controller. 
See Prerequisite Devices  on page 100 for details.

Many connection nodes have a plus sign icon to indicate that there are multiple ports of that 
connection type available on this device. Click the plus sign to expand the port view. See Expand / 
Collapse Multi-Connection Nodes  on page 103 for details.

Use the Connection Manager dialog to define more detailed connection information, including 
individual connectors (such as audio/video inputs and outputs) on each device. See Defining 
Physical Connectors For System Devices  on page 107 for details.

VA provides a couple of quick and easy ways to automatically connect Device Elements in the System 
Diagram:

Auto Connect - Select  Edit > Auto Connect (or click the toolbar button in the Standard Toolbar) 
to let VA establish device connections automatically when each device is added to the System 
Diagram. By default, Auto-Connect is enabled.

Connect (device) - Select Device > Connect (or select Connect from the System Diagram Context 
menu). If a Device Element is selected, this option draws connection lines only for the selected 
Device Element. If no Device Element is selected, this option draws connection lines between all 
devices in the System Diagram.

Manually Connecting Devices in the System Diagram:

1. In the System Diagram, left-click and hold on an OUT Connection Node on one Device Element.

2. Drag your mouse over an IN Connection Node of a matching type on the Device Element with which you 
want to connect (FIG. 117):  

For example, if you add an AxLink device, you will connect that device's AxLink (IN) Connection Node 
to an AxLink (OUT) Connection Node on the NetLinx Controller (or intermediate device).

FIG. 116  ABS AxLink Bus Strip Connected to the Central Controller

FIG. 117  Drawing a Connection Line between Device Elements in the System Diagram
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3. As you drag the cursor, a connection line is drawn on the System Diagram,  indicating the connection. 
Until a connection is established, the line is yellow (as shown above). When you release the mouse button 
on a valid connection, the line color changes to indicate the connection type (for example green, as shown 
in FIG. 118):  

See Connection Lines  on page 104 for details.

If an invalid connection is attempted, the cursor will change to indicate that the connection is not allowed 
(FIG. 119):  

Devices/Modules With Multiple Connection Types
Devices that support more than one connection type are listed up to three times in the System Tree with a 
separate listing for each connection type supported by that device.

One example is the HPX-1600 Hydraport, which can be configured to use several different modules, all with 
different connection types. An example System Tree including HPX-1600 is shown below (FIG. 120):  

When a device of a particular connection type is added to the System Diagram, you can change the device 
properties and communication parameters for the selected connection type, but you cannot change the 
connection type.

FIG. 118  Connection Established between Device Elements

FIG. 119  Connection Not Allowed

FIG. 120  System Tree (HPX-1600)
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Defining Physical Connectors For System Devices
In addition to establishing the connection between the NetLinx Central Controller and each device in the 
System Diagram, VA allows you to specify how to connect each individual physical connector on a controlled 
device, in the Connection Manager dialog.

The detailed connection information that you can define with the Connection Manager is included in the 
System Report, and is intended to assist in the installation process. However, this information is optional and 
does not affect the control aspect of the devices in any way. While it recommended that you take advantage of 
this feature of VA, it is possible to skip this process and just connect the equipment without any 
documentation.

For example, while you can draw a connection line from a IR-controlled DVD player to an IR port on the 
NetLinx Central Controller in the System Diagram, there is no way to indicate how to connect the DVD 
player's audio and video outputs (or any other connectors that exist on the player) to other devices in the 
system, until you establish each of these physical connectors via the Connection Manager dialog.

You will need to consult the manufacturer's documentation (or the device itself) to know exactly what 
connectors exist on each device.

1. Right-click on a device element n the System Diagram, and select Connection Manager from the context 
menu.

2. Click the Add Connection button (FIG. 121): 

This adds a new connection to the Connections window. When a new connection is added, by default the 
type is A/C Power

3. In the Properties window, click in the Type field to activate the Connection Type drop-down menu, and 
select a connection type.

4. By default, the Name field is populated with the connection type name. Edit the name as desired.

5. Click in the Direction field to select either input or output (default = output).

6. By default, each connection is added as single connector. To indicate multiple connectors of this type, 
click in the Count field and use the Up and Down arrows to adjust the number of connectors of this type 
to add. If there are more than one connector of a given type, the number of connectors are indicated in the 
Connections window, in parenthesis after the Connector type.

An example Connection Manager dialog for a DVD Player is shown below (FIG. 122): 

FIG. 121  Connection Manager dialog - Add Connection button

FIG. 122  Connection Manager dialog
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Once each connector has been added in the Connection Manager dialog, the DVD Player's Device Element in 
the System Diagram will indicate these connectors, as shown below (FIG. 123): 

Once these connections are available in the Device Element, they can be connected to other devices in the 
diagram just like any other (drag-and-drop to draw a connection line between each input/output node to a 
compatible node on the Central Controller or another device in the system).

To remove a Connection, select it in the Connections window, and click the Delete button (FIG. 124): 

To change the order in which the Connections are listed on the Device Element, select a Connection, and use 
the Up and Down arrow buttons to re-order the list (FIG. 125): 

Filtering Device Connections
Use the options in the View > Filter Connections sub-menu to filter the connection lines on the System 
Diagram by connection type, to present a “cleaner” or more targeted view of the system connections. This sub-
menu can also be access via the Filter Connections toolbar button (FIG. 126): 

The options in this sub-menu are:

Toggle Filter - This option toggles the device connection filter, as specified in the Define Filter 
dialog. By default, the filter is Off.

Define Filter - Click to open the Define Filter dialog, where you can specify which connection 
types to filter out of the System Diagram view. By default, all connections types are included in the 
view (no filtering).

FIG. 123  Example Device Element indicating various connection types

FIG. 124  Connections window - Delete button

FIG. 125  Connections window - Up/Down button

FIG. 126  Filter Connections toolbar button
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To define a device connection filter:

1. Select View > Filter Connections > Define Filter to open the Define Filter dialog.

Click the plus signs to expand the view of any of the five connection types, and de-select the connection 
types that you do not want to include in the System Diagram when the filter is toggled On.

To filter all connections types within any of the five categories, select the top-level check box.

Use the Select All button to select all connection types (so that they are all included in the view, 
even when the filter is toggled On).

Use the Clear All button to clear all selections (so that no connections are included in the view 
when the filter is toggled On).

2. Click OK to save the filter settings.

3. To apply the filter, select View > Filter Connections > Toggle Filter (or click the Toolbar button). Select 
this option again to turn the filter off.

When filtered out, the connection lines for a given type will not be visible on the diagram, and any 
diagram element connection point that is of the filtered out type will be shown in a “disabled” style.

If a connection point is filtered out, you will not be able to drag any connection lines to or from it; 
though any connections made by Auto-Connect when adding a new device will be allowed, but the 
connection lines will not be shown.

Removing Device Connections
To remove a device connection in the System Diagram:

1. Select a device in the System Diagram.

2. Select Device > Remove Connections (or select Remove Connections from the System Diagram context 
menu). You can also select a connection line and press Delete.

Changing the Connection Line Style
By default, all connection lines drawn in both the System Diagram and UI Diagrams are drawn as straight 
lines. Select View > Connection Style > Curves to change the line style to curves (FIG. 127): 

Alternatively, the Define Filter dialog can be accessed via the System Diagram 
context menu (select Filter Connections > Define Filter).

FIG. 127  Connection Line Styles
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Connection Node Types
Refer to the VisualArchitect online help for a description of each connection node type.

Replacing Devices
Replacing the Central Controller
VA requires that there is always one NetLinx Central Controller in each system.

Since you are not allowed to delete the Central Controller, you must use Replace to use a different type:

1. Select the device in the system diagram that you want to replace.

2. Select the device that you want to replace it with, in the Toolbox.

3. Select Edit > Replace (or select Replace Device from the Toolbox System Devices context menu).

Alternatively, you can drag-and-drop a replacement Central Controller from the Toolbox into the System 
Diagram:

1. Position the replacement Central Controller directly on top of the existing one to replace it.

2. When the replacement Controller is positioned correctly to replace the existing one, the Replace icon is 
displayed on the cursor (FIG. 128): 

3. When the Replace Icon appears, release the Controller that you are dragging, and it will replace the 
existing Central Controller.

It is important to note that depending on the differences between the original Central Controller and the 
one that is selected to replace it, some device connections may be lost.

For example, if you replace a NI-4000 - which features eight IR/Serial ports, with a NI-700 - which has 
one IR/Serial Port, you will lose IR/Serial Ports 2-8.

If you have devices connected to any ports on the original Controller that do not exist on the 
replacement Controller, the device connections will be lost for the missing ports, but the devices 
will remain in the System. However, if the replacement Controller has the same number of port 
types as the original, no device connections will be lost.

Also note that when you replace the Central Controller, device properties relative to connection 
type may be lost.

All Central Controllers are added to the system (including replacements) with the same default Connection 
Settings: 

Connection Type = TCP/IP

IP Address/Host Name = (none)

IP Port Number = 1319

Ping For Availability = true

Requires Authentication = false

If any of the settings were changed before the Central Controller was replaced, they will have to be re-entered 
(since the replacement Controller will apply the default settings).

This also holds true for the System Number assignment, which will return to the default setting of 
1.

Any Comments entered will carry over after replacing the Controller.

FIG. 128  Replacing the Central Controller
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Replacing Touch Panels
VA supports replacing a touch panel with another touch panel in the System Diagram. To accommodate 
differences between panel types, VA prompts you to choose from all applicable resolutions and compatible 
templates for the chosen replacement touch panel via options in the Replace Touch Panel dialog:

1. Select the touch panel in the System Diagram that you want to replace.

2. Select the touch panel with which you want to replace it from the Toolbox.

3. Select Edit > Replace (or select Replace Device from the Toolbox System Devices context menu).

4. At this point, the Replace Touch Panel dialog is invoked (FIG. 129). 

5. Use the options in this dialog to select a Resolution and Template from all applicable resolutions and 
compatible templates for the replacement touch panel.

If the chosen template for the replacement panel is the same as the template used by the original panel, 
there will be no loss of programming, configuration, or customization.

However, if the chosen template for the replacement touch panel differs from the one used by the original 
touch panel, VA will prompt you with a list of incompatibilities, in the Incompatibilities dialog.

6. Click OK to continue with the touch panel replacement operation, or click Cancel to cancel the operation 
and leave the original touch panel in place.

Alternatively, you can drag-and-drop a replacement touch panel from the Toolbox into the System Diagram:

1. Position the replacement touch panel directly on top of the existing one to replace it.

2. When the replacement touch panel is positioned correctly to replace the existing one, the Replace icon is 
displayed on the cursor (FIG. 130): 

3. When the Replace Icon appears, release the touch panel that you are dragging, and it will replace the 
existing touch panel.

4. At this point, the Replace Touch Panel dialog is invoked.

5. Use the options in this dialog to select a Resolution and Template from all applicable resolutions and 
compatible templates for the replacement touch panel (see above).

6. Click OK to continue with the touch panel replacement operation, or click Cancel to cancel the operation 
and leave the original touch panel in place.

Touch Panel Replacement - Incompatibilities
Where possible, the replacement touch panel will retain from the original touch panel navigation routing, 
navigation text, navigation programming, Feature/Sub-Feature usage and programming, element configuration 
properties, and UI-centric device programming.

The following are the exceptions that will cause incompatibilities:

FIG. 129  Replace Touch Panel dialog

FIG. 130  Replacing a Touch Panel
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If the replacement template differs from the original template, all UI customizations will be lost.

If the replacement template differs from the original template, all external button programming will 
be lost.

If the palette used by the original touch panel does not exist, by name, in the replacement template, 
the replacement template's default palette will be used.

If the replacement template does not have a set of device pages used by the original touch panel, a 
Placeholder will be used instead.

If the replacement template does not have a flow element (Mode, Navigation, or Sub-Navigation) 
with the same number of items as used by the original touch panel, it will be replaced by a like-type 
flow element with the closest number of items greater than the original. If no suitable replacement 
is found, the element will be removed.

Replacing Keypads
VA supports replacing a Keypad in the System Diagram with another Keypad.  VA will copy as much data as 
possible over to the new Keypad (CodeBuilder data, LCD Menu structure, Color, etc.) while at the same time 
preserving Button layout as much as possible. Before the replacement, VA will alert you if any 
incompatibilities or data will be lost, via the Incompatibilities dialog.

For instance, if the new Keypad does not support engraving, or if any CodeBuilder data would be lost because 
due to decrease in button count, VA will alert you before replacement, to give you the chance to cancel the 
operation. See the Keypad Replacement Table for details.

1. Select the Keypad in the system diagram that you want to replace.

2. Select the Keypad with which you want to replace it from the Toolbox.

3. Select Edit > Replace Device (or select Replace Device from the Toolbox System Devices context 
menu).

If the replacement Keypad is the same as the original Keypad, there will be no loss of programming, 
configuration, or customization.

However, if the replacement Keypad differs from the original Keypad, VA will prompt you with a list of 
incompatibilities, in the Incompatibilities dialog (FIG. 131). 

There is no sure way to replace one Keypad with another, especially when the new Keypad contains 
fewer buttons. Therefore, the Keypad Replacement Table is provided to document a clear direction of 
what will and will not be replaced for all Keypad combinations.

FIG. 131   Incompatibilities dialog 
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4. Click OK to continue with the Keypad replacement operation, or click Cancel to cancel the operation and 
leave the original Keypad in place.

Alternatively, you can drag-and-drop a replacement Keypad from the Toolbox into the System Diagram:

1. Position the replacement Keypad directly on top of the existing one to replace it.

2. When the replacement Keypad is positioned correctly to replace the existing one, the Replace icon is 
displayed on the cursor (FIG. 132): 

3. When the Replace Icon appears, release the Keypad ad that you are dragging, and it will replace the 
existing Keypad.

If the replacement Keypad is the same as the original keypad, there will be no loss of programming, 
configuration, or customization.

However, if the replacement Keypad differs from the original Keypad, VA will prompt you with a list of 
incompatibilities in the Incompatibilities dialog.

4. Click OK to continue with the Keypad replacement operation, or click Cancel to cancel the operation and 
leave the original keypad in place.

When devices are not compatible for replacement (for example, if they require incompatible connection 
types), the cursor icon indicates that replacement is not allowed (FIG. 133): 

Keypad Replacement Table
There is no sure way to replace one keypad with another, especially when the new keypad contains fewer 
buttons.  Therefore, the table below is provided to document a clear direction of what will and will not be 
replaced for all keypad combinations.

The right two columns show the button mapping.  For example, when replacing a single gang keypad with a 
double gang keypad with LCD, the table shows the following button mapping:  

Original Keypad 1..8     |       New Keypad 1..4, 13..16

This means buttons 1..4 of the original will be mapped (copied to) buttons 1..4 of the new keypad and buttons 
5..8 will be copied to buttons 13..16 of the new keypad. 

FIG. 132  Replacing a Keypad

FIG. 133  Replacing a Keypad - Replacement Not Allowed

Keypad Replacement

Keypad Replacement Scenario

CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

Original Keypad New Keypad

1..8 1..8

1 1
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Keypad Replacement (Cont.)

Keypad Replacement Scenario

CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

Original Keypad New Keypad

1..8 1..8

1..8 1..4, 13..16

1..8 9..16

1..6 1..6

1..8 1..6, 7Left, 7Right

1..8 1..8

1 1

1 1

1 1

1 5
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Keypad Replacement (Cont.)

Keypad Replacement Scenario
CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

1 5

1 1

1 1

1 1

1..8 1..8

1 1

1..16 1..16

1..4, 5, 13..16 1..4, 5, 13..16

1..16 9..24
115VisualArchitect Operation/Reference Guide 



System Design
Keypad Replacement (Cont.)

Keypad Replacement Scenario
CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

1..6 1..6

1..8 1..6, 7Left, 7Right

1..14 1..12, 13Left, 13Right

1..4, 13..16 1..8

5 1

1..4, 5, 13..16 1..4, 5, 13..16

1..4, 5, 13..16 1..4, 5, 13..16

1..4, 5, 13..16 9..12, 1, 21..24

1..4,  13..14 1..6

1..4, 13..16 1..6, 7Left, 7Right
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Keypad Replacement (Cont.)

Keypad Replacement Scenario
CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

1..4, 5, 13..16 1..9

9..16 1..8

1 1

9..24 1..16

9..12, 1, 21..24 1..4, 5, 13..16

1, 9..24 1, 9..24

9..14 1..6

9..16 1..6, 7Left, 7Right

9..22 1..12, 13Left, 13Right
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Keypad Replacement (Cont.)

Keypad Replacement Scenario
CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

1..6 1..6

1 1

1..6 1..6

1..6 1..4, 13..14

1..6 9..14

1..6 1..6

1..6 1..6

1..6 1..6

1..6, 7Left, 7Right 1..8

1 1
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Keypad Replacement (Cont.)

Keypad Replacement Scenario
CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

1..6, 7Left, 7Right 1..8

1..6, 7Left, 7Right 1..4, 13..16

1..6, 7Left, 7Right 9..16

1..6 1..6

1..6, 7Left, 7Right 1..6, 7Left, 7Right

1..6, 7Left, 7Right 1..8

1..8 1..8

1 1

1..12, 13Left, 13Right 1..14

1..9 1..4, 5, 13..16
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Replacing Remotes
VA supports replacing a R-1, R-2, or R-3 Remote in the System Diagram with another R-1, R-2, or R-3 
remote.

The replacement Remote will retain all button name, engraving, device mode (if applicable), and 
programming data from the original Remote.

1. Select the Remote in the System Diagram that you want to replace.

2. Select the Remote with which you want to replace it from the Toolbox.

3. Select Edit > Replace Device (or select Replace Device from the Toolbox System Devices context 
menu).

Alternatively, you can drag-and-drop a replacement Remote from the Toolbox into the System Diagram:

1. Position the replacement Remote directly on top of the existing one to replace it.

2. When the replacement Remote is positioned correctly to replace the existing one, the Replace icon is 
displayed on the cursor (FIG. 134): 

When the Replace Icon appears, release the remote that you are dragging, and it will replace the existing 
Remote.

When devices are not compatible for replacement (as is case with MIO R-4 Remotes), the cursor icon 
indicates that replacement is not allowed (FIG. 135): 

Keypad Replacement (Cont.)

Keypad Replacement Scenario
CodeBuilder Button Mapping, Button Name, and Engraving 
Features (If Supported)

1..12, 13Left, 13Right 9..22

1..6 1..6

1..8 1..6, 7Left, 7Right

1..12, 13Left, 13Right 1..12, 13Left, 13Right

The R-4 is considered by VA to be a "touch remote" and cannot be used to replace a 
"standard" Remote or a Touch Panel.

FIG. 134  Replacing a Remote
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Replacing Controlled Devices
VA supports replacing a controlled (third-party) device in the System Diagram with another device of the same 
type.

To replace a controlled device with another similar device from the Toolbox (Devices tab):

1. Click and drag a device from the Devices tab of the Toolbox into the System Diagram.

2. Position the selected device directly on top of the device that you want to replace.

3. Assuming the devices are of the same device type, when the replacement device is positioned correctly to 
replace the existing one, the Replace icon is displayed on the cursor. When the Replace Icon appears, 
release the device that you are dragging, and it will replace the existing one (FIG. 136). 

If the devices are not compatible for replacement, the cursor icon indicates that replacement is not allowed 
(FIG. 137): 

Alternatively, you can use the Replace Device option in the Toolbox System Devices context menu:

1. Select the device in the System Diagram that you want to replace.

2. Select the device that you want to replace it with, in the Toolbox.

3. Select Edit > Replace Device (or select Replace Device from the Toolbox System Devices context 
menu). This option is only enabled if the devices are of the same device type and compatible for 
replacement.

It is important to note that device properties relative to connection types may be lost:

All devices are added to the System with the default connection settings for that device's connection 
type. For example, by default all RS-232/422/485 devices are added with RS-232 set as the 
Connection Type. So, if any of the default settings were changed before the device is replaced, the 
properties for the replacement device will need to be re-entered.

Input mapping information may also be lost when a controlled device is replaced, since each device 
is likely to have different I/O options.

Note that any Comments entered will carry over after replacing the device.

FIG. 135  Replacing a Remote - Replacement Not Allowed

FIG. 136  Replacing a Controlled Device

FIG. 137  Replacing a Controlled Device - Replacement Not Allowed
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Duplicating Devices
Duplicating Touch Panels
VA supports the ability to create a functional duplicate of a touch panel already defined and used in the project, 
via the Edit > Duplicate menu item or the Duplicate item in the System Diagram context menu when a touch 
panel is selected on the System diagram.

1. Select a touch panel in the System Diagram.

2. Select Edit > Duplicate (or right-click on the selected touch panel and select Duplicate from the System 
Diagram context menu). This action invokes the Duplicate Touch Panel dialog (FIG. 138). 

3. Select the type of Touch Panel to use for the duplicate panel. Click the Browse (...) button to view 
thumbnails of all supported touch panels in the Select Control Device dialog (FIG. 139). 

4. Select the screen Resolution for the duplicate panel (if you have selected a touch panel that supports 
multiple screen resolutions).

5. Select the Template to use on the duplicate panel. Click the Browse (...) button to view thumbnails of all 
available templates in the Select User Interface Template dialog (FIG. 140). 

FIG. 138  Duplicate Touch Panel dialog

FIG. 139  Select Control Device dialog
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6. Click OK to close the Duplicate Touch Panel dialog.

If you select the exact same template that is used by the source touch panel, the new touch panel will be 
an exact copy with no information lost. However, if the template selected for the duplicate touch panel 
differs from that used by the source panel, this operation is subject to the same incompatibilities described 
in the Replacing Touch Panels section on page 111.

If incompatibilities are found, VA will present the Incompatibilities dialog (see FIG. 131 on page 113), in 
which you can view the list of incompatibilities, and either proceed or cancel the operation.

Duplicating DMS Keypads
VA supports the ability to create a functional duplicate of a DMS Keypad already defined and used in the 
project, via the Edit > Duplicate menu item or the Duplicate item in the System Diagram context menu when 
a DMS Keypad is selected on the System diagram:

1. Select a DMS Keypad in the System Diagram.

2. Select Edit > Duplicate (or right-click on the selected Keypad and select Duplicate from the System 
Diagram context menu). This action invokes the Duplicate DMS Keypad dialog (FIG. 141).

3. Select the type of Touch Panel (in this case, a Keypad)  to use for the duplicate Keypad. Click the Browse 
(...) button to view thumbnails of all supported DMS Keypads in the Select Control Device dialog.

4. Click OK to close the Duplicate DMS Keypad dialog.

FIG. 140  Select User Interface Template dialog

FIG. 141  Duplicate DMS Keypad dialog
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Duplicating R-4 Remotes
VA supports the ability to create a functional duplicate of an MIO R-4 Remote already defined and used in the 
project, via the Edit > Duplicate menu item or the Duplicate item in the System Diagram context menu when 
an MIO R-4 Remote is selected on the System diagram:

1. Select an R-4 Remote in the System Diagram.

2. Select Edit > Duplicate (or right-click on the selected R-4 Remote and select Duplicate from the System 
Diagram context menu). This action invokes the Duplicate Remote dialog (FIG. 142)..

3. Click OK to close the Duplicate Remote dialog.

System Diagram context menu
Right-click anywhere inside the System Diagram to access the System Diagram context menu. Refer to the VA 
online help for descriptions of the options in the context menu.

FIG. 142  Duplicate Remote dialog
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UI Design

Overview
A separate UI tab is added for each User-Interface device added to the system. Use these tabs to design the 
navigation layout for each of the UI devices. 

FIG. 143  UI Diagrams

Touch Panel
UI Diagram

Keypad
UI Diagram

Remote
UI Diagram
125VisualArchitect Operation/Reference Guide 



UI Design
For each Touch Panel and R-4 in the system, there is a Touch Panel UI tab, which displays the UI 
diagram for each panel. See the Defining the UI - Touch Panels section on page 144.

For each Keypad in the system, there is a Keypad UI tab, which displays the Keypad Diagram for 
each keypad. See the Defining the UI - Keypads section on page 159.

For each Remote in the System, there is a Remote UI tab, which displays the Remote Diagram for 
each remote. See the Defining the UI - Remote Controllers section on page 169.

The navigation that is established here will be reflected in the resulting Touch Panel, Keypad, and Remote 
templates generated by VA. 

Adding UI Elements To The UI Diagram
The first step in defining the UI for a panel-equipped UI device (Touch Panel, R-4 remote or DMS Keypad) is 
to add UI Elements to the UI Diagram. 

This includes selecting the elements (pages and popup pages) that you want in the UI, adding them to the UI 
diagram, connecting elements (to establish) the flow from one page to the next, and configuring UI element 
properties.

Notes:

You must select a template for the panel (via the Template option in the Properties window) to 
populate the UI element tabs in the Toolbox with selections.

You must install at least one template (via the User Interface Template Manager dialog) to have a 
template available to apply to your panel.

1. In the Toolbox, click on an UI element tab to display the UI elements of that type available to choose 
from, within the template currently applied to this panel (FIG. 144). 

2. Select the desired UI element and drag-and-drop it into the UI diagram. Each element in the UI diagram 
is represented by a UI element.

FIG. 144  Toolbox (with a UI tab selected in the Diagram area))

Click to collapse the Mode Selection (UI elements) view

Click to expand the Navigation (UI elements) view

Click to expand the Sub-Navigation (UI elements) view

Click to expand the Features (UI elements) view

Click to expand the Sub-Features (UI elements) view

Click to expand the Placeholders (UI elements) view

Click to expand the Devices view
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Mode Selection Elements - Select a Mode Selection element with the number of modes that you 
want to define. Mode Selection elements can define from 2 to 8 mode selections.

Navigation Elements - Select a Navigation element with the number of devices that you want to 
allow access to. Navigation elements can support up to 8 devices per page.

Sub-Navigation Elements - Select a Sub-Navigation element with the number of devices that you 
access from the page. Sub-Navigation elements can support up to 8 devices per page.

Placeholder Elements - These elements provide empty pages to which functionality can be added 
in TPDesign4 after the panel project is generated. As such, you can include one or more of these in 
their project as if it were a device interface. Note that each placeholder must be named uniquely.

3. Connect the UI Elements to each other, to establish flow between pages. Different UI element types have 
different connection requirements.

4. Review the UI element properties for this element and edit if necessary.

Connection Nodes - UI Elements
Each Touch Panel UI Element has Connection Nodes on either side that allow each UI Element to be 
connected to other UI Elements in the Panel UI Diagram (FIG. 145). 

The node on the left side of the UI Element is the Input (IN) Node, and accepts incoming 
connections from other UI Elements.

The nodes on the right side of the UI Element are Output (OUT) Nodes, and provide outgoing 
connections to other UI Elements.

Connecting Elements In The UI Diagram
Each element in the UI diagram has at least two Connection Nodes. Connection nodes represent connections 
between elements (pages) in the Touch Panel UI. UI element connections are established by creating lines 
from one element's Output connection node to another element's Input connection node.

1. In the UI diagram, left-click and hold on the output node of a desired device element.

2. Drag your mouse over a valid input connection node on another UI element, or the required intermediate 
device (such as an Expansion or Networking device) that allows the device to connect to the Central 
Controller.

The cursor will change to indicate which nodes are not permitted for the type of connection you are attempting 
(FIG. 146): 

FIG. 145  UI Elements - Connection Nodes

FIG. 146  Connecting UI Elements

Connection Node (OUT)Connection Node (IN)

Connection Nodes (OUT)

Connection Node (IN)
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Connection Lines - UI Diagram
The connection lines used on UI diagrams are color-coded to indicate the type of UI Element the connection is 
being made to.  

Unique colors are used when a connection is being made to a Mode, Navigation, Sub-Navigation, Device, 
Placeholder, Feature, Sub-Feature, or back to the Start Device node: 

Removing UI Element Connections
To remove a UI element connection:

1. Select an element in the UI diagram and right-click to open the UI Diagram context menu.

2. Select Remove Connections.

Changing the Connection Line Style
Refer to Changing the Connection Line Style section on page 109.

UI Element Types
UI Element Type - Start Device
Initially, the only UI Elements in a Touch Panel UI Diagram are the third-party devices that have been added to 
the system, and the Start Device.

The Start Device represents the Touch Panel for which you are designing the UI in this UI Diagram, and 
represents the starting point for the UI. In other words, the Start Device represents the "Home Page" on the 
Touch Panel. Other UI Elements connect to the Start Device Element to establish paths of navigation within 
the Touch Panel UI.

Start Device UI elements have one Input (IN) Connection Node on the left side, and one Output (OUT) 
Connection Node on the right side (FIG. 147): 

Use the IN Connection Node on the Start Device element to create one or more paths for the end-user to return 
to the Home Page.

The path back to the Start Device can only be made from a Mode Selection element, or from a Navigation (or 
Sub-Navigation) element.

You can create this path back to the Start Device page from more than one Mode Selection or Navigation 
element. Depending on the overall layout of the UI, you might consider creating multiple paths back to the 
Home Page (FIG. 148): 

Connection Lines - UI Diagram

Connection Type Connection Line Color

• Mode Selection green

• Navigation cyan

• Sub-Navigation cyan

• Features blue

• Sub-Features blue

• Placeholders white

• Devices light brown

Alternatively, you can select Remove Connections from the Device menu. You can 
also select a connection line and press Delete.

FIG. 147  UI Element Type - Start Device

Start Device (Touch Panel) name

Connection Node (OUT)Connection Node (IN)
from Mode Selection, Navigation

or Sub-Navigation UI Element
to Mode Selection, Navigation
or Sub-Navigation UI Element
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Use the OUT Connection Node on the Start Device to connect the Home Page to either a Mode Selection UI 
Element or a Navigation UI Element.

UI Element Type - Mode Selection
Mode Selection elements provide the end user the ability to select from multiple modes on the panel 
(FIG. 149). 

Modes are used to separate areas of the Touch Panel UI, so that you don't have to try to fit a device button for 
every device in the system on a single Navigation page. Modes can be used for several purposes, including:

To separate functionality - for example, one Mode could provide access to all A/V equipment, 
while a different mode could be used for non-A/V equipment.

To separate zones - in a system that includes equipment that is installed in four separate areas, you 
could assign each zone to its own Mode.

To customize panel layout - modes can be used to provide a separate UI for different individuals. 
For example, Dad has his own mode that provides to access to the equipment that he wants to 
control, while Mom has a different mode that provides access to devices that she is interested in 
using. You could even set up a mode for the kids that allows them to control some limited set of 
devices like the TV and DVD player.

These are only a few basic examples, and modes can be used to accomplish any combination of 
these and more, depending on your job requirements.

Consider using one of the exit nodes on the Mode and Navigation elements to connect back to the 
Start Device. This will provide the end-user with a button that brings them back to the Start page 
(see FIG. 148 on page 129).

UI Element Type - Navigation
Navigation (Nav) elements provide the end user the ability to select a third-party device to control. Navigation 
elements are panel pages containing a buttons that represent each controlled device in the system (FIG. 150).  

FIG. 148  Creating a Return To Home

FIG. 149  UI Element Type - Mode Selection ("Mode 4" shown)

Mode Selection UI Element name

Connection Nodes (OUT)

Connection Node (IN)
from Start Device, Mode Selection,

to Start Device, Mode Selection,
Navigation, or Sub-Navigation 

Navigation, or Sub-Navigation
UI Element

UI Element

Mode Selection UI Elements may be replaced by dragging a new one into the UI 
diagram. This saves time by replacing all connections automatically - see Replacing 
UI Elements on page 143 for details.

FIG. 150  UI Element Type - Navigation ("Nav 4" shown)

Navigation UI Element name

Connection Nodes (OUT)

Connection Node (IN)
from Start Device, Mode Selection,

to Start Device, Mode Selection,
Navigation, Sub-Navigation, Features, 

Navigation, or Sub-Navigation
UI Element

Placeholder or Device UI Element
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If your panel is designed for a single-mode system (does not utilize Mode Selection UI Elements), 
then the Navigation pages are accessed directly from the Start device element.

If your panel uses multiple modes, then each Mode would provide access a separate Navigation 
element.

Sub-Navigation UI Elements provide a method of presenting additional functionality to Navigation 
Elements in cases where you need more room than the Navigation UI Element provides.

Device UI Elements can be connected directly to Mode Selection UI Elements, providing access to 
Device Control pages, directly from the Navigation Page.

Consider using one of the output (OUT) nodes on Navigation Selection UI Elements to connect 
back to the Start Device. This will provide the end-user with a button that brings them back to the 
Start page.

UI Element Type - Sub-Navigation
Sub-Navigation elements provide a method of presenting additional functionality to Navigation Elements in 
cases where you need more room than the Navigation element provides.

Device UI Elements can be connected directly to Sub-Navigation UI Elements, providing access to 
Device Control pages, from the Sub-Navigation Page.

Consider using one of the output (OUT) nodes on Sub-Navigation UI Elements to connect back to 
the Start Device. This will provide the end-user with a button that brings them back to the Start 
page.

UI Element Type - Features
Features UI Elements represent panel pages containing buttons that provide specific device functions, 
including ComputerControl, TakeNote, Macro Buttons and Video Window (FIG. 151). 

Features elements provide the end user the ability to access a specific set of features for a third-party 
controlled device.

UI Element Type - Sub-Feature
Sub-Features elements are popup pages that provide specific feature sets (i.e., Volume Controller) that can be 
applied to device UI pages (FIG. 152). 

Navigation UI Elements may be replaced by dragging a new one into the UI diagram. 
This saves time by replacing all connections automatically - see Replacing UI 
Elements on page 143 for details.

Sub-Navigation UI Elements may be replaced by dragging a new one into the UI 
diagram. This saves time by replacing all connections automatically - see Replacing 
UI Elements on page 143 for details.

FIG. 151  UI Element Type - Feature

FIG. 152  UI Element Type - Sub-Feature

Features UI Element name

Connection Node (OUT)
Connection Node (IN)

from Navigation, or Sub-Navigation
to Sub-Feature UI ElementUI Element

Sub-Feature UI Element name

Connection Node (IN)
from Features UI Element
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UI Element Type - Placeholder
Placeholder elements provide empty pages to which functionality can be added in TPDesign4 after the panel 
project is generated. Placeholders can be thought of as specialized device interfaces that have no function. 

UI Element Type - Device Elements
Device Elements represent the device-specific pages in the UI. Device Elements provide access to the 
controlled functions of each device in the system (FIG. 154). 

UI Element Properties
When a UI element is selected in a UI Diagram, detailed information for that UI element is displayed in the 
Properties window. The rows displayed this table will vary depending on the nature of the selected UI element.

Using Quick Input
Select Quick Input from the Edit menu (or the System Diagram context menu or Panel UI Diagram context 
menu) to access the Quick Input sub-menu.

The Quick Input setting allows you to enter a particular device or UI element property, without having to select 
the property in the Properties Window.

Use the Edit > Quick Input submenu to specify which device property to assign Quick Input to. The options 
are:

Name (default setting): With this option selected, you can select a device and type to change that 
device's name.

Current Property: Highlight any device property (in the Properties window) and select Current 
Property to assign the selected property to Quick Input.

For example, select the Device Number property (in the Properties window), and select Current 
Property from the Quick Input sub-menu, then any time you select a device in the System Diagram, 
you can just type and press the Enter key to enter a device number for the selected device.

Note that VA will prompt you if the value entered is outside of the allowed range for the selected 
property.

Disabled: This option disables the Quick Input feature.

UI Element Properties - Start Device Element
The Start Device represents the Touch Panel or MIO R-4 remote for which this project is being designed.

An example Start Device element for a MVP-5200i touch panel is shown below (FIG. 155): 

The parameters for the Start Device Element are set via fields in the Properties window (FIG. 156): 

FIG. 153  UI Element Type - Placeholder

Placeholder UI Element name

Connection Node (IN)
from Navigation or Sub-Navigation

Connection Node (OUT)
to Sub-Feature UI Element

UI Element

All Placeholders must be named uniquely.

FIG. 154  UI Element Type - Device Element

FIG. 155  UI Element Type - Start Device (MVP-5200i)

Device UI Element name

Connection Node (IN)
from Navigation or Sub-Navigation

Connection Node (OUT)
to Sub-Feature UI Element

UI Element
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When the Start Device element is selected in a UI diagram, the Properties window is populated with the 
following properties: 

UI Element Properties - Mode Selection
Mode Selection elements provide panel pages used specifically for selecting between two or more modes on 
the panel (FIG. 157). 

The parameters for Mode Selection UI Elements are set via fields in the Properties window (FIG. 158): 

FIG. 156  UI Element Properties - Start Device

UI Element Properties - Start Device

• Name See page 140.

• Comments See page 137.

• Category See page 137.

• Model Number See page 139.

• Color See page 137.

• FG Number See page 138.

• MSRP See page 139.

• Device Number See page 137.

• IP Address/Host Name See page 139.

• Template See page 140.

• Color Scheme See page 137.

• Skin See page 140.

• Unicode Font See page 140.

FIG. 157  UI Element Type - Mode Selection

FIG. 158  UI Element Properties - Mode Selection
132 VisualArchitect Operation/Reference Guide



UI Design
When a Mode Selection element is selected in a UI diagram, the Properties window is populated with the 
following properties: 

UI Element Properties - Navigation
Navigation elements provide panel pages that provide access to other elements in the UI diagram (FIG. 159). 

The parameters for Navigation UI Elements are set via fields in the Properties window (FIG. 160): 

When a Navigation element is selected in a UI diagram, the Properties window is populated with the following 
properties: 

UI Element Properties - Mode Selection

• Name See page 140.

• On-Screen Name See page 140.

• Comments See page 137.

• Category See page 137.

• Template Element See page 140.

• Device Port Number See page 137.

Items

• Item 1... See page 139.

FIG. 159  UI Element Type - Navigation

FIG. 160  UI Element Properties - Navigation

UI Element Properties - Navigation

• Name See page 140.

• On-Screen Name See page 140.

• Comments See page 137.

• Category See page 137.

• Template Element See page 140.

• Device Port Number See page 137.

Items

• Item 1... See page 139.
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UI Element Properties - Sub-Navigation
Sub-Navigation elements provide panel pages that provide access to other elements in the UI diagram.

When a Sub-Navigation element is selected in a UI diagram, the Properties window is populated with the 
following properties: 

UI Element Properties - Features
Feature elements provide panel pages containing buttons that represent specific functions (including 
ComputerControl, TakeNote, Video Window and Macro Buttons) in the UI diagram. Features elements also 
provide the end user the ability to access a specific set of features for a third-party controlled device 
(FIG. 161). 

The parameters for Feature UI Elements are set via fields in the Properties window (FIG. 162): 

When a Feature element is selected in a UI diagram, the upper portion of the Properties window is populated 
with the following properties: 

The lower portion of the window presents Feature-specific options:

Features UI Element Properties - ComputerControl (see Feature Property - ComputerControl on 
page 141)

Features UI Element Properties - TakeNote (see Feature  Property - TakeNote on page 142)

UI Element Properties - Navigation

• Name See page 140.

• On-Screen Name See page 140.

• Comments See page 137.

• Category See page 137.

• Template Element See page 140.

• Device Port Number See page 137.

Items

• Item 1... See page 139.

FIG. 161  UI Element Type - Features

FIG. 162  UI Element Properties - Features

UI Element Properties - Features

• Name See page 140.

• On-Screen Name See page 140.

• Comments See page 137.

• Category See page 137.

• Template Element See page 140.

• Device Port Number See page 137.
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Features UI Element Properties - Video Window (see Feature Property - Video Window on 
page 142)

Use the options in the Customize UI Pages dialog to edit the default Features pages as desired.

UI Element Properties - Sub-Features
Sub-Feature elements provide panel pages provide specific feature sets (i.e., Volume Control) that can be 
applied to device UI pages (FIG. 163). 

The parameters for Sub-Feature UI Elements are set via fields in the Properties window (FIG. 164): 

When a Sub-Feature element is selected in a UI diagram, the upper portion of the Properties window is 
populated with the following properties: 

UI Element Properties - Placeholder
Placeholder elements provide empty pages to which functionality can be added in TPDesign4 after the panel 
project is generated. Placeholders can be thought of as specialized device interfaces that have no function. As 
such, you can include one or more of these in their project as if it were a device interface (FIG. 165). 

The parameters for Placeholder UI Elements are set via fields in the Properties window (FIG. 166): 

When a Placeholder  element is selected in a UI diagram, the upper portion of the Properties window is 
populated with the following properties:

 

FIG. 163  UI Element Type - Sub-Features

FIG. 164  UI Element Properties - Sub-Features

UI Element Properties - Sub-Features

• Name See page 140.

• On-Screen Name See page 140.

• Comments See page 137.

• Category See page 137.

• Template Element See page 140.

• Device Port Number See page 137.

FIG. 165  UI Element Type - Placeholder

FIG. 166  UI Element Properties - Placeholder
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UI Element Properties - Device Elements
Device elements contain the UI for each controlled device in the system (FIG. 167). 

The parameters for Device UI Elements are set via fields in the Properties window (FIG. 168): 

When a Device element is selected in a UI diagram, the Properties window is populated with the following 
properties: 

UI Element Properties - Sub-Features

• Name See page 140.

Note: All placeholders must be named uniquely.

• On-Screen Name See page 140.

• Comments See page 137.

• Category See page 137.

• Template Element See page 140.

• Device Port Number See page 137.

FIG. 167  UI Element Type - Device Elements

FIG. 168  UI Element Properties - Device Elements

UI Element Properties - Device Elements

• Name See page 140.

• On-Screen Name See page 140.

• Comments See page 137.

• Category See page 137.

• Manufacturer See page 139.

• Model Number See page 139.

• Template Element See page 140.

• Device Port Number See page 137.
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UI Element Properties 

UI Element Properties

Button Name The button name is for use within VA only, and is intended to assist in developing 
unique descriptive names.

This is not the text that will be engraved on the button (see Engraving Text on 
page 138).

Note: This property applies only to MIO-R-1, R-2 and R-3 Remotes.

Category The VA device category of this Controller (read-only).

Note that the Category field is displayed as both a Device property and a UI Element 
property.

Color Click to access the drop-down menu, and select from a listing of color options 
available for this device.

Note that this selection is automatically reflected in the FG Number field.

Note that the Color field is displayed as both a Device property and a UI Element 
property.

Color Scheme Once a Template has been selected, this field is enabled. Click to access the drop-
down menu and select a color theme to apply to the selected template.

Color themes can be used in conjunction with Templates and Skins to easily create 
custom UI page layouts.

The Color Scheme affects the text and background area of the selected Template.

Note that the Color Scheme field is displayed as both a Device property and a UI 
Element property.

Comments Click to add developer's comments regarding this device.

Once comments have been added to a device, a yellow comment icon is added to 
the Device Element in the System Diagram (or the Start Element in a UI Diagram), 
and the comments are displayed when the cursor hovers over the element: 

Note that the Comments property is displayed as both a Device property and a UI 
Element property.

Device Mode This field allows you to specify a device to be controlled with the remote with any of 
the bottom six buttons on the remote.

Select the device mode from the drop-down menu of devices in your system. Note 
that this field is only available when one of the lower six button is selected in the 
Remote UI.

Note: This property applies only to MIO-R-1, R-2 and R-3 Remotes.

Device Number Central Controllers: The current Device Number setting for this Controller 
(default = 0).

• Other devices: The current Device Number setting for this device (see Device 
Number Defaults on page 75.

• Note that the Device Number field is displayed as both a Device property and a UI 
Element property.

Device Port Number The Touch Panel's default device port number assignment (click to edit).

The first UI Element added to the UI Diagram is assigned default Device Port 
Number 10; each one added thereafter increments it's default Device Port Number 
by +10 (20, 30, 40, etc).
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UI Element Properties (Cont.)

Engraving Font Select AMX Icon 2 (for symbols), or Arial, Arial Narrow or Arial Unicode MS for text 
from the drop down menu.

AMX Icon 2 provides various control-oriented icons that can be engraved on the 
buttons.

The VA Engraving module supports the fonts included in the supported OS (System) 
languages. You must have the language loaded on your OS and then use Arial 
Unicode MS to render the text on the button.

Note: This property applies only to MIO-R-1, R-2 and R-3 Remotes.

Engraving Scale Select a scale factor to apply to the engraved text on the selected button 
(default = 1.0, or 100%).

Click inside the text field to enable Up and Down arrows to scale the selected button 
text up or down, in .1 (or 10%) increments.

• 0.5 = 50%

• 0.6 = 60%

• 0.7 = 70%

• 0.8 = 80%

• 0.9 = 90%

• 1.0 = 100% (default)

• 1.1 = 110%

• 1.2 = 120%

• 1.3 = 130%

• 1.4 = 140%

• 1.5 = 150%

Note: This property applies only to MIO-R-1, R-2 and R-3 Remotes.

Engraving Text Enter the text that you want to have engraved on the selected button in this text field. 
To enter text, click inside the text field and type directly into the field.

Alternatively, click on the browse button (...) to access the Enter Text dialog - enter 
the button text and click OK to save.

Note: In addition to the 10 character limit in the KeypadBuilder application, the 
maximum number of characters allowed is based on font choice as well as size and 
specific characters used.

Note: This property applies only to MIO-R-1, R-2 and R-3 Remotes.

FG Number The AMX "Finished Goods" number associated with this device (read-only).

Note that the FG Number field is displayed as both a Device property and a UI 
Element property.
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UI Element Properties (Cont.)

Items The Items list at the bottom of the Properties window indicates the UI Elements and 
controlled devices that are connected to the selected UI element.

When other UI Elements are connected to the selected Element, each connected 
Element's Name is added to the slot associated with the node to which it is 
connected. For example, a Mode 4 Mode Selection element with connections to 
three Navigation elements and to the Start Device element (as shown below), 

Will indicate Nav 2, Nav3, Nav2 and Start in the Items list: 

When controlled devices are connected to this element, the default device names 
(Manufacturer and Model Number) are added to the Item slots for easy identification 
(click to edit). For example, a Nav 2 Navigation  element with connections to two 
device elements (as shown below), 

Will indicate the connected devices  in the Items list: 

Note that when you edit an Item name, the new name is reflected in the selected 
device element (in the UI diagram).

IP Address/Host Name Enter an IP address (or Host Name if applicable) for this device.

Note that the IP Address/Host Name field is displayed as both a Device property and 
a UI Element property.

Manufacturer This field indicates the name of the selected device's manufacturer (read-only).

Model Number The product model number of this device (read-only).

Note that the Model Number field is displayed as both a Device property and a UI 
Element property.

MSRP The AMX Manufacturer's Suggested Retail Price for this device (read-only).

Note that the MSRP field is displayed as both a Device property and a UI Element 
property.
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UI Element Properties (Cont.)

Name Start Device - The (default) system name for the UI (Start Device) element (click to 
edit). Note that for the Start Device, the UI Element Name is the same as the Device 
Name.

All other UI Elements - The (default) system name for the selected UI element.

Note: It only appears on the UI diagram, it is not displayed on the generated Touch 
Panel page.

On-Screen Name This field allows you to specify a On-Screen Name for this UI element (click to edit).

The On-Screen Name is displayed on the panel page that this element represents.

Click inside this row to enter a View Name (which may contain Unicode characters) 
in the Enter View Name dialog.

When you add a On-Screen Name to an element, the On-Screen Name is indicated 
in parenthesis beneath the Name on this element (in the UI diagram).

Typically, the On-Screen Name is used to enter Unicode text for display on the panel, 
or to leave the system name of a device to as the default 'Manufacturer Model 
Number' (e.g., 'Marantz DV9500) while displaying a different name on the panel 
(e.g., 'DVD').

Skin Once a Template has been selected, this field is enabled. Click to access the 
drop-down menu and select a Skin to apply to the selected template.

Skins can be used in conjunction with Templates and Color Schemes to easily create 
custom UI page layouts.

Skins allow you to further customize your UI page layout by easily changing the 
appearance of the Menu area of the page, without altering the Template or Color 
Scheme selections.

Note that the Skin field is displayed as both a Device property and a UI Element 
property.

Template Click inside this field to access the drop-down menu and select a template to apply 
to this panel.

Note: VA only presents templates that include a resolution supported by the selected 
panel.

Click Browse to access the Select User Interface Template dialog.

Note that the Template field is displayed as both a Device property and a UI Element 
property.

Template Element • Navigation UI Elements: The selection's UI element type (read-only).

• Device UI Elements: Click to select the template element type from the drop-down 
list that best describes the type of device selected. The options in the drop-down 
list reflect the device types listed in the Devices tab of the Toolbox.

Unicode Font This field is enabled only after a Template has been selected. Click to access the 
drop-down menu and select a font to use with the selected template.

• Note that you can scroll through the font list by double-clicking in the text field.

• Note that the Unicode Font field is displayed as both a Device property and a UI 
Element property.
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Feature Property - ComputerControl
When a ComputerControl (Feature) UI Element is selected in the UI Diagram, the following properties are 
presented in the lower portion of the Properties window (FIG. 169):      

Use the options in the Customize UI Pages dialog to edit the default Features pages as desired.

FIG. 169  UI Element Feature Property - ComputerControl

UI Element Feature Property - ComputerControl

ComputerControl Configuration

• Remote Host Enter the IP Address of the PC running the VNC client used by 
ComputerControl.

• Remote Port Enter the port number used by the VNC client (default = 5900).

• Password Enter the Password required by the VNC client (if required).

• Color Depth Select either high color (16-bit), or true color (24-bit). The default setting is 
16-bit.

• Compression Select whether to enable compression on the ComputerControl image to fit 
the target touch panel (Yes or No, default = No).

• Scale To Fit Select whether to scale the ComputerControl image to fit the target touch 
panel (Yes or No, default = No).

• TakeNote Enabled Select whether ComputerControl is TakeNote enabled (Yes or No, 
default = No).

Button Configuration

• LEFT-CLICK Address Code Enter the address code to be assigned to the "Left-Click" button in the 
ComputerControl touch panel page.

• CENTER-CLICK Address Code Enter the address code to be assigned to the "Center-Click" button in the 
ComputerControl touch panel page.

• RIGHT-CLICK Address Code Enter the address code to be assigned to the "Right-Click" button in the 
ComputerControl touch panel page.

• KEYBOARD Address Code Enter the address code to be assigned to the "Keyboard" button in the 
ComputerControl touch panel page.

• DOUBLE-CLICK Address Code Enter the address code to be assigned to the "Double-Click" button in the 
ComputerControl touch panel page.
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Feature  Property - TakeNote
When a TakeNote (Feature) UI Element is selected in the UI Diagram, the following properties are presented 
in the lower portion of the Properties window (FIG. 170):      

Feature Property - Video Window
When a Video Window (Feature) UI Element is selected in the UI Diagram, the following properties are 
presented in the lower portion of the Properties window (FIG. 171):      

Removing UI Elements
There are several ways to remove UI Elements from the UI Diagram:

Right-click on an element in the UI diagram and select Delete from the UI Diagram context menu.

Select an element in the UI diagram and select Delete from the Edit menu.

Select an element in the UI diagram and click the Delete Toolbar button.

Select an element in the UI diagram and press the Delete key.

The program will prompt you to verify this action before the device is removed from the system.

FIG. 170  UI Element Feature Property - TakeNote

UI Element Feature Property - TakeNote

Graphic - BACKGROUND Configuration

• Graphic BACKGROUND Configuration

• TakeNote Host Enter the IP Address of the PC running the VNC client used by ComputerControl and 
TakeNote.

• TakeNote Port Enter the port number used by the VNC client (default = 1541).

FIG. 171  UI Element Feature Property - Video Window

UI Element Feature Property - Video Window

Video Preview Configuration

• Video Fill Select video signal type (Composite, Component/RGB, Streaming Video or None) 
from the drop-down menu (default = Composite)

• Video Cropping Select a video cropping option from the drop-down menu (default = 4:3/16:9 
Anamorphic). 

This option is only presented if Composite or Component/RGB are selected as the 
Video Fill.

• Video Touch Pass-Thru Select wether to enable video touch pass-thru on this video window button 
(default = no). 

This option is only presented if Composite or Component/RGB are selected as the 
Video Fill.

Click the Don't Show Again option in the Remove Element dialog to avoid being 
prompted again.  You can reactivate this prompt at any time via the Help > Reset 
Message Boxes option.
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Replacing UI Elements
VA supports replacing a Mode, Navigation, or Sub-Navigation UI Element on a UI diagram with another 
element of the same type.

To replace a Mode, Navigation, or Sub-Navigation element:

1. Click and drag a UI element from the Toolbox into a UI Diagram.

2. Position the selected UI element directly on top of the element that you want to replace.

3. Assuming the elements are of the same type, when the replacement element is positioned correctly to 
replace the existing one, the Replace icon is displayed on the cursor.

When the Replace Icon appears, release the element that you are dragging, and it will replace the existing 
one (FIG. 172): 

If the elements are not compatible for replacement, the cursor icon indicates that replacement is not 
allowed (FIG. 173): 

Alternatively, you can use the Replace Element option in the Toolbox User Interfaces context menu:

1. Select the element in the UI Diagram that you want to replace.

2. Select the element that you want to replace it with, in the Toolbox.

3. Select Edit > Replace (or select Replace Element from the Toolbox User Interfaces context menu).

It is important to note that depending on the differences between the original UI element and the one that is 
selected to replace it, some UI element properties may be lost.

If the replacement element has an equal or greater number of connections, all connections, 
connection names, comments and CodeBuilder data will be carried over to the replacement element 
in the order they existed on the original element.  

If the replacement element has fewer number of connections, the original connection data will be 
transferred to the replacement in order, skipping unused connections, until all available connections 
in the replacement have been used.  After which, any remaining connections in the original element 
will be lost.

FIG. 172  Replacing UI Elements

FIG. 173  Replacing UI Elements - Replacement Not Allowed

This option is only enabled if the elements are compatible for replacement.
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Defining the UI - Touch Panels
Defining the UI - Touch Panels
For every panel-equipped UI device (Touch Panel, R-4 remote or DMS Keypad) added to the System 
Diagram, a Panel UI tab is created. This is where you will create a UI diagram that defines the layout and 
navigation of the panel pages and buttons that provide the GUI for the end-user.

As a basic example of Touch Panel navigation, each panel has a start page that is displayed when the panel is 
powered up. The start page will typically contain several buttons that, when pushed by the user, will flip to 
other pages on the panel. A very simple scenario would be to have buttons on the Start page that provide 
access to device-specific pages. In this case, the user might be presented with four buttons:

CD Player, DVD Player, Display and Sound System. When the user presses the CD Player button, the device 
page for the CD Player is invoked, allowing the user to control the CDP via the control buttons on that page. 
Similarly, the DVD Player button would open the DVD Player's device page with transport controls for that 
device. Likewise, the Display and Sound System buttons would take the user to the Display device page and 
the Sound System device page.

More typically, Panel UI navigation can be more complex, to accommodate multiple modes and zones of 
control within the system. For more complex systems, the Start page might contain buttons that take the user to 
Mode Selection pages to allow them to select from two or more control modes (for example to separate A/V 
equipment from HVAC equipment), rather than directly to a device page.

In many cases, controlled devices are too complex to represent all of their functions on a single Touch Panel 
page. In these cases, you might choose to use multiple pages to organize device functions in a way that makes 
it easy for the end-user to control the device.

Note that when you select a Panel UI tab, the options in the Toolbox change to support UI design, and the 
Touch Panel Toolbar is displayed.

Select and apply a UI Template before starting the UI design. Without a template, there are no UI elements 
available to select from.

Initially the UI diagram indicates the selected UI device as the Start Device element, and the controlled 
devices in the system. Note that each device in the system is represented with its own UI element. In the 
context of the Panel UI tab, these elements represent separate pages in the Touch Panel design, not the physical 
devices. Each device has its own page, where you will define the buttons that provide access to device 
functions.

The basics of defining the Panel UI include:

1. Adding UI Elements to the UI diagram - drag-and-drop UI Elements from the Toolbox onto the diagram. 
See the Adding UI Elements To The UI Diagram section on page 126.

2. Connect the UI Elements - draw connection lines to establish the flow between the pages and UI 
Elements. See the Connecting Elements In The UI Diagram section on page 127.

3. Set the UI Element Properties - view and edit properties (including Name, Comments, Category, Device 
Port Number and more) for each UI element. See the UI Element Properties section on page 131.

4. Customizing Panel UI Pages - add, remove and edit buttons on panel UI pages. See the Customizing 
Panel UI Pages section on page 155.

Mode/Navigation/Sub-Navigation Button Feedback
For Mode, Navigation, and Sub-Navigation UI elements that have been added to a Panel UI diagram, VA will 
automatically establish appropriate feedback for the buttons that represent the individual connection points.

For connection points that are connected to a Device or Feature element, their buttons will be generated with 
"channel" feedback and the appropriate code generated to establish a mutually exclusive channel group, set 
output channel state, and connect feedback back to the button.

For connection points that are not connected to a Device or Feature element, either because they are unused or 
because they are "macro" buttons that perform a programmed action, their buttons will be generated with 
"momentary" feedback. No code is necessary for these buttons, as the press/release feedback is handled 
completely by the touch panel itself.

As an example, refer to the following UI Diagram (FIG. 174): 
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In the resulting TPDesign4 project for this touch panel, the "DVD" and "CDP" buttons on the Nav 4 page will 
have "channel" feedback because they are connected to their respective devices; while the "System Off" and 
"Home" button will have "momentary" feedback because they are unconnected.

If we assume that:

a.  the Nav 4 element has been addressed in the generated code as:

dvTP1_NAV_Nav41 = 10001:10:0

b.  the four items in the navigation will be assigned channel codes 1 through 4:

(DVD = 1, VCR = 2, System Off = 3, and Home = 4),

an entry will be made in the DEFINE_MUTUALLY_EXCLUSIVE section of the main source file that looks 
like the following:

DEFINE_MUTUALLY_EXCLUSIVE

// Nav 4 - mutually exclusive group

([dvTP1_NAV_Nav41, 1], [dvTP1_NAV_Nav41, 2])

This will establish a mutually exclusive channel group for the "DVD" and "CDP" buttons of the Nav 4 
element. This means that a maximum of only one of the channels in the group can be "on" at a time.

NetLinx will automatically turn "off" all other channels in a mutually exclusive group when one member is 
turned "on". There will be a mutually exclusive channel group for each Mode, Navigation, or Sub-Navigation 
element in the system that has connections to Device or Feature elements.

Channel activation code will also be generated for connected Mode, Navigation, or Sub-Navigation elements 
in the system. If a BUTTON_EVENT definition has been generated for the channel, no new event definition 
will be generated and code to turn "on" (i.e. activate) the output side of the channel when the input side is 
pressed (i.e. a "TO" statement) will be added to the existing definition. If on the other hand, a 
BUTTON_EVENT definition hasn't been generated for the related channel, a new event block and push 
handler will be generated and the activation code will be added to it to appear as follows in the output:

//-----------------------------------------------------------

//

// EVENT TYPE: BUTTON_EVENT for dvTP1_NAV_Nav41

// API NAME: DVD

// PURPOSE: This button event is used to handle the

// activation of button channel 1 for

// device NAV_Nav41.

//

//-----------------------------------------------------------

BUTTON_EVENT[dvTP1_NAV_Nav41, 1]

{

   PUSH:

   {

      TO[dvTP1_NAV_Nav41, 1]

// Any additional programming generated here

   }

}

//-----------------------------------------------------------

//

FIG. 174  Panel UI diagram
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// EVENT TYPE: BUTTON_EVENT for dvTP1_NAV_Nav41

// API NAME: DVD

// PURPOSE: This button event is used to handle the

// activation of button channel 2 for

// device NAV_Nav41.

//

//-----------------------------------------------------------

BUTTON_EVENT[dvTP1_NAV_Nav41, 2]

{

PUSH:

   {

   TO[dvTP1_NAV_Nav41, 2]

// Any additional programming generated here

   }

}

Finally, feedback statements will be added to the DEFINE_PROGRAM section that will cause the button 
display to reflect the current state of the output channel:

DEFINE_PROGRAM

// Feedback statements for "Nav 4" (mutually exclusive group support)

[dvTP1_NAV_Nav41, 1] = [dvTP1_NAV_Nav41, 1]

[dvTP1_NAV_Nav41, 2] = [dvTP1_NAV_Nav41, 2]

The resulting behavior on the touch panel will be that the Mode, Navigation, or Sub-Navigation buttons that 
takes the user to a set of control pages will be turned "on" when they are pressed, and remain "on" until another 
button in the same Mode, Navigation, or Sub-Navigation that takes the user to a set of control pages is pressed.

All other buttons on these elements will be turn "on" only for the duration of the press.

External Button Programming
When CodeBuilder is invoked for a device from a UI Diagram (i.e., touch panel, R-4 remote, DMS keypad), 
and the UI device has external buttons associated with it, an additional tab for External Buttons is available in 
the Events bar on the left side (FIG. 175): 

This section displays a list of events for the R-4's external buttons. Only those buttons that have channel codes 
assigned to them in the UI template will appear.

The names of the events depend upon the button's channel code:

If the channel code is a G4API code that is defined for the Duet device class of the selected device, 
its G4API name will be used.

If the channel code is not defined in the G4API for the Duet device class of the selected device, the 
name given to the button in the UI template will be used.

Only those external buttons whose channel codes are not defined in the G4API for the Duet device class of the 
selected device can be programmed. Their handlers are defined just as any other would from within 
CodeBuilder.

FIG. 175  CodeBuilder dialog - External Buttons tab.jpg
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External buttons that have G4API codes defined for the Duet device class of the selected device will still 
appear in the list, for completeness, but are not programmable, as their events will already appear in the User 
Interface Buttons section. Buttons that overlap the G4API for a given device are denoted with a red circle with 
a slash through it. The note ‘Programming for this event can be defined in the User Interface Buttons section’ 
is displayed in the Handler area when these buttons are selected.

UI Templates
VA utilizes UI Template (.VAT) files to greatly simplify the process of designing user-interfaces for the Touch 
Panel(s) in your system.

A UI Template is a pre-fabricated collection of integrated Touch Panel pages and buttons that provide a 
consistent and intuitive user-navigation to the end-user. Many templates support multiple resolutions for use 
on various types and sizes of touch panels. Many templates also offer multiple color themes for additional 
flexibility.

While VA comes with at least one template installed and ready for selection, additional templates 
can be installed. Once installed, templates are available to be applied to touch panels in any VA 
project.

VA allows you to apply a different template to each Touch Panel in the system.

The Basic System Assistant dialog includes options (Resolution and Template) for applying a 
template to the selected Touch Panel.

The User Interface Template Manager dialog includes options for Installing new templates, as well 
as Removing and Previewing installed templates.

Many templates support multiple Color Schemes. Click in the Color Schemes field in the Properties window 
to view and select from the color schemes available for the selected template. Click Browse to access the 
Color Schemes dialog (FIG. 176)): 

Selecting a UI Template - Via Device Properties
To select and apply a template to a Touch Panel in your system:

1. Select a Touch Panel in the System Diagram.

2. In the Properties window, click on Template (FIG. 177): 

External buttons on MIO R-4 remotes are handled on a device-by-device basis (see 
MIO R-4 External Button Programming for details).

FIG. 176  Properties Window - Color Schemes drop-down menu
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3. Click Browse to open the Select User Interface Template dialog, where you can browse thumbnails of the 
installed templates (FIG. 178). 

Templates for Intercom-Enabled Touch Panels
The Touch Panel Templates for the MVP-8400, NXD/NXT-CV7, and NXD/NXT-CV10 have been updated for 
use with the (intercom-enabled) MVP-8400i, NXD-700Vi, and NXD-1000Vi touch panels respectively.  

For each of these templates, an Intercom Feature and/or Sub-Feature has been added, to allow you  to 
selectively add support for intercom control to desired touch panels.

As with other template capabilities (e.g., video windows, etc.), these new elements do not have any 
functionality if used on a touch panel without intercom support.

FIG. 177  Selecting a UI Template - Via Device Properties

FIG. 178  Select User Interface Template dialog
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Installing UI Templates
VA comes with several Touch Panel templates by default. More Templates are available to download and 
install via the InConcert Resource Center.

In order to select a UI template to use with the touch panels in your system, you must first install it via the User 
Interface Template Manager dialog.

1. Select Managers > User Interface Template Manager to access the User Interface Template Manager 
dialog. Note that before you have installed any templates (or if you remove all installed templates), the 
preview window indicates "No Installed Templates".

2. Click the Install button to open the Install sub-menu, which provides two ways to install templates - 
From AMX.com, or From File (FIG. 179): 

From AMX.com - this option allows you to download UI Template files (.VAT) from the www.amx.com 
web site. You must have Internet access to use this option.

When you make this selection, the AMX.com Template Library dialog retrieves the ,VAT file(s) 
from the AMX web site (FIG. 180). 

Select the templates that you want to download, and click Install.

FIG. 179  Install sub-menu (User Interface Template Manager dialog)

FIG. 180  AMX.com Template Library dialog 
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From File - this option allows you to  install VAT files from a local directory (either on your PC or on 
your LAN). This option is useful in cases where VAT file(s) have previously been downloaded to a local 
centralized location.

When you make this selection, the Install Template From File dialog is invoked (FIG. 181). 

Use the Path field at the top of the dialog to navigate and select a file directory that contains at least 
one ,VAT file.

Select a template from the preview window and click Install. This action installs the selected ,VAT 
and closes the dialog, returning you to the User Interface Template Manager dialog.

The selected template is now represented in the preview area, and is available for selection.

3. Close this dialog to complete the install process.

The templates you've installed are now indicated in the User Interface Template Manager, and are available for 
selection via the Properties window.

Uninstalling UI Templates

1. Select Managers > User Interface Template Manager (or click the Toolbar button) to open the User 
Interface Template Manager dialog.

2. Select the template that you want to uninstall (in the thumbnail preview area of the dialog).

3. Click the Remove button (FIG. 182). 

4. The program will prompt you to verify this action before the template is permanently uninstalled (click 
OK to proceed).

FIG. 181  Install Template From File dialog

FIG. 182  Remove button (User Interface Template Manager dialog)
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Previewing Touch Panel UI Elements
The Preview dialog allows you to preview a selected UI element in a  touch panel UI Diagram. Use this feature 
to preview the touch panel page layout, including the UI Template selection, Color Scheme selection and Skin 
selection.

1. Select a UI element in a touch panel UI Diagram to activate this option.

2. Select Touch Panel > Preview UI (or click the Toolbar button) to preview the selected UI element in the 
Preview dialog (FIG. 183). Note that the preview is based on the selected UI element, as well as the UI 
template, Color Scheme and Skin selected for the touch panel. 

Click Fit Image to scale the preview image to fit the window on this dialog (default = enabled).

Click Save to save the preview image as a .PNG file. This selection invokes the Save Preview 
Image dialog, where you can specify a filename and target directory for the saved .PNG file. By 
default, the image is named according to the device that the UI element is associated with, and the 
default target directory is the directory

that you have saved your VA project to.

Click To Clipboard to save the preview image to the clipboard. This option is a handy way to open 
the image in a separate application, via a Paste operation.

FIG. 183  Install Template From File dialog

Alternatively, you can access this dialog by right-clicking on any UI element and 
selecting Preview UI from the context menu.
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Color Schemes
Many UI Templates support multiple Color Schemes. Color Schemes add flexibility to your panel UI's visual 
design by using different palettes to create variations on the template design. An example set of color schemes 
is shown below (FIG. 184): 

Use the Color Schemes dialog to preview and select from the Color Schemes available for the selected 
template.

Changing the Color Scheme on a UI Template
Use the Color Schemes dialog to preview and select from the Color Schemes available for the selected User 
Interface template:

1. Select a Touch Panel in the system diagram to populate the Properties Window for that panel.

2. Select and apply a UI Template, if you haven't already done so.

3. Once you have selected a template, the Color Scheme field is enabled in the Properties Window 
(FIG. 185): 

4. Click in the Color Schemes field to enable the down-arrow, then click the arrow to display a list of color 
schemes available for the selected template.

5. Click the Browse button at the bottom of this list to open the Color Schemes dialog.

6. Click on the thumbnail image of the color scheme that you want to apply to the selected panel.

7. Click OK to close the dialog and apply the selected Color Scheme.

The new Color Scheme is indicated in the Properties Window for this panel.

FIG. 184  Color Schemes

FIG. 185  Properties window - Color Scheme field
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Skins
Skins allow you to further customize your UI page layout by easily changing the appearance of the Menu area 
of the page, without altering the Template or Color Scheme selections.

An example set of Skins is shown below (FIG. 186): 

Use the Skins dialog to preview and select from the Skins available for the selected template.

The images below provide an illustration of how different skins affect the layout of the "Angles" template.

The first Skin option uses the name of the selected Template. This default setting does not apply a Skin 
(FIG. 187): 

The following Skin options add various colors/textures to the selected Template, as shown in the following 
examples:

An example of the Granite Skin (FIG. 188): 

FIG. 186  Skins

FIG. 187  Skins - Default Setting (No Skin Applied)

FIG. 188  Skins - Default Setting ("Granite" Skin Applied)
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An example of the Slate Skin (FIG. 189): 

An example of the Wood Skin (FIG. 190): 

Changing the Skin on a UI Template
Use the Skins dialog to preview and select from the Skins available for the selected User Interface template:

1. Select a Touch Panel in the System Diagram to populate the Properties Window for that panel.

2. Select and apply a UI Template, if you haven't already done so.

3. Once you have selected a template, the Skin field is enabled in the Properties Window (FIG. 191): 

4. Click in the Skin field to enable the down-arrow, then click the arrow to display a list of color schemes 
available for the selected template.

5. Click the Browse button at the bottom of this list to open the Skins dialog.

FIG. 189  Skins - Default Setting ("Slate" Skin Applied)

FIG. 190  Skins - Default Setting ("Wood" Skin Applied)

FIG. 191  Properties window - Skin field
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6. Click on the thumbnail image of the Skin that you want to apply to the selected panel.

7. Click OK to close the dialog and apply the selected Skin.

The new Skin is indicated in the Properties Window for this panel.

Customizing Panel UI Pages
VA generates a default Device page as well as any Features and Sub-Features popup pages that were added to 
the UI, for each controlled device in the system. These default pages represent the basic functionality of the 
device, based on device type and the selected UI Template.

Use the options in the Customize UI Pages dialog to edit these default pages as desired.

Adding UI Elements to the Touch Panel Page
VA generates default Touch Panel pages for each third-party (controlled) device in the system. These default 
pages represent the basic functionality of the device, based on device type and the selected UI Template. Use 
the options in the Customize UI Pages dialog to edit these default pages if necessary.

To add UI elements to the Touch Panel page:

1. With a device element selected in a UI Diagram, select Touch Panel > Customize UI Pages (or click the 
toolbar button) to access the Customize UI Pages dialog. The Touch Panel page associated with the 
selected device is displayed in the Design View window (in its default configuration).

The User Interface Elements window (on the right-side of the dialog) displays a listing of all UI elements 
supported by this device. Note that these elements are color-coded (blue or gray - FIG. 192): 

A blue icon indicates that the elements are currently included in the Touch Panel page, 

A gray icon indicates that the elements that are not currently included on the page. These elements 
can be added (as new buttons) to the panel page.

If you select a button in the Design View window, a green flag next to the element's icon (in the 
User Interface Elements window) indicates which element the selected button represents.

2. To add an element to the panel page, simply double-click on any unused element in the User Interface 
Elements list. This action adds a new button for the selected element to the Design View window.

3. Click and drag the button to position it as desired.

4. To change the text displayed on the new button, right-click on the button and select Edit Element 
Properties from the context menu (or click the Toolbar button). Type the text that you want to display on 
this button in the Enter Text dialog.

Editing UI Element Properties
The Edit Element Properties dialog allows you to edit various aspects of a selected UI element, including the 
button’s shape/style, button text, text justification, font, text color and word-wrap:

1. With a Device, Feature or Sub-Feature element selected in a UI Diagram, select Touch Panel > 
Customize UI Pages to access the Customize UI Pages dialog. The Touch Panel page associated with the 
selected device is displayed in the Design View window (in its default configuration).

2. Select a button in the Design View window. Note that when you select a UI element in the Design View 
window, a green flag next to the element's icon (in the User Interface Elements window) indicates which 
element the selected button represents (FIG. 193). 

3. Click on the Edit Element Properties Toolbar button (or right-click on the button and select Edit Element 
Properties from the Panel UI Diagram context menu). This opens the Edit Element Properties dialog.

FIG. 192  User Interface Elements window (Customize UI Pages dialog)

FIG. 193  User Interface Elements window) (Customize UI Pages dialog)
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4. Enter or edit the text that want to show on the selected UI element, and click OK to save your changes 
and close this dialog.

Deleting UI Elements from the Touch Panel Page
VA generates default Touch Panel pages for each third-party (controlled) device in the system. These default 
pages represent the basic functionality of the device, based on device type and the selected UI Template. You 
can use the options in the Customize UI Pages dialog to edit these default pages if necessary.

To delete UI elements from the Touch Panel page:

1. With a device element selected in a UI Diagram, select Touch Panel > Customize UI Pages to access the 
Customize UI pages dialog. The Touch Panel page associated with the selected device is displayed in the 
Design View window in its default configuration.

The User Interface Elements window (on the right-side of the dialog) displays a listing of all UI 
elements supported by this device. Note that these elements are color-coded (blue or gray).

The elements with a blue icon are currently included in the Touch Panel page, gray icons indicate 
the elements that are not currently included on the page. These elements can be added (as new 
buttons) to the panel page.

If you select a button in the Design View window, a green flag next to the element's icon (in the 
User Interface Elements window) indicates which element the selected button represents.

2. Select the button that you want to remove and press Delete.

Alternatively, you can right-click on any button and select Delete Element from the context menu, 
or click on the Delete Element Toolbar button.

You can also select the desired element in the User Interface Elements window and press Delete (or 
right-click and select Delete Element from the context menu or click the Delete Element Toolbar 
button).

Note that once the selected element is deleted in the Design View, the element is indicated as unused in the 
User Interface Elements window (with a gray icon).

Editing Panel Buttons
VA generates Touch Panel pages for each third-party (controlled) device in the system. These default pages 
represent the basic functionality of the device, based on device type and the selected UI Template. You can use 
the options in the Customize UI Pages dialog to edit these default pages as necessary.

To edit a Button on a Touch Panel UI page:

1. With a UI element selected in a UI Diagram (any UI element other than the Touch Panel itself), select 
Touch Panel > Customize UI Pages (or click the toolbar button) to access the Customize UI pages 
dialog. The Panel page associated with the selected device is displayed in the Design View window, in its 
default configuration.

2. Select a button in the Design View window.

Note that when you select a button, a green flag next to the element's icon (in the User Interface Elements 
window) indicates which element the selected button represents (FIG. 194). 

3. Click on the Edit Element Properties Toolbar button (or right-click on the button and select Edit Element 
Properties from the context menu). This opens the Edit Element Properties dialog.

FIG. 194  Button Selection (Customize UI Pages dialog)
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Changing the Button Shape Style:
In the Edit Element Properties dialog:

1. Click the arrow button in the Shape Style Property to open the open the drop-down menu of available 
shape styles (FIG. 195). 

2. Select a Shape Style for the selected button, and click OK to save your changes.

Changing the Button Fill Color:

1. Click the Browse (...) button in the Fill Color Property (FIG. 196) to open the Colors dialog. 

2. Select the desired fill color, and click OK to save your changes.

Changing the Border Color:

1. Click the Browse (...) button in the Border Color Property (FIG. 197) to open the Colors dialog. 

2. Select the desired border color, and click OK to save your changes.

Editing Panel Button Text
VA generates Touch Panel pages for each third-party (controlled) device in the system. These default pages 
represent the basic functionality of the device, based on device type and the selected UI Template. You can use 
the options in the Customize UI Pages dialog to edit these default pages as necessary.

To edit the text displayed on a Button on a Touch Panel UI page:

1. With a UI element selected in a UI Diagram (any UI element other than the Touch Panel itself), select 
Touch Panel > Customize UI Pages (or click the toolbar button) to access the Customize UI pages dialog. 
The Panel page associated with the selected device is displayed in the Design View window, in its default 
configuration.

2. Select a button in the Design View window.

Note that when you select a button, a green flag next to the element's icon (in the User Interface Elements 
window) indicates which element the selected button represents (see FIG. 194 on page 156).

3. Click on the Edit Element Properties Toolbar button (or right-click on the button and select Edit Element 
Properties from the context menu). This opens the Edit Element Properties dialog.

Editing the Button Text:

In the Edit Element Properties dialog:

1. Click the Browse (...) button in the Text Property (FIG. 198) to open the Enter Text dialog. 

2. Enter or edit the text that want to show on the selected button, and click OK to save your changes.

FIG. 195  Properties window - Shape Style

FIG. 196  Properties window - Fill Color

FIG. 197  Properties window - Border Color

FIG. 198  Properties window - Text
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Changing the Button Text Justification:

1. Click the arrow button in the Text Justification Property (FIG. 199) to open the drop-down (default = 
center-middle). 

2. Select the desired Font, Style and Size, and click OK to save your changes.

Changing the Button Text Font/Style/Size:

1. Click the Browse (...) button in the Font Property (FIG. 200) to open the Choose Font dialog. 

2. Select the desired Font, Style and Size, and click OK to save your changes.

Changing the Button Text Color:

1. Click the Browse (...) button in the Text Color Property (FIG. 201) to open the Colors dialog. 

2. Select the desired color, and click OK to save your changes.

Toggling Word Wrap for Button Text:

1. Click the arrow button in the Word Wrap Property (FIG. 202) to open the drop-down (yes / no - 
default = yes). 

2. Select the desired option, and click OK to save your changes.

Character Map dialog
Click the Character Map button (in the Enter Text dialog or Enter Display Text dialog) to view a character 
map of the selected font, and select a character to be inserted in the button text, in the Character Map dialog.

To insert a special character in the Enter Text dialog, select a character and click Insert. The selected character 
will be inserted into the UI element text, at the cursor location.

Use <Ctrl><Enter> to create a line return.

FIG. 199  Properties window - Text Justification

FIG. 200  Properties window - Font

FIG. 201  Properties window - Text Color

FIG. 202  Properties window - Word Wrap
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Working With Features and Sub-Features
The Customize UI Pages dialog treats Features and Sub-Features popup pages much the same as Device pages, 
with a few notable differences:

Because Feature and Sub-Feature elements are not devices and are not covered by the G4API, the actual 
names given to the buttons in the template will be used to identify the elements in the User Interface Elements 
tree.

In the example below, from the 20 buttons originally displayed on the page, buttons 9 through 20 have been 
removed; and buttons 1 through 8 have been re-labeled and rearranged (FIG. 203): 

Defining the UI - Keypads
Keypad UI Diagram
For every Keypad added to the system, a separate UI tab is added to the Diagram Area. Each UI tab consists of 
a Keypad UI Diagram - the graphic representation of the buttons on the keypad. Click on any button on the UI 
diagram to select it for editing, via the button properties in the Properties window.

UI Diagram - Keypads With Labelled Buttons
Mio Modero Prestige S/D Keypads use a UI diagram that represents the buttons that provide the user with 
control functionality (FIG. 204). 

This UI Diagram type is used for the following Keypads:

Mio Modero Prestige S: Single-gang keypad with labeled buttons and LED feedback.

Mio Modero Prestige D: Double-gang keypad with labeled buttons and LED feedback.

FIG. 203  Example Macro Pages (Customize UI Pages dialog)

FIG. 204  Keypad UI - Mio Modero Prestige S/D.jpg
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UI Diagram - Keypads With Custom Engraved Buttons
Mio Modero Classic S/D, and Elite S/D Keypads also use a UI diagram that represents the buttons. These 
keypads use custom-engraving to label the buttons. Use button properties to specify the engraving text, font 
and font scale (FIG. 205). 

This UI Diagram type is used for the following Keypads:

Mio Modero Classic S: Single-gang keypad with engravable buttons and LED feedback.

Mio Modero Classic D: Double-gang keypad with engravable buttons and LED feedback.

Mio Modero Elite S: Single-gang keypad with engravable backlit buttons.

Mio Modero Elite D: Double-gang keypad with engravable backlit buttons.

UI Diagram - Keypads With Custom Engraved Buttons and LCD Display
Mio Modero Elite SL/DL Keypads use a similar UI diagram to represents the buttons that provide the user 
with control functionality. These keypads use custom-engraving and also feature a customizable LCD display 
(FIG. 206). 

This UI Diagram type is used for the following Keypads:

Mio Modero Elite SL: Single-gang keypad with engravable backlit buttons and LCD.

Mio Modero Elite DL: Double-gang keypad with engravable backlit buttons and LCD.

Mio Modero Attache: Wireless IR keypad, table-top

FIG. 205  Keypad UI - Engraved Buttons

For Keypads that do not feature an LCD display, the UI consists channel codes 
assigned to each button.

FIG. 206  Keypad UI - Engraved Buttons and LCD Display

For Keypads that feature an LCD display, the UI also includes items displayed on the 
LCD display.
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UI Diagram - MIO-DMS Keypads
Mio Modero DMS/Pinnacle Keypads feature a customizable LCD display and buttons (DMS) or Slider 
(DMS-P) (FIG. 207): 

Because these keypads utilize a dynamic menu (on a LCD display) and either a set of 8 buttons (MIO-DMS) or 
a Slider (MIO-DMS-P), the UI diagram looks and acts essentially the same as for Touch Panels and R-4 
remotes (FIG. 208). 

This UI Diagram type is used for the following Keypads:

Mio Modero DMS: Dynamic menu select keypad with 8 buttons.

Mio Modero DMS P: Dynamic menu select keypad with Slider.

DMS Keypads utilize Mode and Navigation elements that have 12 Item slots. Use these 12 Item slots to 
connect to devices to Navigation (Nav) elements, Nav elements to Mode elements, or Nav elements to other 
Nav elements (FIG. 209). 

Refer to the Defining the UI - Touch Panels topic for details on adding and connecting UI elements 
in a panel-type UI diagram.

FIG. 207  Keypad UI - MIO-DMS Keypads

FIG. 208  UI Diagram - MIO-DMS Keypads

FIG. 209  Sample DMS pages
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Program the Mio Modero DMS Keypads with the KeypadBuilder application. Refer to the 
KeypadBuilder Instruction Manual and online help for details.

Refer to the Mio Modero DMS & Mio Modero DMS Pinnacle Operation/Reference Guide for 
detailed installation and programming information.

Defining the UI - Keypads
For every keypad added to the system, a Keypad UI diagram is created, with a graphical representation of the 
buttons (and LCD display when applicable) on the keypad. Click on any button on the Keypad UI diagram to 
select it for editing. The selected button's properties are displayed in the Properties window.

The type of each Keypad in the System determines the type of UI diagram used to define navigation. Click on 
a Keypad UI tab to view the UI diagram, where you can add, edit and view button layout, menu actions, button 
label text and assign channel codes on each button.

To define the UI for Keypads, use the Button Properties fields in the Properties Window to assign a Button 
Name, specify the Text to be engraved, and view the Channel Code assigned to each button:

1. Click on a button in the Keypad UI diagram. This action displays the properties for the selected button in 
the Properties window.

For keypads that feature a LCD menu (including the Mio Modero Elite SL and DL), there is the 
additional (read-only) Menu Action property.

2. Enter a text label for the selected button in the Button Name field of the Device Properties window. The 
button name is for use within VA only, and is intended to assist in developing unique descriptive names. 
This is not the text that will be engraved on the button (see Engraving Text below).

3. Enter the text that you want to have engraved on the selected button in the Engraving Text field. To enter 
text, click inside the text field and type directly into the field. Alternatively, click on the browse button 
(...) to access the Enter Text dialog - enter the desired text and click OK to save.

Use the Engraving - Show Bounding Box option to determine wether your text will fit within the 
engraving boundaries of the button.

4. Select the font to use for the engraved text from the Engraving Font drop-down menu (AMX Icon 2 (for 
symbols), Arial, Arial Narrow or Arial Unicode MS).

The AMX Icon 2 font provides various control-oriented icons that can be engraved on the buttons.

The VA Engraving module supports the fonts included in the supported OS (System) languages. 
You must have the language loaded on your OS and then use Arial Unicode MS to render the text 
on the button.

Specify the size of the text from the Engraving Scale drop-down menu. Select a scale factor to 
apply to the engraved text on the selected button (default = 1.0, or 100%). Click inside the text field 
to enable Up and Down arrows to scale the selected button text up or down, in .1 (or 10%) 
increments.

In addition to the 10 character limit in the KeypadBuilder application, the maximum 
number of characters allowed is based on font choice as well as size and specific 
characters used.
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Keypad Buttons
Keypads rely on buttons to allow the end-user to control system devices.

Click on any button on the Keypad UI diagram to select it for editing, via the button properties in the 
Properties window (FIG. 210). 

Keypad UI Diagram - Button Layout
Click on any button on the Keypad UI diagram to select it for editing. The selected button's properties are 
displayed in the Properties window. The labels displays are toggled via options in the Keypad Menu (Show 
Button Numbers, Show Menu Actions, Show Button Name).

FIG. 211 indicates the layout for buttons in the Keypad diagram for regular and LCD buttons (Button Numbers 
(Channel Codes), Button Names, Menu Actions (if applicable) and Engraved Text, if applicable). 

Button Numbers (Channel Codes)

Button Names, Menu Actions (if applicable)

Engraved Text (if applicable) 

FIG. 210  Properties Window - Keypad Button selected

FIG. 211  Keypad UI Diagram (Show Button Numbers, Show Menu Actions, Show Button Names options enabled)

Button Number (Channel Code)

Engraved Text

Menu Action

Button Name

Menu Actions only apply to Keypads equipped with an LCD display.
163VisualArchitect Operation/Reference Guide 



UI Design
Setting Keypad Button Properties
When you select a button in a Keypad UI diagram, the following additional Keypad Button Properties fields 
appear in the Properties window: 

Combining Buttons
Use the Combine Button option in the Keypad menu (or in the Keypad Toolbar) to combine two adjacent 
keypad buttons into a single button that spans the width of the two original buttons.

1. Select Keypad > Combine Buttons to enable the function.

2. Identify the two buttons that you want to combine, and click the button on the left.

3. This action applies the button information from the selected button and assigns it to the button directly to 
the right of it, thus treating two buttons as one.

The combined buttons are also indicated in the Keypad image in the UI tab (FIG. 212): 

Keypad Button Properties

• Button Name: See page 137.

• Menu Action: This read-only field displays the Menu Action value for the selected button.

This field is displayed only if a LCD-equipped Keypad is selected.

• Channel Code: This field displays the selected button's Channel Code assignment. 

• The channel code is the same as the button number and is read-only.

• The Channel Code represents communication out of the keypad to the master 
controller.

• Engraving Text: See page 138.

• Engraving Font: See page 138.

• Engraving Scale: See page 138.

Combine Buttons can only be used on buttons that are horizontally adjacent to each 
other, and only combines two buttons.

FIG. 212  Combining Buttons

Combining buttons adds double buttons to your custom engraving order.
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Uncombining Buttons
To uncombine a button, select the button again (with Combine Buttons still enabled). In this case, the button 
on the right retains the information.

Engraving - Show Bounding Box
Use the Keypad > Engraving - Show Bounding Box option to display the printable area on each button.

All characters must fit within the bounding box in order to print properly.

In addition to the 10 character limit in the KeypadBuilder application, the maximum number of 
characters allowed is based on font choice as well as size and specific characters used.

If your characters do not fit completely inside the bounding box, the characters are displayed in red 
as a warning (FIG. 213): 

Exporting Keypad Button Engraving Templates as DXF Files
Once you have specified the text that you want to have engraved on each of the buttons on the keypad, you can 
export the button engraving template as a DXF file. 

1. Select a Keypad UI tab for a keypad that has button engraved text indicated.

2. Select Keypad > Engraving - Export DXF File (or click the Toolbar button) to open the Export DXF 
File dialog.

3. Specify the filename and target directory for the exported DXF file.

4. Click Export. The system prompts you when the process is complete.

FIG. 213  Engraving - Show Bounding Box

DXF files are generally compatible with CAD graphics programs.
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Keypad LCD Display Menus
Several Keypads (including the Mio Modero Elite SL, Elite DL and Attache) feature a LCD screen that 
displays a fixed menu (FIG. 214). 

There are two main concepts involved in configuring the LCD menu:

Main Menu - The Main Menu displays a listing of the devices that the end-user can control via this 
Keypad.

Sub Menus - For each device listed in the Main Menu, there is a device-specific Sub Menu that 
provides specific controls for the selected device. Sub menus also typically provide a way for the 
end-user to return from the sub-menu to the Main Menu.

Use the options in the Keypad Fixed Menu Editor dialog to edit the contents of the LCD menu.

Adding Devices to the Main Menu
To control a device via a Keypad, you must first add each controlled device to the Main Menu on the LCD 
Display:

1. Open the Keypad UI tab for an LCD display-equipped Keypad to display the Keypad UI diagram.

2. Select Keypad > Edit LCD Menu (or click the Toolbar button) to open the Keypad Fixed Menu Editor 
dialog. Initially, the dialog indicates the [Add Menu Item] option, highlighted in the Main Menu window 
(FIG. 215). 

FIG. 214  Keypads with LCD Displays
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3. Click the Add button to open the Add Main Menu Item dialog (FIG. 216). 

4. Click on the Select a Device radio button.

5. Select a device in the Devices list. The selected device's name (based on the Manufacturer and Model) is 
automatically added to the Item Caption text field. You can edit this text if necessary, in the Item Caption 
field.

6. Click OK to add the device to the Main Menu.

At this point, you can either create a sub menu for this device (by adding Events to the device's sub menu), or 
add more devices to the Main Menu.

FIG. 215  Keypad Fixed Menu Editor dialog

FIG. 216  Add Main Menu Item dialog
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Adding Separator Lines to the Main Menu
Consider using separators to drop a horizontal line between items on the Main Menu, to separate devices or 
device types. To add a separator, click on [Add Menu Item] in the Main Menu window (of the Keypad Fixed 
Menu Editor dialog):

1. Click Add to open the Add Main Menu Item dialog (FIG. 217). 

2. Select the Separator radio button (note that a horizontal line is indicated in the Item Caption field).

3. Click OK.

Once you have added the devices that you want to provide control for to the Main Menu, you need to create a 
device-specific sub menu for each device. The device sub menu provides specific controls for each device to 
the end-user.

Adding Events to a Device Sub Menu
Once you have added the devices that you want to provide control for to the Main Menu, you need to create a 
device-specific sub menu for each device. The device sub menu provides specific controls for each device to 
the end-user. This accomplished by adding Events to each device's Sub Menu:

Events represent the various control functions supported by each device. Examples include Power, Play, Setup, 
etc. Add Events to the sub menu for each device to provide controls for the selected device to the end-user.

If you are not already in the Keypad Fixed Menu Editor dialog, open the Keypad's UI tab and select Keypad > 
Edit LCD Menu (or click the Toolbar button).

Assuming you have already added at least one device to the Main Menu, select a device in the Main Menu 
window to enable the [Add Menu Item] option to the Sub Menu window.

1. Click on [Add Menu Item] in the Sub Menu window.

2. Click on the Add button to open the Add Sub Menu Item dialog.

3. Select an event from the Events list. The selected event's name is automatically added to the Item 
Caption text field. You can edit this text if necessary.

4. Click OK to add the event to the Sub Menu.

FIG. 217  Add Main Menu Item dialog (Seperator selected)
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Repeat this process to add all of the events that you want to control from this keypad.

Generating KeypadBuilder Project Files
To generate KeypadBuilder Project (.KPB) Files for keypads (as well as MIO R-1, R-2 and R-3 Remotes):

1. With a Keypad UI tab selected, select Keypad > Generate KeypadBuilder Project (or click the Toolbar 
button).

This selection opens the Generate KeypadBuilder Project dialog, where you can edit the name and target 
directory for the resulting KPB project file.

By default, the KPB file is named as follows:

VA Project Name - Keypad Name.KPB

2. Edit the file name and target directory as desired, and click Save to generate the KPB project file.

Once it has been created, this project file can be opened and edited in the KeypadBuilder 
application (available for free download from www.amx.com). Select the Open Project In 
KeypadBuilder option to automatically open the resulting file once it is generated.

Refer to the KeypadBuilder on-line help for details.

Defining the UI - Remote Controllers
MIO R-1, R-2 and R-3 remotes use buttons to allow the end-user to make selections (similar to Keypads), 
while MIO R-4 remotes feature a color LCD touch screen (which is more similar to touch panels). 

As a result, the approach to defining UI navigation for remotes depends entirely on which type of remote you 
are working with.

Once you have added a remote to the System Diagram, a UI tab is created for each remote.

FIG. 218  Remote Controllers

Color LCD Touch Screen (240x320)

R-1 / R-2 / R-3 R-4
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UI Diagram - MIO R-1, R-2 and R-3 Remotes
For every MIO R-1, R-2 and R-3 remote added to the system, a separate UI tab is added to the Diagram Area. 
Each UI tab consists of a UI Diagram - the graphic representation of the buttons on the remote. 

The UI Diagram for these remotes is similar to Keypad UI diagrams - click on any button on the Remote UI 
diagram to select it for editing. The selected button's properties are displayed in the Properties window.

An example MIO R-1/R-2/R-3 UI diagram is shown below (FIG. 219): 

Note that when you select a UI tab for MIO R-1, R-2 and R-3 remotes, the Remote Toolbar is displayed.

UI Diagram - MIO R-4 Remotes
For every MIO R-4 Remote added to the system, a separate UI tab is added to the Diagram Area. Each UI tab 
consists of a UI Diagram - the graphic representation of the elements in the remote's Panel GUI, and their 
navigation layout. This is where you can add and connect UI Elements to establish a flow from one area of the 
UI to another. 

The UI Diagram for MIO R-4 remotes is similar to Touch Panel UI diagrams - click on any UI Element on the 
R-4 UI diagram to select it for editing. The selected UI Element's properties are displayed in the Properties 
window.

An example MIO R-4 UI diagram is shown below (FIG. 220): 

Right-click on any UI element to access the UI Diagram context menu.

Use the Preview UI option to preview a selected element in a UI Diagram.

Note that each UI element in the UI Diagram represents a separate page on the panel. FIG. 221 
shows an example Device UI element for a DVD player:

 

FIG. 219  UI diagram - MIO R-1/R-2/R-3 Remotes

FIG. 220  UI diagram - MIO R-4 Remotes
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Use the options in the Customize UI Pages dialog to add/remove buttons and edit button text on the panel 
pages.

Defining the UI - MIO R-1, R-2 and R-3 Remotes
MIO R-1, R-2 and R-3 remotes use buttons to allow the end-user to make selections (similar to Keypads). To 
define the UI for MIO R-1, R-2 and R-3 remotes, use the Button Properties fields in the Properties Window to 
assign a Device Mode, Button Name and specify the Text to be engraved on each button:

1. Click on a button in the Remote UI diagram. This action displays the properties for the selected button in 
the Device Properties window.

2. Enter a text label for the selected button in the Button Name field of the Properties window. The button 
name is for use within VA only, and is intended to assist in developing unique descriptive names. This is 
not the text that will be engraved on the button (see Engraving Text below).

3. Enter the text that you want to have engraved on the selected button in the Engraving Text field. To enter 
text, click inside the text field and type directly into the field. Alternatively, click on the browse button 
(...) to access the Enter Text dialog - enter the desired text and click OK to save.

Use the Engraving - Show Bounding Box option to determine wether your text will fit within the 
engraving boundaries of the button.

4. Select the font to use for the engraved text from the Engraving Font drop-down menu (AMX Icon 2 (for 
symbols), Arial, Arial Narrow or Arial Unicode MS).

The AMX Icon 2 font provides various control-oriented icons that can be engraved on the buttons.

The VA Engraving module supports the fonts included in the supported OS (System) languages. 
You must have the language loaded on your OS and then use Arial Unicode MS to render the text 
on the button.

5. Select a scale factor to apply to the engraved text on the selected button (default = 1.0, or 100%). Click 
inside the text field to enable Up and Down arrows to scale the selected button text up or down, in .1 (or 
10%) increments.

FIG. 221  R-4 UI Preview

In addition to the 10 character limit in the KeypadBuilder application, the maximum 
number of characters allowed is based on font choice as well as size and specific 
characters used.
171VisualArchitect Operation/Reference Guide 



UI Design
Remote Button Properties
AMX Mio R-1, R-2 and R-3 remotes feature six customizable buttons to allow the end-user to control system 
devices. Click on any button on the Remote UI diagram to select it for editing, via the button properties in the 
Properties window (FIG. 222). 

When you select a button in a Remote UI diagram (MIO R-1, R-2 and R-3 remotes only), the following 
Remote Button Properties fields appear in the Properties window: 

Exporting the Remote Button Engraving Template as a DXF File
Once you have specified the text that you want to have engraved on each of the buttons on the Remote, you 
can export the button engraving template as a DXF file.

1. Select a Remote UI tab for a keypad that has button engraved text indicated.

2. Select Remote > Engraving - Export DXF File (or click the Toolbar button) to open the Export DXF 
File dialog.

3. Specify the filename and target directory for the exported DXF file.

4. Click Export. The system prompts you when the process is complete.

FIG. 222  Properties WIndow - Remote Button Selected

Remote Button Properties

• Button Name See page 137.

• Device Mode See page 137.

• Engraving Text See page 138.

• Engraving Font See page 138.

• Engraving Scale See page 138.

DXF files are generally compatible with CAD graphics programs.
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Defining the UI - MIO R-4 Remotes
Since MIO R-4 remotes utilize a panel, the process of defining navigation is similar to that for touch panels.

Once you have added a MIO R-4 remote to the System Diagram, a MIO R-4 UI tab is created for that remote. 
This is where you will create a UI diagram that defines the layout and navigation of the panel pages and 
buttons that provide the GUI for the end-user.

Note that when you select a R-4 UI tab, the options in the Toolbox change to support UI design, and 
the Touch Panel Toolbar is displayed.

Select and apply a UI Template before starting the UI design. Without a template, there are no UI 
elements available to select from.

Initially the UI diagram indicates the R-4 (as the Start Device element), and the controlled devices in the 
system. Note that each device in the system is represented with its own UI element. In the context of the Panel 
UI tab, these elements represent separate pages in the UI design, not the physical devices. Each device has its 
own page, where you will define the button that provides access to device functions.

The basics of defining the R-4's UI include:

1. Adding UI Elements to the UI diagram - drag-and-drop UI Elements from the Toolbox onto the 
diagram. See the Adding UI Elements To The UI Diagram section on page 126.

2. Connect the UI Elements - draw connection lines to establish the flow between the pages and UI 
Elements. See the Connecting Elements In The UI Diagram section on page 127.

3. Set the UI Element Properties - View and edit properties (including Name, Comments, Category, 
Device Port Number and more) for each UI element. See the UI Element Properties section on page 131.
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Creating Device Macros (Using CodeBuilder)

Overview
Use the CodeBuilder dialog to define macros for buttons associated with third-party (controlled) devices in 
your system.

A macro is a series of commands and procedures that are carried out in response to a single button event. 
Macros are typically used in control systems to allow the end-user to trigger several events from a single 
Touch Panel button. For example, a macro could trigger a lighting scene, cause a projection screen to be 
lowered, power up a DVD changer and other associated A/V equipment and set a particular volume level, all 
from a single button event.

There are three types of Button Event handlers supported by CodeBuilder, and you can assign macros to all 
three:

Push - Specifies the actions that should be performed when a button is pressed. By default, Push 
events are used by all events.

Release - Specifies the actions that should be performed when a button is released (after a Push).

Hold - Specifies the actions that should be performed when a button is pressed and held for a 
minimum length of time.

The Hold Duration (the minimum time required for a Hold button event) is specified in the Button 
Event Options dialog (in 1/10 second increments).
By default, the minimum time required for a Hold button event is 5 seconds (Hold Duration = 50).

Defining Device Macros
To Define Device Macros for UI Buttons:

1. Select a third-party device (in either the System Diagram or the System Tree) and select Device > 
CodeBuilder from the context menu. The CodeBuilder command is also available in the Device menu. 
This invokes the CodeBuilder dialog.

2. In the User Interface Buttons tab, select a button. This is the button that you want to use to trigger the 
macro (FIG. 223). 

3. Select Code > Button Event Options (or click the Toolbar button) to open the Button Event Options 
dialog.

4. Select the Event Handler(s) to use with this button event (Push, Release and Hold).

At least one handler must be used with each event.

By default, the Push handler is selected (FIG. 224): 

FIG. 223  CodeBuilder - User Interface Buttons tab - User Defined1 Selected
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Click OK to save your changes and close the dialog.

5. In the Event window, there is a tab for each Event Handler that was selected in the Button Event Options 
dialog (FIG. 225): 

These tabs allow you to build macros specific to each event handler type associated with the selected UI 
button.

6. Double-click on an element in the General, Function or Status tabs to add it to the bottom of the macro 
steps in the Event window. Then, click and drag to reposition the step in the macro as desired (FIG. 226). 

Click the General tab to select from the general-purpose macros available (including If-Else-EndIf, 
Delay, DoPush Event and Comment).

Click the Functions tab to view and select from a list of functions available for each third-party 
device in the system (click any device name to expand its functions list). By default, the Functions 
 tab allows access to all devices in the system, to allow you to create macros that involve multiple 
devices. Use the Filter Functions and Filter Status options  to show only the currently selected 
device.

Many Functions have selectable parameters. You can specify parameters either via the drop-down 
menu on the macro step (in the Event window), or by toggling the Show Friendly Names of 
Functions option and selecting the specific Function/Parameter directly in the Functions tab.

Click the Status tab to view and select from a list of status-related functions available for each 
third-party device in the system (click any device name to expand its status-related functions list). 
By default, the Status tab allows access to all devices in the system, to allow you to create macros 
that involve multiple devices. Use the Filter Functions and Filter Status options to show only the 
currently selected device.

Click on the Properties tab to define and select variables to add to the macro. See Working With 
Variables section on page 188 for details.

FIG. 224  Button Event Options dialog - Push Handler selected

FIG. 225  CodeBuilder - Event window
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7. Click OK to save your changes and close the CodeBuilder dialog.

Adding General-Purpose Macros
In the CodeBuilder dialog, with a button selected in the User Interface Button tab (or External Buttons tab):

1. Select the Push Event, Release Event or Hold Event tab (in the Event window) to specify the Button 
Event type to which this macro will be applied.

2. Open the General tab.

3. Double-click on one of the general-purpose macros to add the representative macro block to the Event 
Window: 

FIG. 226  CodeBuilder - Event window

The first macro is added to the top of the Event window. Each macro after that is 
added to the bottom of the list. The order of events in the current macro will follow the 
order indicated in the Event window. Click-and drag to move items around in the list 
to specify order.

General Purpose Macros

If_else-Endif Double-click to add an If_else-Endif  block to the Event window: 

Click in the If field to select "NOT" from the drop-down, if desired.

Other construct blocks or variables can be added within the  If_else-Endif  
construct, by dragging them from the General, Functions, Status and 
Properties tabs, and dropping them in-between the If, Else, and End If lines in 
this block: 

See Also

• Variable Replacement in IF-ELSE Statements section on page 195

• Creating an IF Conditional with a Variable section on page 196

• Compound IF-ELSE With Variables section on page 197
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Adding Device Functions
To add device functions to a specific device, select the device in the System Diagram or in a UI Diagram and 
launch CodeBuilder (Device > CodeBuilder, or select CodeBuilder from the System Diagram context menu 
or UI Diagram context menu.

In the CodeBuilder dialog, with a button selected in the User Interface Button tab (or External Buttons tab):

1. Select the Push Event, Release Event or Hold Event tab (in the Event window) to specify the Button 
Event type to which this macro will be applied.

2. Open the Functions tab. By default, the Functions tab provides a list of all Devices in the currently active 
System. To filter the list to show only the selected Device, click the Filter Functions button in the 
Functions tab toolbar (FIG. 227):      

 

Delay Double-click to add a Delay block (Wait construct)  to the Event window: 

Click in the Delay field to enter a delay time (in 1/10 second) other than default 
setting of 10 (.1 second).

Other construct blocks or variables can be added within the Delay construct, by 
dragging them from the General, Functions, Status and Properties tabs, and 
dropping them in-between the Delay, and EndDelay lines in this block: 

See Also

• Variable Replacement In Delay Macros section on page 198

DoPush Event Double-click to add a DoPush Event block (User Interface Button -> Push 
Event)  to the Event window: 

Click in the DoPush field to select the UI Element or Device for which this Push 
Event will apply. The list presented in this drop-down menu represents the UI 
Elements and Devices present in the currently active System.

Click in the field to the right of the DoPush field to select a specific DoPush 
function. The list presented in this drop-down menu represents the specific 
functions available for the selected UI Element or Device:

• If a UI Element is selected, this list presents the UI items available. For 
example, if the "Mode 2" (two items) UI Element is selected in the DoPush 
field, then the items available here are "Item 1" and" Item 2".

• If a Device is selected, this list presents the functions available for that 
device. For example, if a DVD Player is selected, then the items available 
here are a listing of functions supported by that DVD Player (i.e. "AB Repeat, 
Angle, Audio, Back, Cancel, etc.).

Comment Double-click to add a Comment block (user text to describe functionality)  to 
the Event window: 

Double-click inside this text field to open the Edit Comment dialog. Enter the 
comment text in this dialog, and click OK to close the dialog and add the 
comment text to the Event Window.

FIG. 227  Function tab Toolbar
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3. Click the plus-sign next to any device in the Function tab to expand the view to show all supported 
functions for that device. Select a function to view information for that function (FIG. 228): 

4. Double-click on one of the Functions macros to add the representative macro block to the Event Window 
(FIG. 229): 

5. Use the fields in the Function block to specify various function-specific parameters. For example, the 
setPower macro for the UDM-0404 provides drop-down menus to allow to specify a Port, and a power 
setting for this function (FIG. 230): 

Function tab Toolbar

Filter Functions This option filters the device list in the Functions tab to show functions of only 
the device targeted by CodeBuilder. 

By default, Filter Functions is off (shows functions for all the devices in the sys-
tem).

Show Friendly Names This option allows CodeBuilder to show functions in a "friendlier" manor, to 
depict specific device functionality. 

When this option is turned off (the default setting), the Functions tab displays 
all SNAPI/Duet functions for each device.

Show Function Information This option toggles the display of parameter information within the Functions 
tab. 

When enabled, this window displays a list of all parameters used by the 
selected function. In cases where two or more functions with the same name 
are listed in the status tree, the Function Information window describes the 
parameter difference between each function.

Default = enabled.

FIG. 228  CodeBuilder - Functions tab

FIG. 229  Macro Block added to the Event WIndow

The first macro is added to the top of the Event window. Each macro after that is 
added to the bottom of the list. The order of events in the current macro will follow the 
order indicated in the Event window. Click-and drag to move items around in the list 
to specify order.
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Adding Status Functions
To add device status functions to a specific device, select the device in the System Diagram or in a UI Diagram 
and launch CodeBuilder (Device > CodeBuilder, or select CodeBuilder from the System Diagram context 
menu or UI Diagram context menu.

In the CodeBuilder dialog, with a button selected in the User Interface Button tab (or External Buttons tab):

1. Select the Push Event, Release Event or Hold Event tab (in the Event window) to specify the Button 
Event type to which this macro will be applied.

2. Open the Status tab. By default, the Status tab provides a list of all Devices in the currently active 
System. To filter the list to show only the selected Device, click the Filter Status button in the Status tab 
toolbar.

3. Click the plus-sign next to any device in the Status tab to expand the view to show all supported functions 
for that device. Select a function to view information for that function (FIG. 231): 

4. Double-click on one of the Status macros to add the representative macro block to the Event Window 
(FIG. 232): 

 

FIG. 230  Editing the Function Macro Block

FIG. 231  CodeBuilder - Status tab

FIG. 232  Editing the Status Macro Block

The first macro is added to the top of the Event window. Each macro after that is 
added to the bottom of the list. The order of events in the current macro will follow the 
order indicated in the Event window. Click-and drag to move items around in the list 
to specify order.
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5. Use the fields in the Status block to specify various function-specific parameters. For example, the 
getInput status macro for the UDM-0404 provides drop-down menus to allow to specify an output 
number, and an input number connected for this function:

Note that information on each field in the Status block is provided in the CodeBuilder dialog Status Bar 
along the bottom of the dialog (FIG. 233): 

Defining Custom Macro UI Buttons
Any Duet module-controlled or IR-controlled device added to the system that has User Interface Button events 
that are programmable via CodeBuilder also has a set of ten user-defined events that can be programmed as 
per-device macro buttons.

These are available from within the list of User Interface Buttons in CodeBuilder as 'User-defined n' 
(FIG. 234): 

These user-defined macro buttons are programmable just as any other event in CodeBuilder, and may also be 
assigned UI-specific programming if CodeBuilder is launched while a UI Diagram is active.

To add a custom macro button in CodeBuilder:

1. Click on one of the User-Defined buttons in the User Interface Buttons window.

2. Double click on a General, Functions or Status item  to add it to the Event window.

3. Define the Device Macros for this custom button in the same way as for other UI buttons.

Likewise, a set of user-defined buttons are available from within the Customize UI Pages dialog in the Device 
Buttons list as 'User-defined n' (FIG. 235): 

FIG. 233  CodeBuilder dialog Status Bar

FIG. 234  CodeBuilder - User Interface Buttons

FIG. 235  Customize UI Pages dialog - Device Buttons list
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Customize these buttons as desired, relative to the custom Macro functionality defined in CodeBuilder.

UI Buttons - Code Blocks
CodeBuilder displays all UI Buttons, including those with pre-defined device Code Blocks. Code Blocks are 
pre-defined segments of NetLinx code that handle the primary programming for a given event / UI button.

UI buttons that have pre-defined Code Blocks associated with them are indicated in the User Interface Buttons 
tab with a yellow alert icon (FIG. 236): 

Further, a prompt is displayed in the Event Window when a Code Block is selected (FIG. 237): 

VA allows you to augment Code Block UI buttons and events, the same as other "non-Code Block" 
buttons and events.

Code Block actions as well as those manually added via CodeBuilder execute with the Code Block 
actions executing first.

CodeBuilder - Adding Comments To Button Events
Use the Comments option in the General tab to add a multi-line block of text to a button event:

1. Double-click or drag-and-drop the Comment option from the General tab into the Event 
Window (FIG. 238): 

2. This adds an empty Comment line to the macro.  

3. Double-click on the Comment line to access the Edit Comment dialog.

4. Enter as much comment text as desired.

The format is straight ASCII text.

Empty lines are discarded.

When you click OK, the Comment block in the Event Window expands/contracts to fit the text 
entered. A comment containing more than one line appears as a single block, and can be collapsed/
expanded (just like an "If" block).   

A comment functions as an individual block in Code Builder regardless of how many lines are 
present. Other items cannot be moved inside a comment block since it functions as a single block.

The only way to get a separate block of comment is to add another comment.

5. Press OK to close this dialog.

FIG. 236  User Interface Buttons Tab - Yellow Alert Icon

FIG. 237  Event WIndow - Predefined Code Prompt.

FIG. 238  CodeBuilder - Adding a Comment
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Editing Comments

1. Double-click on an existing Comment in the Event Window to invoke the Edit Comment dialog, in order 
to edit the comment text.

2. Click OK to save changes.

CodeBuilder: UI-Centric Programming
The  UI-Centric Programming View of the CodeBuilder dialog features additional UI-Centric programming 
functionality, which allows you to program device events specifically for the selected UI device (the device 
represented in the active UI Diagram), as opposed to using the typical system-wide programming.

There are two ways of placing CodeBuilder into the UI-Centric Programming View:

1. With a User Interface button selected, select UI-Specific Event Programming in CodeBuilder's Code 
menu (or click the Toolbar button) to enter into UI-Centric programming for the selected button.

2. Select Code > UI-Specific Event Programming.

The title of the CodeBuilder dialog reflects the context of the CodeBuilder session, in the form of 
"CodeBuilder - deviceName on touchPanelName".

In this view, the CodeBuilder dialog - Buttons/Device States Window (on the left side) uses an extra state icon 
to reflect which events have been overridden to be UI-centric and which are system-wide (FIG. 239): 

When switching an Event to UI-centric programming, you are given the option to start with the default 
programming, current programming, or no programming, in the UI-Specific Event Programming dialog.

When switching an Event back to system-wide programming, any current UI-centric programming for that 
Event will be lost. Changes made to Events that are not marked as UI-centric will behave as VA currently 
does, with the modifications being made to the system-wide programming for the given device.

Comments are carried over, and appear (as Comments) in the generated code as 
well.

FIG. 239  CodeBuilder: UI-Centric Programming View

CodeBuilder presents the option to switch the selected Event from system-wide to UI-
centric programming via the UI-Specific Event Programming option in the Code 
menu, Toolbar, or the Events tree context menu.
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Similarly, when CodeBuilder is invoked for a device from the System Diagram, no extra functionality is 
available for UI-centric programming. All changes are made against the system-wide programming for the 
given device.

UI-Centric Programming - Generated BUTTON_EVENT code
The BUTTON_EVENT code generated for any Events that have UI-centric programming uses a 
SELECT…ACTIVE construct in order to determine what code to execute. For example, assuming the 
following addresses and array have been declared for control of a DVD player by three separate touch panels 
(all currently generated by VA):

dvTP1_DISC1 = 10001:11:0

dvTP2_DISC1 = 10002:11:0

dvTP3_DISC1 = 10003:11:0

…

VOLATILE DEV dvTP_DISC1[] = {dvTP1_DISC1, dvTP2_DISC1, dvTP3_DISC1}

Touch panel 1 will use system-wide programming for the Play event; while both touch panels 2 and 3 will use 
UI-centric programming.

The BUTTON_EVENT handler will be generated as follows in the DISC1.axi include file for the DVD player:

BUTTON_EVENT[dvTP_DISC1, BTN_PLAY]

{

   PUSH:

      {

       STACK_VAR DEV dvCurrent

       dvCurrent = dvTP_DISC1[GET_LAST(dvTP_DISC1)]

      SELECT

      {

         ACTIVE (dvCurrent = dvTP2_DISC1):

         {

            // UI-centric programming for touch panel 2

         }

         ACTIVE (dvCurrent = dvTP3_DISC1):

         {

            // UI-centric programming for touch panel 3

         }

        ACTIVE (1):

        {

           // system-wide programming for all other touch panels

        }

      }

   }

}

This code compares the device that triggered the event against those that were defined with UI-centric 
programming, executes the appropriate code if the UI-centric was used, or executes the default system-wide 
code if not.
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External Button Programming
When CodeBuilder is invoked for a device from a UI Diagram (i.e., touch panel, R-4 remote, DMS keypad), 
and the UI device has external buttons associated with it, an additional tab for External Buttons is available in 
the Events bar on the left side (FIG. 240): 

This section displays a list of events for the R-4's external buttons. Only those buttons that have channel codes 
assigned to them in the UI template will appear. The names of the events depend upon the button's channel 
code:

If the channel code is a G4API code that is defined for the Duet device class of the selected device, 
its G4API name will be used.

If the channel code is not defined in the G4API for the Duet device class of the selected device, the 
name given to the button in the UI template will be used.

Only those external buttons whose channel codes are not defined in the G4API for the Duet device class of the 
selected device can be programmed. Their handlers are defined just as any other would from within 
CodeBuilder.

External buttons that have G4API codes defined for the Duet device class of the selected device will still 
appear in the list, for completeness, but are not programmable, as their events will already appear in the User 
Interface Buttons section. Buttons that overlap the G4API for a given device are denoted with a red circle with 
a slash through it. The note ‘Programming for this event can be defined in the User Interface Buttons section’ 
is displayed in the Handler area when these buttons are selected.

MIO R-4 External Button Programming
When Code Builder is invoked for a device from a R-4 UI Diagram, an additional tab for External Buttons is 
available in the Events bar on the left side (FIG. 241): 

This section displays a list of events for the R-4's external buttons. Only those buttons that have channel codes 
assigned to them in the UI template will appear. The names of the events depend upon the button's channel 
code:

If the channel code is a G4API code that is defined for the Duet device class of the selected device, 
its G4API name will be used.

If the channel code is not defined in the G4API for the Duet device class of the selected device, the 
name given to the button in the UI template will be used.

Only those external buttons whose channel codes are not defined in the G4API for the Duet device class of the 
selected device can be programmed. Their handlers are defined just as any other would from within 
CodeBuilder.

External buttons that have G4API codes defined for the Duet device class of the selected device will still 
appear in the list, for completeness, but are not programmable, as their events will already appear in the User 
Interface Buttons section. Buttons that overlap the G4API for a given device are denoted with a red circle with 
a slash through it (see Button - VOLUME DOWN, Button - VOLUME MUTE and Button - VOLUME UP 
above). The note ‘Programming for this event can be defined in the User Interface Buttons section’ is 
displayed in the Handler area when these buttons are selected.

FIG. 240  CodeBuilder - External Buttons Tab

External buttons on MIO R-4 remotes are handled on a device-by-device basis (see 
MIO R-4 External Button Programming for details).
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External buttons on MIO R-4 remotes are handled on a device-by-device basis. This means that the external 
button programming must be done individually for each controlled device:

1. In the R-4 UI Diagram, select a controlled device and select Device > CodeBuilder (or select 
CodeBuilder from the UI Diagram context menu).

2. Use the External Buttons tab to program the R-4's external buttons for the selected device only.

3. Repeat this process for each controlled device.

External Button Programming - NetLinx Source Code Generation
VA will generate BUTTON_EVENT code for each external button that has programming associated with it. 
These will be generated into the code block include file for the device being programmed.

The device of the event will be address of the set of pages for the device being programmed on the specific 
user interface; not the entire array of user interfaces that control the device.

External buttons that use channel codes not in the G4API for the Duet device class of the selected device will 
use the numeric channel code defined in the UI template for the event channel:

BUTTON_EVENT[dvTP1_DISC1, 600]

{

   PUSH:

   {

       // Non-G4API external button programming for touch panel 1

   }

}

Because each device in a UI template may be made up of multiple pages, VA will only use the codes from the 
"main" page to build the list of programmable external buttons.

If the device is only made up of a single page, that page will be considered the "main" page.

If the device is made up of multiple pages, the page flips attached to the device Info button will be 
used to determine which page is the "main" page.

FIG. 241  CodeBuilder - External Buttons Tab (R-4 Remotes)

For the MIO R-4, there is no way to globally set what a button should do (e.g., set 
volume buttons to always do one thing no matter the device); to achieve this, the 
external buttons have to be programmed to do the same thing on each device in the 
system.

In order for the UI templates to be compatible with this framework, any external 
buttons that template designers wish to make available for programming must be set 
to override the global external button settings and assigned either a G4API code that 
matches the intended functionality of the button, or a non-G4API code for "general 
purpose" external buttons. 
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Online/Offline Event Programming
For all system devices controlled by Duet modules, with the exception of devices containing I/O and Relay 
ports, VA supports Online and Offline as programmable events. When Code Builder is opened for such a 
device, the Device State Events tab is added to the dialog.

Upon selection of one of these events, you can add programming steps to its handler,  just like any of the User 
Interface Buttons events.

However, you are not allowed to add or remove handlers, as these events do not follow the same Push/Hold/
Release scheme as the 'User Interface Buttons' events do.

VA will generate the Online and Offline events in the Include file (.AXI) for the target device as the following 
NetLinx CodeBlock:

DATA_EVENT[vdvDevice]

{

   ONLINE:

   {

      [generated statements] …

   }

   OFFLINE:

   {

      [generated statements] …

   }

}

Where vdvDevice is the VA-assigned Duet virtual device number.

In addition, any statement that would have generated as a NetLinx TO construct from a Push handler will 
generate as an equivalent PULSE construct when used in the Online or Offline events. 

This is a requirement of the NetLinx language, as TO can only be used from within a Push handler, and will 
effectively perform the same operation as if the user pressed a UI button, held it for the default pulse time (0.5 
seconds), and then released the button.

I/O Event Programming
For all AMX system devices that contain I/O control ports (e.g., Central Controllers, Expansion devices, etc.), 
VA supports programming of the I/O channels as “buttons”, via the CodeBuilder dialog.

The events are listed in the User Interface Buttons tab and are named ‘I/O n’, where n is from 1 to the number 
of I/O ports contained on the device.

They may be programmed just as any other User Interface Buttons event, including the ability to define any or 
all of the available Push, Hold, and Release handlers.

The Push handler is executed when the I/O channel goes from off to on,

The Hold handler is executed when it remains on for a specified duration

The Release handler is executed when it goes from on to off.

VA will generate the NetLinx code for these events in the Include file (.AXI) for the target I/O device as the 
following NetLinx CodeBlock:

BUTTON_EVENT[dvDevice, ioChannel]:

{

   PUSH:

   {

      [generated statements] …

   }

    HOLD[holdTime]:

   {

      [generated statements] …

   }

   RELEASE:

   {

      [generated statements] …

   }

}
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Where:

dvDevice is the physical device address of the I/O ports, and not the Duet virtual device address 
that is used to control the I/O ports via Duet module;

ioChannel is the number of the I/O port (1 to the number of I/O ports contained on the device).

Working With Variables
VA provides basic variable support via CodeBuilder.

Each variable represents a place to store data that can change at runtime.

CodeBuilder variables can be one of four basic types: String, Number, Boolean or Decimal (see 
Variable Data Types).

Variables are created and managed in the Properties tab of the CodeBuilder dialog (FIG. 242): 

The Properties tab presents all known variables in a list categorized by data type: String, Number, 
Boolean and Decimal. Each variable entry is composed of three properties:

Name - Alphanumeric text to identify a variable. The name shows up in the CodeBuilder Event 
Handler when it is used in a macro step.

Description - User defined description of the variable.

Value - The initial value set for the variable when it is created. The default value for string is 
empty; the default value for number is 0; and the default value for floating point is 0.0.

Variable support in CodeBuilder includes the following:

Assigning a literal value to a variable

Assigning one variable to another

Assigning the return value of a status function to a variable

Using variables as function parameter values

Comparing a variable to a literal value

Comparing one variable to another

Comparing a variable to a status function return value

Using a variable as the time parameter for a Delay

All statement types as listed above are translated into syntactically correct NetLinx program source code 
during control system file generation.

FIG. 242  CodeBuilder - Properties Tab

Variable manipulation (i.e., math or string processing) is not supported.
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You can use CodeBuilder variables in place of any editable literal value in the Event Handler, including:

function parameters of the same type.

IF-ELSE statements: function parameters (left side of the comparison operators)

IF-ELSE statements: comparison value (right side of the comparison operator)

input for the Delay macro (General-Purpose macro) - integer variables only

CodeBuilder variables can be dropped on the Event Handler to be assigned values such as:

a literal value,

the value returned by a function (status),

or another CodeBuilder variable.

CodeBuilder variables are global in context to a VA project. Variables defined in a particular CodeBuilder 
session can be accessed, manipulated, and even deleted by future CodeBuilder sessions of the same project in 
VA.

Defining Variables
To add variables to a macro in CodeBuilder, select the device in the System Diagram or in a UI Diagram and 
launch CodeBuilder (Device > CodeBuilder, or select CodeBuilder from the System Diagram context menu or 
UI Diagram context menu. Once one or more variables have been defined, they are available for use in any 
macro in the currently active System. 

In the CodeBuilder dialog, with a button selected in the User Interface Button tab (or External Buttons tab):

1. Open the Properties tab.

2. Click the plus-sign next to any of the variable types in the Properties tab to expand the view to show all 
variables that have been defined per type (FIG. 243). 

3. Double-click on one of the variables to add the representative variable block to the Event Window 
(FIG. 244): 

FIG. 243  CodeBuilder - Properties Tab

FIG. 244  Variable Block added to the Event WIndow
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Variable Data Types
The types of variables supported by VA encapsulate all of the supported simple data types used by Code 
Builder. Each variable data type represents a place to store data that can be set and/or referenced at runtime. 
The following table indicates which NetLinx data types are encapsulated by CodeBuilder variables. 

The following types are not supported:

TSE - Type Safe Enumeration, a class which groups together values of a common type.

Complex Data Types

Variable Validation
Variables can be plugged into function parameters, assigned status function results, and can even be compared 
to one another.

For validation purposes, CodeBuilder forces you to use variables for like-typed parameters, values etc. For 
example, you are not allowed to drag a string on top of a parameter that takes a number.

CodeBuilder also validates parameters that have ranges. If you type in a value that does not match the required 
range, CodeBuilder will issue an error message. However, CodeBuilder does not validate the variable for a 
range - it can only validate the fact that the parameter is a number, string or decimal (therefore the variable 
must match).

CodeBuilder cannot fully validate a variable against a range since its contents are unknown at design time. 
Variables by definition have an initial value, but it can change in any CodeBuilder session (for example, by 
assignment to a status function). The only way to know for sure what a variable's value is at any point in time 
is

by checking the variable at run time. Since CodeBuilder is a "design time" tool and not a "runtime" tool, this is 
not possible utilizing CodeBuilder. Instead, CodeBuilder provides you with enough information to make an 
informed decision on how to use a variable correctly.

CodeBuilder - Adding a New Variable
In the CodeBuilder dialog (Properties tab):

1. Click the Add Variable toolbar button to open the Add Variable dialog.  

2. Use the radio buttons in the Type area to choose a data type (String, Number, Boolean or Decimal).

3. Enter alphanumeric text for the Name and a Description (optional).

4. Enter an Initial Value for the variable.

Click Add to add the variable as defined, leaving this dialog open (to add more variables).

Click Add and Exit to add the variable as defined, and close this dialog.

Click Exit to close this dialog, without adding a variable.

5. The new variable will appear in alphabetical order under its data type category.

Variable Data Types

CodeBuilder Variable 
Data Types

NetLinx Data Types

• String • CHAR: 0-255 (8-bit), byte values and character strings

• WIDECHAR: 0-65535 (16-bit) wide character strings

• Number • INTEGER: 0-65535 (16-bit)

• SINTEGER: -32,767 to 32,767 (16-bit)

• SLONG: -2,147,483,647 to -2,147,483,647 (32-bit)

• Decimal • FLOAT: 1.17E-38 to 3.40E38 with 7 digits of precision (32-bit)

• DOUBLE: 2.22E-308 to 1.79E308 with 16 digits of precision (64-bit)

• Boolean TRUE/FALSE, 1/0
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CodeBuilder - Editing A Variable
To change the name, description and/or value of an existing variable:

In the CodeBuilder dialog (Properties tab):

1. Select a variable.

2. Press the Edit Variable toolbar button to open the Edit Variable dialog.

3. Edit the Name, Description and Initial Value fields as desired; the variable will be renamed everywhere it 
is used.

Alternatively, you can change the Initial Value of a variable by double-clicking the value in the variable 
list.

4. Click OK to close the dialog.

CodeBuilder - Deleting A Variable
In the CodeBuilder dialog (Properties tab):

1. Select a variable.

2. Click the Delete Variable toolbar button.

Variables - NetLinx Code Generation
The NetLinx code generated by VA includes complete support for any user-defined variables created and/or 
utilized via CodeBuilder.

Declarations, initializations and references to user-defined variables are translated to the correct NetLinx 
syntax when generated in output.

The following statements are true relating to the output of variables in NetLinx source code:

All variables created and used in programming via the CodeBuilder interface will be declared as 
system-global VOLATILE variables, meaning they will not retain their value between control 
system reboots.

All integer variables created by code generation (i.e. both user variables and system-generated 
variables) will be declared using the signed long (SLONG) type, to alleviate conflicts related to 
storage size and compiler warnings related to implicit type conversion and potential truncation.

All decimal variables created by code generation (i.e. both user variables and system-generated 
variables) will be declared using the double precision floating point (DOUBLE) type, to alleviate 
conflicts related to storage size and compiler warnings related to implicit type conversion and 
potential truncation.

All user variable declarations will appear in the DEFINE_VARIABLE section of the main.AXS file 
generated by VisualArchitect.

According to NetLinx programming convention, variable names will be prefixed with characters 
similar to Hungarian Notation to indicate their type.

User variables and system-generated global variables will be generated in the same section (i.e. 
mixed together) and grouped by data type.

Variables will be initialized to the value they should have as designated by the user or by the 
system, where appropriate. If the user hasn't provided an initial value via CodeBuilder, the variable 
will be assigned to its default initial value.

Detailed comments will be generated on the right-hand side of all variable declarations. Comments 
next to user-created variables will include the user's description of each variable (if the user 
provided one), while comments next to system-generated variables will include a description of the 
reason the variable has been declared.

The variable Type cannot be changed.

If the variable is used in any IF-ELSE-ENDIF statements, CodeBuilder will prompt 
you to verify that all the variable will be removed from all code. Click OK to proceed.
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Variable names as specified by the user in CodeBuilder will be retained verbatim in generated 
output so that the user can readily recognize references to their own variables in generated output, 
if needed. If a naming conflict is encountered between a user variable name and a system-generated 
variable name, the code generator will alter only the name of the conflicting system-generated 
variable iteratively until a name is found that does not conflict with any other global variable name 
in the system.

The variable declarations section output will appear similar to the following example:

(***********************************************************)

(*              VARIABLE DEFINITIONS GO BELOW              *)

(***********************************************************)

DEFINE_VARIABLE

// Integer Variables

VOLATILE SLONG MyIntegervariable = 10

VOLATILE SLONG DelayCount = 500

VOLATILE SLONG slVPROJ1ContrastLevel = 0

VOLATILE SLONG slCAM1PanLevel = 0

VOLATILE SLONG slCAM1TiltSpeedLevel = 0

// Floating Point (decimal) Variables

VOLATILE DOUBLE dLocalTemperature = 0.000000

VOLATILE DOUBLE dWEATHER1WeatherBarometerLevel = 0.000000

// String Variables

VOLATILE CHAR cWEATHER1WeatherScale[DUET_MAX_PARAM_LEN]

In the sample output above, the first two integer variables were created in CodeBuilder, while the remaining 
variables were automatically generated by VA to support other system control operations. Again, actual 
variable declaration output will have comments on the right-hand side that will include user comments and/or 
how the variables are used.

Variable Assignment Step
The variable assignment step consists of the following:

Variable = Value

where Variable is the name of the variable being assigned and Value is any one of the following: a 
literal value, a status function, or another variable.

There are three ways to create a variable assignment step:

1. Double-clicking a defined variable: creates a variable assignment step in the form variable = literal at the 
end of the currently selected Event Handler macro.

2. Left click dragging-and-dropping a defined variable between steps inserts a variable assignment step 
(again in the form variable = literal) at the desired location of the Event Handler list.

3. Right click dragging-and-dropping a defined variable between steps then choosing Insert Variable 
Assignment from the context menu inserts a variable assignment step (again in the form variable = literal) 
at the desired location of the Event Handler list.

Upon creation the literal will contain the default value found in the Variable definition tab (FIG. 245). 

In the following example, individual variable comments have been removed for 
readability, but they will appear in generated output.
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After initial creation the variable assignment step can be changed in the following ways:

Drag-and-Drop another Variable Onto a Literal

Drag-and-Drop a Status Function Onto a Literal

Assigning Variables
The following examples show how a variable can be assigned: 

Drag-and-Drop Another Variable Onto a Literal
Dragging and dropping another variable on top of the literal assigns a variable to another variable. During the 
drag-and-drop operation, note the visual change for the literal when dragging the variable over the literal 
location (FIG. 246). 

The figure below illustrates the visual indication given, after the drag-and-drop of a Variable over a Literal 
(FIG. 247): 

FIG. 245  Variable Assignment Step - Adding a Defined Variable to the Event Handlers List

By literal:

By another variable:

By the result of a Status:

FIG. 246  Variable Assignment Step - Adding Another Variable Onto a Literal

FIG. 247  Variable Assignment Step - Visual Indication after Drag and Drop
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Drag-and-Drop a Status Function Onto a Literal

Dragging and dropping a status function on top of the literal assigns the variable with the result of a status 
function. During the drag-and-drop operation you should see a visual change for the literal when dragging the 
status function over the literal location.

The following figure illustrates the visual indication given when dragging a status function over the literal in a 
variable assignment step (FIG. 248). 

The following figure illustrates the visual indication given, after the drag-and-drop of a Status function over a 
Literal (FIG. 249): 

Note that after changing the value on the right-hand of the assignment to a variable or a status function, you 
can revert back to a literal by double-clicking the field on the right-hand side of the assignment and entering 
the forced data type.

Replacing Literals In Existing Steps With Variables
CodeBuilder supports replacement of literals with variables, and the opposite: the replacement of a variable 
with a literal of the correct data type.

You can change a literal by double-clicking the literal block and entering text in the expected format (number, 
string or decimal).

To replace a literal with a variable, drag-and-drop a variable on top of the literal. The only requirement is that 
both the literal value being replaced and the variable are the same data type. When dragging the variable, the 
UI should only high-light literal values of the same type.

At any time you can revert back to a literal value or replace it with another variable.

The following topics outline all the scenarios where variable replacement can be used.

You can revert back to the literal value by double-clicking the variable " AudioOn".

FIG. 248  Variable Assignment - Dragging A Status Function Over The Literal

FIG. 249  Variable Assignment Step - Visual Indication after Drag and Drop Status Over Literal

You can revert back to the literal value by double-clicking on the status " Ashly 
Audio24.24M: isDeviceOnLine".
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Variable Replacement In Function Blocks
Function blocks can appear as a function call step. Functions can have one or more parameters. If the 
parameter is editable through the use of an edit box it can be replaced by a variable.

As you drag a variable onto the function call, parameters that allow replacement should visibly change when 
the mouse passes over them to indicate drop-acceptance (FIG. 250): 

Once you drop a variable onto a parameter the parameter block changes to look like a variable block 
(FIG. 251): 

Variable Replacement in IF-ELSE Statements
IF-ELSE statements provide a way to test conditions and perform actions based on the result of those tests. 
CodeBuilder supports variable replacement on either side of the conditional "=", whether testing the result of a 
function to the contents of a variable, or replacing function parameter(s) with variables.

As you drag a variable onto the IF-ELSE statement, parameters that allow replacement visibly change when 
the mouse passes over them to indicate drop-acceptance (FIG. 252): 

FIG. 250  Variable Replacement In Function Blocks

FIG. 251  Variable Replacement In Function Blocks - Visual Indication after Drag and Drop

You can revert back to a literal value by double-clicking the variable "ProcessorLevel" 
and typing in a number. The text "ProcessorLevel" is replaced with the literal value.

FIG. 252  Variable Replacement in IF-ELSE Statements
195VisualArchitect Operation/Reference Guide 



Creating Device Macros (Using CodeBuilder)
When you drop a variable onto a parameter the parameter block changes to look like a variable block 
(FIG. 253): 

Creating an IF Conditional with a Variable
By selecting the right mouse button on a variable and dragging and then dropping the variable between steps 
you will be presented with a menu with two choices: Insert Variable Assignment and Insert Variable Condition 
(FIG. 254): 

Insert Variable Assignment will be defaulted, and if chosen an IF-ELSE-END block will be created with the 
variable:

The variable name will appear on the left-hand-side of the conditional operator and an editable 
literal value will appear on the right-hand-side of the conditional operator.

If the variable is a number, an integer literal value is expected on the right-hand of the equals sign 
and so on with the other types.

As you drag a variable onto the empty IF-ELSE step, CodeBuilder indicates that the variable can be added 
(FIG. 255): 

FIG. 253  Variable Replacement in IF-ELSE Statements - Visual Indication after Drag and Drop

FIG. 254  Creating an IF Conditional with a Variable

You can also create an IF-ELSE step with a variable by first creating an empty If step 
and then drag-and-drop a variable onto the IF-ELSE block.

FIG. 255  Creating an IF Conditional wIth a Variable - Adding a Variable To An Empty IF-ELSE Step
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When you drop a variable onto an empty IF-ELSE step, CodeBuilder identifies the variable (FIG. 256): 

You can enter a literal value by double-clicking the literal, or you can drag-and-drop another 
variable on top of the literal to compare two variables (FIG. 257): 

You can also drag-and-drop a status function onto the literal to compare a variable to the result of a 
status function (FIG. 258): 

Double-click on the right side of the condition to change the function status or variable back to a 
literal (similar to a variable assignment statement).

Compound IF-ELSE With Variables
Like the status function, CodeBuilder also supports compound IF-ELSE steps for variable drag-and-drop 
operations (FIG. 259): 

FIG. 260 illustrates the visual indication given after the drag-and-drop (of compound IF-ELSE steps over a 
Literal): 

FIG. 256  Creating an IF Conditional wIth a Variable - CodeBuilder Identifies The Variable

FIG. 257  Creating an IF Conditional wIth a Variable - Entering a Literal Value

FIG. 258  Creating an IF Conditional wIth a Variable - Entering a Status Function

FIG. 259  Compound IF-ELSE With Variables
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Variable Replacement In Delay Macros
Variable replacement for Delay macros works just like variable replacement for function call macros 
(FIG. 261): 

The figure below illustrates the visual indication given after the drag-and-drop of Delay macros over a Literal 
(FIG. 262): 

FIG. 260  Compound IF-ELSE With Variables - Visual Indication after Drag-and-Drop

FIG. 261  Variable Replacement In Delay Macros

FIG. 262  Variable Replacement In Delay Macros - Visual INdication After Drag-and-Drop

You can revert back to a literal value by double-clicking "DelayVal" and entering 
numeric text. The entered literal will replace the variable name.
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Finishing the Project

Overview
After creating a system, there are a few steps involved in finishing the project:

1. Review the Project Properties (see the Working With Projects section on page 21).

2. Save the Project (see the Saving VA Project Files section on page 28).

3. Generate and Transfer System Files (see Generating And Transferring System Files  on page 199).

4. Generate the System Report (see System Report  on page 202).

Optionally, there are a few other steps that can be taken:

1. Exporting Diagram Images (see Exporting Diagram Images  on page 206).

2. Printing the Diagrams (see Printing The Diagrams  on page 207).

Generating And Transferring System Files
Once your VA project is complete, you are ready to generate and transfer the system files required by the 
Central Controller to make the system work.

1. Select System > Generate and Transfer System Files (or click the Toolbar button) to access the 
Generate & Transfer System Files dialog (FIG. 263). 

The FileTransfer2 application (available for free download from www.amx.com)is 
required to perform transfers.

FIG. 263  Generate & Transfer System Files dialog
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This dialog displays a list of all System files in the active Project, with options (check boxes) to generate 
and transfer each file in the list.

2. Select an Output Folder for Generated System files, via the Output folder field at the top of this dialog. 
Click the Browse button to locate and select a target folder in the Browse For Folder dialog.

Click the Create project subfolder (added to output folder path) option to allow VA to create a new 
subfolder for generated System files, within the folder selected in the Output folder field.

3. Click the select/de-select the Generate and Transfer check boxes for the System files in the list to 
specify wether to Generate and/or Transfer each System file in the list. By default, all items are selected 
for both Generate and Transfer.

Click the top check box in the Generate and Transfer columns to automatically select or de-select all 
System files in the list.

4. Select a Compile option:

Select Compile With Debug Info to include variable symbol information in the compiled file. This 
allows the debugger to identify and validate variable symbols in the code. You must compile with 
debug info in order to debug NetLinx files.

Select Build With Source to compile the source code with the executable code so that you may 
later retrieve the source code from the device you send the compiled code to. If Build with Source 
is disabled, only the executable code is sent when the file is transferred to the master (default = 
disabled).

Select Build With Password Protection to apply a password to the Source file. Once applied, you 
cannot extract the source code from the Central Controller (via NetLinx Studio’s Extract From 
SRC command) unless you provide the correct password. The password must be at least 6 
characters in length (maximum of 20 characters, default = disabled).

5. Click Start.

The Progress bars indicate the status of the operation, and the program will alert you if there are any problems 
or issues with the system files during the process.

Notes:
You can also generate the KeypadBuilder project (KPB) file via the Generate KeypadBuilder 

Project option in the Keypad menu.

You can also generate the TPDesign4 project (TP4) file via the Generate TPDesign4 Project option 
in the Touch Panel menu.

You can also generate the System Report (HTML) file via the System Report option in the System 
menu.

Generating the System Report
Select System > System Report (or click the Toolbar button) to access the System Report dialog (FIG. 264). 

NetLinx Studio is available for free download from www.amx.com, and comes with its 
own online help and documentation.

FIG. 264  System Report dialog
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Use this dialog to specify an output folder for the System Report (HTML) file for this project:

1. Specify an Output Folder: Enter the directory path for the target directory for the System Report, or 
click the folder icon to browse for the target directory.

2. Select the Open Report in Associated Viewer option to automatically open the System Report, using the 
program associated with HTML files (typically Internet Explorer) when the report is generated.

3. Click Generate to generate the System Report.

The resulting HTML file is placed in the specified output folder.

The System Report filename is based on the System Name associated with the project. For 
example: "SystemName - VAReport.HTML"

The System Report is a detailed summary of all devices in the system and their connection 
information, in the form of an HTML file.

There are two ways to approach generating the system report:

1. Select System > System Report - This selection opens the System Report dialog, where you can specify 
the target (Output) folder for the System Report file. In this case, the System Report file (alone) is 
generated and copied to the Output folder.

2. Select System > Generate & Transfer System Files - This selection opens the Generate & Transfer 
System Files dialog. Verify that the Generate System Report option is checked (this is the default 
setting). In this case, the System Report will be generated automatically along with all other System files, 
when the Start button in this dialog is clicked.

Generating The TPDesign4 Project (.TP4) File

1. With a Touch Panel UI Diagram open, select Touch Panel > Generate TPDesign4 Project (or click the 
Toolbar button). 

This selection opens the Generate TPDesign4 Project dialog, where you can edit the name and target 
directory for the resulting TP4 project file (FIG. 265). 

By default, the TP4 file is named as follows:

VA Project Name - Touch Panel Name.TP4

2. Edit the file name and target directory as desired, and click Save to generate the TP4 project file.

Once it has been created, this project file can be opened and edited in the TPDesign4 application 
(available for free download from www.amx.com). Select the Open Project In TPDesign4 option 
to automatically open the resulting file once it is generated.

Refer to the TPDesign4 on-line help for details.

FIG. 265  Generate TPDesign4 Project dialog
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Transfer Previously Generated System Files

1. Select System > Generate and Transfer System Files (or click the Toolbar button) to access the 
Generate & Transfer System Files dialog (see FIG. 263 on page 199): 

2. Under Actions, select Transfer Previously Generated System Files.

3. Under Transfer Options, specify a Transfer Folder (source directory) that contains the system files that 
will be transferred. Click the browse icon to navigate to the desired folder in the Browse for Folder 
dialog.

4. Click Start.
The Progress bars indicate the status of the operation, and the program will alert you if there are any problems 
or issues with the system files during the process.

System Report
The System Report is a detailed summary of all devices in the system and their connection information, in the 
form of an HTML file. Scroll down to view the contents of the System Report. The contents of the System 
Report will depend on the devices in your system, but the main sections in every System Report include:

System Report - Cover Page
The front page of the System Report includes the date and time that the report was generated, along with basic 
project information (FIG. 266): 

Project - This is the name of the Project, as entered in the Project Properties dialog.

Project Location - This is the full directory path of the project.

Dealer Name - This is the name of the Dealer, as entered in the Project Properties dialog.

FIG. 266  System Report - Title Page

Click on any item in the Table of Contents to jump to that heading in the report.
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System Report - System Diagram
This is a printable version of the System Diagram for this project (FIG. 267). 

System Report - Equipment List
This is a listing of every device in the system (FIG. 268). 

System Report - Accessory List
This is a listing of every accessory in the system (FIG. 269). 

FIG. 267  System Report - System Diagram

FIG. 268  System Report - Equipment List

FIG. 269  System Report - Accessory List
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System Report - Installation Checklist
Use the Installation Checklist as a guide to the installation process. Each item in the checklist should be 
completed before you continue (FIG. 270). 

System Report - Wiring Connections
This section includes detailed wiring and connection information for each device in the system. Use the 
information in these sections to aid in the installation process. The subsections under Wiring Connections will 
depend on the devices in the system, and the types connections that exist between system devices.

System Report - Default Cable FG Information
VA provides FG numbers for device cables, whenever it is possible to discern which type of cable is required 
for each Equipment Connection in the project (FIG. 271). 

Cable FG information is included in the Cable column in the ‘Wiring Connections’ section of the System 
Report.

If there is only one compatible device cable for any given Equipment Connection, it will be listed in 
the System Report.

If there are multiple compatible cables, all possible cables are listed in the System Report with 
instructions to contact Customer Service for assistance in choosing/creating the proper cable.

System Report - Installation Instructions
This section of the report provides a summary of the Device Addressing, plus several subsections that describe 
various aspects of configuring device addressing on the Central Controller and AMX devices (including 
"Master Addressing via Terminal - Telnet", "NetLinx Device Addressing via the Master's UI", "Modero Touch 
Panels Device Addressing", and more (FIG. 272). 

FIG. 270  System Report - Installation Checklist

FIG. 271  System Report - Default Cable FG Information

FIG. 272  System Report - Installation Instructions
204 VisualArchitect Operation/Reference Guide



Finishing the Project
System Report - General Information
This section lists general information about the project, including module information (FIG. 273). 

System Report - Troubleshooting and Support
This section contains troubleshooting information relating to many different aspects of the control system 
(FIG. 274). 

System Report - Contact Information
This section provides contact information for AMX technical support.

FIG. 273  System Report - General Information

FIG. 274  System Report - Troubleshooting and Support
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Exporting Diagram Images
You can export the System Diagram and any or all UI Diagrams as image files, via the Export Diagram Images 
option:

1. Select System > Export Diagram Images (or click the Toolbar button) to open the Export Diagram 
Images dialog (FIG. 275). 

There are several types of diagrams that can be exported via the options in this dialog:

System - This option exports the entire System diagram (default = selected).

System (Control) - This option exports only the Control connections in the System diagram 
(default = de-selected).

System (Power) - This option exports only the Power connections in the System diagram (default 
= de-selected).

System Audio/Video - This option exports only the A/V connections in the System diagram 
(default = de-selected).

UI diagrams - Each option following the System (Audio/Video) option represents a UI device in 
the system.

2. To exclude any diagrams from being exported, uncheck the check box next to its listing in the Diagram 
area. Each diagram with a check mark will be exported as an individual image file of the selected file 
type.

3. Select an Output Folder for the file(s). By default, VA uses the folder that the project is saved to.

4. Specify a Filename Template:

Use $P to insert the project name

Use $D to insert the diagram name

The file extension (.BMP, .PNG or .JPG) is added automatically

FIG. 275  Export Diagram Images dialog

Use the Select All and Deselect All buttons to select/deselect all diagrams in the list.
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5. Make additional export options as desired:

Scale - To scale the exported image(s) down, enter a percentage of the original size (default = 100/
original size).

File - Select a file type for exported files (.BMP, .PNG or .JPG, default = JPG).

Compression - Specify the level of compression for exported images (JPG only). For high image 
quality (and larger file sizes) position the slider near the Quality side, for smaller file sizes (with 
lesser quality), position the slider in the Size side.

Show grid - Check this option to include the diagram grid in the exported image(s).

Export For Print (white diagram background) - This option applies a white background (for best 
printing results).

Export as greyscale - Check to export the diagram(s) as greyscale images.

Printing The Diagrams
You can print the diagrams in the System Diagram and any or all UI tabs via the Print Diagrams option:

1. Select System > Print Diagrams (or click the Toolbar button) to open the Print Diagrams dialog 
(FIG. 276). 

There are several types of diagrams that can be printed via the options in this dialog:

System: This option prints the entire System diagram (default = selected).

System (Control): This option prints only the Control connections in the System diagram (default 
= de-selected).

System (Power): This option prints only the Power connections in the System diagram (default = 
de-selected).

System Audio/Video: This option prints only the A/V connections in the System diagram (default 
= de-selected).

UI diagrams: Each option following the System (Audio/Video) option represents a UI device in 
the system (default = selected).

FIG. 276  Print Diagrams dialog
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2. To exclude any diagrams from being printed, uncheck the check box next to its listing in the Diagram 
area. Each diagram with a check mark will be exported as an individual image file of the selected file 
type.

3. Specify the Margins for the printout: Enter the space you want to allocate as margins on the printed page 
(in inches) in these fields. The default margin settings are:

Left = 0.5"

Right = 0.5"

Top = 0.25"

Bottom = 0.25"

4. Specify a Header / Footer for the printouts:

Use $SYSTEM$ to insert the system name

Use $DIAGRAM$ to insert the diagram name

Use $DEALER$ to insert the dealer name

Use $DESIGNER$ to insert the designer name

Use $REVISION$ to insert the revision name or number

Use $DATE$ to insert the current date

5. Make additional print options as desired:

Use common scaling factor - This option resizes all print images to the same scale to fit the page 
(default = enabled).

Print grid - Check this option to include the diagram grid in the printout(s).

Print background color - Check this option to include the background color in the printout(s). By 
default, this option is disabled - diagrams are printed with a white background.

Print as greyscale - Check to print the diagram(s) in greyscale.

VA Generated System Files
When you select to generate system files, via the options in the Generate & Transfer System Files dialog (see 
FIG. 263 on page 199), VA generates several files and folders.

The result of a Generate & Transfer System Files, or Generate System Files operation is the following set of 
folders and system files:

VA-Generated Folders
Include folder - contains any Include (.AXI) files required by the system.

IR folder - contains all IR (.IRL) files required by the devices in the system.

Module folder - contains all Duet module (.JAR) files required by the devices in the system.

Other folder - contains any system files other than the VA-generated files.

Report folder - contains the System Report and support files for this project (" projectname-
VAReport.html").

Source folder - contains the Master Source Code file (.AXS) required by the Central Controller.

User Interface folder - contains all Touch Panel (.TP4) and keypad (.KPB) user-interface files. 
There is one UI file generated for each UI device in the system.

VA-Generated Files
There are several individual files generated that are not copied into any of the VA-generated directories. There 
are only a few that are of interest:

 ,APW - this is the project workspace file for the project. APW files can be opened in NetLinx 
Studio. Workspace files allow you to edit any of the system files within NetLinx Studio. Refer to 
the NetLinx Studio on-line help for information on Workspace files.

CodeGen.log - this is a detailed log file of the file generation process. This is a text file, and can 
opened in any text editor (i.e. Notepad).

Use the Select All and Deselect All buttons to select/deselect all diagrams in the list.
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Custom Include Files
There are two custom Include (.AXI) files generated when you generate a VA project:

Custom.AXI - The "Custom.AXI" include file is used for making any custom programming 
changes for the system. When you generate your control system, it will reside in the Project's 
Include sub-folder.

CustomDefs.AXI - The "CustomDefs.AXI" file (also in the Project's Include sub-folder) allows 
programmers to create custom definitions that override AMX defaults.

Making Your Project Portable
In some situations you may need to prepare your VA Project so that it can be opened on a PC that does not 
have VA installed.

In this example, you would use the NetLinx Studio 2 application to transfer the System files generated in VA.

To make your VA project portable:

1. In VisualArchitect, use the Generate System Files option in the Generate & Transfer System Files dialog 
to generate the system files for your VA project (without initiating the transfer process).

One of the files that is generated with this option is a NetLinx Studio Workspace (.APW) file. This is the 
file that you will open in NetLinx Studio 2.

2. Launch NetLinx Studio 2, and select File > Open Workspace to access the Open Workspace dialog.

3. In the Open Workspace dialog, locate and open the ,APW file created for this project by VA.

This file can be found in the root of the project subfolder, in the Output Folder specified in the Generate 
options of the Generate & Transfer System Files dialog.

4. In Studio's workspace view, right-click the Include folder and select "Add Existing Include File…" from 
the context menu. This opens the Add Existing Include File dialog. In this dialog:

a.  Browse to C:\Program Files\Common Files\AMXShare\AXIs.

b.  Select the SNAPI.axi, G4API.axi, and MioRemoteAPI.axi files and click Open to add them to the 
project.

5. In NetLinx Studio, select Project > Export Workspace To Go to access the Export Workspace Files To 
Go dialog (FIG. 277): 

Depending on the equipment included in your system, some of these files may not 
appear (for example, if your system does not include any keypads, there would not 
be a KPB file generated).

If a Custom.AXI and/or CustomDefs.AXI file is not already present in the Include 
folder, VA will provide newly initialized AXIs. However, if there is a Custom.AXI and/or 
CustomDefs.AXI file present in the Include folder, it will be used in the Project, and 
will not be overwritten.

NetLinx Studio will ask you if you want to open each of the selected files for editing 
before they are added, which is unnecessary in this case. Click No to add the three 
files to the project without opening them.
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6. Set the Workspace Files options:

a.  Verify (or edit if necessary) the full path and file name of the exported "To Go" (.AXW) file. AXW 
files preserve all relative file path information for the Projects, Systems and System files contained in 
the Workspace, making them ideal for distribution to remote sites.

b.  Verify (or edit if necessary) the file name of the NetLinx Studio Workspace (.APW) file that will be 
created.

7. Check the Include Module Files that are not part of the Workspace option.

8. Click on Export to export the Workspace file (including all module files) to the specified "To Go" 
(.AXW) file name and target directory.

9. Select Project > Import From Exported AXW File to access the Select a AXW File For Extraction 
dialog (FIG. 278): 

FIG. 277   Export Workspace Files To Go dialog (NetLinx Studio)

Verify that the Keep Existing Folder Names option is unchecked.
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10. Locate and select the "To Go" (.AXW) file you just created for this project, and click Open.

a.  When you open a AXW file, NetLinx Studio will prompt you to specify a target directory to extract 
the files contained in the AXW file to in the Import From AXW File dialog (FIG. 279): 

b.  Click on Extract. NetLinx Studio may prompt you to verify new directories, if any were indicated in 
the Extract To field (in the Import From AXW File dialog).

c.  Click OK, and NetLinx Studio will indicate when the AXW File Extraction is complete (FIG. 280). 

d.  Click OK.

e.  Once NetLinx Studio has opened the AXW file, VA prompts you close the current workspace (select 
Yes or No).

FIG. 278  Select a AXW File For Extraction dialog (NetLinx Studio)

FIG. 279  Select a AXW File For Extraction dialog (NetLinx Studio)

FIG. 280  AXW File Extraction Complete dialog (NetLinx Studio)
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Working with Presets (.MXD and .PXD) Files

AMX Preset Editor is a stand-alone application that allows you to add CD and DVD discs to a Media Library, 
and create Media Preset Files (for CDs & DVDs) and Station Preset Files (for TV Channels/Radio Stations) 
that can then be added to your VA Project. 

Preset Editor is packaged as a integrated utility with VisualArchitect.

To launch Preset Editor from VisualArchitect, select File > Preset Editor.

Alternatively, you can launch Preset Editor from the Start menu (without having to launch VA): Select 
Programs > AMX Control Disc > VisualArchitect > Preset Editor.

There are two basic types of Preset files that can be created and managed with Preset Editor:

A Media Preset file (*.MXD) contains a list of CDs and/or DVDs that correspond to a disc or slot 
number (for CD/DVD changers with a number of slots, each slot can contain a CD or DVD).

A Station Preset file (*.PXD) contains a list of station presets. Each preset corresponds to a radio or 
television channel. Presets work basically like buttons on the face of a receiver - each one jumps to 
the channel it represents.

Preset and Media Content Database Files
If your VA Project includes Preset (.PXD) and/or Media (.MXD) Content Database files (created in 
ContentDatabaseEditor), these files will need to be sent to the Central Controller via FTP.

Use any FTP client application (for example "SmartFTP "), FTP any ,PXD and ,MXD files to the root 
directory of the Central Controller that this project will be loaded on.

Media Preset Files (CDs and DVDs)
Media Preset files (.MXD) contain a list of CDs and/or DVDs that corresponds to disc or slot numbers, for 
CD/DVD changers/players that have multiple slots (each one containing a CD or DVD). Media Preset files are 
used in VisualArchitect projects to represent content loaded on multi-slot CD/DVD changers/players.

Before a CD or DVD can be added to a Media Preset file, it must first be added to the Media Library. Once a 
CD or DVD is present in the Media library, it available to be added to one or more Media Preset files.

Channel Preset Files (TV Channels and Radio Stations)
Channel Preset files (.PXD) contain a list of channel presets. Each preset corresponds to a radio station or 
television channel.

Channel Preset files are used in VA projects to represent channel presets for TV and radio receivers, and 
associate a channel or station with a button.

Refer to the Preset Editor online help and Instruction Manual for details on 
using Preset Editor, including instructions on configuring FreeCDDB options 
to identify media.

You will need to provide the IP Address of the Central Controller in the FTP Client 
application.
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Attaching a Preset File to a VA Project
The process of attaching a preset file to a VisualArchitect (VA) project is simple. Assuming you have already 
created and saved at least one Preset (.MXD or ,PXD) File:

1. In VA, select the (third-party) device to which you want to attach your Preset File.

Media Preset Files (.MXD) can only be attached to devices that are capable of playing back audio/video 
media (including CD/DVD changers). If a device is compatible with Media Preset Files, the Media 
Library File Path property is included (in the Properties window) when the device is selected (FIG. 281): 

Channel Preset Files (.PXD) can only be attached to devices that are capable of selecting TV channels 
and/or radio stations (including receivers, TVs, etc.). If a device is compatible with Channel Preset Files, 
the Preset Library File Path property is included (in the Properties window) when the device is selected 
(FIG. 282): 

2. Use the Media Library File Path or Preset Library File Path property to select the Preset File that you 
want to attach to the selected device. Click the Browse (...) button in this field to access the Open dialog, 
where you can locate and select the desired Preset file.

3. Click OK to close the Open dialog and attach the selected file to the device.

The path and name of the attached Preset File is indicated in the Media Library File Path or Preset Library File 
Path field.

FIG. 281  Properties window - Media Library File path field

FIG. 282  Properties window - Preset Library File path field
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Troubleshooting

Overview
AMX provides several useful troubleshooting tools. In NetLinx systems you can use Terminal, Telnet, or the 
Central Controller's browser-based UI. 

If VA Freezes During File Transfers
If VA appears to hang up during a file transfer operation, it is likely due to an incorrect System Number 
assignment.

An incorrect System Number assignment will cause all transfers to time-out, giving the appearance 
of a freeze-up.

The System Number is assigned as a device property for the Central Controller (default = 1).

The symptom is that FileTransfer2 indicates an error, but the Progress bars seem to indicate activity, and the 
Cancel button is disabled so there's no obvious way to terminate the transfers.

To "un-hang" VA in this situation:

1. Right-click on the File Transfer task bar icon, and select SHOW. This opens the FileTransfer2 application 
dialog.

2. Check the status of your transfers, and close FileTransfer2. Once FileTransfer2 shuts down, VA should be 
ready to use.

3. Check the System Number assignment for the Central Controller. By default, it is set to "1" (the system 
you are currently connected to).

4. Correct the system number assignment and save the project.

5. Press Ctrl+T to generate and transfer the system files.

If VA Fails to Connect To the NetLinx Master
If you receive an error indicating that VA has failed to connect to the Master (FIG. 283): 

Setting the master's Ping For Availability property to False.

Opening up both the inbound and outbound ICMP ports on your firewall (instructions vary 
depending on the firewall).

The problem has to due most likely with firewall settings on your PC.

If VA Won't Compile Your Project
There are a few things that could prevent VA from successfully compiling your project. If your project won't 
compile, check the following:

1. Do you have "Power User" (or "Administrator") access rights on the PC running VA?

Because the VA compiler writes to common areas of the registry, the User that is logged in on the PC 
cannot belong to the Restricted User group. Their User Account profile must be set to either "Power 
User" (or "Administrator").

To see what your access rights are on your PC, go to Start > Settings > Control Panel > User Accounts to 
open the User Accounts dialog.

FIG. 283  Error Message - VA has failed to connect to the Master
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In the Users tab, look for your User Name, and see which Group you are assigned to. If you see 
"Restricted User", then you'll have to contact your network administrator and have them change this 
setting.

2. Are there any apostrophes in either the Project Name, or in the file path of the directory that the project is 
compiled into?

Apostrophes anywhere in the file path for the project will prevent VA from compiling successfully.

For example, a Project named "Joe's VA Projects" will be problematic. Remove the apostrophe and re-
save the project.

Likewise, an Output Folder (as specified in the Generate & Transfer System Files dialog) named "Joe's 
VA Projects" will also prevent a successful compile. Again, remove the apostrophe from the directory 
name and recompile.

Ethernet Cable Troubleshooting Tips
Look for the following things when troubleshooting Ethernet:

With 10Base-T & 100Base-T, verify the cable being used has the correct number of twists to meet 
the data grade specifications.

Electrical interference can be caused by tying the network cable together with monitor and power 
cords. Outside interference also can be caused by fluorescent lights, electric motors, and other 
electrical devices.

Make sure the connectors are both pinned properly and crimped tightly.

Check the cable lengths to make sure that distance specifications are not exceeded.

If excess shielding on the coax cable is exposed, it may be inadvertently grounding out the 
connector.

Check for missing terminator(s) with improper impedance ratings.

Troubleshooting - Device Discovery (DD) Devices
There are two error messages that might be received from the Central Controller under the following project 
conditions:

The Project loaded on the Central Controller uses only Device Discovery devices (that is, there are 
0 non-Device Discovery devices in the project).

The Central Controller has not been loaded with code files that refer to non-Device Discovery 
devices.

In this situation the following errors are visible, if you have connected to the Central Controller via 
Telnet, and have messaging turned on (MSG ON):

Error Message:

DynamicDeviceDetector.retrieveUrlJar: missing filename in URL response

DynamicDeviceDetector.retrieveDriverDependencies: failed to retrieve dependencydevicesdkrt.jar

This message indicates that the following requires system file is missing from the Central Controller: " 
devicesdkrt.jar"

Error Message:

DynamicDeviceDetector.retrieveUrlJar: missing filename in URL response 

DynamicDeviceDetector.retrieveDriverDependencies: failed to retrieve dependencysnapirouter.jar

This message indicates that the following requires system file is missing from the Central Controller: 

"snapirouter.jar"

Solution:
Copy the missing files to the Central Controller, via the Controller's built-in web UI:

1. In your web browser (i.e.: Internet Explorer or compatible), enter the following URL:

http://masters-ip/ (example: http://123.45.6.78/), to access the Controller's built-in web interface.

2. Open the Manage Other Devices page: click on the Manage Other Devices link (from within the System 
Settings section of the Navigation frame).

3. In the Manage Device Modules section of this page, select the Browse button (next to Select File To 
Upload).
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4. Locate and select the file: 

devicesdkrt.jar.

By default, VA copies these files to the following directory:

Program Files\Common Files\AMXShare\Duet\Bundle

5. Select Upload File.

6. Select the Browse button (next to Select File To Upload).

7. Locate and select the file: snapirouter.jar.

8. Select Upload File.

RS-232 Control Troubleshooting
To verify that your code and/or hardware are sending strings:

1. Send a string by pressing a Touch Panel button to send a command.

2. Use either the Master's UI - NetLinx Diagnostics page (System Settings > Manage System > Diagnostics) 
or a Terminal emulator. You should see the TX (transmit) LED light to indicate transmission.

If you do not see the TX LED illuminate, you must first correct your code, or configure the 
hardware properly.

If your device does not use hardware handshaking, be sure handshaking is disabled on the port. 
Hardware handshaking can be disabled by sending an 'HSOFF' command to the device port.

RS-232 Control Troubleshooting - Cabling
Once you have a good indication from the TX LED:

1. Short pins 2 and 3 on the DB-9 or Phoenix connector on the port.

2. Send a command and watch the TX and RX (receive) LEDs. You should see both LEDs light when each 
command is sent.

If only the TX LED is lighting, the unit is not sending strings and you should send it in for repair.

If both LEDs light up, move on to the next step.

3. Connect the cable that is going to the controlled device on the port and disconnect it at the terminal (far) 
end.

4. Short the TX and RX pins together on the equipment end of the cable. This is usually pins 2 and 3, but 
verify with the cable specs to be sure. Again, you should see both TX and RX LEDs illuminate.

If you do, remove the short and test again. The RX LED should no longer light.

If it continues, this indicates there is a short between TX and RX in the cable. Repair and re-test.

This test will verifies the continuity of the TX and RX wires within the cable, but does not completely test 
the cable. The Ground conductor can only be tested using a meter.

5. Disconnect the cable at both ends and connect an ohmmeter to both the ground and RX pins.

6. Short these conductors at the terminal (far end) of the cable and watch the meter for continuity readings. 
Also verify there are no shorts between any of the conductors when the ends are disconnected.

AMX tries diligently to verify cable specs, but sometimes there are changes in equipment. It is not unusual that 
TX and RX wires must be reversed to get the proper polarity. Try reversing these wires, but replace them to the 
normal position if that does not help.

RS-232 Control Troubleshooting - Settings
Once the cabling has been verified, the communication specifications must then be confirmed. 

These specifications include: baud rate, parity, data bits, stop bits, and flow control.

Some AMX devices use DIP switches to configure baud, data, and stop bits (ex: Mio Moderos) 
whereas some use software configuration. Confirm the setting by double checking the switch 
positions.

Cycle the switches to be sure they are firmly secured to their correct position. For software 
configured ports, re-send the configuration commands.

Confirm with the equipment manual, what the default settings are for the controlled device. Some 
devices can be changed, so be sure the default setting have not been altered.
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You can test the actual output of the RS-232 port by connecting the port to a computer COM port 
and using a Terminal Emulator to display the transmitted string to the screen. 

For example, the Axcent3 port #1 can be connected to a laptop's COM1 port using a standard AMX 
programming cable (FG10-727). This would be wired as follows; pin 2to pin3; pin 3 to pin2; and pin 5 to 
pin 5.

Send a string from the Axcent3 to the terminal program in Hyper Terminal (configured at the 
correct settings for the controlled device). Does the string display on screen? Is the information the 
same as your code is sending?

If the string is received as you see it in the code, the system is working properly.

You may need to change the display mode in the terminal program. In the Studio terminal, you can 
right click in the display area and choose Display from the menu. Select to display as ASCII, 
Decimal, or Hexadecimal, depending on how you would like to view the strings.

RS-232 Control Troubleshooting - The Controlled Device
Although not every process can be described, some aspects of verification are commonplace. You must verify 
the following information by either reviewing the corresponding device's manual, or contacting the 
manufacturer for details:

Baud rates are set to their default values (If it can be altered, verify current settings).

Cable pin specification are the same as the actual cable.

Make certain the COM port is enabled.

Check unit address (match this with the address in code).

Try sending strings from within Terminal.

If the manufacturer provides control software, see if that works with the target device.

RS-232 Control Troubleshooting - Technique
Terminal SEND commands can aid you in finding problems. While connected to the Master program port 
(within Terminal), you will find that you have two types of commands which allow you to troubleshoot: 
SEND_STRING and SEND_COMMAND.

The SEND_STRING command will send the string that follows out of the noted port. 

The syntax is: SEND_STRING <#>,"<String>" Where <#> equals the device number (You cannot 
use the device name in Terminal). "<String>" equals the string you want to send.

The SEND_COMMAND commands are port configuration commands like the command to set the 
baud rate, parity, and data and stop bits.

SEND_COMMAND <#>, ""SET BAUD 9600, N,8,1'"
Or the command to turn on hardware handshaking: SEND_COMMAND <#>, "' HSON'"

RS-232 Control Troubleshooting - Terminal PASS Mode
In Terminal, while connected to the Central Controller's program port, you can type:

PASS <#>
Where <#> equals the device number. While you cannot use the device name in Terminal, remember to use 
D:P:S within NetLinx.

In this mode, whatever you type on the keyboard will be sent directly out the RS-232 port as you type it. 
Anything that is returned by the controlled device will then be displayed on your screen. Your keystrokes are 
not echoed on the screen in this mode. The port's setting dictates the baud rate, etc. This is very handy for 
ASCII based commands, but Decimal and Hex characters cannot be found on the keyboard.

Exit PASS mode by holding down the [Shift] key and pressing the + twice, then release the shift and press 
Escape [Esc] twice (Shift +, +, Esc, Esc).

RS-232 Control Troubleshooting - Flow Control
Flow control dictates whether any handshaking is used. There are three possibilities: none (the most common), 
hardware, and software.

Hardware handshaking involves the use of two additional conductors to send a 'Request to Send' (RTS) signal 
between the devices. RTS is an output signal to the far end device that states it is OK to send data. The 'Clear 
to Send' (CTS) connection is an input signal that receives the RTS from the far end.
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When the RS-232 port is configured for hardware handshaking, no data is sent until the port receives a 'high' 
signal on the CTS pin from the RTS pin at the far end. Similarly, no data will be returned unless the RTS pin 
goes 'high', indicating it is able to receive data. 

There is another level of hardware handshaking using DTR and DSR, or Data Set Ready and Data Terminal 
Ready. These are primarily used by modems to communicate with PCs. These modes are not used in AMX 
gear, and you will find no connections for these signals.

Software handshaking uses data signals over the data wiring. This method is quite rare, and you should contact 
Tech Support if you have any questions regarding it's use.

NetLinx Diagnostics
NetLinx Diagnostics Control Device / Emulate Device
In this diagnostic window of the UI, you can send commands or strings out to any NetLinx RS-232 port by 
selecting the appropriate options, typing device number and the string or command in the control window, and 
pressing the "Send" button. Enabling Emulation (via the Emulate radio box), you can send the strings back to 
the control port that are expected from the OEM controlled device. Enabling the Emulation also allows for 
Pushes to be sent.

The Control/Emulate page on the UI allows a user to either Control a device or Emulate a device. This is done 
by controlling a device's channels, levels, and sending both send commands and strings to the target device.

1. Click the Manage System link (from within the System Settings section of the Navigation frame).

2. Clicking on any of the Online Tree items opens menu items with the Control/Emulate button option 
available.

3. Click the Control/Emulate button to open the Control/Emulate dialog.

4. Click the Update Status button to query the Central Controller for the status of the currently entered 
level and channel.

5. Select either the Control or Emulate option:

To Control a device means that the program generates messages which appear to a specified device 
to have come from the Controller. The options in this frame allow you to specify the <D:P:S> 
combination for the device you want to control.

To Emulate a device means that the program generates messages which appear to the Controller to 
have come from a specified <D:P:S> combination (real or fictitious). The options in this frame 
allow you to specify the <D:P:S> combination for the device you want to emulate.

Selecting this option adds a Push button with the Channel Code section of this page.

6. Enter a System Number, Device Number, and Port Number into the appropriate fields.

These values correspond to the device you wish to control (real or fictitious).

The Device, Port, and System value ranges are 1 - 65535.

7. Within the Channel Code section, enter a valid Channel number to emulate Channel messages (i.e., Push/
Release, CHON, and CHOFF) for the specified <D:P:S>.

The Channel number range is 1 - 65535.

8. Select the On or Off buttons to Emulate Channel ON (CHON) and Channel OFF (CHOFF) messages for 
the specified <D:P:S>.

9. Select the Push button to Emulate a push/release on the channel specified. You can click and hold down 
the Push button to see how the device/Controller responds to the push message.

10. Within the Level Code section, enter a valid Level number and Level data value for the specified 
<D:P:S> and press the Send button to transmit this data.

The Level number range is 1 - 65535.

The table below contains the valid Level data types and their ranges: 
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11. To Emulate sending a String or Command, type a String or Command within the corresponding field and 
press the Send button to transmit this data.

When entering a send command (in the context of this dialog) do not include the "send c" or 
"SEND_COMMAND" in the statement - only type what would normally occur within the quotes, but 
don't include the quotes either.

For example to send the "CALIBRATE" send command, simply type CALIBRATE (no quotes) rather 
than SEND_COMMAND < dev> "CALIBRATE".

String Expressions start and end with double quotes (" "). Double quotes are not escaped, rather 
they are embedded within single quotes. String expressions may contain string literals, decimal 
numbers, ASCII characters and hexadecimal numbers (prepended with a $), and are comma-
delimited.

String Literals start and end with single quotes ( ' ). To escape a single quote, use ''' (three single 
quotes).

Manage System - Diagnostics
This page allows an authorized user to setup and monitor diagnostic messages coming from and going to 
devices available on the Online Tree. This dialog also allows the user to watch the ICSP commands being sent 
to/from a device. There are several different types of asynchronous notifications that can be selected for a 
device:port:system (D:P:S) combination. Each notification type is represented by a column in the table.

All messages are displayed in the Notifications tab of the Output Display window in NetLinx Studio.

1. Click the Manage System link (from within the System Settings section of the Navigation frame).

2. Clicking on any of the Online Tree items opens menu items with the Diagnostics button option available.

3. Click the Diagnostics button to open the Diagnostics dialog.

4. Use the Refresh Interval drop-down to select from the following values: 2 seconds, 5 seconds, or 10 
seconds. This refresh interval allows you to select how often your messages are updated.

Setting Up and Removing a Diagnostic Filter
Setup a diagnostic filter by scrolling down the page and clicking the Modify button below the first empty 
column. This action opens the Device Configuration dialog as a secondary popup window.

1. Configure a diagnostic filter using the parameters available within the Diagnostic Configuration dialog.

The Diagnostic Configuration dialog allows you to select both the notifications you wish to receive and 
the target devices (within the Online Tree) for these notifications. There are several different types of 
asynchronous notifications that can be selected for a device:port:system (D:P:S) combination. Each 
notification type is represented by a column in the table.

2. Select an open Preset number entry from within Presets drop-down list. 

3. Make all desired notification selections and press the Store button. Pressing this button opens a popup 
field labeled Explorer User Prompt - Preset Name? where you enter the name associated with this new 
Preset.

Press OK to return to the previous Device Configuration popup dialog.

Click Cancel to exit this popup and return to the previous dialog without making any changes.

4. Press the down arrow (adjacent to the Preset drop-down list) to display a listing of all currently available 
Presets. Select a previously configured Preset and press the Recall button to populate all available fields 
and radio buttons with the selections associated with this chosen Preset.

Minimum Value Maximum Value

CHAR 0 255

INTEGER 0 65535

SINTEGER -32768 32767

LONG 0 429497295

SLONG -2147483648 2147483647

FLOAT -3.402823466e+38 3.402823466e+38
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5. Once you have made your modifications/selections within this dialog, press the Update button to save 
your changes and return to the Diagnostics dialog.

The Notification options available are described in the following table: 

This preset mechanism is done via cookies so it does not persist across multiple 
browsers/computers.

Notification Options

Feature Description

• Update Click this button once you have completed setting up your filter. The popup then 
closes and returns you to the Diagnostics window. 

Watch the bottom Incoming Message pane for messages to begin coming in from the 
target device(s).

• Remove This list of up to 10 presets comes defaulted with Preset 0: All Devices, All Notifica-
tions   

• Store: Save the current notification selections to a Preset profile. Pressing this 
button opens a popup field labeled Explorer User Prompt - Preset Name? where 
you enter the name associated with this new Preset.

Click OK to save both the Preset parameters and name, and then return to the 
Diagnostic Configuration dialog. Click Cancel to exit this popup and return to the 
previous dialog without making any changes.

• Recall: Allows a user to recall a previously existing Preset. This action then 
populates every field and radio button with the selections associated with the 
chosen Preset. This preset mechanism is done via cookies so it does not persist 
across multiple browsers/computers.

Note: A Preset MUST be Recalled before clicking the Update button. If you do not 
press this button, none of the fields or checkboxes are modified or selected. In 
essence, all options become disabled. Note: The All Devices entry cannot be 
removed.

Note: The only way to modify the information within a Diagnostic filter is to remove 
the assigned Preset, change the information, and assign a new Preset. Refer to step 
5 of this section for more information.

• System/Device/Port Device, Port, System: Use these fields to enter a device:port:system (D:P:S) 
combination for the device from which you want to enable notifications.

The specified device then appear in the Device field within the Diagnostic 
Configuration dialog.

A value of 0 for any option gives you all of the systems, devices, or ports. 
This dialog also allows you to store/recall presets.
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Remove a diagnostic filter by clicking the Modify button below it (from the Diagnostics dialog), then pressing 
the Remove button to delete this filter from the Diagnostics dialog.

Once a Preset is assigned to a specific Diagnostic filter "slot" (up to 8), its System:Device:Port fields are 
disabled, and can't be modified unless the Preset in that slot is removed and replicated with new information 
within these fields.

Modifying a Diagnostic Filter
To modify a Diagnostic filter's information (such as System/Device/Port):

1. Navigate to an empty Diagnostic filter slot and click the Modify button below the filter.

2. Select a previously unused Preset and store it with a new name.

3. Click the Remove button to remove this duplicate Preset from the specific filter slot.

4. Re-open the empty slot by clicking the Modify button, select the duplicated Preset and click Recall.

5. Change the necessary information (such as the System/Device/Port), then save it as the original Preset 
name, and click the Update button.

6. Use the Incoming Message field to view all the internal system diagnostic messages that are generated 
by a NetLinx master controller. This message field is a text box where you can select all the text within it 
and then copy/paste it for storage.

• NetLinx Notification 
Types

• All Notifications: Enables (selects) every notification field.

• Online/Offline Messages: Generates a message when there is a change in the 
target device's online/offline status.

• Configuration Messages: Generates a message when there is a change in the 
target device's configuration.

• Input Channel Changes: Generates a message when there is an input channel 
change (i.e. Push/Release) in the target device.

• Output Channel Changes: Generates a message when there is an output channel 
change (i.e. CHON/CHOFF) in the target device.

• Feedback Channel Changes: Generates a message when there is a feedback 
channel change in the target device.

• Level Changes From Device: Generates a message when there is a level channel 
change from the target device.

• Level Changes To Device: Generates a message when there is a level channel 
change to the target device.

• String From Device: Generates a message when there is a string from the target 
device.

• String To Device: Generates a message when there is a string sent to the target 
device.

• Command From Device: Generates a message when there is a command from the 
target device.

• Command To Device: Generates a message when there is a command to the target 
device.

• Status Messages: Generates a message when there is a change in the target 
device's status.

• Custom Events From Device: Generates a message there is a custom event 
occurring from the target device.
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Web Update

Overview
The AMX WebUpdate program is a stand-alone application that communicates with the AMX website. 
WebUpdate allows a user to select from a list of available AMX Software programs to choose for updating, 
determines the latest version of the selected applications, returns a listing of available updates, allows a user to 
download the selected installation files, and upon request, launches the installation of those downloads. 

Refer to the WebUpdate on-line help for details and instructions.

Installing WebUpdate
1. Go to www.amx.com, and log in as a Dealer.

2. Select the Tech Center link at the top of the page (FIG. 284): 

3. In the Tech Center menu along the left side of the page, select, click on the Application Files link 
(FIG. 285): 

4. In the Application Files page, click on WebUpdate (FIG. 286): 

5. In the WebUpdate page, click on the download link (FIG. 287): 

The WebUpdate application is not installed by NetLinx Studio, and must be installed 
separately.  If not found, NetLinx Studio will prompt you to download the application 
from www.amx.com.

FIG. 284  www.amx.com - Tech Center link selected

FIG. 285  www.amx.com Tech Center - Application Files link selected

FIG. 286  Application Files page - WebUpdate selected
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6. Read the License Agreement, and click I Accept to proceed.

7. In the Save As dialog, select a target directory for the WebUpdateSetup.exe file (FIG. 288): 

8. Click Save.

9. Double-click on the WebUpdateSetup.exe file to install WebUpdate.

10. The program will prompt you to restart your PC for changes to take effect. Save your work and restart 
your PC.

Once installed, select Help > WebUpdate to launch the WebUpdate application. WebUpdate will check for 
updates and ask you to select which update(s) to download and install.

FIG. 287  WebUpdate download link

FIG. 288  Saving WebUpdateSetup.exe
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WebUpdate User Interface Templates
To download User Interface Template Families via WebUpdate:

1. Click Help > WebUpdate User Interface Templates to open the AMX.com Template Library dialog.

The Template Families available to download are indicated in the main window.

By default, the Show Only New Templates option is selected. De-select this option to show all UI 
Template Families available to download.

2. Click on a Template Family to view the selected Template Family Properties (read-only).

3. Click the double-arrow icon on a Template Family icon to display thumbnail images of all templates 
contained (click Expand All to expand all Template Families - FIG. 289): 

4. Click to select individual Templates (ctrl+click for multi-select), or click Select All to specify which 
Templates within the Template Family to include in the download.

5. Click Install to download and install the selected Templates.

6. The progress of the Download/Install operation is indicated in the Progress bar (FIG. 290): 

If VA discovers that you are downloading a Template that is already present in VA, the Replace Template 
dialog prompts you to either replace the template, or abort the download/install operation. 

7. VA indicates the results of the operation (FIG. 291): 

8. Click OK. The new Template(s) are now available for selection.

FIG. 289  Expanding a Template Family

FIG. 290  Progress bar

FIG. 291  Templates Successfully Installed
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WebUpdate Duet Modules
To download Duet Modules via WebUpdate:

1. Click Help > WebUpdate User Interface Templates to open the WebUpdate Duet Module dialog.

2. Click in side the checkboxes (in the Download column) for each Module to select the Duet Modules that 
you want to download and install.

By default, all Modules are selected. Use the Select All and Select None to facilitate the selection 
process, as there may be many Modules listed.

3. Click Download to initiate the download operation.

4. The progress of the Download/Install operation is indicated in the Progress bar (FIG. 292): 

5. VA indicates when the download is complete, and alerts you that the Database will be refreshed to install 
the new and updated Modules (FIG. 293): 

6. Click OK to initiate the Database Refresh operation.

FIG. 292  Progress bar

FIG. 293  Download Complete

All Projects must be closed before the Database can be refreshed - close your 
Project if necessary.
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WebUpdate System Design Libraries (SDL)
System Design Library (SDL) files represent pre-configured VA Project/Systems designed to accommodate 
various installation types. 

SDLs are available for Dealers to download and install from www.amx.com (in the Markets section):

1. From the Help menu, select WebUpdate System Design Libraries (SDL). If VA finds any SDL files, the 
WebUpdate System Design Libraries dialog opens. 

2. Select the files you want to download by clicking the corresponding check box for each item.

3. Click Download.

4. Read the License Agreement, select I Agree and click Next to proceed.

5. The program alerts you once the SDL installation is complete (FIG. 294): 

6. Click Finish to proceed. This action invokes the WebUpdate System Design Libraries Report dialog 
(FIG. 295): 

Click Print to print the Download and Installation Report.

Click OK to close this dialog.

Once installed, the SDL is available for selection via the System Design Library dialog (FIG. 296): 

FIG. 294  SDL Installation Complete

FIG. 295  WebUpdate System Design Libraries Report dialog
227VisualArchitect Operation/Reference Guide 



Web Update
FIG. 296  System Design Library dialog
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AMX Icon 2 Character Map
Use the AMX Icon 2 font to use symbols instead of text for many standard transport and control 
functions, for use on engraved keypad buttons (FIG. 297). 

FIG. 297  AMX Icon 2 Character Map

Digit 1Capital letter Y

Digit 2

Digit 3

Digit 4

Digit 5

Digit 6

Equals Sign

Capital letter E

Capital letter I

Capital letter Q

Capital letter R

Capital letter T

Capital letter U

Capital letter W

Capital letter X

Capital letter Z

Lowercase b

Lowercase c

Lowercase e

Lowercase i

Lowercase m

Lowercase n

Lowercase q

Lowercase r

Lowercase t

Lowercase u

Lowercase v

Lowercase w

Lowercase x

Lowercase y

Lowercase z

Soft hyphen
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Extended ASCII Characters/Hex Table 
100 101 102 103

Dec Hex Char Dec Hex Char Dec Hex Char Dec Hex Char

128 80 Ç 160 A0 á 192 C0 ? 224 E0 ?

129 81 ü 161 A1 í 193 C1 ? 225 E1 ß

130 82 é 162 A2 ó 194 C2 ? 226 E2 ?

131 83 â 163 A3 ú 195 C3 ? 227 E3 ?

132 84 ä 164 A4 ñ 196 C4 ? 228 E4 ?

133 85 à 165 A5 Ñ 197 C5 ? 229 E5 ?

134 86 å 166 A6 ª 198 C6 ? 230 E6 µ

135 87 ç 167 A7 º 199 C7 ? 231 E7 ?

136 88 ê 168 A8 ¿ 200 C8 ? 232 E8 ?

137 89 ë 169 A9 ? 201 C9 ? 233 E9 ?

138 8A è 170 AA ¬ 202 CA ? 234 EA ?

139 8B ï 171 AB ½ 203 CB ? 235 EB ?

140 8C î 172 AC ¼ 204 CC ? 236 EC ?

141 8D ì 173 AD ¡ 205 CD ? 237 ED ?

142 8E Ä 174 AE « 206 CE ? 238 EE ?

143 8F Å 175 AF » 207 CF ? 239 EF ?

144 90 É 176 B0 ? 208 D0 ? 240 F0 ?

145 91 æ 177 B1 ? 209 D1 ? 241 F1 ±

146 92 Æ 178 B2 ? 210 D2 ? 242 F2 ?

147 93 ô 179 B3 ? 211 D3 ? 243 F3 ?

148 94 ö 180 B4 ? 212 D4 ? 244 F4 ?

149 95 ò 181 B5 ? 213 D5 ? 245 F5 ?

150 96 û 182 B6 ? 214 D6 ? 246 F6 ÷

151 97 ù 183 B7 ? 215 D7 ? 247 F7 ?

152 98 ÿ 184 B8 ? 216 D8 ? 248 F8 °

153 99 Ö 185 B9 ? 217 D9 ? 249 F9 ?

154 9A Ü 186 BA ? 218 DA ? 250 FA ·

155 9B ¢ 187 BB ? 219 DB ? 251 FB ?

156 9C £ 188 BC ? 220 DC ? 252 FC ^(n)

157 9D ¥ 189 BD ? 221 DD ? 253 FD ²

158 9E ? 190 BE ? 222 DE ? 254 FE ?

159 9F ƒ 191 BF ? 223 DF ? 255 FF ?
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AMX Power Calculator
Select Help > Power Calculator to open the AMX Power Calculator.xls worksheet file (FIG. 298). 

This worksheet uses macros to calculate maximum wiring distances and voltage drop. based on cable size and 
distance. When opening the file, select Enable Macros.

The AMX Power Calculator worksheet performs two main calculations:

Calculates the maximum length of a specific size of cable for a device or devices. (Choose between 
Foot and Meter measurements.) You can also get the total current draw for this group of devices.

Calculates the voltage drop of a length of cable for a device or devices, based on current draw.

Red means it exceeds the allowable voltage drop.

1. Select the tab (along the bottom of the screen) that contains the type of device(s) you are working with.

2. Under "QTY" in column A, enter a quantity for each device (listed under "Product Title" in column B). 
This number should represent the number of each device that will be in the system.

FIG. 298  AMX Power Calculator

You'll need to have a program loaded on your PC that can open XLS files (such as 
Microsoft® Excel) in order to use this worksheet.
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3. To calculate voltage drop, enter "Cable Length" (in column G).

4. Press the TAB key (or click in any other cell) to enter the information and update the table with the 
various cable and voltage drop information that it provides:

Max Cable Length (Column C, Rows 4-10): This group of cells shows the total feet of cable of a 
particular size that can support the selected equipment.

Total Current Draw (Column A, Row 6): This cell shows the total current draw for all devices 
entered. The System tab shows the total for all pages.

Voltage Drop (Columns G, H, I - Rows 4-10): This group of cells shows the voltage drop for a 
selected cable length and device set. Enter the estimated cable length in the yellow box and read the 
voltage drop for the wire gauge at the right. Use a cable gauge that is shown in green.

By default, length is calculated in feet. Click the drop-down menu (in column E) to 
change "FEET" to "METERS".

All current draw values are "Worst Case" or Max values as listed in AXPower.txt.
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3000 RESEARCH DRIVE, RICHARDSON, TX 75082 USA •  800.222.0193  •  469.624.8000  •  469-624-7153 fax  • 800.932.6993 technical support  •  www.amx.com

Increase Your Revenue
through education + knowledge

In the ever-changing AV industry, continual education is key to success. AMX University is 
dedicated to ensuring that you have the opportunity to gather the information and 
experience you need to deliver strong AMX solutions. Plus, AMX courses also help you 
earn CEDIA, NSCA, InfoComm, and AMX continuing education units (CEUs).

Visit AMX University online for 24/7/365 access to:
- Schedules and registration for any AMX University course
- Travel and hotel information
- Your individual certification requirements and progress
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