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AMX Software License and Warranty Agreement
• LICENSE GRANT. AMX grants to Licensee the non-exclusive right to use the AMX Software in the manner described in this 

License. The AMX Software is licensed, not sold. This license does not grant Licensee the right to create derivative works of the 
AMX Software. The AMX Software consists of generally available programming and development software, product documenta-
tion, sample applications, tools and utilities, and miscellaneous technical information. Please refer to the README.TXT file on 
the compact disc or download for further information regarding the components of the AMX Software. The AMX Software is sub-
ject to restrictions on distribution described in this License Agreement. AMX Dealer, Distributor, VIP or other AMX authorized 
entity shall not, and shall not permit any other person to, disclose, display, loan, publish, transfer (whether by sale, assignment, 
exchange, gift, operation of law or otherwise), license, sublicense, copy, or otherwise disseminate the AMX Software. Licensee 
may not reverse engineer, decompile, or disassemble the AMX Software. 

• ACKNOWLEDGEMENT. You hereby acknowledge that you are an authorized AMX dealer, distributor, VIP or other AMX autho-
rized entity in good standing and have the right to enter into and be bound by the terms of this Agreement.

• INTELLECTUAL PROPERTY. The AMX Software is owned by AMX and is protected by United States copyright laws, patent 
laws, international treaty provisions, and/or state of Texas trade secret laws. Licensee may make copies of the AMX Software 
solely for backup or archival purposes. Licensee may not copy the written materials accompanying the AMX Software. 

• TERMINATION. AMX RESERVES THE RIGHT, IN ITS SOLE DISCRETION, TO TERMINATE THIS LICENSE FOR ANY REA-
SON UPON WRITTEN NOTICE TO LICENSEE. In the event that AMX terminates this License, the Licensee shall return or 
destroy all originals and copies of the AMX Software to AMX and certify in writing that all originals and copies have been 
returned or destroyed. 

• PRE-RELEASE CODE. Portions of the AMX Software may, from time to time, as identified in the AMX Software, include PRE-
RELEASE CODE and such code may not be at the level of performance, compatibility and functionality of the GA code. The 
PRE-RELEASE CODE may not operate correctly and may be substantially modified prior to final release or certain features may 
not be generally released. AMX is not obligated to make or support any PRE-RELEASE CODE. ALL PRE-RELEASE CODE IS 
PROVIDED "AS IS" WITH NO WARRANTIES.

• LIMITED WARRANTY. AMX warrants that the AMX Software (other than pre-release code) will perform substantially in accor-
dance with the accompanying written materials for a period of ninety (90) days from the date of receipt. AMX DISCLAIMS ALL 
OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH REGARD TO THE AMX SOFTWARE. THIS LIM-
ITED WARRANTY GIVES LICENSEE SPECIFIC LEGAL RIGHTS. Any supplements or updates to the AMX SOFTWARE, 
including without limitation, any (if any) service packs or hot fixes provided to Licensee after the expiration of the ninety (90) day 
Limited Warranty period are not covered by any warranty or condition, express, implied or statutory.

• LICENSEE REMEDIES. AMX's entire liability and Licensee's exclusive remedy shall be repair or replacement of the AMX Soft-
ware that does not meet AMX's Limited Warranty and which is returned to AMX in accordance with AMX's current return policy. 
This Limited Warranty is void if failure of the AMX Software has resulted from accident, abuse, or misapplication. Any replace-
ment AMX Software will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. 
Outside the United States, these remedies may not available. NO LIABILITY FOR CONSEQUENTIAL DAMAGES. IN NO 
EVENT SHALL AMX BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES 
FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER 
PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THIS AMX SOFTWARE, EVEN IF AMX HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/COUNTRIES DO NOT ALLOW 
THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITA-
TION MAY NOT APPLY TO LICENSEE.

• U.S. GOVERNMENT RESTRICTED RIGHTS. The AMX Software is provided with RESTRICTED RIGHTS. Use, duplication, or 
disclosure by the Government is subject to restrictions as set forth in subparagraph ©(1)(ii) of The Rights in Technical Data and 
Computer Software clause at DFARS 252.227-7013 or subparagraphs ©(1) and (2) of the Commercial Computer Software 
Restricted Rights at 48 CFR 52.227-19, as applicable.

• SOFTWARE AND OTHER MATERIALS FROM AMX.COM MAY BE SUBJECT TO EXPORT CONTROL. The United States 
Export Control laws prohibit the export of certain technical data and software to certain territories. No software from this Site may 
be downloaded or exported (i) into (or to a national or resident of) Cuba, Iraq, Libya, North Korea, Iran, Syria, or any other coun-
try to which the United States has embargoed goods; or (ii) anyone on the United States Treasury Department's list of Specially 
Designated Nationals or the U.S. Commerce Department's Table of Deny Orders. AMX does not authorize the downloading or 
exporting of any software or technical data from this site to any jurisdiction prohibited by the United States Export Laws.

This Agreement replaces and supersedes all previous AMX Software License Agreements and is governed by the laws of 
the State of Texas, and all disputes will be resolved in the courts in Collin County, Texas, USA. For any questions concern-
ing this Agreement, or to contact AMX for any reason, please write: AMX License and Warranty Department, 3000 Research 
Drive, Richardson, TX 75082.
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Preset Editor
Preset Editor

Overview
AMX Preset Editor is a stand-alone application that allows you to add CD and DVD discs to a Media Library, 
and create Media Preset Files (for CDs & DVDs) and Station Preset Files (for TV/Radio Stations) that can then 
be added to your VA Project.

Preset Editor is packaged as a integrated utility with VisualArchitect™. To launch Preset Editor from 
VisualArchitect™, select File > Preset Editor.

Alternatively, you can launch Preset Editor from the Start menu (without having to launch VA): Select 
Programs > AMX Control Disc > VisualArchitect™ > Preset Editor (FIG. 1). 

There are two basic types of Preset files that can be created and managed with Preset Editor:

A Media Database file (*.MXD) contains a list of CDs and/or DVDs that correspond to a disc or 
slot number (for CD/DVD changers with a number of slots, each slot can contain a CD or DVD).

A Station Preset file (*.PXD) contains a list of station presets. Each preset corresponds to a radio 
or television channel. Presets work basically like buttons on the face of a receiver - each one jumps 
to the channel it represents.

Getting Started
When the Preset Editor application is launched, the Welcome screen is displayed, prompting you to select a 
starting point for working with the application:

New Document: Click to start a new Preset File document. This option invokes the Create New 
Preset File dialog, where you are prompted to select the type of Preset File that you want to create. 
The two types are:

Media Preset file - for CDs and DVDs, with the file extension *.mxd.

Station Preset file - for TV and Radio stations, with the file extension  *.pxd.

Open Document: Click to open an existing Preset Editor file for editing. This option invokes the 
Open Existing Preset File dialog, where you can locate and select the Preset file that you want to 
edit.

It is important to note that before any item (CD, DVD, TV or Radio Station) can be added to a Preset File 
(Media Preset or Station Preset), it must first be added to the Media Library.

FIG. 1  Launching Preset Editor (without VA)
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Preset Editor
Attaching a Preset File to a VA Project
The process of attaching a preset file to a VisualArchitect™ (VA) project is simple. Assuming you have already 
created and saved at least one Preset (*.mxd or *.pxd) file, and have at least one controlled device in your VA 
project:

1. In VA, select the (third-party) device to which you want to attach your Preset File.

Media Preset Files (*.mxd) can only be attached to devices that are capable of playing back audio/
video media (including CD/DVD changers). If a device is compatible with Media Preset Files, the 
"Media Library File Path" property is included (in the Properties window) when the device is 
selected (FIG. 2). 

Station Preset Files (*.pxd) can only be attached to devices that are capable of selecting TV 
channels and/or radio stations (including receivers, TVs, etc). If a device is compatible with 
Station Preset Files, the "Preset Library File Path" property is included (in the Properties 
window) when the device is selected (FIG. 3): 

2. Use the Media Library File Path or Preset Library File Path property to select the Preset File that you 
want to attach to the selected device. Click the Browse (...) button in this field to access the Open dialog, 
where you can locate and select the desired Preset file.

3. Click OK to close the Open dialog and attach the selected file to the device.

The path and name of the attached Preset File is indicated in the Media Library File Path or Preset Library File 
Path field.

FIG. 2  Attaching a Preset File to a VA Project - Media Preset Files (*.mxd)

FIG. 3  Attaching a Preset File to a VA Project - Station Preset Files (*.pxd)
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Preset Editor
The Preset Editor Workspace
FIG. 4 shows the basic elements of the Preset Editor workspace: 

Menu Bar
The Preset Editor Menu Bar contains the following menus:

File Menu 

Option Menu
Reset Splash Screen - Select this option to open the Welcome To the AMX Preset Editor dialog each time the 
application is launched. Use this option if you have disabled this dialog via the Show this dialog at startup 
option (FIG. 5): 

FIG. 4  The Preset Editor Workspace

File Menu Options

• New: Click to invoke the Create New Preset dialog, where you will specify the type of content database 
you want to create (Media - CDs and DVDs, or Station - TV/Radio stations Presets).

• Open: Click to access the Open Existing Preset File dialog, to locate and select existing Media (*.MXD) 
or Station Preset (*.PXD) files to view and edit.

• Save: Saves all changes, via the Save Preset File dialog. This option saves the file under it's current 
name, to it's current location.

• Save As: Save the active Preset file to a different name and/or location, via the Save Preset File dialog.

• Exit: Closes the Preset Editor application. The application will prompt you to save any changes before 
shutting down.

FIG. 5  Show this dialog at startup option (Welcome To the AMX Preset Editor dialog)

Title Bar (shows name of currently open preset file)
Menu Bar Media Library Toolbar

Preset Toolbar

Media Library Window Preset Content Window
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Preset Editor
Media Library Menu
The options in this menu allow you manage the Media Library: 

Help Menu 

Media Library Menu Options

• Add Entry to Media Library: Click to access the Select Type sub menu, to select the type of entry to add 
(CD, DVD, Radio Station or TV Station). 

Select a type from this menu to open the appropriate Add <Media Type> to 
Library dialog.

• Add Multiple Entries to
Media Library:

This option allows you add multiple entries of any type. 

Click to invoke the Select the media type dialog, where you can select the type 
of entry to add first (CD, DVD, Radio Station or TV Station). 

Click OK to open the appropriate Add <Media Type> to Library dialog. Fill in the 
information and click OK to close the Add <Media Type> to Library dialog and 
return to the Select Media Type dialog to repeat the process as desired. 

See Adding Multiple Entries to Media Library.

• Remove Entry from 
Media Library:

Removes the selected entry from the Media Library. 

The program will prompt you before permanently removing the selected entry. 

See Removing an Entry From the Media Library for details.

• Edit Properties: Opens the appropriate Edit <media type> in Library dialog, where you can view 
and edit the information entered for the selected entry.

• Identify Disc: Initiates an attempt at identifying the CD in your PC's local CD drive using the 
online CDDB database.

Note: If the disc is identified, the Disc Properties dialog is invoked, to allow you 
to review (and edit if necessary)  the retrieved disc information. When you 
press OK in the Disc Properties dialog, the disc is automatically added to the 
Media Library. 

See Editing Disc/Station Properties for details.

• Manage Genres: Opens the Genre Manager dialog to manage the Genres available in the Media 
Library. 

See Managing Genres for details.

• Manage Categories: Opens the Category Manager dialog to manage the Categories available in the 
Media Library. 

See Managing Categories for details.

• Configure CDDB: This option opens the FreeCDDB Settings dialog, where you can configure 
your access to multiple CDDB sites for disc (audio CD) identification.

Help Menu Options

• Preset Editor Help: Launches this help file.

• About Preset Editor: Invokes the "About" dialog, which indicates the version number of your Preset 
Editor application.
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Preset Editor
Media Library Window
The Media Library window displays the contents of the Media Library. The Media Library window contains 
several tabs. The tabs displayed depend on the selection made in the Create New Preset File dialog (FIG. 6):

If you selected Media Preset - CDs and DVDs (*.mxd), then the tabs presented are specific to 
media presets (CD and DVD). See Media Preset Content Windows on page 8.

If you selected Station Preset - TV stations and Radio stations (*.pxd), then the tabs presented 
are specific to station presets (TV and  Radio).

The Search tab is displayed regardless of the preset type selected in the Create New Preset File 
dialog, the Media Library window (see Media Library Bar - Search tab). 

Media Library Toolbar
The Media Library Toolbar provides shortcuts to basic database-oriented functions (FIG. 7):      

FIG. 6  Media Library Window

FIG. 7  Media Library Toolbar

Media Library Toolbar Options

• Add To Media Library: Click to access the Select Type sub menu to select the type of media you want to add 
(Add CD, Add DVD, Add Radio Station, Add TV Station). Select a type from this 
menu to open the appropriate Add <Media Type> to Library dialog.

• Remove Entry From 
Media Library:

Removes the selected disc from the Media Library.

Note that if you select to remove an Artist folder (in the CD tab of the Media Library 
window), all CDs by that artist will be removed. The program will prompt you to verify 
this action before any media is removed from the Media Library.

CD/DVD tabs TV/Radio tabs Search tab
(for Media Preset files) (for Station Preset files)

Add Entry to Media Library
Remove Entry From Media Library Edit Properties

Identify CD

Genre Manager
Category Manager
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Preset Editor
Media Library Window - CD tab
The CD tab of the Media Library window displays all CDs that have been added to the Media Library. This tab 
is available if you have either opened an existing Media Preset (*.MXD) file, or selected to create a new Media 
Preset file (via options in the Welcome screen and Create New Preset File dialog).

Music is sorted in the CD tab by Artist name. Click the "+" symbol next to any Artist name to 
expand the list to show all CD Titles by that artist that are in the Media Library.

Click the "+" symbol next to any CD Title to expand the list to show the Genre and Summary items, 
as well as all of the Tracks contained in that CD. See Editing Disc/Station Properties.

You can drag-and-drop individual tracks or entire CDs from the Media Library window to the Media Preset 
Content Window. Each item dragged from the Media Library window takes up a single row in the Media 
Preset Content Window. For example, if you drop an entire CD onto a row in the Media Preset Content 
Window, the entire CD occupies a single row, and when that item is invoked via the Touch Panel (by the end-
user), the CD will play in it’s entirety, based on the Tracks list it contains.

If you drop an individual track from a CD in the Media Library Bar to a row in the Media Preset Content 
Window, the entire disc is added to the Content Window and will played when selected.

Media Library Window - DVD tab
The DVD tab of the Media Library window displays all DVDs that have been added to the Media Library. This 
tab is available if you have either opened an existing Media Preset (*.MXD) file, or selected to create a new 
Media Preset file (via the options in the Welcome screen and Create New Preset File dialog).

DVDs are sorted in the DVD tab by DVD Titles. Click the "+" symbol next to any Title to expand 
the list to show all the Genre and Summary items, and the Chapter Info folder. See Editing Disc/
Station Properties.

Click the "+" symbol next to the Chapter Info folder to expand the list to show all of the chapters 
contained in that DVD.

You can drag-and-drop entire DVDs from the Media Library window to the Media Preset Content Window. 
Each DVD dragged from the Media Bar takes up a single row in the Media Preset Content Window.

Media Library Toolbar Options (Cont.)

• Edit Properties: Click to open the appropriate Edit <media type> In  Library dialog, based on the type 
of media selected.

• Identify CD: Initiates an attempt at identifying the CD in your PC's local CD drive.

• Manage Genres: Opens the Genre Manager dialog, where you can add, rename or delete Genres (for 
CDs and DVDs) from the Media Library.

• Manage Categories: Opens the Category Manager dialog, where you can add, rename or delete 
Categories (for Radio and TV stations) from the Media Library.

You can drag items from the Media Library window directly into your Preset Content 
Windows - see the Preset Files section on page 29 for details.

If you drop an Artist folder onto a row in the Media Preset Content Window, all CD 
Titles in the Artist folder will be added.

Dropping individual chapters from a DVD onto the Media Preset Content Window is 
not supported. If you drop any chapter from a DVD into the Media Preset Content 
Window, the entire DVD is added.
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Preset Editor
Media Library Window - TV tab
The TV tab of the Media Library window displays all TV stations that have been added to the Media Library. 
The TV and Radio tabs are available if you have either opened an existing Station Preset (*.PXD) file, or 
selected to create a new Station Preset file (via the options in the Welcome screen and Create New Preset File 
dialog).

TV stations are sorted by Category. Each folder in the TV tab represents a different Category. Click 
the "+" symbol next to any Category folder to expand the list to show the stations contained within 
that folder.

Click the "+" symbol next to any TV channel to expand the list to show the station (number), Genre, 
Image and Summary items.

Media Library Window - Radio tab
The Radio tab of the Media Library window displays all Radio stations that have been added to the Media 
Library. The TV and Radio tabs are available if you have either opened an existing Station Preset (*.PXD) file, 
or selected to create a new Station Preset file (via the options in the Welcome screen and Create New Preset 
File dialog).

Radio Stations are sorted by Category. 

Click the "+" symbol next to any Radio station to expand the list to show the Station (number), 
Genre, Image and Summary items.

Media Library Window - Search tab
The options in the Search tab of the Media Library window allow you search for entries in the Media Library.

Enter a text string in the Search For field, select search filters as desired, and click the Search button.

Search results are displayed in this tab (see Searching For an Entry in the Media Library). 

Media Library Window Context Menu
Right-click on any item in the Media Library window to access the Media Library window context menu: 

The Category folders suffixed with "- [AMX]" are automatically added and maintained 
by AMX, and cannot be modified. These are provided by AMX to offer a quick-start to 
creating Station Presets using common stations. See the Managing 
Categories section on page 25 for details.

Media Library Window Context Menu Options

• Add Entry: Click to open the Disc Type sub-menu, where you can specify the type of entry 
you want to add (CD, DVD, Radio Station or TV Station). 

Select a type from this menu to open the appropriate Add <Media Type> to 
Library dialog.

• Remove Entry: Removes the selected entry from the Media Library. The program will prompt you 
before permanently removing the selected title from the Media Library. See 
Removing an Entry From the Media Library.

• Manage Genres 
(CD and DVD tabs only):

This option opens the Genre Manager dialog, where you can manage the 
Genres available in the Media Library. See Managing Genres for details.

• Manage Categories 
(Radio and TV tabs only):

This option opens the Category Manager dialog, where you can manage the Cat-
egories available in the Media Library. See Managing Categories for details.

• Edit Properties: Opens the appropriate Edit <media type> in Library dialog where you can view 
and edit the information entered for the selected disc/station.
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Preset Editor
Preset Content Windows
Media Preset Content Windows
When you create a new Media Preset file (see Creating a New Media Preset File), a new Media Preset Content 
window is opened (FIG. 8). 

Use these windows to add the discs that are to be included in this database. Media Preset Content windows 
consist of a table with the following columns: 

Station Preset Content Windows
When you create a new Station Preset, a new Station Preset Content window is opened (FIG. 9). 

FIG. 8  Media Preset Content Window

Media Preset Content Windows

• Slot#: The numbered rows represent the number and order of the Discs in this Preset file (read-only).

• Type: This column indicates the type (CD or DVD) of each disc.

• Title: This column indicates each discs' title. To enter a disc title, click inside the Title cell and type the 
title as you want it to appear for selection.

• Artist: This column indicates the artist name associated with each disc. For CDs, this would be the 
name of the artist or band, and for DVDs it could be used for the Director, key actors, or whatever 
best fits your needs. Remember that DVDs (as well as CDs) can be searched by Artist, so give 
some thought to how to best use this field.

• Genre: This column indicates the genre name associated with each disc.

• Summary: Enter a text description of the CD or DVD in this text field.

FIG. 9  Station Preset Content Window
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Preset Editor
Use these windows to add the stations that are to be included in this Preset file. Station Preset Content 
windows consist of a table, with the following columns: 

Preset Toolbar
The Preset Toolbar provides shortcuts to basic file and edit functions:      

Preset Content Window Context Menu
Right-click on a selected item in the Media or Station Preset Content Windows to access the following context 
menu: 

Station Preset Content Windows

• Slot#: The numbered rows represent the number and order of the Stations in this Preset file (read-only).

• Type: This column indicates the type (Radio or TV) of each station.

• Title: This column indicates each station's title. Click inside this cell to edit if necessary.

• Image This column indicates the logo image associated with each station. To associate a logo with a 
station, click inside the Image cell and select the image with a name that matches the station you 
are adding. See Creating Custom Images for Radio and TV Stations.

• Station This column indicates the station number associated with each Station Preset. Click inside this 
cell to edit if necessary.

• Genre: This column indicates the genre name associated with each station.

• Summary: Enter a text description of the station in this text field.

FIG. 10  Media Library Toolbar

Preset Toolbar Options

• New Preset File: Creates a new Preset File. The program will prompt you to specify the type (Media or 
Station), via the Create New Preset File dialog.

• Open Preset File: Opens an existing Preset file (*.MXD or *.PXD) via the Open Existing Preset File dialog.

• Save Preset File: Saves the current Preset file.

• Add Preset: Adds a new (empty) entry to the active Preset File window, in the row above the 
selection.

• Remove Preset: Removes the selected entry from the active Preset File window.

• Move Preset Up: Moves the selected entry up one position in the list.

• Move Preset Down: Moves the selected entry down one position in the list.

Preset Content Window Context Menu Options

• Add Preset Adds an empty slot or preset to the bottom of the list.

• Remove Preset Removes a selected item from the list.

• Move Preset Up / 
Move Preset Down

Moves the selected item up or down one row in the list.

New Preset File
Open Preset File
Save Preset File

Add Preset
Remove Preset

Move Preset Up
Move Preset Down
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The Media Library
The Media Library

Overview
The Media Library represents a repository of all entries (CDs, DVDs, TV and Radio stations) that have been 
added to Preset Editor.

The Media Library is displayed in the Media Library window.

Once a CD or DVD is in the Media Library, it is available to be added to one or more Media Preset 
files.

Once a TV or Radio station is in the Media Library, it is available to be added to one or more 
Station Preset files.

Working With the Media Library
In order for any item (CD, DVD, TV or Radio Station) to be added to a Preset file (Media Preset or Station 
Preset), it must first be added to the Media Library, as described in the following sections:

Adding a CD to the Media Library using CDDB
Preset Editor uses an online media identification service to automatically identify CDs for addition to the 
Media Library.

1. Insert the CD in your PC’s drive.

2. Click the Identify CD/DVD toolbar button to initiate the identification of this disc.

Alternatively, select Media Library > Identify CD/DVD (or press Ctrl+I).

In some cases, the disc reports more than one possible match. If this happens, the FreeDB Query 
Results dialog is displayed - select the correct match from the list of possible matches and click OK 
to continue.

If you receive the message: "Failed to retrieve CDDB sites!", you may need to configure your 
CDDB options, via the FreeCDDB Settings dialog (see Configuring FreeCDDB Options).

3. When the disc is identified, the Edit CD in Library dialog is displayed, where you can edit the CD 
information (if necessary), and add this CD to the Media library (FIG. 11): 

You must have an active Internet connection to use the Identify CD feature.

Hold down the Shift key to prevent the disc from auto-playing, if necessary.

In some cases, discs may not be identified via the Identify CD/DVD option (if they do 
not exist on the CDDB servers, or if you do not have access to the CDDB servers). In 
these cases, you can enter disc information manually. See Adding a CD to the Media 
Library Manually for details.
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The Media Library
4. Review the information in this dialog, edit if necessary, and click OK to enter the CD into the Media 
Library.

The CD is added to the Media Library, and is indicated in the Media Library window (CD tab).

Once a CD is listed in the Media Library Bar, it is available to be added to one or more Media Preset files.

FIG. 11  Edit CD In Library dialog
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Adding a CD to the Media Library Manually
While Preset Editor uses an online media identification service to automatically identify CDs for addition to 
the Media Library, in some cases, discs may not be identified via the Identify Disc option (if they do not exist 
on the CDDB servers, or if you do not have access to the CDDB servers). 

In these cases, you can enter the disc information manually:

1. Select Media Library > Add Entry To Media Library > CD to open the Add CD To Library dialog 
(FIG. 12).

Alternatively, select Add CD from the Add To Media Library toolbar button drop-down menu (FIG. 13). 

2. Enter the disc information as desired:

You can enter multiple Artist and Genre names, separated by commas.

Note that DVDs are organized in the Media Library window by Artist name.

FIG. 12  Add CD To Library dialog

FIG. 13  Add CD (Add To Media Library toolbar button drop-down menu)

The information in all fields in this dialog is optional, but it is recommended that you 
enter as much information as possible to facilitate searches and disc information 
displays.
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The Media Library
Enter a text description of the disc in the Summary field.

3. Add tracks (song titles):

a.  Place the cursor in an available row of the Tracks table.

b.  Type the title of the Track and press Enter. Note that when you begin typing, an addition al track row 
is automatically added to the table.

c.  Place the cursor in the next available row to add another Track (title), and repeat this process until all 
tracks have been added.

Use the Up and Down arrow buttons to re-sort the Track list if necessary.

To remove a Track, select the title and click the Remove button.

4. Click OK to enter the disc into the Media Library.

The disc is added to the Media Library and listed in the Media Library window (CD tab).

Double-click on the Artist name to expand a list of all CD titles currently in the Media Library 
associated with that artist.

Once a CD is listed in the Media Library window, it is available to be added to one or more Media Preset files.
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Adding a DVD to the Media Library
Unlike CDs, DVDs do not utilize an online database for disc identification. All DVDs must be manually added 
to the Media Library:

1. Select Media Library > Add Entry To Media Library > DVD to open the Add DVD To Library dialog 
(FIG. 14). 

Alternatively, select Add DVD from the Add To Media Library toolbar button drop-down menu 
(FIG. 15). 

2. Enter the disc information as desired:

FIG. 14  Add DVD To Library dialog

FIG. 15  Add DVD (Add To Media Library toolbar button drop-down menu)

The information in all fields in this dialog is optional, but it is recommended that you 
enter as much information as possible to facilitate searches and disc information 
displays.
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Enter the disc Title, Artist and Genre information in the top three fields. 

Once you have added at least one Artist and one Genre name, those names are available for 
selection via the drop-down menus next to these fields for future disc additions.

You can enter multiple Artist and Genre names, separated by commas.

Note that DVDs are organized in the Media Library window by Artist name.

Enter a text description of the disc in the Summary field.

3. Add tracks (chapter titles):

a.  Place the cursor in an available row of the Tracks table.

b.  Type the title of the Track and press Enter. Note that when you begin typing, an addition al track row 
is automatically added to the table.

c.  Place the cursor in the next available row to add another Track (title), and repeat this process until all 
tracks have been added.

Use the Up and Down arrow buttons to re-sort the Track list if necessary.

To remove a Track, select the title and click the Remove button.

4. Click OK to enter the disc into the Media Library.

The disc is added to the Media Library and listed in the Media Library window (DVD tab).

Double-click on the Artist name to expand a list of all DVD titles currently in the Media Library 
associated with that artist.

Once a DVD is listed in the Media Library window, it is available to be added to one or more Media Preset 
files.

Adding Radio Stations to the Media Library
All Radio Stations must be manually added to the Media Library:

1. Select Media Library > Add Entry To Media Library > Radio Station to open the Add Radio Station 
To Library dialog (FIG. 16). 

Alternatively, select Add Radio Station from the Add To Media Library toolbar button drop-down menu 
(FIG. 17). 

FIG. 16  Add Radio Station To Library dialog

FIG. 17  Add Radio Station (Add To Media Library toolbar button drop-down menu)
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2. Enter the Radio Station’s information as desired.

Enter the Radio Station's Title, Channel and Genre information in the top three fields. 

Once you have added one or more Genre name, those names are available for selection via the 
drop-down menu next to this field for future channel additions.

You can enter multiple Genre names, separated by commas.

Note that Radio Stations are organized in the Media Library window by Title name.

Enter a text description of the disc in the Summary field.

3. Select a channel icon to associate with this Radio Station from the Image drop-down. See Creating 
Custom Images for Radio and TV Stations.

4. Enter a Category to which this station will be added.

Once you have added at least one Category name, those names are available for selection via the drop-
down menus next to these fields for future additions. See the Managing Categories for details.

5. Enter a text description of the channel in the Summary field.

6. Click OK to enter the Radio Station into the Media Library.

The Radio Station is added to the Media Library and listed in the Media Library window (Radio tab).

Once a Radio Station is listed in the Media Library window, it is available to be added to one or more Station 
Preset files.

Adding TV Stations to the Media Library
All TV Stations must be manually added to the Media Library:

1. Select Media Library > Add Entry To Media Library > TV Station to open the Add TV Station to 
Library dialog (FIG. 18). 

Alternatively, select Add TV Station from the Add To Media Library toolbar button drop-down menu 
(FIG. 19). 

The information in all fields in this dialog is optional, but it is recommended that you 
enter as much information as possible to facilitate searches and disc information 
displays.

FIG. 18  Add TV Station To Library dialog

FIG. 19  Add TV Station (Add To Media Library toolbar button drop-down menu)
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2. Enter the TV Station’s information as desired.

Enter the TV Station’s Title, Channel and Genre information in the top three fields. 

Once you have added one or more Genre name, those names are available for selection via the 
drop-down menu next to this field for future station additions.

You can enter multiple Genre names, separated by commas.

Note that TV Stations are organized in the Media Library window by Title name.

Enter a text description of the disc in the Summary field.

3. Select a channel icon to associate with this TV station from the Image drop-down. See the Creating 
Custom Images for Radio and TV Stations section on page 19 for details.

4. Enter a Category to which this station will be added.

Once you have added at least one Category name, those names are available for selection via the drop-
down menus next to these fields for future additions. See the Managing Categories section on page 25 for 
details.

5. Enter a text description of the station in the Summary field.

6. Click OK to enter the TV Station into the Media Library.

The TV Station is added to the Media Library and listed in the Media Library window (TV tab).

Once a TV Station is listed in the Media Library window, it is available to be added to one or more Station 
Preset files.

The information in all fields in this dialog is optional, but it is recommended that you 
enter as much information as possible to facilitate searches and disc information 
displays.
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Creating Custom Images for Radio and TV Stations
Custom images can be associated with Station Presets, for further customization of your Station Preset 
buttons:. Working with custom images for Presets requires the use of TPDesign4.

Load The Image Into An Open Slot

1. In TPDesign4: Select Panel > Resource Manager to access the Resource manager dialog.

2. Open the Slots tab.

3. Select the slot to which you want to add a custom image (in the range of 500 - 524).

4. Click the Import button.

5. Locate and select the graphic that you want to apply to this slot.

By default, TPD4 projects have 500 slots available. Therefore, to utilize slot numbers 500 - 524, you'll 
need to add at least 24 slots to the TPD4 project. This is done via the Maximum Number of Image Slots 
for Panel dialog (Panel > Set Maximum Icon Slots).

Reserved Images occupy slots 300 - 474
Custom Images use slots 500 - 524

Add the Image to a Station Preset

1. In Preset Editor: Open the Station Preset (*.PXD) file open that contains the Preset(s) to which you want 
to add custom icon graphics.

2. Select the Slot # for a channel that will use a custom icon.

3. Click inside the Image column, to access a drop-down list of Station Preset icons.

4. Scroll to the bottom of the list to find the Custom 1 (500) - Custom 25 (524) entries (FIG. 20): 

The Custom # (1-25) indicates the custom image number used by VA.

The number in parenthesis that follows each image number (500-524) indicates the icon slot 
number that TPD4 will use to associate the custom image to the preset button (in the Resource 
Manager - Slots tab).

5. Select an unused Custom Image entry, and make note of the icon slot number. The image that occupies 
the selected icon slot number (in TPD4's Resource Manager) will be applied to this Preset button.

For example, if you select "Custom 1 - (500)" from the Image drop-down in Preset Editor, the image that 
has been loaded into slot 500 will be applied to this Preset Button.

FIG. 20  Station Preset icons
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Editing Disc/Station Properties
You can edit the properties for any entry in the Media Library, via options in the Edit <entry type> In Library 
dialog.

1. Click to select the entry that you want to edit in the Media Library window (CD, DVD, Radio or TV tab).

To access the CD & DVD tabs, select File > New to open the Create New Preset File dialog, and 
select Media Preset - CDs and DVDs (*.mxd).

To access the TV & Radio tabs, select File > New to open the Create New Preset File dialog, and 
select Station Preset - TV stations and Radio stations (*.pxd).

2. Click the Properties toolbar button (or select Media Properties > Edit Properties, or click Ctrl+P) to 
access the appropriate Edit <entry type> In Library dialog (based on the type of entry selected), pre-
populated with the selected entry's information (FIG. 21). 

3. Edit the properties as desired, and click OK to save your changes.

FIG. 21  Edit <entry type> In Library dialogs

You can access these dialogs by right-clicking on an entry in the Media Library 
window and selecting Properties from the Media Library window context menu.
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Removing an Entry From the Media Library
To remove an item (CD, DVD, TV or Radio station) from the Media Library,

1. In the Media Library window, select the item that you want to remove.

2. Select Media Library > Remove Entry From Media Library (or click the toolbar button, or press 
Ctrl+Delete). 

When removing an Artist entry from the Media Library window, all CDs associated with that artist 
will be removed from the Media Library. 

To delete a single CD, expand the Artist entry in the Media Library window and select the specific 
CD that you want to remove.

3. The program will prompt you to verify this action before the item is removed (FIG. 22): 

To remove an individual Track from a disc, use the Delete option in the Edit CD In Library dialog (FIG. 23). 

FIG. 22  Delete Confirmation dialog

If you remove discs that are included on one or more Media Preset files from the 
Media Library, those discs will remain in the Media Preset files to which they were 
added. However, they will not be available to add to other Media Preset files.

FIG. 23   Edit CD In Library dialog
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Searching For an Entry in the Media Library
To search for any item in the Media Library, click the Search tab of the Media Library Bar to access the search 
fields (FIG. 24): 

1. Open a Media or Station Preset file, and click on the Search tab in the Media Library window.

2. Enter a text string in the Search for field.

3. Optionally, apply the filters to your search:

Click the down-arrow in the Look In field to select a particular information field to which you wish 
to limit the search (Artist, Album, Track Title). 

Click the down-arrow in the Filter By field to select a particular type to which you wish to limit the 
search (CD, DVD, Radio or TV). 

The default setting is "no filter".

4. Click the Search button to initiate the search.

The results of your search are listed (in order of their relevance) in the window at the bottom of the Search tab 
(FIG. 25): 

FIG. 24  Media Library Bar - Search tab
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You can drag-and drop the results of a Search from the Search tab into a Media Preset Content Window, or in 
the case of a Radio or TV station, in to a Station Preset Content Window.

Adding Multiple Entries to Media Library
The Add Multiple Entries to Media Library option in the Media Library menu allows you add multiple 
entries of a any type to the Media Library. 

1. Select Media Library > Add Multiple Entries to Media Library to invoke the Select the media type 
dialog (FIG. 26). 

2. Select the type of entry to add first (CD, DVD, Radio Station or TV Station). 

3. Click OK to open the appropriate Add <Media Type> to Library dialog.

4. Fill in the information and click OK to close the Add <Media Type> to Library dialog and return to the 
Select Media Type dialog to repeat the process as desired.

FIG. 25  Search tab showing example Search Results

FIG. 26  Select the media type dialog
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Managing Genres
Click the Manage Genres toolbar button to open the Genre Manager dialog. This dialog is separated into four 
tabs, representing the four types of items that can be added to Media and Station Preset files. Each tab lists the 
genres available to each of the preset types.

Adding a Genre

1. Select Media Library > Manage Genres (or click the Genre Manager toolbar button, or click Ctrl+G) 
to open the to access the Genre Manager dialog (FIG. 27). 

2. Select the tab that represents the type of preset for which you want the Genre to be available (CD, DVD, 
Radio or TV).

3. Click the Add button. This invokes the Add a New Genre dialog (FIG. 28). 

4. Type the new Genre name in the text field provided, and click OK.

The new Genre is added to the bottom of the list, in the active tab. Once added, it is available for selection 
from the Genre drop-down for that type of item in a Media Preset or Station Preset Content window.

5. Repeat this process as necessary, click the Close button when finished to close this dialog.

FIG. 27  Genre Manager dialog

FIG. 28  Add a New Genre dialog
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Removing a Genre

1. Select Media Library > Manage Genres (or click the Genre Manager toolbar button, or click Ctrl+G) 
to open the to access the Genre Manager dialog.

2. Select the tab that represents the type of preset from which you want to remove a Genre.

3. Select the Genre that you want to remove from the list of Genres.

4. Click the Delete button.

5. When finished, click the Close button.

Managing Categories
Categories apply only to Radio and TV stations, and allow you to add an entire set of stations to a Station 
Preset file quickly and easily. Use the Category Manager dialog to manage the Categories available in the 
Media Library. Click the Manage Categories toolbar button to open the Category Manager dialog.

Pre-Defined ("- [AMX]") Categories
There are several pre-defined Categories available for selection in Preset Editor (for example, the Category 
named "Dish America’s Top 250 - [AMX]" is a pre-defined Category with 250 popular TV stations used by 
Dish America customers).

Category folders in the Media Library Bar that are suffixed with "- [AMX]" are automatically added and 
maintained by AMX, and cannot be modified. These are provided by AMX to offer a quick-start to creating 
Station Presets using common stations. 

However, you can create new Categories based on predefined AMX Categories, from scratch or via the Copy 
feature.

Adding a Category

1. Select Media Library > Manage Categories (or click the toolbar button, or press Ctrl+T) to access the 
Category Manager dialog (FIG. 29). 

2. Click the Add button to invoke the Add a New Category dialog (FIG. 30). 

3. Type the name that you want to assign to the new Category and press OK. The new Category is added to 
the bottom of the list (in the Category Manager dialog).

Alternatively, you can create a new category by typing a new name in the Category field of the Add TV 
Station to Library dialog.

FIG. 29  Category Manager dialog
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Assigning a TV or Radio Station To The New Category

1. Select a TV or Radio station in the Media Library window and select Media Library > Edit Properties 
(or click the toolbar button, or press Ctrl+P) to access the Edit <TV Station or Radio Station> In Library 
dialog (FIG. 31). 

2. Click the down-arrow in the Category field to select from a drop-down menu of all Categories, including 
any that you have created.

3. Click OK. 

Removing a Category

1. Select Media Library > Manage Categories (or click the toolbar button, or press Ctrl+T) to access the 
Category Manager dialog.

2. Select the Category that you want to remove.

3. Click the Delete button.

If there are no stations associated with the selected Category, the program will simply prompt you 
to verify this action before the Category is deleted.

If there are one or more stations associated with the selected Category, the Delete Category dialog 
is invoked, to specify how to handle the stations that have been associated to the Category that you 
are about to delete:

Select Delete the records to delete the station(s) associated with this Category.

Select Copy Records to new category. Select a category below: to select a category from the list 
in this dialog to re-assign the station(s) to.

4. Click OK to close this dialog.

FIG. 30  Add a New Category dialog

The new Category will not appear in the Media Library window (Radio and/or TV 
tabs) until at least one station is assigned to it.

FIG. 31  Edit <TV Station or Radio Station> In Library dialog
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Renaming Categories

1. Open the Category Manager dialog.

2. Select the Category that you want to rename.

3. Click the Rename button to invoke the Rename Category dialog (FIG. 32). 

4. Enter the desired name for this Category, and click OK.

Copying Categories
Use the Copy feature of the Category Manager to make a copy of an existing Category, and save it under a 
different name. Use this feature as a time-saver in cases where you need to create a custom Category that is 
similar to one that you already have. For example, you could make a copy of the "Dish America’s Top 250" 
Category, and edit it to fit a particular customer’s needs without having to manually add each station.

1. Open the Category Manager dialog.

2. Select the Category that you want to copy, and click the Copy button to invoke the Copy to a New 
Category dialog (FIG. 33). 

3. Enter a name for the copied version of the Category, and click OK.

4. The new Category is added to the list.

5. At this point, you can add, remove and edit the contents of the Category as desired.

FIG. 32  Rename Category dialog

FIG. 33  Copy to a New Category dialog
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Preset Files

Media Preset Files (CDs and DVDs)
Media Preset Files (*.mxd) contain a list of CDs and/or DVDs that corresponds to disc or slot numbers, for 
CD/DVD changers/players that have multiple slots (each one containing a CD or DVD). Media Preset files are 
used in VisualArchitect™ projects to represent content loaded on multi-slot CD/DVD changers/players.

Note that before a CD or DVD can be added to a Media Preset file, it must first be added to the Media Library:

Once a CD or DVD is present in the Media library, it available to be added to one or more Media Preset files.

Creating a New Media Preset File
Media Preset (*MXD) files include disc (CD and DVD) titles, and associate a media preset with a button.

To create a new Media Preset file:

1. In the Preset Content Window, click the New Preset toolbar button (FIG. 34) (or select File > New) to 
access the Create New Preset File dialog (FIG. 35). 

2. Select Media Preset - CDs and DVDs (*.mxd) (FIG. 35). 

Before you can add discs to a Media Preset file, the discs must first be present in the 
Media Library. See the Working With the Media Library section on page 11 for details.

The example shown here shows adding Items from the CD tab. The steps for adding 
DVDs are basically the same. The primary difference is that while CDs are 
categorized in the Media Library window by Artist name, DVDs are categorized by 
Title. 

FIG. 34  New Preset File toolbar button

FIG. 35  Create New Preset File dialog
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This selection opens a new (empty) Preset Content Window, with one empty slot (FIG. 36): 

3. Enter a Title and Description for this Media Preset file, if desired.

4. Click and drag Artist folders or individual discs (CDs and DVDs) from the Media Library Bar into empty 
slots in the Media Preset Content Window.

Adding All Discs For a Selected Artist To The Preset File (CDs Only)
CDs are categorized in the Media Bar by Artist (name). Therefore, an Artist folder in the Media Bar may 
contain multiple CD titles. Click on an Artist name in the Media Bar to expand the list of CDs titles present in 
the Media Library for the selected Artist. 

On the other hand. DVDs are categorized in the Media Bar by Title. Therefore, there is only entry in the Media 
Bar for each DVD Title in the Media Library. You can view the Chapter list for a DVD in the Chapter Info sub-
folder (included with each DVD folder in the Media Bar).

1. In the CD tab of the Media Library window, click and drag an Artist folder from the Media Bar to an 
empty slot in the Preset Content Window. The example in FIG. 37 shows that the Artist "Skid Row" has 
two CD titles in the Media Library. 

FIG. 36  Adding items to a new Media Preset file

Enter a description for this Media Preset here
Enter a Title for this Media Preset file here

Click and drag a CD or DVD title onto an empty row to add
the entire disc to this Preset file as a single item.

CDs - Click on an Artist to expand the list of discs (if there are
multiple entries for that artist).

Click on a disc title to expand the view to display a listing of

Media Library Bar Media Preset Content Window

all tracks (CDs) or chapters (DVDs) on the selected disc.

Only entire discs (CDs and DVDs) can be added to Media Preset Files. Preset Editor 
does not support adding individual tracks/chapters. If you drag and drop an individual 
track or chapter into a Preset Content window, the entire disc is added to the Preset 
File.
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2. All CD titles for the selected Artist are added to the Preset File (FIG. 38): 

Note that each time you add an entry to the Preset File, a new empty row is automatically added, to allow 
you to add subsequent items.

FIG. 37  Adding all CDs for an Artist to the Media Preset File

FIG. 38  Adding all CDs for an Artist to the Media Preset File

In this example, the Artist "Skid Row" has two 
CD titles in the Media Library.

Click and drag an Artist folder into an empty slot
in the Preset Content Window to add all CD titles
to this Preset.
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Adding a Selected Disc (CD or DVD) To a Media Preset File

1. Click and drag a disc (CD or DVD) folder from the Media Bar to an empty slot in the Preset Content 
Window (FIG. 39). 

2. The selected disc is added to the Preset File (FIG. 40). 

Note that each time you add an entry to the Preset File, a new empty row is automatically added, to allow 
you to add subsequent items.

The order of items in the Preset Contents window is the order in which they will be displayed on the 
Touch Panel. Use the Move Up and Move Down toolbar buttons to re-order the items as desired.

Only entire discs (CDs and DVDs) can be added to Media Preset Files. Preset Editor 
does not support adding individual tracks/chapters. If you drag and drop an individual 
track or chapter into a Preset Content window, the entire disc is added to the Preset 
File.

FIG. 39  Adding a disc (CD or DVD) to a Media Preset File - drag and drop

FIG. 40  Adding a disc (CD or DVD) to a Media Preset File

Click and drag a disc folder into an empty slot
in the Preset Content Window to add all titles
from the selected disc to this Media Preset File.
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Saving the Media Preset File
Click the Save Preset File toolbar button (or select File > Save As) to specify a name and target location for 
the new Media Preset file in the Save Media Preset File dialog (FIG. 41). 

Editing Media Preset Files
1. To open an existing Media Preset (*.MXD) file for editing, select File > Open to invoke the Open 

Existing Preset File dialog, and select Media Database (*.mxd) in the Files of Type drop-down 
(FIG. 42): 

2. Select the MXD file that you want to edit, and click Open.

3. The selected MXD file is opened and displayed in a Media Preset Content Window.

You can change the Title and Description for this Media Preset file in the text fields at the top of the 
dialog.

To re-order the discs in the list, select a disc and drag-and-drop it into a new position in the list (or 
use the Move Up and Move Down toolbar buttons).

To change the disc type (from CD to DVD or vice-versa), select a disc in the list, click in the Type 
column, and select the appropriate disc type (CD or DVD) from the drop-down.

To change the title of a selected disc, click in the Title column and edit the text as desired.

To change the Artist name associated with a selected disc, click in the Artist column. This will only 
change the artist name within this specific preset entry.

To change the Genre associated with a selected disc, click in the Genre column and select the 
appropriate genre from the drop-down list of all genre names currently in the Media Library.

FIG. 41  Saving the Media Preset File

FIG. 42  Opening Existing Preset File dialog
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To change the summary information of a selected disc, click in the Description column and edit the 
text as desired.

4. Click the Save toolbar button (or select File > Save) to save your changes.

Removing a Disc From a Media Preset File

1. Select the disc (CD or DVD) you want to remove in the Media Preset Content window.

2. Click the Remove Preset toolbar button (FIG. 43). 

Station Preset Files (TV and Radio Stations)

FIG. 43  Removing a CD From a Media Preset File

Removing a disc from a Media Preset file does not delete it from the Media Library. It 
will still be available for adding to other Media Preset files. To permanently delete a 
disc from the Media Library, select the disc in the Media Library Bar and select Media 
Library > Remove Entry From Media Library.
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Station Preset files (*.PXD) contain a list of station presets. Each preset corresponds to a TV or radio station. 
Station Preset files are used in VisualArchitect™ projects to represent station presets for TV and radio 
receivers.

Creating a New Station Preset File
1. In the Preset Content Window, click the New Preset toolbar button (FIG. 44) (or select File > New) to 

access the Create New Preset File dialog (FIG. 45). 

2. Select Station Preset - TV stations and radio stations (*.pxd) (FIG. 45). 

This selection opens a new (empty) Preset Content Window, with one empty slot (FIG. 36): 

Before you can add TV or Radio Stations to a Station Preset file, the stations must 
first be present in the Media Library. See the Working With the Media Library section 
on page 11 for details.

FIG. 44  New Preset File toolbar button

FIG. 45  Create New Preset File dialog
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3. Enter a Title and Description for this Station Preset file, if desired.

4. Click and drag Category folders, and/or individual Stations from the Media Library Bar into empty slots 
in the Station Preset Content Window.

To add all TV stations contained within a Category (such as "Dish America’s Top 250"), drag-and-
drop the Station title folder from the Media Bar to the Media Preset Contents window. Each station 
contained within the selected folder is added to it’s own row in the Media Preset Contents window. 
In the case of "Dish America’s Top 250", this would result in 250 items added to the Media Preset 
Contents window.

To add individual stations, expand the Station title folder in the Media Library window to show the 
stations, and drag-and-drop stations to the Station Preset Content window.

FIG. 46  Adding items to a new Station Preset file

Enter a description for this Station Preset here
Enter a Title for this Station Preset file here

Click and drag a TV or Radio Station Category onto an
empty row to add all stations in that category to this Station

Click on a Category title to expand the view to display a listing of

Media Library Bar Station Preset Content Window

all stations in the selected category.

Preset file. 
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Preset Files
Editing Station Preset Files
1. To open an existing Station Preset (*.PXD) file for editing, select File > Open to invoke the Open 

Existing Preset File dialog, and select Station Database (*.pxd) in the Files of Type drop-down 
(FIG. 42): 

2. Select the PXD file that you want to edit, and click Open.

3. The selected PXD file is opened and displayed in a Station Preset Content Window.

You can change the Title and Description for this Station Preset file in the text fields at the top of the 
dialog.

To re-order the stations in the list, select a station and drag-and-drop it into a new position in the list 
(or use the Move Up and Move Down toolbar buttons).

To change the station type (from TV to Radio or vice-versa), select a station in the list, click in the 
Type column, and select the appropriate station type (TV to Radio) from the drop-down.

To change the title of a selected station, click in the Title column and edit the text as desired.

To change the image (icon) associated with a selected station, click in the Image column, and select 
the appropriate image icon from the drop-down.

To change the station number of a selected station, click in the Station column and edit the number 
as desired.

To change the Genre associated with a selected channel/station, click in the Genre column and 
select the appropriate genre from the drop-down list of all genre names currently in the Media 
Library, or enter a custom genre name as desired.

To change the summary information for a selected station, click in the Summary column and edit 
the text as desired.

4. Click the Save toolbar button (or select File > Save) to save your changes.

FIG. 47  Opening Existing Preset File dialog

The items in the TV tab (of the Media Bar) suffixed with "- [AMX]" are automatically 
added and maintained by AMX, and cannot be modified. These are provided by AMX 
to offer a quick-start to creating Station Presets using common stations.
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Preset Files
Removing a Station From a Station Preset File

1. Select the station (TV or Radio) you want to remove in the Station Preset Content window.

2. Click the Remove Preset toolbar button (FIG. 43). 

FIG. 48  Removing a Station From a Station Preset File

Removing a station from a Station Preset file does not delete it from the Media 
Library. It will still be available for adding to other Station Preset files. To permanently 
delete a station from the Media Library, select the station in the Media Library Bar and 
select Media Library > Remove Entry From Media Library.
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Configuring FreeCDDB Options
Configuring FreeCDDB Options

Overview
If, when attempting to identify a disc (via the Media Library > Identify CD option), you receive the message: 
"Failed to retrieve CDDB sites!", you may need to configure your CDDB options in order to connect to the 
CDDB servers.

Use the options in the FreeCDDB Settings dialog to establish a list of servers that provide disc information. 

Select Media Library > Configure CDDB (or press Crtl+D) to access this dialog.

Automatically Generating the CDDB Site List
1. Select Media Library > Configure CDDB to open the FreeCDDB Settings dialog (FIG. 49). 

2. Click Get Sites.

If you are able to connect to the Freedb.org CDDB servers, the FreeDB Sites list will be populated 
with a list of available servers.

If you receive the message: "Failed to retrieve CDDB sites!", you may need to configure your 
HTTP proxy server options.

You must have access to the Internet to identify media via the CDDB service.

FIG. 49  FreeCDDB Settings dialog 
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Configuring FreeCDDB Options
Manually Adding a CDDB Server
1. Click Add (in the FreeCDDB Settings dialog) to open the Add FreeDB Site dialog (FIG. 50). 

2. Enter the IP address or URL (in the Server field), Path information, and the desired Port of the CDDB 
server.

3. Click OK to close the dialog and return to the FreeCDDB Settings dialog. The server you just added is 
now included at the bottom of the CDDB Sites list.

4. Use the Move Up and Move Down to sort the list as desired.

Removing a CDDB Server
1. Select the server that you want to remove in the FreeDB Sites list (in the FreeCDDB Settings dialog).

2. Click Remove.

FIG. 50  Add FreeDB Site dialog
40  Preset Editor - Operation Reference Guide



6/
14

  ©
20

10
 A

M
X

. A
ll 

rig
ht

s 
re

se
rv

ed
. A

M
X

 a
nd

 t
he

 A
M

X
 lo

g
o

 a
re

 r
eg

is
te

re
d

 t
ra

d
em

ar
ks

 o
f A

M
X

. A
M

X
 r

es
er

ve
s 

th
e 

ri
g

ht
 t

o
 a

lte
r 

sp
ec

ifi
ca

tio
ns

 w
ith

o
ut

 n
o

tic
e 

at
 a

ny
 t

im
e.

3000 RESEARCH DRIVE, RICHARDSON, TX 75082 USA •  800.222.0193  •  469.624.8000  •  469-624-7153 fax  • 800.932.6993 technical support  •  www.amx.com

Increase Your Revenue
through education + knowledge

In the ever-changing AV industry, continual education is key to success. AMX University is 
dedicated to ensuring that you have the opportunity to gather the information and 
experience you need to deliver strong AMX solutions. Plus, AMX courses also help you 
earn CEDIA, NSCA, InfoComm, and AMX continuing education units (CEUs).

Visit AMX University online for 24/7/365 access to:
- Schedules and registration for any AMX University course
- Travel and hotel information
- Your individual certification requirements and progress
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