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IMPORTANT SAFETY INSTRUCTIONS    

COPYRIGHT NOTICE
AMX© 2016, all rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any 
means, electronic, mechanical, photocopying, recording, or otherwise, without the prior written permission of AMX. Copyright protection claimed 
extends to AMX hardware and software and includes all forms and matters copyrightable material and information now allowed by statutory or judicial 
law or herein after granted, including without limitation, material generated from the software programs which are displayed on the screen such as 
icons, screen display looks, etc. Reproduction or disassembly of embodied computer programs or algorithms is expressly prohibited.

LIABILITY NOTICE
No patent liability is assumed with respect to the use of information contained herein. While every precaution has been taken in the preparation of this 
publication, AMX assumes no responsibility for error or omissions. No liability is assumed for damages resulting from the use of the information 
contained herein. Further, this publication and features described herein are subject to change without notice.

AMX WARRANTY AND RETURN POLICY
The AMX Warranty and Return Policy and related documents can be viewed/downloaded at www.amx.com.

1. READ these instructions.
2. KEEP these instructions.
3. HEED all warnings.
4. FOLLOW all instructions.
5. DO NOT use this apparatus near water.
6. CLEAN ONLY with dry cloth.
7. DO NOT block any ventilation openings. Install in accordance with the manufacturer's instructions.
8. DO NOT install near any heat sources such as radiators, heat registers, stoves, or other apparatus (including amplifiers) that 

produce heat.
9. DO NOT defeat the safety purpose of the polarized or grounding type plug. A polarized plug has two blades with one wider than the 

other. A grounding type plug has two blades and a third grounding prong. The wider blade or the third prong are provided for your 
safety. If the provided plug does not fit into your outlet, consult an electrician for replacement of the obsolete outlet.

10. PROTECT the power cord from being walked on or pinched, particularly at plugs, convenience receptacles, and the point where 
they exit from the apparatus.

11. ONLY USE attachments/accessories specified by the manufacturer.

12. USE ONLY with a cart, stand, tripod, bracket, or table specified by the manufacturer, or sold with the apparatus. When a cart is 
used, use caution when moving the cart/apparatus combination to avoid injury from tip-over.

13. UNPLUG this apparatus during lightning storms or when unused for long periods of time.
14. REFER all servicing to qualified service personnel. Servicing is required when the apparatus has been damaged in any way, such as 

power-supply cord or plug is damaged, liquid has been spilled or objects have fallen into the apparatus, the apparatus has been 
exposed to rain or moisture, does not operate normally, or has been dropped.

15. DO NOT expose this apparatus to dripping or splashing and ensure that no objects filled with liquids, such as vases, are placed on 
the apparatus.

16. To completely disconnect this apparatus from the AC Mains, disconnect the power supply cord plug from the AC receptacle.
17. Where the mains plug or an appliance coupler is used as the disconnect device, the disconnect device shall remain readily operable. 
18. DO NOT overload wall outlets or extension cords beyond their rated capacity as this can cause electric shock or fire. 

The exclamation point, within an equilateral triangle, is intended to alert the user to the presence of important operating and maintenance 
(servicing) instructions in the literature accompanying the product.

The lightning flash with arrowhead symbol within an equilateral triangle is intended to alert the user to the presence of uninsulated "dangerous 
voltage" within the product's enclosure that may be of sufficient magnitude to constitute a risk of electrical shock to persons.

ESD Warning: The icon to the left indicates text regarding potential danger associated with the discharge of static electricity from an outside 
source (such as human hands) into an integrated circuit, often resulting in damage to the circuit.

WARNING: To reduce the risk of fire or electrical shock, do not expose this apparatus to rain or moisture.
WARNING: No naked flame sources - such as lighted candles - should be placed on the product.
WARNING: Equipment shall be connected to a MAINS socket outlet with a protective earthing connection.
WARNING: To reduce the risk of electric shock, grounding of the center pin of this plug must be maintained. 
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G4 PanelBuilder
G4 PanelBuilder 
Overview
G4 PanelBuilder is a stand-alone application (installed separately) from AMX that allows you to quickly create TPD4 projects for G4 
Touchpanels, using either pre-fabricated templates from AMX, or user-designed templates (FIG. 1). 

The G4 PanelBuilder application is designed to do the bulk of the basic layout and navigational design of a touch panel design. 
TPD4 is required to complete the project by specifying channel mapping information, and to generally fine-tune the project as 
needed.
Although G4 PanelBuilder is installed separately, it is fully integrated with TPD4. For example, the File > New From G4 PanelBuilder 
option (available only if G4 PanelBuilder is installed) launches the G4 PanelBuilder application to allow you to create a new TPD4 
project.
Use the set of options in the File menu to access the key functions of the G4 PanelBuilder application:

Click File > New From G4 Panel Builder to create a new TP4 panel project using G4 PanelBuilder.
Click File > Import Touch Panel Template to import an existing PanelBuilder (*.TPT) or Visual Architect template file (*.VAT) 

into TPD4 as a starting point for your panel design.
Click File > Export G4 PanelBuilder Template to export the active TP4 project as a PanelBuilder Template file (*.TPT).

System Requirements
G4 PanelBuilder supports the following platforms:

Windows 2000 (Service Pack 3 or greater)

NOTE: If you are installing on a Windows 2000 machine, you must have Administrator rights to install and run all required 
System f iles.

Windows XP Home and Professional (Service Pack 1 or greater)

Other PC requirements:
Pentium 233 MHZ processor (minimum requirement); 300 MHZ or faster recommended.
75 MB of free disk space (minimum requirement); 150 MB recommended.
128 MB of installed memory (RAM).
Minimum (VGA) screen resolution of 800x600
Windows-compatible CD-ROM drive.
Windows-compatible mouse (or other pointing device).

FIG. 1  G4 PanelBuilder
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G4 PanelBuilder
Supported AMX (G4) Touch Panel Types
MVP-7500: 7.5" Modero ViewPoint (wireless) Touch Panel
MVP-8400: 8.4" Modero ViewPoint (wireless) Touch Panel
NXT/NXD-1200V: Enhanced 12" Modero Touch Panel
NXT/NXD-1200VG: Enhanced 12" Modero Touch Panel (with video capabilities)
NXT/NXD-1500VG: Enhanced 15" Modero Touch Panel (with video capabilities)
NXT/NXD-1700VG: Enhanced 17" Modero Touch Panel (with video capabilities)
NXT/NXD-CV7: 7" Modero Touch Panel (with video capabilities)
NXT/NXD-CA12: 12" Modero Touch Panel
NXT/NXD-CV12: 12" Modero Touch Panel (with video capabilities)
NXT/NXD-CA15: 15" Modero Touch Panel
NXT/NXD-CV15: 15" Modero Touch Panel (with video capabilities)
NXT/NXD-CV17: 17" Modero Touch Panel (with video capabilities)
NXP-TPI/4: Touch Panel Interface 4

NOTE: The nomenclature " NXT" indicates the table-top (tilt) model, and "NXD" represents the wall-mount version.

Screen Resolutions and Panel Types
Any number of template files (*.TPT) can be created to constitute a template family; it is suggested you create one for each 
resolution totaling 6. The resolutions and panel types are as follows: 

According to the table there are only 6 resolutions, the minimum number to make a template family, but 12 different panel types. 
You only need one template per resolution but you should consider instances such as the MVP-8400(i), where the Pixels Per Inch is 
higher than the CV12 and the MVP-7500's limited color depth. Both examples are situations where you might consider making 
specific templates for those panel types.

Screen Resolutions and Panel Types
Resolution Panel Type

640x480 • MVP-7500 • TPI4

800x600 • MVP-8400
• MVP-8400i

• CA12
• CV12
• TPI4

800x480 • CV7 • CV10
• CV10/PB

1024x768 • CV15
• CA15

• TPI4

1280x768 • CV17

1280x1024 • TPI4
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Basic Operations
Basic Operations
Getting Started
Creating A New Project
The first step towards designing a new *.TP4 file is creating a new project file (*.PB4).
1. Launch the G4 PanelBuilder application.
2. Select File > New. This launches the New Project dialog.
3. Type the Job Name in the corresponding field.
4. Select the Panel Type and Resolution from the drop down menus.
5. Select your desired template family from the thumbnails listed.

NOTE: If no templates are shown you will need to load them. You can either Install A Template from File or Install Templates from 
AMX.com.

6. After you have clicked on your desired template, click OK.
7. Your new project is now open to the G4 PanelBuilder Application Interface. A Start element is in place within the Diagram area.

NOTE: If a project is already open and you select open a new or existing project, you are prompted by the Save As dialog. The 
previous project will remain on screen until you are done setting up the new project.

Adding A Toolbox Element to The Diagram
Once you have a project file open you can add elements to the panel file.
1. Select the element type within the Toolbox.
2. Find the desired element, click-and-drag the element to the Diagram area.

3. Now connect the Start element to the Navigation element. Click on the Exiting node (white) on the Start element and drag it to 
the other element. All possible connections are indicated by a green outline. If the connection cannot happen the outline is 
red. A connection line appears between the two elements.

FIG. 2  Drag a Navigation element to the Diagram area

FIG. 3  Drag Start node to Navigation element node
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Basic Operations
4. You can now edit the properties for the Navigation element or select another element to add to the diagram area.

NOTE: An element will populate the corresponding appropriate f ield, when connecting. This saves you the trouble of naming element 
properties.

Adding Elements via The Diagram Menu
Designing G4 PanelBuilder projects is done through graphic representation. The flow between the pages is done through the 
Diagram area. Connections are then made between the elements in the Diagram area. To add an element using the Diagram menu:
1. Open a project or create a new project file.
2. Select Diagram > Add Element, then select the element with the appropriate number of selections or device for your criteria.
You can either click and drag or nudge the elements within the Diagram area. Select an element and use your arrow keys to nudge.

Connecting Elements
Developing flow between pages is made possible by creating lines from one element's exiting node to another element's entering 
node.
1. With a template open and elements present in the diagram area, left-click and hold on the exiting node of a desired element.
2. Drag your mouse over any part of another element. If a connection is permissible, the element highlights in green. If the 

connection is not possible the element highlights in red.
You have now created the flow from one page to another.

Editing Diagram Element Properties via The Diagram Menu
Once an element is in place in the Diagram area, it is necessary to name the node and place text for the corresponding buttons.
1. Select an element in the Diagram area.
2. Select Diagram > Properties to open the Diagram Properties dialog.
3. Click within the text fields to edit. You can either type the name or use the browse (...) button to edit the Connections f ields.
4. Once all fields are edited, click OK.

Generating A TPDesign4 Project
After your new project has all the necessary elements, their nodes are connected and the element properties are set; you are ready 
to generate a .TP4 file.
1. Select File > Generate TPDesign4 Project to launch the Generate TPDesign4 Project dialog.
2. Select the location to save the file and place a check next to Open project in TPDesign4 if you want G4 PanelBuilder to launch 

the newly created file within TPDesign4.
3. Click Save.

NOTE: When you generate a TPDesign4 project G4 PanelBuilder stores information to the .PB4 f ile. As a result the f ile will indicate 
being "dirty" or changed. You will need to save the .PB4 f ile.

Saving A Project
To save a G4 PanelBuilder project file (*.PB4):
1. Select File > Save. If this is the first instance of a save for your project, the Save As dialog launches.
2. Type the File name in the field provided.
3. Locate the directory you would like to save within.
4. Place a check next to Package template with project f ile if you would like to include the .TPT file with the .PB4 file. Doing this 

will allow you to open the G4 PanelBuilder file on other machines running the application.
5. Click Save.

FIG. 4  Drag Navigation element node to Device element node

Navigation populated by Device element
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Basic Operations
Select Save As if you would like to save your project under another name or different location.
1. Select File > Save As to launch the Save As dialog.
2. Type the File name in the field provided.
3. Locate the directory you would like to save within.
4. Place a check next to Package template with project f ile if you would like to include the .TPT file with the .PB4 file. Doing this 

will allow you to open the G4 PanelBuilder file on other machines running the application.
5. Click Save.

NOTE: When you generate a TPDesign4 project G4 PanelBuilder stores information to the .PB4 f ile. As a result the f ile will indicate 
being "dirty" or changed. You will need to save the .PB4 f ile.

Closing A Project
To exit an open project but leave G4 PanelBuilder running:

Select File > Close. If you have not already saved, the Close Project dialog will prompt you.
If the file save is current the file closes.

NOTE: When you generate a TPDesign4 project G4 PanelBuilder stores information to the .PB4 f ile. As a result the f ile will 
indicate being "dirty" or changed. You will need to save the .PB4 f ile.

Templates
Preview a Template via Template Manager
G4 PanelBuilder pages derive their look from templates (*.TPT files). Template Manager allows you access to all template files 
located on your computer. To preview any template located on your computer using Template Manager:
1. Select File > Template Manager to launch the Template Manager dialog.
2. Double-click on the thumbnail of a template family.
3. Select a thumbnail for one of the panel types within the family.
4. Click on the Samples button to launch the Template Samples Images dialog.

Opening a Most Recently Used Template
The Tasks Pane is a collection of frequently used functions. This is intended to add convenience to panel design.
In the Tasks Pane, under Start a new project, is a list of recently used templates.

To create a new G4 PanelBuilder project using one of the templates listed, click on the link for the desired template name. A 
new project file opens using your selected template.

Install a Template via Template Manager
The style for your panel pages is dictated by the template (.TPT) file you are using. You can download templates from AMX.com or 
create your own and then load them into G4 PanelBuilder.
1. First, launch the Template Manager dialog by selecting File > Template Manager.
2. Click the Install button in the bottom left corner.
3. Select either:

From AMX.com
From File

Install Templates from AMX.com
G4 PanelBuilder project files (*.PB4) derive their style from templates. In addition to making your own templates, you can download 
AMX created templates. To install a .TPT file from AMX.com:
1. Select File > Template Manager to open the Template Manager dialog.
2. In the bottom left corner of the dialog, select Install.
3. Select From AMX.com from the drop-down list to launch the AMX.com Template Library dialog.
4. Select a thumbnail of one of the template families.
5. Click the Install button.
If the .TPT file already resides on your computer you will be prompted by the Replace Template dialog. Select on of the following:

Yes - Confirms the replacement of the .TPT file on a panel-by-panel basis.
Yes All - Confirms the replacement of all .TPT files at one time.
No - Denies the replacement of the .TPT file on a panel-by-panel basis.
No All - Denies the replacement of all .TPT files at one time.
Abort - Cancels the template import with no changes.

NOTE: If you replace a .TPT f ile that is referenced by a .PB4 f ile, it will be updated in the .PB4 f ile.

6. After the template has been installed, click Close.
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Basic Operations
Install a Template From File
G4 PanelBuilder utilizes templates to apply appearances to panel pages. You can import your own local files as a template (.TPT) for 
use within G4 PanelBuilder.
1. Select File > Install Templates From File to launch the dialog.
2. Locate the .TPT file you would like to import.
3. Click Install.

NOTE: Templates are identif ied by their job names. Regardless of f ile name, if the job name already exists, you are prompted by the 
Replace Template dialog.

If you replace a .TPT file that is referenced by a .PB4 file, it will be updated in the .PB4 file.

Remove a Template From G4 PanelBuilder
Panel pages designed in G4 PanelBuilder depend on templates to dictate their style. The Template Manager allows you to preview, 
add and remove templates from your local directory.
To remove template files (*.TPT) files:
1. Open the Template Manager dialog by selecting File > Template Manager.
2. Select the thumbnail of the template to be removed.
3. Click Remove at the bottom of the window.
4. Confirm you have selected the appropriate template and click OK.

Opening A Project
To open a (*.PB4) file in G4 PanelBuilder:
1. Select File > Open to launch the Open Project dialog.
2. Select the file and click OK.

NOTE: If a project is already open and you select open a new or existing project, you are prompted by the Save As dialog. The 
previous project will remain on screen until you are done setting up the new project.

Changing Color Schemes
If the template you are working with has more than one color scheme available the Color Schemes button is active in the toolbar.
To change the color scheme of your project file:
1. With your project file open go to Project > Color Schemes to open the Color Schemes dialog.
2. Select the color scheme in the field and click OK.
While the color change is not reflected in the toolbox, you will see it if you select an element and go to Diagram > Preview.

Creating a New Project from File
You can change templates attributed to projects and create a new project as a result.
1. Select File > New From File to launch the New From File dialog.
2. Open your desired project file (*.PB4).
3. The next window to open is the New project dialog. Select the new template to be used with the project.
4. Click OK.

NOTE: If a project is already open and you select open a new or existing project, you are prompted by the Save As dialog. The 
previous project will remain on screen until you are done setting up the new project.

Editing Project Properties
You can edit some of the project's properties as well as add information specific to you, i.e., Dealer ID and Designer ID.
1. Select File > Project Properties to launch the Project Properties dialog.
2. Place your cursor within the white fields to add and edit text.
To set a password for the project:
1. Click the drop-down menu for Protection. Select either:

read-only - project can be opened; not changed.
locked - project cannot be opened.

NOTE: Password protection extends only to TPDesign4. Projects password protected in G4 PanelBuilder can still be opened and 
used.

2. Type a password in the field provided.
3. Re-type the password within Conf irm.
4. Click OK when all changes have been made.

NOTE: Project properties differ from f ile properties established in TPDesign4. File properties entered in TPDesign4 are what is 
displayed in the Template Manager dialog.
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Basic Operations
Alternate Screen Names
G4 PanelBuilder supports alternate screen names for use with elements with longer names. Within TPDesign4, the template 
designer can designate abbreviated text for substitution. You can then change the on-screen text in PanelBuilder and the default 
text fits without the need for modification.
The full name of the element is always displayed in the toolbox area.

Using Unicode Text
G4 PanelBuilder supports assigning text to template elements that differs from the element name. This means you can rename an 
element, and the new name will be used to populate panel titles and button names. Additionally, the new text can be set in Unicode. 
To assign Unicode text to a template element:
1. Select the element within the diagram area.
2. Select Diagram > Properties to open the Diagram Properties dialog.
3. Click on the browse button (...) to launch the Unicode Edit dialog widow.
4. Type the Unicode within the text field and the equivalent is displayed below.
5. Click OK to close the Unicode Edit dialog.
6. Click OK to close the Diagram Properties dialog.
The Unicode can now only be edited via the Unicode Edit dialog. If the element name and screen name differ, both are displayed 
within the node.
If Unicode characters are specified but the template does not support the specified font a Unicode font is used only in those 
instances. To set the Unicode Font:
1. Select Project > Project Properties to open the Project Properties dialog.
2. From the drop down list, select the font G4 PanelBuilder is to use in the event the Unicode character font is not supported.
3. Click OK.

Preview Diagram Element
G4 PanelBuilder files are designed within the diagram area using graphic representation for the panel pages. It is necessary to see 
how the pages will look when finished. Will the text fit the selected button? To preview an element within the Diagram area:
1. Select an element in the Diagram area.
2. Select Diagram > Preview to launch the Diagram Preview dialog. This view is what the finished panel will look like.
3. When finished click Close.

Preview a Toolbox Element
G4 PanelBuilder uses graphic representation within the Diagram area to develop panel files and express flow between pages. While 
the toolbox does contain thumbnails for the elements, you can view larger screenshots of each element. To preview a toolbox 
element:
1. Select an element in either the toolbox or Diagram area.
2. Select Toolbox > Element Preview to launch the Template Sample Images dialog.
3. Click Close when you are finished.

Globally Remove an Element Instance
G4 PanelBuilder uses the Diagram area as a graphic representation for the flow panel pages take. You create this flow by placing 
elements within the Diagram area and then connecting them accordingly.
You can delete these elements from the work area individually or in a global fashion. To globally remove an element:
1. Select the element thumbnail to be removed within the Toolbox.
2. Select Toolbox > Remove All Instances From Diagram.

Undo, Redo And Delete
The crux of G4 PanelBuilder is the graphically driven interface of the Diagram area. You are able to move elements around within 
the provided area as well as connect them to develop a flow. It is possible to edit these actions via the Edit menu. The functions, 
undo, redo and delete do not apply to changes made to element properties.
To Undo an action in the Diagram area:

Select Edit > Undo.
To Redo an Undo or Delete action:

Select Edit > Redo.
To delete an element or connection in the Diagram area:
1. Select the item in the Diagram area.
2. Select Edit > Delete.
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Create Snapshots to Clipboard
Since designing panel projects in G4 PanelBuilder is a visual exercise, where you drag and link individual elements to make a flow 
within the Diagram area. It is necessary to be able to show the design or "snapshot" of the intended look. Once you are ready to 
create a snapshot to your computer's clipboard:
1. Select Diagram > Copy Snapshot To Clipboard.
2. Open a graphic program, i.e., Paint or Photoshop and paste the image into it.

NOTE: Even if you zoom in or out of the Diagram area, the default, 100%, view is used in creating a snapshot to clipboard.

Show and Hide Grid
The Diagram area allows you to visually arrange your panel pages and connect them to create a flow. You can toggle a grid to snap 
the elements to on and off. To show the grid:

Select Diagram > Show Grid. When a check is present next to this function in the Diagram menu, the elements will align 
incrementally and the gird is shown.

Snap To Grid
The Diagram area allows you to visually arrange your panel pages and connect them to create a flow. To have the elements snap to 
the grid:

Select Diagram > Snap To Grid. When the check is present the elements snap to the grid. The elements align according to 
the grid in the Diagram area.

Zoom In and Out of Diagram
When designing a G4 PanelBuilder file, you place elements within the Diagram area, set properties and create connections between 
the elements to establish flow. To zoom in or out of the Diagram area:

Select Diagram > Zoom Out/In. This function will zoom incrementally.
To select the percentage in which to zoom:

Select Diagram > Zoom and then select the desired percentage.

NOTE: Even if you zoom in or out of the Diagram area, the default, 100%, view is used in creating a snapshot to clipboard.

Using Web Updates
Newer versions of G4 PanelBuilder can now be acquired via the internet. The Web Update utility accesses the AMX web site with the 
application ID and version number and searches for updates.
1. Select Help > Web Update to check for updates.
2. If updates are available for the installed version of G4 PanelBuilder they will be downloaded at this time.
3. After the download is complete Web Update will close G4 PanelBuilder and the updates will be added.
If you do not have Web Update installed, you will receive a window indicating where it can be downloaded.

Exiting G4 PanelBuilder
After you have created a new touch panel page, generated it and saved it, you are ready to close G4 PanelBuilder.

Select File > Exit. If you have not already saved a currently open project, you are prompted to do so now. Confirm, deny or 
cancel the changes.
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Creating Templates for G4 PanelBuilder
Creating Templates for G4 PanelBuilder
Overview
A G4 PanelBuilder template is a TPD4 file complete with pages, popups and buttons, named in a manner that G4 PanelBuilder will 
understand the relationship between all of the elements. Then, based on the established elements, G4 PanelBuilder customizes the 
TPD4 file based on the navigation flow you designed.
Any number of template files (*.TPT) can be created to constitute a template family, it is suggested you create one for each 
resolution totaling 6. You only need one template per resolution but you should consider instances such as the MVP-8400(i), where 
the Pixels Per Inch is higher than the CV12 and the MVP-7500's limited color depth. Both examples are situations where you might 
consider making specific templates for those panel types.
1. You should spend some time deciding what you want the panel to do. What navigation model are you going to use? You know 

you're going to have the required template elements but are some of your menus so complex they will require sub-menus? 
What devices and features will the template include? Consider using some optional template elements. Careful consideration 
will reveal the type of navigation you will need.
Things to remember:
You must have a minimum of 1 Navigation element.
You must have a minimum of 1 Placeholder element.
You must have a main preview image ("[preview].jpg" or "[preview].png").
You cannot create a "drill-down" style of navigation with G4 PanelBuilder.
Your navigation menus will always be on top of your Devices. Make sure they do not conflict with each other.
Suggestion: Create a simple TPD4 file showing the desired output. Doing this gives you a starting point to begin looking at 
how to modify the TPD4 file to create a template.

2. You are ready to begin restructuring the elements to fit your needs. Start with the Device and Navigation elements first and the 
Placeholder elements last. The key for creating your own elements naming conventions. G4 PanelBuilder looks for navigations 
with the name, [nav#navName]pageName.
Suggestions: Start with the most complex Device element first, then make copies of it. This method allows you to modify and 
delete thus the pages are more likely to be similar. Also, create several different variations of Navigation and Sub-Navigations 
(3 items, 4 items, etc...).

3. Create the preview images for the elements. Images do not have to be full size, in fact AMX templates utilize a 1/4 screen size 
to reduce the template file size.
Suggestion: Mock up the interface in TPDesign4 by opening the corresponding page and display all applicable popups. Select 
Page > Copy Image To Clipboard. Then open the resource manager and select Paste. Now rename the new image to the 
appropriate element name.

4. After you have completed the template design, do a generate. A .TPT file is created and a list of errors and warnings are 
displayed at this time, if applicable.

5. Repeat the design for other resolutions.
Things to remember:
You can use TPD4's Save As Other Panel Type when appropriate or as a starting point.
Leave the "Job Name" in the Panel Properties the same for all related TPD4 files, this is the basis of a template family.
Not all resolutions have to be done at once. If necessary you can build the ones you currently need and address the other 

resolutions as they present themselves.
Below is the workspace for TPDesign4. The pages are highlighted in the color of the element they represent (FIG. 5). 
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Creating Templates for G4 PanelBuilder
Creating a New Touch Panel Project
G4 PanelBuilder provides a quick alternative to creating touch panel projects from scratch. Use this option to launch the G4 
PanelBuilder application and create the basic layout and navigation of your panel file. 
1. Select File > New From G4 PanelBuilder to launch the G4 PanelBuilder application. In G4 PanelBuilder, there are several 

possible approaches to creating a new PanelBuilder (*.PB4) file in the G4 PanelBuilder application:
(In G4 PanelBuilder, select File > New (or select Choose Template in the Tasks Pane) to create a new PanelBuilder project file 

based on existing templates (that were either downloaded from www.amx.com, or were created in TPDesign4). 
(In G4 PanelBuilder, select File > New From File (or select Start From Existing Project in the Tasks Pane) to open a copy of an 

existing PanelBuilder project file to use as a starting point.
(In G4 PanelBuilder, select a template from the list of recently opened templates (or select Start a New Project in the Tasks 

Pane).
2. In G4 PanelBuilder, develop the PanelBuilder project as desired. Refer to the G4 PanelBuilder help file for details on creating a 

G4 PanelBuilder (*.PB4) file.
3. In G4 PanelBuilder, select File > Save to save the PB4 file. Use File > Save As to save the file under a new name and/or specify 

a different target directory.
4. In G4 PanelBuilder, select File > Generate TPDesign4 Project. In the Generate TPDesign4 Project dialog, specify a name and 

target directory for the (*.TP4) file. By default, once the TP4 file has been generated, the project is automatically opened in 
TPDesign4 (de-select the Open Project in TPDesign4 option to disable this feature).
If the project does not automatically open in TPDesign4, launch TPDesign4 and open the project file (File > Open). TPDesign4 
treats projects generated in G4 PanelBuilder the same as any other TP4 project file; use TPDesign4 to assign channel mapping 
information and make any other refinements to the project as needed.

5. Save the project (File > Save). The file is now ready for transfer.

NOTE: Use the Panel > Send to G4 PanelPreview option to preview the resulting panel f ile in the G4 PanelPreview application.

FIG. 5  G4 PanelBuilder Template - workspace for TPDesign4
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Creating Templates for G4 PanelBuilder
Importing G4 PanelBuilder Templates
You can import existing G4 PanelBuilder template (*.TPT) files to take advantage of the prefabricated elements they contain:
1. Select File > Import G4 PanelBuilder Template to access the Import G4 PanelBuilder dialog. Locate and open the desired 

template file (*.TPT).
If you have downloaded G4 PanelBuilder templates from www.amx.com, they reside in the following directory:
C:\Program Files\Common Files\AMXShare\G4Templates

2. The selected template file is opened in TPDesign4 as a TP4 project file.
3. Modify and save the file as needed.

Creating G4 PanelBuilder Templates
You can use TPDesign4 to create custom G4 PanelBuilder template (*.TPT) files.
A template is essentially just a TPDesign4 project (*.TP4) file with pages, popup pages and buttons named in a specific way that 
allows G4 PanelBuilder to recognize the elements in the project, and understand the relationships between these elements. Once a 
project file is exported as a G4 PanelBuilder Template (*.TPT) file, it can be used as a starting point for panel design in the G4 
PanelBuilder application.
The basics of this operation are simple: once you have created or opened a TP4 file, select File > Export As G4 PanelBuilder 
Template. Assuming that the project adheres to the various rules required by G4 PanelBuilder for a valid template file, the file is 
exported with the TPT file extension. There are certain basic requirements that must be met by the TP4 file before it can be 
exported as a G4 PanelBuilder Template (TPT) file:

The project must contain at least one Navigation Element. A Navigation element consists of at least one popup (may 
contain multiple popups), and represents the place where you make most navigation selections (i.e. a main menu page).

The project must contain at least one Placeholder Element. A Placeholder element is a blank or empty device/feature 
element that allows you to include items in the project that are not specifically included in the template.

The project must contain at least one main Preview image. A Preview image is the image that is used for thumbnail 
representation of the template within the G4 PanelBuilder application.

If TPD4 detects that there are problems with the file that would prevent it from being used by G4 PanelBuilder, these errors and 
warnings are listed in the Export As G4 PanelBuilder dialog.

Creating Templates with Alternate Screen Names
G4 PanelBuilder supports alternate screen names for use with elements with longer names. The alternate name must be defined by 
the template creator.
You must create an info button for the device and use this syntax:

[info]alternate name
For example, the device Audio Conference could have the alternate screen name of Audio Conf. displayed on the navigation button. 
The info button is defined as:

[info]Audio Conf

Creating Templates with Color Schemes
When you create a template within TPDesign4 you can designate color palettes from which to work. Defined color palettes are Color 
Schemes, utilized by G4 PanelBuilder for changing color schemes.

Def ine The Color Scheme
1. Within TPDesign4, select Panel > Edit Palettes to open the Edit Palettes dialog.
2. Select Rename to edit the name of the palette.
3. Define the colors used in the palette.
4. Repeat steps 2 and 3 for as many color schemes you want available within the template file.
5. Click Close.

Create A Preview Image
Before TPDesign4 will export a template file, all color schemes must have a sample image.
1. Select a panel page that best represents the color scheme used. It is suggested you use the same panel page for all color 

schemes to better show the color changes.
2. With the selected panel page open and active, select Page > Create Template Preview Image to open the Create Template 

Preview Image dialog.
3. Set Element Type to Palette.
4. The Name must match the name you used in step 2 of Def ine The Color Scheme.
5. You can set the Scale, File Format and Compression at your discretion.
6. Click OK.
You can now export the file as a template, open and use it within G4 PanelBuilder.
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TPDesign4 and G4 PanelBuilder
TPDesign4 and G4 PanelBuilder
Overview
Although G4 PanelBuilder is installed separately from TPDesign4, it is fully integrated with TPD4. For example, the File > New From 
G4 PanelBuilder option in TPDesign4 (available only if G4 PanelBuilder is installed) launches the G4 PanelBuilder application to 
allow you to create a new TPD4 project.
Use the set of options in the TPDesign4 File menu to access the key functions of the G4 PanelBuilder application:

Click File > New From G4 Panel Builder to create a new TP4 panel project using G4 PanelBuilder.
Click File > Import Touch Panel Template to import an existing PanelBuilder (*.TPT) or Visual Architect template file (*.VAT) 

into TPD4 as a starting point for your panel design.
Click File > Export G4 PanelBuilder Template to export the active TP4 project as a PanelBuilder Template file (*.TPT).

Creating a New TPD4 Project Using G4 PanelBuilder
The G4 PanelBuilder application (installed separately) provides a quick alternative to creating touch panel projects from scratch in 
TPDesign4. Use this option to launch the G4 PanelBuilder application and create the basic layout and navigation of your panel file. 
In TPDesign4:
1. Select File > New From G4 PanelBuilder to launch the G4 PanelBuilder application. In G4 PanelBuilder, there are several 

possible approaches to creating a new PanelBuilder (*.PB4) file in the G4 PanelBuilder application:
In G4 PanelBuilder - select File > New (or select Choose Template in the Tasks Pane) to create a new PanelBuilder project 

file based on existing templates (that were either downloaded from www.amx.com, or were created in TPD4).
In G4 PanelBuilder - select File > New From File (or select Start From Existing Project in the Tasks Pane) open a copy of an 

existing PanelBuilder project file to use as a starting point.
In G4 PanelBuilder - select a template from the list of recently opened templates listed under Start a New Project in the 

Tasks Pane).
2. (In G4 PanelBuilder) Develop the PanelBuilder project as desired. Refer to the G4 PanelBuilder help file for details on creating a 

G4 PanelBuilder (*.PB4) file.
3. (In G4 PanelBuilder) Select File > Save to save the PB4 file. Use File > Save As to save the file under a new name and/or 

specify a different target directory.
4. (In G4 PanelBuilder) Select File > Generate TPD4 Project. In the Generate TPD4 Project dialog, specify a name and target 

directory for the (*.TP4) file.
By default, once the TP4 file has been generated, the project is automatically opened in TPD4 (de-select the Open Project in 
TPD4 option to disable this feature).

5. If the project does not automatically open in TPD4 (see above), launch TPD4 and open the project file (File > Open). TPD4 
treats projects generated in G4 PanelBuilder the same as any other TP4 project file. Use TPD4 to assign channel mapping 
information and make any other refinements to the project as needed.

6. Save the project (File > Save).
The file is now ready for transfer.

NOTE: Use the Panel > Send to G4 PanelPreview option to preview the resulting panel f ile in the G4 PanelPreview application.

Importing G4 PanelBuilder Templates
You can import existing G4 PanelBuilder template (*.TPT) files into TPDesign4 to take advantage of the prefabricated elements they 
contain:
1. Select File > Import Touch Panel Template to access the Import Touch Panel Template dialog. Locate and open the desired 

template file (*.TPT).
If you have downloaded G4 PanelBuilder templates from www.amx.com, they reside in the following directory:
C:\Program Files\Common Files\AMXShare\G4Templates

2. The selected template file is opened in TPD4 as a TP4 project file.
3. Modify the file as needed.

Chameleon Images, Custom Palettes and G4 PanelBuilder
Chameleon images can be used in conjunction with custom palettes to create G4 PanelBuilder template files that, when opened in 
the G4 PanelBuilder application, are capable of switching from one color scheme to another without having to edit the buttons 
directly. For example, you could create a single template file with four different color palettes that would allow you to use the same 
template to quickly produce four different variations on the design - one color scheme for each design. The Color Schemes feature 
in G4 PanelBuilder allow you to apply different "color skins" to a single template.
Since the Fill and Border colors are in turn associated with a particular color palette (which is saved as part of the TPD4 project), 
the colors used to render the chameleon image will change if and when a different color palette is applied to the template in the G4 
PanelBuilder application.
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TPDesign4 and G4 PanelBuilder
Chameleon images utilize the 4 color channels that comprise 32-bit PNG images to define separate colorizable regions.
Using chameleon images coupled with custom palettes to create Color Schemes requires the use of both TPD4 and G4 
PanelBuilder: Chameleon images are imported and applied to buttons (or popup pages) in TPD4. Custom palettes are created in 
TPD4, and saved as part of the TPD4 project. TPD4 is also required to export the project as a G4 PanelBuilder Template (*.TPT). 
However, the primary benefits of these features are realized in the G4 PanelBuilder application (via the Project > Color Schemes 
feature).
Not all TPD4 projects support the Color Schemes feature in G4 PanelBuilder. In order to utilize Chameleon Images and Color 
Schemes in G4 PanelBuilder, the TPD4 project must meet several requirements before being exported as a G4 PanelBuilder 
template file (via the File > Export as G4 PanelBuilder Template option):
The project must utilize at least one chameleon image (meaning that a chameleon image has been applied to at least one button in 
the project). There are also several requirements for images to allow them to be recognized as chameleon images by TPD4. The 
project must include at least one custom palette (in addition to the default palette). The project must include one preview image for 
each of the custom palettes that are included. These preview images are used to display the color options that are available for this 
template in G4 PanelBuilder. Note that if the exported project does not meet these requirements, the Color Schemes feature in G4 
PanelBuilder will be disabled for this template.
When a valid TPD4 project file is exported as a G4 PanelBuilder template, and then opened in the G4 PanelBuilder application, the 
Project > Color Schemes option (in the G4 PanelBuilder application) allows you to apply different color schemes to the template 
with a single click.
See Also:

For instructions on creating new palettes in TPD4 (and related topics), refer to the TPDesign4 online help.
For instructions on exporting TPD4 projects as G4 PanelBuilder Templates, refer to the Creating G4 PanelBuilder Templates 

section (below).
For instructions on using the Color Schemes feature in G4 PanelBuilder to apply different color schemes to a panel builder 

project, refer to the G4 PanelBuilder online help.

Creating G4 PanelBuilder Templates
You can use TPD4 to create custom G4 PanelBuilder template (*.TPT) files.
A template is essentially just a TPD4 project (*.TP4) file with pages, popup pages and buttons named in a specific way that allows 
G4 PanelBuilder to recognize the elements in the project, and understand the relationships between these elements.
Once a TP4 project file is exported as a G4 PanelBuilder Template (*.TPT) file, it can be used as a starting point for panel design in 
the G4 PanelBuilder application.
The basics of this operation are simple: once you have created or opened a TP4 file, select File > Export As G4 PanelBuilder 
Template. Assuming that the project adheres to the various rules required by G4 PanelBuilder for a valid template file, the file is 
exported with the TPT file extension. There are certain basic requirements that must be met by the TP4 file before it can be 
exported as a G4 PanelBuilder Template (TPT) file:

The project must contain at least one Navigation Element. A Navigation element consists of at least one popup (may 
contain multiple Popups), and represents the place where you make most navigation selections (i.e. a main menu page).

The project must contain at least one Placeholder Element. A Placeholder element is a blank or empty device/feature 
element that allows you to include items in the project that are not specifically included in the template.

The project must contain at least one main Preview image. A Preview image is the image that is used for thumbnail 
representation of the template within the G4 PanelBuilder application. TPD4 offers a tool that aid in the creation of preview 
images that are embedded in G4 PanelBuilder template files, the Create Template Preview Image dialog is available via the 
Page menu (FIG. 6): 

NOTE: Projects that utilize custom palettes must also contain one preview image for each color palette that will be available for 
selection in G4 PanelBuilder (via the Color Schemes option).

FIG. 6  Create Template Preview Image dialog
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Template Requirements
Template Requirements
Overview
There are a few key items required of all templates. TPD4 will not allow you to create a template without:

A minimum of 1 Navigation Element
A minimum of 1 Placeholder Element
A main Preview Image ("[preview].jpg" or "[preview].png")  

FIG. 7  G4 PanelBuilder Templates - Required Template Elements

G4 PanelBuilder Templates - Required Template Elements
Navigation Elements

This is the main menu where most of your navigation selections are made.
• Consists of at least one popup but can contain multiple Popups.
• Cannot contain any pages
• Only one can be displayed at a time.

[ nav#navName] pageName

• navName • The name of the Navigation as it will appear within G4 PanelBuilder.

• pageName • The base page name that will be used in the generated TP4 project.

Only one of the pages or Popups in A Navigation element can contain an Info button. The Info button contains the page flip information 
for displaying the Navigation element and can contain an optional icon image.

[info]buttonName

• buttonName This is unused and the button is deleted in the generated TP4 project.

The Popups in the Navigation element must contain at lest one item button that will be filled with navigation information. Item buttons are 
ordered within the Navigation element in order of left to right then top to bottom.

[item]buttonName

• buttonName This is the button name used in the generated TP4 project.

Popups in a Navigation element can contain one or more Title buttons. The text will be replaced with the name given to the Navigation in 
the generated TP4 project.

[title]buttonName

• buttonName This is the button name used in the generated TP4 project.
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Template Requirements
Optional Template Elements
There are required elements when developing templates but G4 PanelBuilder also supports a series of optional elements that will 
make your templates more robust.
There are rules that govern all template elements (see FIG. 7 on page 18): 
Your templates can have any of the following: 

G4 PanelBuilder Templates - Required Template Elements (Cont.)
Placeholder Elements

This is a blank device element that allows you to represent unique items in the diagram area.
• Is one page and may have optional Popups.
• Only one Placeholder element can be displayed at a time.

[ placeholder#placeholderName]pageName

• placeholderName The name of the Placeholder element as it appears in G4 PanelBuilder.

• pageName The base page name used in the generated TP4 project.

Only one page or popup within a Placeholder element can contain an Info button. The Info button contains the page flip information for 
displaying the Placeholder element and can also contain an optional icon image.

[info]buttonName

• buttonName This is unused and the button is deleted in the generated TP4 project.

The pages and pops in a Placeholder element can contain one or more Title buttons. The text is replaced with the name given to the 
Placeholder element in the generated TP4 project.

[title]buttonName

• buttonName The button name will be used in the generated TP4 project.

G4 PanelBuilder Templates - Optional Template Elements
MODE ELEMENTS

This element is generally used for designating "modes" your system will work in, i.e., "Video Conference Mode" or "Presentation Mode." 
Additionally, Mode elements can be associated with rooms.
• Consists of a single page and can contain multiple Popups.
• Only one Mode element can be displayed at a time.

[mode#modeName]pageName

• modeName The name of the Mode as it will appear in G4 PanelBuilder.

• pageName The base page name used in the generated TP4 project.

Only one page in a Mode element can contain an Info button. The Info button contains the page flip information for displaying the Mode 
element and can also contain an optional icon image.

[info]buttonName 

This text is used to populate the mouseover element description in the toolbox.

• buttonName Unused; the button is deleted in the generated TP4 project.

The page in the Mode element must contain at least one Item button that contains the navigation information. Item buttons are ordered 
within the Mode element by left-to-right then top-to-bottom.

[item]buttonName

• buttonName The button name used in the generated TP4 project.

Popups in a Mode element can contain one or more Title buttons, whose text is replaced with the name given to the Mode in the generated 
TP4 project.

[title]buttonName

• buttonName The button name used in the generated TP4 project.

SUB-NAVIGATION ELEMENTS

This element is a submenu and can occur on screen with Navigation elements.
• Consists of at least one popup and can contain multiple Popups.
• Cannot contain pages.

[subnav#navName]pageName

• navName The name of the Sub-Navigation element as it appears in G4 PanelBuilder.

• pageName The base page name that is used in the generated TP4 project.

Only one of the Popups in a Sub-Navigation element can contain an Info button, which contains the page flip information for displaying 
the Sub-Navigation element and can also contain an optional icon image.
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G4 PanelBuilder Templates - Required Template Elements (Cont.)
[info]buttonName

This text is used to populate the mouseover element description in the toolbox.

• buttonName Unused; the button is deleted in the generated TP4 project.

Popups in the Sub-Navigation element must contain at least one Item button that will contain navigation information. Item buttons are 
ordered in the Navigation element left-to-right then top-to-bottom.

[item]buttonName

• buttonName The button name used in the generated TP4 project.

The Popups in a Sub-Navigation element can contain one or more Title buttons. The text within the Title buttons are replaced with the 
name given to the Sub-Navigation in the generated TP4 project.

[title]buttonName

• buttonName The button name used in the generated TP4 project.

SPLASH ELEMENTS

This element is a popup that can contain an image, i.e., corporate logo.
• Consists of at least one popup and can contain multiple Popups.
• Cannot contain pages.

[splash#splashName]pageName

• splashName The name of the Splash element as it appears in G4 PanelBuilder.

• pageName The base page name that is used in the generated TP4 project.

Only one of the popups in a Splash element can contain an Info button, which contains the page flip information for displaying the Splash 
element and can also contain an optional icon image.

[info]buttonName

This text is used to populate the mouseover element description in the toolbox.

• buttonName Unused; this button is deleted in the generated TP4 project.

Popups in a Splash element can contain one or more Title buttons. The text within the buttons is replaced with the name given to the 
Splash element in the generated TP4 project.

[title]buttonName

• buttonName The button name used in the generated TP4 project.

DEVICE ELEMENTS

This element is the actual device used. For reference, consult AMX templates where we list the most commonly used devices.
• Consists of one page and can contain multiple Popups.
• Only one Device element can be displayed at a time.

[device#deviceName]pageName

• deviceName The name of the Device as it appears in G4 PanelBuilder.

• pageName The base page name used in the generated TP4 project.

Only one page or popup in a Device element can contain an Info button which contains the page flip information for displaying the Device 
element and can also contain an optional icon image.

[info]buttonName

This text is used to populate the mouseover element description in the toolbox.

• buttonName Unused; the button is deleted in the generated TP4 project.

Pages and popups in a Device element can contain one or more Title buttons. The text within the buttons is replaced with the name given 
to the Device element in the generated TP4 project.

[title]buttonName

• buttonName The button name used in the generated TP4 project.

FEATURE ELEMENTS

This element resembles the Device element. However, there can only be one Feature element in a panel design, i.e., the "Clean Panel" 
feature.
• Consists of one page and can contain multiple popups.
• Only one Feature element can be displayed at a time.

[feature#featureName]pageName

• featureName The name of the feature as it appears in G4 PanelBuilder.

• pageName The base page name that is used in the generated TP4 project.

Only one page or popup in a Feature element can contain an Info button, which contains the page flip information for displaying the 
Feature element and can also contain an optional icon image.
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Template Requirements
Rules for Navigating a Template
In addition to the template requirements and required elements,  there are rules for navigating the templates and template wide 
conventions you need to heed.
When navigating to a Device, Feature or Placeholder element from a Navigation element:

Hide all Popups on the page for that element.
Perform the standard page flip to the page for that element.
Show any Popups for the element.
Show any Popups for the linked Sub-Feature, when applicable.
Show the Navigation element that is linked to the element.

NOTE: Any Sub-Navigation elements that may have been currently displayed will be hidden.

When navigating to a Device, Feature or Placeholder element from a Sub-Navigation element:
Hide all Popups on the page for that element.
Perform the standard page flip to the page for that element.
Show any Popups for the element.
Show any Popups for the linked Sub-Feature, when applicable.
Show the Navigation element that is linked to the Sub-Navigation element or chain.
For Sub-Navigations the user must set "Hide On Action" to No, then show the Sub-Navigation element that is linked to the 

element. Otherwise, the Sub-Navigation is not shown.
Info buttons are optional and only have to be included within an element if the order the popup pages is shown is important, if not 
all popup pages should be initially shown, or if an icon is used on the corresponding Navigation or Sub-Navigation button.
If the Info button is omitted, popup pages are shown in alphabetical order.

Template Wide Conventions
Text Replacement - The string "[text]" is required on the button wherever text is to be replaced in the output file. The 

string "[text]" allows you to prepend/ postpend text with characters. If the text on a button to be replaced does not contain 
'[text]" then it is unchanged.

Panel Title - A template can contain as many buttons named "[panelTitle]" as necessary, they are replaced with the "Job 
Name" of the panel.

Preview Images - A template must contain a main preview image and can also contain a preview image for each element. 
The main preview image should be named '[preview].JPG" (or .PNG). The element previews should follow the same naming 
conventions as their page prefixes, i.e., "[device#DVD].JPG." There can only be one preview image per element.

G4 PanelBuilder Templates - Required Template Elements (Cont.)
[info]buttonName

This text is used to populate the mouseover element description in the toolbox.

• buttonName Unused; the button is deleted in the generated TP4 project.

The pages and popups in the Feature element can contain one or more Title buttons, whose text is replaced with the name given to the 
Feature in the generated TP4 project.

[title]buttonName

• buttonName The button name that is used in the generated TP4 project.

SUB-FEATURE ELEMENTS

This element represents the "universal" features that appear on many pages, i.e., "volume."
• Consists of at least one popup and can contain multiple popups.
• Cannot contain pages.

[subFeature#subFeatureName]pageName

• subFeatureName The name of the Sub-Feature element as it appears in G4 PanelBuilder.

• pageName The base page name that is used in the generated TP4 project.

Only one of the pages or popups in a Sub-Feature element can contain an Info button, which contains the page flip information for 
displaying the Sub-Feature element and can also contain an optional icon image.

[info]buttonName

This text is used to populate the mouseover element description in the toolbox.

• buttonName Unused; the button is deleted in the generated TP4 project.

Popups in a Sub-Feature element can contain one or more Title buttons, whose text is replaced with the name given to the Sub-Feature 
element in the generated TP4 project.

[title]buttonName

• buttonName The button name that is used in the generated TP4 project.
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Creating Navigation Elements
In order for a TP4 file to be successfully exported as a G4 PanelBuilder Template file (*.TPT), the TP4 project file must contain at 
least one Navigation Element. A Navigation element consists of at least one popup (may contain multiple Popups), and represents 
the place where you make most navigation selections (i.e. a main menu page).
To create a basic Navigation element, create a new popup page (Panel > Add Popup Page) , and name it according to the naming 
convention required by G4 PanelBuilder for Navigation elements:
[ nav#navName] pageName

navName - The name of the Navigation as it will appear in G4 PanelBuilder.
pageName - The base page name that will be used in the generated TP4 project.

The following example illustrates the implementation of a Navigation popup, as seen in the "graphiclySound-Orange" template 
(available from AMX). Note that the template includes several variations on the same Navigation theme, offering different numbers 
of buttons.
The example shown in FIG. 8 is for the Navigation popup named "[nav#3 Selections]Navigation 3", which as the name implies, 
contains three buttons: 

Example Navigation Popups in the Workspace Window - these represent the variations on the Navigation theme for different 
numbers of buttons (FIG. 9): 

The "[nav#3 Selections]Navigation 3" popup as it appears in the Workspace (FIG. 10): 

FIG. 8  Properties window - Navigation popup - "[nav#3 Selections]Navigation 3"

FIG. 9  Workspace window - Example Navigation Popups

FIG. 10  [nav#3 Selections]Navigation 3" popup
22G4 PanelBuilder - Instruction Manual



Template Requirements
G4 PanelBuilder Templates - Creating Placeholder Elements
In order for a TP4 file to be successfully exported as a G4 PanelBuilder Template file (*.TPT), the TP4 project file must contain at 
least one Placeholder Element. A Placeholder element is basically a blank device/feature element that allows you add items to the 
project in G4PanelBuilder that are not included in the template. Placeholder elements consist of one page, and may contain multiple 
Popups.  Only one Placeholder element can be displayed at a time. 
To create a basic Placeholder element, create a new Page (Panel > Add Page) , and name it according to the naming convention 
required by G4 PanelBuilder for Placeholder elements:
[placeholder#placeholderName] pageName

placeholderName - The name of the Placeholder element as it will appear in G4 PanelBuilder.
pageName - The base page name that will be used in the generated TP4 project.

Here's an example implementation of a Placeholder element, as seen in the " graphiclySound-Orange" template (FIG. 11): 

Example Placeholder page in the Workspace Window (FIG. 12): 

The "[ placeholder#Placeholder]Placeholder" page as it appears in the Workspace (FIG. 13): 

FIG. 11  Example (General) properties for a Placeholder page

FIG. 12  Example Placeholder page in the Workspace Window

FIG. 13  [ placeholder#Placeholder]Placeholder" page
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Creating Preview Images
In order for a TP4 file to be successfully exported as a G4 PanelBuilder Template file (*.TPT), the TP4 project file must contain at 
least one Main Preview Image. However, you can create multiple preview images to represent various elements in the project.
Preview Images are used in G4 PanelBuilder for both the thumbnail  images displayed in the Template Manager, as well as the icons 
in the toolbox.

Preview Images cannot be used within the panel design itself.
They must be either JPG or PNG files.

NOTE: If you have created multiple color palettes as part of your TP4 project, and intend to use them to enable the Color Schemes 
feature in G4 PanelBuilder, you must create a separate preview image for each custom palette that you want to be available for 
application (via the Project > Color Schemes option in G4 PanelBuilder).

To create preview images for your G4 PanelBuilder template:
1. Open a page in a Design View window.
2. Select Page > Create Template Preview Image to open the Create Template Preview Image dialog. The preview Image will be 

created using the page that currently has edit focus (FIG. 14): 

3. Select the type of preview image you want to create from the Element Type drop-down menu. This menu lists all of the types of 
project elements that are recognized by G4 PanelBuilder. Pick the one that best describes the type of element you are creating 
a preview image for.
The first item in the list is Main Preview, which represents the main preview image that is required by G4 PanelBuilder for the 
template to be valid.

4. If you have selected any element other than the Main Preview element, then you can enter an alternative name for it in the 
Element Name text f ield. 
For all element types other than the Main Preview element, the name represents the element name for which the preview is 

being created. For example, if you have created a DVD Device element, the preview image for this would need to be created 
as Device element type, and DVD as the name. 

Default values for these fields are pulled from the name of the page being displayed. For example, if the DVD page 
mentioned above is named "[device#VCR]Main", then the dialog will be re-populated with "Device" as the element type and 
"VCR" as the name.

5. Use the up and down arrows next to the Scale % f ield  to scale the image, if desired. For example, in order to minimize the file 
size of the template, you may decide to reduce the zoom on your preview image(s) to 25%.

6. In the File Format drop-down, select either JPG or PNG as the file format for the image file. If you select JPG, you can specify 
the compression setting using the Compression slider bar. The Size side of the bar optimizes the file size of the image file 
(typically at the expense of image quality). Conversely, the Quality side of the bar optimizes the file for image quality, which 
usually results in a larger file size.

7. Click OK to create the preview image.
Once the preview image has been generated, it appears in the Resource Manager (Images tab). If you created a Main Preview 
image, it will be named [preview].JPG or [preview] .PNG. Otherwise, it will be named according to the name specified above. Select 
the image and click the Export button to export the image to another directory, if desired.

FIG. 14  Create Template Preview Image dialog
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Template Requirements
AMX Element Naming Conventions
Use the following naming convention to allow for portability between templates. Errors could occur if the elements do not match 
from template to template.

Alternate Screen Names for Template Elements
Template elements can now be given an alternate name that will be used as the default on-screen text when added to a project in 
G4 PanelBuilder. The text will be taken from the name that follows the '[info]' tag on an Info button's name. For instance, to use a 
shorter name for the Audio Conference element, name your Info button '[info]Audio Conf'. 

AMX Element Naming Conventions
Device Name Example

Audio Conference [device#Audio Conference]Audio Conference

Cable Box [device#Cable Box]Cable Box

Camera [device#Camera]Camera

Cassette Deck [device#Cassette Deck]Cassette Deck

CD [device#CD]CD

G4 Computer Control [device#Computer Control]G4CC

Document Camera [device#Document Camera]Document Camera

Door [device#Door]Door

DSS [device#DSS]DSS

DVD [device#DVD]DVD

DVR [device#DVR]DVR

HVAC - Dual [device#HVAC - Dual]HVAC - Dual

HVAC - Single [device#HVAC - Single]HVAC - Single

Lift [device#Lift]Lift

Light Zone [device#Light Zone]Light Zone

Monitor [device#Monitor]Monitor

Pool [device#Pool]Pool

Screen [device#Screen]Screen

Security [device#Security]Security

Shade [device#Shade]Shade

Slide Projector [device#Slide Projector]Slide Projector

Spa [device#Spa]Spa

Switcher size [device#Switcher size]Switcher size

Radio [device#Radio]Radio

TV [device#TV]TV

VCR [device#VCR]VCR

Video Projector [device#Video Projector]Video Projector

Volume - Dual [device#Volume -Dual]Volume - Dual

Volume - Single [device#Volume - Single]Volume - Single

Feature Name Example

US Weather Maps [feature#US Weather Maps]US Weather Maps

Mode Names Example Description

Mode X [mode#Mode 3]Mode 3 [mode#Mode x]   x = the number of mode options

Navigation Names Example Description

Nav X [nav#Nav 3]Nav 3 [nav#Nav 3]Nav 3   x = the number of navigation options
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Program Reference
Program Reference
The G4 PanelBuilder Work Area
The G4 PanelBuilder Application Interface is the main view you work with when creating a new panel file (*.PB4), as you can see it 
is visually driven.      

FIG. 15  G4 PanelBuilder Application Interface

G4 PanelBuilder Work Area
Menu Bar The menu bar is the location of all functions for G4 PanelBuilder.

Toolbar The toolbar contains icons for the commonly used functions.

Toolbox All elements available within a selected template reside in the toolbox. The toolbox is only available when a template is 
open.

Status Bar In addition to giving you the current status of G4 PanelBuilder, i.e., Ready. The status bar also provides a brief 
description of toolbar and menu items via mouse over.

Instance Counter The instance counter tracks and displays the number of times an element is used within the current project.

Diagram Area The Diagram area is the graphical representation of the flow your panel file will follow. After pulling the elements from 
the Toolbox you can connect and develop the elements.

Tasks Pane The tasks pane is a collection of links to commonly used functions. In addition to opening projects (both new and 
existing), tasks pane tracks recently opened projects and templates. To access anything listed in the tasks pane, click 
on any of the items listed.

Quick Links Located within the Tasks Pane is a small sub-section quick links. These links allow you quick access to adding and 
managing templates within G4 PanelBuilder.

Toolbox Instance Counter

Diagram Area Quick Links

Tasks Pane
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Program Reference
Diagram Area
The Diagram area is the graphical representation of the flow your panel file will follow. After pulling the elements from the Toolbox 
you can connect and develop the elements. You can either click and drag or nudge the elements within the Diagram area. Select an 
element and use your arrow keys to nudge.

Toolbar
The toolbar contains icons for the commonly used functions:      

FIG. 16  Diagram Area

Diagram Area
Entering Node This node receives the connection line from another element.

Exiting Node This node connects out to another element.

Element The building block of the panel files, i.e., Modes, Navigation, Devices, and etc.

Connection Line The graphical representation of the connection between two elements. The color of the connection line is dictated by 
the element it is exiting.

FIG. 17  Toolbar

Toolbar
New Launches the New Project dialog.

New From File Launches the New From File dialog.

Open Launches the Open Project dialog.

Save Saves the current project. If the project has not been previously saved it will launch the Save As dialog.

Generate TPDesign4 Project Launches the Generate TPDesign4 Project dialog.

Delete Deletes the element currently selected in the Diagram area.

Undo Undoes action taken in diagram area. Undo does not apply to text changes within elements.

Redo Reverses the undo action taken within the diagram area.

Color Schemes Launches the Color Schemes dialog.

Zoom Out Decreases the magnification of the diagram area. Increments are 150%, 125%, 100%, 75% and 50% of 
work area.

Zoom In Increases the magnification of the diagram area. Increments are 150%, 125%, 100%, 75% and 50% of 
work area.

Copy Snapshot To Clipboard Copies only the diagram area to your computer's clipboard.

Template Manager Launches the Template Manager dialog.

Entering
Node

Exiting Node Element

Connection Line

New

Template Manager
Copy Snapshot To Clipboard
Zoom In/Out
Color Schemes
Undo/Redo

New From File
Open
Save
Generate TPDesign4 Project
Delete
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Program Reference
Tasks Pane
The tasks pane is a collection of links to commonly used functions. In addition to opening projects (both new and existing), tasks 
pane tracks recently opened projects and templates. To access anything listed in the tasks pane, click on any of the items listed.

Quick Links
Located within the Tasks Pane is a small sub-section quick of links. These links allow you quick access to adding and managing 
templates within G4 PanelBuilder.

FIG. 18  Tasks Pane

Tasks Pane
Recently Opened Projects A list of file names for recently opened existing projects.

Open Project Launches the Open Project dialog.

Recently Opened Templates A list of file names for recently opened templates.

New File Launches the New Project dialog.

New from File Launches the New From File dialog.

FIG. 19  Quick Links

Quick Links
Install Templates From 
AMX.com

If a internet connection is available, G4 PanelBuilder connects to AMX's collection of online templates. The 
templates are found in AMX.com Template Library dialog.

Install Templates From File Launches the Install Templates From File dialog.

Template Manager Launches the Template Manager dialog.

Recently
Opened
Projects

Open Project

Recently Opened Templates
New File

New from File

AMX.com Template Library
Install Template from File
Open Template Manager
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Program Reference
Toolbox
All elements available within a selected template reside in the toolbox. The toolbox is only available when a template is open.

As you can see, the toolbox is divided into elements with specific pages contained therein. Click on the element you would like to 
add, i.e., Navigation, Device, etc. All available elements will be shown. When available, a thumbnail representation of the page will 
appear within the toolbox; otherwise a general image will be shown for the thumbnail. Mouse-over the element to get a description. 
Once you have found the element you would like to use, you can right-click on the thumbnail to access the toolbox context menu or 
drag-and-drop the element into the diagram area. 
Only elements contained within the template are represented within the toolbox. If the template does not contain a particular 
element, you will not see it in the toolbox.

Color Schemes
Templates can contain multiple color palettes, allowing you to switch from one color scheme to another within one template. The 
current scheme is reflected in the element preview but the elements in the toolbox will remain the main color scheme.
Used either with Chameleon buttons or standalone, you can use a single template that can deliver different predefined color 
schemes.

Status Bar
Located at the bottom of the G4 PanelBuilder Application Interface is the status bar. In addition to giving you the current status of 
G4 PanelBuilder, i.e., Ready. The status bar also provides a brief description of toolbar and menu items via mouse over.

Viewing Panes
The G4 PanelBuilder Application Interface is composed of panes, sections containing tools for creating a panel project. To reveal or 
hide different panes:

Select View > (any of the panes listed; a check mark indicates the pane is in view) Toolbar, Tasks Pane, Toolbox or Status 
Bar.

Changing Visual Style
To change the appearance of G4 PanelBuilder, select View > Visual Style and select from the following:

Default
Office XP®
Office 2003®

FIG. 20  Toolbox

Element
(i.e., Mode Element
with 3 items)

Element Sections
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