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IMPORTANT SAFETY INSTRUCTIONS    

COPYRIGHT NOTICE
AMX© 2016, all rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any 
means, electronic, mechanical, photocopying, recording, or otherwise, without the prior written permission of AMX. Copyright protection claimed 
extends to AMX hardware and software and includes all forms and matters copyrightable material and information now allowed by statutory or judicial 
law or herein after granted, including without limitation, material generated from the software programs which are displayed on the screen such as 
icons, screen display looks, etc. Reproduction or disassembly of embodied computer programs or algorithms is expressly prohibited.

LIABILITY NOTICE
No patent liability is assumed with respect to the use of information contained herein. While every precaution has been taken in the preparation of this 
publication, AMX assumes no responsibility for error or omissions. No liability is assumed for damages resulting from the use of the information 
contained herein. Further, this publication and features described herein are subject to change without notice.

AMX WARRANTY AND RETURN POLICY
The AMX Warranty and Return Policy and related documents can be viewed/downloaded at www.amx.com.

1. READ these instructions.
2. KEEP these instructions.
3. HEED all warnings.
4. FOLLOW all instructions.
5. DO NOT use this apparatus near water.
6. CLEAN ONLY with dry cloth.
7. DO NOT block any ventilation openings. Install in accordance with the manufacturer's instructions.
8. DO NOT install near any heat sources such as radiators, heat registers, stoves, or other apparatus (including amplifiers) that 

produce heat.
9. DO NOT defeat the safety purpose of the polarized or grounding type plug. A polarized plug has two blades with one wider than the 

other. A grounding type plug has two blades and a third grounding prong. The wider blade or the third prong are provided for your 
safety. If the provided plug does not fit into your outlet, consult an electrician for replacement of the obsolete outlet.

10. PROTECT the power cord from being walked on or pinched, particularly at plugs, convenience receptacles, and the point where 
they exit from the apparatus.

11. ONLY USE attachments/accessories specified by the manufacturer.

12. USE ONLY with a cart, stand, tripod, bracket, or table specified by the manufacturer, or sold with the apparatus. When a cart is 
used, use caution when moving the cart/apparatus combination to avoid injury from tip-over.

13. UNPLUG this apparatus during lightning storms or when unused for long periods of time.
14. REFER all servicing to qualified service personnel. Servicing is required when the apparatus has been damaged in any way, such as 

power-supply cord or plug is damaged, liquid has been spilled or objects have fallen into the apparatus, the apparatus has been 
exposed to rain or moisture, does not operate normally, or has been dropped.

15. DO NOT expose this apparatus to dripping or splashing and ensure that no objects filled with liquids, such as vases, are placed on 
the apparatus.

16. To completely disconnect this apparatus from the AC Mains, disconnect the power supply cord plug from the AC receptacle.
17. Where the mains plug or an appliance coupler is used as the disconnect device, the disconnect device shall remain readily operable. 
18. DO NOT overload wall outlets or extension cords beyond their rated capacity as this can cause electric shock or fire. 

The exclamation point, within an equilateral triangle, is intended to alert the user to the presence of important operating and maintenance 
(servicing) instructions in the literature accompanying the product.

The lightning flash with arrowhead symbol within an equilateral triangle is intended to alert the user to the presence of uninsulated "dangerous 
voltage" within the product's enclosure that may be of sufficient magnitude to constitute a risk of electrical shock to persons.

ESD Warning: The icon to the left indicates text regarding potential danger associated with the discharge of static electricity from an outside 
source (such as human hands) into an integrated circuit, often resulting in damage to the circuit.

WARNING: To reduce the risk of fire or electrical shock, do not expose this apparatus to rain or moisture.
WARNING: No naked flame sources - such as lighted candles - should be placed on the product.
WARNING: Equipment shall be connected to a MAINS socket outlet with a protective earthing connection.
WARNING: To reduce the risk of electric shock, grounding of the center pin of this plug must be maintained. 
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Mio Modero Keypad Projects
Mio Modero Keypad Projects
Overview
Use KeypadBuilder to create files (*.KPB) that allow you to get the most out of Mio Modero keypads and the devices they control. 
FIG. 1 shows the KeypadBuilder interface as it appears with a Keypad project active.

Creating A New Keypad Project
To create a new KeypadBuilder file, go to File > New Project > Mio Modero Keypad. The device type that opens depends upon what 
is set in the Project Conf iguration dialog.

Keypad Project Navigation Pane
The KeypadBuilder Project Navigation Pane is open when a Keypad project file is active. This is the main area for accessing the 
configuration modules in creating a keypad device file. 

Navigation Menu
Only available when a .KPB file is open, this menu is the crux of adding functionality to the keypad device. While viewing a graphic 
representation of your selected keypad device, you can do the following: 

FIG. 1  Project Navigation Pane - Keypad projects

Navigation Menu
Project Configuration... Opens the Project Configuration dialog. This is topical Project Information, Device Selection and Device 

Setup Information.

Button Configuration... Opens the Button Configuration dialog. Click to select buttons, and then assign button properties, 
Configuration Options and Display Options. The Channel Map can be accessed from this dialog.

Engraving... Opens the Engraving dialog. Click to select buttons and create either text or icon engraving instructions. 
The engraving dialog develops a .DXF file that must be provided to AMX to create your custom engraved 
buttons. Keypad display options and export options are also available in this dialog.

LCD Configuration... For keypad devices equipped with an LCD, the LCD Configuration dialog sets up Display Options, the 
presence of Dynamic Text, and Line Options.

Fixed Menu System... For keypad devices equipped with an LCD, the Fixed Menu Configuration 
dialog allows for the creation of Menu and one tier of sub-menus. The Main Menu can contain a maximum 
of 10 items. You can edit and add menu and sub-menu items.

Complex-Script Glyphs Launches the Add/Edit Keypad Glyphs dialog. Create glyph renderings of text and characters for menu/
sub-menu items.

Button Channel 

Engraving 

Menu Action

Button #

Button Name

This Button’s Channel is Locked

Assignment

Information

Navigation Menu
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Mio Modero Keypad Projects
Project Conf iguration
Click the Project Conf iguration button in the Navigation Menu to access the Project Configuration dialog (FIG. 2). The options in 
this dialog allow you to specify Project Information, information to make the file unique and Device Selection, the type of keypad 
device to be programmed.  

Setting the Keypad Project Conf iguration
With a new KeypadBuilder project file open, click Project Properties in the Navigation Pane.
1. Enter information in to the Project Information section as necessary. 

2. Under the Device Selection section, establish the device that uses the keypad project file. The Device Selection section 
contains a drop-down list of all keypad devices capable of being programmed by KeypadBuilder. Select the keypad device you 
wish to design for, and the device appears in the window below. If the keypad device differs from the default file that opened, 
select the keypad device from the drop down menu.

NOTE: Changing the device selection clears any previous unsaved work.

3. Select the color of your keypad device from the Color Selection drop-down list. The type of device selected dictates the colors 
available to choose from.

4. Click OK to confirm the changes or Cancel to exit and lose all changes.

FIG. 2  Project Configuration dialog (Keypad projects)

• Project Name The name of the keypad device project. This field is user defined and optional.

• Designer The designer name creating the KeypadBuilder file. This field is user defined and 
optional.

• Dealer Dealer name providing the keypad file. This field is user defined and optional.

• Purchase Order This name will populate the file name of the .DXF in the engraving section.

• Sales Order This name will populate the file name of the .DXF in the engraving section.

• Comments Any additional comments or clarifications for the file. This field is user defined and 
optional.
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Mio Modero Keypad Projects
Button Conf iguration
Click the Button Conf iguration button in the Navigation Menu to access the Button Conf iguration dialog (FIG. 3). The options in 
this dialog allow you to set the keypad button properties. 

Setting the Keypad Button Conf iguration
With a new KeypadBuilder project file open, click Button Conf iguration in the Navigation Pane.
1. By clicking on a button in the Keypad Device area, select a button you wish to configure.

NOTE: The Number f ield cannot be edited, this number is dictated by the selected device’s f irmware and is intended to assist in 
navigating the keypad device f ile.

2. Type the name of the button in the Name field. The button name is useful in tracking channel assignments. This name should 
not be confused with what is sent to engraving, this name is strictly within KeypadBuilder.

3. Enter the Channel Code for the button assignment in the field provided. KeypadBuilder inserts the next available code if you 
click Auto Assign.
Placing a check next to Lock Channel for Menus and Sub Menus makes the assigned channel code unavailable for any other 
button assignments.

4. Set the Menu Action value by selecting one from the drop down list. A menu action interacts with the fixed menu items you can 
set later.

NOTE: If you have a menu system, it is a good idea to be aware of possible navigation issues. When you have more menu line 
items than what is supported by your device display, an Up and Down menu action allows you to access them. If you have sub-
menus, you might need a Home menu action to return you to the main menu. 

5. Click Update to set the values for your selected button. Clicking on another button before clicking Update will drop all settings 
for your selected button. Repeat this for all of your buttons including the LCD button.

6. Set the Conf iguration Options.
To create blank buttons:

NOTE: Blank buttons contain no channel code assignment. It is important to assign blank buttons before the engraving process 
as they are included in the order.

a.  Click Blank Buttons. 
b.  Now click on any button in the Keypad Device area to make it a blank. Making a button that previously held information 

blank drops all configuration information. 
c.  Click Blank Buttons again to exit mode.

FIG. 3  Button Configuration dialog

• Up moves the navigation up through the menu system.

• Down moves the navigation down through the menu system.

• Select activates the navigation item in the menu system.

• Home returns the navigation back to the main menu system.
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Mio Modero Keypad Projects
To combine buttons:

NOTE: Combine Buttons takes the button information from the selected button and assigns it to the button directly to the right 
of it, thus treating two buttons as one. The button on the right retains no information. Combining buttons adds double buttons to 
your custom engraving order.

a.  Click Combine Buttons. 
b.  Click on any button and it combines with the button to its immediate right. The button configuration information of the 

right button is dropped. 
c.  Click Combine Buttons again to exit mode.

NOTE: It is important to set your blank and combined buttons before creating the engraving f ile; they are included in the custom 
order you place with AMX.

7. Set the Display Options: 
These display options are for use within the Button Conf iguration window. Placing a check in any box activates its display.   

8. Click Display Channel Map to view a listing of channel codes that have already been assigned within your active KeypadBuilder 
file. Click on any channel code number to see its current allocation.  

9. Click OK to keep changes and exit the Button Conf iguration module; otherwise, click Cancel and lose the changes.

Engraving
Click the Engraving button in the Navigation Menu to access the Engraving dialog (FIG. 4). The options in this dialog allow you to 
create the .DXF file that AMX needs to create your device’s custom keypad. 

Creating the Keypad Engraving File
With a new KeypadBuilder project file open, click Engraving in the Navigation Pane.
1. Click on a button in the Keypad Device area to select the button you wish to engrave.

NOTE: The Number f ield cannot be edited, this number is dictated by the selected device’s f irmware and is intended to assist in 
navigating the keypad device f ile.

The button Name is for use within KeypadBuilder only and is intended to assist in developing unique names. The name is 
established in the Button Conf iguration module.

If a Menu Action is assigned in the Button Configuration module, the action is displayed in this field; otherwise, it is blank.

• Show Button Numbers Displays all button numbers. 

• Show Button Names Displays the button name if set. 

• Show Channel Codes Displays set channel codes for the keypad device.

• Show Menu Actions Displays the menu action value for the button.

Channel Code The assigned channel code number.

Assigned To If used, the item and description of the button using the channel code.

FIG. 4  Engraving dialog
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Mio Modero Keypad Projects
2. In the Font Selection drop down menu, select between placing a symbol, AMX Icon 2, or text, Arial, Arial Narrow, or Arial 
Unicode MS. 
If you selected a text font, type the text you want displayed in the Text field.
If you select Icon in the font selection, you could use letters to get the associated icon but the Symbols drop down list is a 

simpler approach.
The Symbols drop down list is available when you select AMX Icon in the font selection list. The list is a collection of icons 
created by AMX. When you select an icon the corresponding letter is placed in the Text field. If you select more than one 
icon, it will not replace the previous icon, but rather add it and display all selected icons.

Buttons can have 1-10 characters.

NOTE: The KeypadBuilder Engraving module supports the engraving of its listed supported OS languages. You must have the 
language loaded on you OS and then use Unicode to render the text on the button.

3. In the Text f ield, enter either the text or icon set to display on the selected button. 
4. Set the size of either the symbol or text on the button. Click on the Scale drop down menu and select a ratio ranging from 0.5 

to 1.5. The larger the ratio, the more area of the button the text or icon fills.

NOTE: If your font selection or scale is greater than the area of the button that can be engraved, you will receive a warning in 
this f ield and KeypadBuilder will not create the .DXF f ile.

5. Set the Display Options as desired. The display options are for use within the Engraving window. Placing a check in any box 
activates its display. 

6. Click Update.
7. Click Engraving File Preview to open the Engraving Template Preview dialog. This is a graphic representation of the jig used in 

engraving.
8. Click Export DXF File... to open the Export DXF File dialog to create the .DXF file necessary for engraving. 
9. Within the Export DXF File dialog, set the destination directory for the file. Either type or click Browse to determine where to 

save the file.
10. Type a Description of the file in the field provided. The description aids in making a unique file name for the engraver. The File 

to Export f ield displays what the final file name is. For example:
C:\(Media Room)-S12-D0-SB0-DB0-CElite Taupe.DXF 

NOTE: KeypadBuilder will not create the DXF f ile if the information exceeds the bounding box.

11. Click Done to exit the dialog.
12. Click OK to save changes to the Engraving module and return to the Navigation Pane.

Anatomy of A DXF File 

• Show Button Numbers Displays all button numbers. 

• Show Button Names Displays the button name if set. 

• Show Menu Actions Displays the menu action value for the button.

• Show Channel Codes Displays set channel codes for the keypad device.

• Show Bounding Box Displays the surface area of the button you can engrave.

C:\ Destination directory for the .DXF file.

(Media Room) Populated by the Description field.

S12 12 single buttons.

D0 0 double buttons.

SB0 0 single blank buttons.

DB0 0 double blank buttons.

CElite An Elite keypad device.

Taupe The keypad color is taupe.
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LCD Conf iguration
Click the LCD Conf iguration button in the Navigation Menu to access the Conf igure LCD Keypad Display dialog (FIG. 5). The options 
in this dialog control what menu items are shown and how they are displayed in devices equipped with an LCD. 

Setting The Keypad LCD Conf iguration
With a new KeypadBuilder project file open, click LCD Conf iguration in the Navigation Pane. After you have set the options you 
need, click OK.
1. Under LCD Display Resolutions, select the arrangement for your LCD device. The Display Resolution is the maximum number of 

lines and type of font family that can be displayed at one time on your selected device. Click on the font family and the number 
of lines to display on the device menu.
Only one font family can be used on a device. 
If you change the font, you need to include the font information when sending the configuration file. See the Send 

Conf iguration Files dialog  on page 2.
2. If you want to designate any lines as dynamic you must make a selection under Dynamic Text. Click on the number of lines you 

want set as dynamic.
Dynamic Text is information sent from the master and displayed on the device, i.e., time or temperature.
Selecting No Lines for line allocation will cause the device to have lines of displayed menu (text) and no dynamic 

information. 
All lines can be allocated for either menu or dynamic. 
Regardless of the display arrangement, the items must be contiguous; the menu items and dynamic items must be grouped 

together. Display lines cannot alternate between menu and dynamic items. 
Based on the number of lines you select as being dynamic, the rest are allocated to menu items. It is possible to have either 

all or no dynamic lines.
The Align feature allows you to decide which, menu or dynamic, items are displayed first. Top places the dynamic items at 

the top of the list and Bottom puts them at the bottom.
3. Based on your selection in the Dynamic Text section, the Line Options section could be populated with all menu items, all 

dynamic items or a mix of the two.
a.  Click on the line number you want to edit.
b.  You can change the justification of menu items. Click the radio button to move the item either Left, Center, or Right.
In addition to justification you can set other values for dynamic items:
Remove the check next to Visible to remove the dynamic item from the display.
Place a check next to Level to make the dynamic display line a level indicator.

If you set the dynamic line as a level, click the Level Style you want to display.
4. Use the Sleep Screen Display Options to set the LCD to display an image when not in use or "sleep" mode. 

Basic graphic formats are supported: .bmp, .png, and .jpg. 
The resolution can be no bigger than 96 x 96, and items smaller than that resolution are centered. 

FIG. 5  Configure LCD Keypad Display dialog
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Images must be monochrome.
a.  Click the Import Icon... button to launch the Import Splash Screen Icon File dialog.
b.  Locate your file and click Open. Below the image reads, "Splash Screen Active."

5. Click OK to keep changes and exit the LCD Conf iguration module. Otherwise, click Cancel and lose the changes.

Fixed-Menu Conf iguration
After the LCD display has been configured, you can set the menu items for navigating the device. Remember to include menu 
navigation buttons in the Button Conf iguration  on page 8 if your number of menu items exceeds the number of lines displayed in 
the LCD. 
Click the Fixed-Menu Conf iguration button in the Navigation Menu to access the Fixed-Menu Configuration dialog (FIG. 6). The 
options in this dialog allow you to create the navigation hierarchy for your keypad device.        

FIG. 6  Fixed-Menu Configuration dialog

Fixed Menu Conf iguration
Main Menu The main menu is the top level navigation for display, with a maximum of 10 main menu items. Neither the first nor the 

last menu item can be a separator item.
• Edit Menu Properties - Either double click on Edit Menu Properties or select it and click Edit, doing so opens the Edit 

Keypad Menu window. Edit menu properties and channel assignments for the keypad menu. These functions are also 
addressed in the Button Conf iguration  on page 8. You can set the menu properties to either Text, Unicode, or 
Complex Script.

• Add Menu Item - Either double click on Add Menu Item or select it and click Add Item, doing so opens the Add/Edit 
Menu Item window. Add menu items through this window. The menu properties determines the type of menu item 
you can add.

Sub Menu The sub menu is the next level of navigation under the main menu. There is a maximum of 10 sub menu items. Neither 
the first nor the last sub menu item can be a separator item.
• Edit Sub-Menu Properties - Either double click on Edit Sub-Menu Properties or select it and click Edit, doing so opens 

the Edit Keypad Menu window. Edit sub menu properties and channel assignments for the keypad menu. You can set 
the sub menu properties to either Text, Unicode, or Complex Script.

• Add Sub-Menu Item - Either double click on Add Sub-Menu Item or select it and click Add Item, doing so opens the 
Add/Edit Menu Item window. Add sub menu items through this window. The sub menu properties determines the type 
of menu item you can add.

Menu Type The selected menu or sub menu is either Text (the basic single-byte ANSI character set), Unicode (multi-byte character 
representation), or Complex Script (a graphic rendering of any type face character entered). This is the menu text 
displayed within the LCD.

Channel The assigned channel of either the menu or sub menu selected.

Up Moves the selected menu item up in increments of one line in the order of display.

Down Moves the selected menu item down in increments of one line in the order of display.

Add Item Opens the Add/Edit Menu Item window. Add menu and sub menu items through this window.

Delete/Undelete Select a menu item and click Delete; removes a menu or sub menu item from display. Once deleted it is indicated with 
(DELETED) next to the affected item. To undelete, select the menu item and click Undelete. Deleted items are not sent 
to the device and are permanently removed upon saving the file.

Edit Opens the Edit Keypad Menu window. Edit menu properties and channel assignments for the keypad menu and sub 
menus.
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Setting The Fixed-Menu Conf iguration
1. Click Fixed-Menu Conf iguration in the Navigation Pane to access the Fixed-Menu Conf iguration dialog. 

By default, KeypadBuilder is set to create the display items in text. If you plan to use Unicode, you must set it before adding any 
menu items, and the same applies when adding sub menus.

2. In the Fixed Menu Conf iguration dialog, double-click Edit Menu Properties in the Main Menu field. This invokes the Edit Keypad 
Menu dialog (FIG. 7). Edit menu properties and channel assignments for the keypad menu. These functions are also addressed 
in the Button Conf iguration section on page 8. You can set the menu properties to either Text, Unicode, or Complex Script.  

The main menu is the top level navigation for display, with a maximum of 10 main menu items. Neither the first nor the last 
menu item can be a separator item.

NOTE: The Edit Keypad Menu dialog is the same arrangement for both Menu and Sub Menu items. 

3. In the Edit Keypad Menu dialog (Menu Type section), click the radio button for either Text, Unicode, or Complex Script. This is 
the method by which KeypadBuilder displays your menu items within the LCD. This setting applies to all menu items

NOTE: A menu type can only be switched if there are no menu items present, and this is true for sub menus too.

To add a Text Menu Item, refer to the Adding a Menu Item (Text) section on page 14.
To add a Unicode Menu Item, refer to the Adding a Menu Item (Unicode) section on page 15.
To add a Complex Script Menu Item, refer to the Adding a Menu Item (Complex Script) section on page 16.
Under Menu Channel Map, notice the Button field is a list of the button numbers with the names you assigned in the Button 
Conf iguration module. The box directly to the right of Button displays the currently selected button number. You can select 
buttons by either clicking on them in the Button list or selecting the button on the graphic keypad device.
If not already set, you can assign channels at this time. You can either:
Type the channel number in the field next to Channel.
Click the UP and DOWN arrows next to the Channel field to navigate through the numbers.
Click Auto Assign and KeypadBuilder will allocate the next available channel.
If you are uncertain as to what channels have been assigned where, click Channel Map to see.

4. Click Update after you make changes to each button.
5. Click OK after you are done.

Fixed Menu Conf iguration (Cont.)
Channel Map Click Channel Map to view a listing of channel codes that have already been assigned within your active KeypadBuilder 

file. Click on any channel code number to see its current allocation.

Close Closes the Fixed-Menu Configuration module. There is no cancel and the changes are kept.

FIG. 7  Edit Keypad Menu dialog
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Adding a Menu Item (Text)
With Menu Type set to Text in the Edit Keypad Menu dialog (FIG. 7), double-click on either a Main Menu item or a Sub-Menu item in 
the Fixed-Menu Configuration dialog to access the Add/Edit Menu Item dialog (FIG. 8). 

The following options apply to keypad menu items that have been designated as the menu type, Text.    

To add a menu item, with Text selected as the Menu Type (in the Edit Keypad Menu dialog - see FIG. 7).
1. In the Fixed Menu Edit dialog, double-click Add Menu Item in the Main Menu field. This invokes the the Add/Edit Menu Item 

dialog (FIG. 8).
2. Type the name of the menu item as it is to display in the LCD in the Item Caption field.
3. Place a check in the boxes of all items that apply.
4. If this menu item requires a channel assignment either type it or click Auto Assign to have KeypadBuilder allocate the next 

available channel. If you are uncertain as to what channels have been assigned where, click Channel Map to see.
5. Click OK when you are done.

FIG. 8  Add/Edit Menu Item dialog (Text)

• Item Caption The name displayed for either the menu or sub menu item.

• Has Sub-Menu (only active 
in main menu items)

Assigns a sub menu to the selected menu item.

• Separator A blank line between items. This line counts as one of the device’s allocated display lines.

• Select Active (only active in 
main menu items)

Navigating and releasing on a menu item is the only necessary action to make it active; there 
is no need for a select button.

• Return to Main After menu or sub menu item is selected, the display returns to the device’s main menu.

• Channel Code The assigned channel of either the menu or sub menu selected. Either type a channel code 
in, click the up and down arrows or click Auto Assign to enter a channel code.

• Auto Assign Takes the next unassigned channel code.

• Channel Map Click Channel Map to view a listing of channel codes that have already been assigned within 
your active KeypadBuilder file.
Click on any channel code number to see its current allocation.

• OK Confirms changes and closes the window.

• Cancel Clears changes and closes the window.
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Adding a Menu Item (Unicode)
With Menu Type set to Unicode in the Edit Keypad Menu dialog (FIG. 9), double-click on either a Main Menu item or a Sub-Menu item 
in the Fixed-Menu Configuration dialog to access the Add/Edit Menu Item dialog (FIG. 9). 

The following options apply to keypad menu items that have been designated as the menu type, Unicode.  

To add a menu item, with Unicode selected as the Menu Type (in the Edit Keypad Menu dialog - see FIG. 7).
1. In the Fixed Menu Edit dialog, double-click Add Menu Item in the Main Menu field. This invokes the Add/Edit Menu Item dialog 

(FIG. 9).
2. Enter the Unicode text in the Menu Caption f ield. The corresponding Unicode Send Command Value is displayed beneath the 

text box.
3. Place a check in the boxes of all items that apply.
4. If this menu item requires a channel assignment, either type it or click Auto Assign to have KeypadBuilder allocate the next 

available channel. If you are uncertain as to what channels have been assigned where, click Channel Map to see.
5. Click OK when you are done.

FIG. 9  Add/Edit Menu Item dialog (Unicode)

• Menu Caption The name displayed for either the menu or sub-menu.

• Unicode Character Codes The Unicode translation for the text assigned to the menu or sub menu.

• Has Sub-Menu (only active 
in main menu items)

Assigns a sub menu to the selected menu item.

• Separator A blank line between items. This line counts as one of the device’s allocated display lines.

• Select Active (only active in 
main menu items)

Navigating and releasing on a menu item is the only necessary action to make it active; there 
is no need for a select button.

• Return to Main After menu or sub menu item is selected, the display returns to the device’s main menu.

• Channel Code The assigned channel of either the menu or sub menu selected. Either type a channel code 
in, click the up and down arrows or click Auto Assign to enter a channel code.

• Auto Assign Takes the next unassigned channel code.

• Channel Map Click Channel Map to view a listing of channel codes that have already been assigned within 
your active KeypadBuilder file.
Click on any channel code number to see its current allocation.

• OK Confirms changes and closes the window.

• Cancel Clears changes and closes the window.
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Adding a Menu Item (Complex Script)
With Menu Type set to Complex Script in the Edit Keypad Menu dialog (FIG. 9), double-click on either a Main Menu item or a Sub-
Menu item in the Fixed-Menu Configuration dialog to access the Add/Edit Menu Item dialog (FIG. 10).   

The following options apply to keypad menu items that have been designated as the menu type, Complex Script.  

To add a menu item, with Complex Script selected as the Menu Type (in the Edit Keypad Menu dialog - see FIG. 7).
1. In the Fixed Menu Edit dialog, double-click Add Menu Item in the Main Menu field. This invokes the Add/Edit Menu Item dialog 

(FIG. 10).
2. Select the desired Glyph from the Glyph Select list.
3. Place a check in the boxes of all items that apply.
4. If this menu item requires a channel assignment, either type it or click Auto Assign to have KeypadBuilder allocate the next 

available channel. If you are uncertain as to what channels have been assigned where, click Channel Map to see.
5. Click OK when you are done.

FIG. 10  Add/Edit Menu Item dialog (Complex Script)

• Glyph Name The name associated with the glyph. This is for tracking purposes only and is not displayed within 
the LCD.

• Glyph A sample of the graphic as it appears within the LCD.

• Glyph ID Number An ID number KeypadBuilder associates with all glyphs within the project to ensure unique values.

• Item Name The name of the menu or sub menu item. This value only appears in the Fixed-Menu Configuration 
window.

• Has Sub-Menu (only 
active in main menu 
items)

Assigns a sub menu to the selected menu item.

• Separator A blank line between items. This line counts as one of the device’s allocated display lines.

• Select Active (only 
active in main menu 
items)

Navigating and releasing on a menu item is the only necessary action to make it active; there is no 
need for a select button.

• Return to Main After menu or sub menu item is selected, the display returns to the device’s main menu.

• Channel Code The assigned channel of either the menu or sub menu selected. Either type a channel code in, click 
the up and down arrows or click Auto Assign to enter a channel code.

• Auto Assign Takes the next unassigned channel code.

• Channel Map Click Channel Map to view a listing of channel codes that have already been assigned within your 
active KeypadBuilder file.
Click on any channel code number to see its current allocation.

• Glyph Select List of available glyphs and their current state. Click on a glyph to select.

• OK Confirms changes and closes the window.

• Cancel Clears changes and closes the window.
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Editing Sub-Menu Properties
By default, KeypadBuilder is set to create the display items in text. If you plan to use Unicode, you must set it before adding any 
sub-menu items. You can only edit and add sub-menu properties when they have been assigned to menu items.
1. In the Fixed Menu Edit dialog, select a main menu item that has a sub-menu.
2. Double-click Edit Sub-Menu Properties in the Sub Menu field. This invokes the Edit Keypad Menu dialog (FIG. 7).
3. Click the Text, Unicode or Complex Scripts radio button under the Menu Type section. This setting applies to all sub-menu 

items.
Under Menu Channel Map, notice the Button field is a list of the button numbers with the names you assigned in the Button 
Conf iguration module. The box directly to the right of Button displays the currently selected button number. You can select 
buttons by either clicking on them in the Button list or selecting the button on the graphic keypad device.
If the buttons are not locked to a particular channel, you can assign channels at this time. These channel assignments only 
apply when you have selected the menu item. You can either:
Type the channel number in the field next to Channel.
Click the UP and DOWN arrows next to the Channel field to navigate through the numbers.
Click Auto Assign and KeypadBuilder will allocate the next available channel.
If you are uncertain as to what channels have been assigned where, click Channel Map to see.

4. Click Update after you make changes to each button.
5. Click OK after you are done.

Adding a Sub-Menu Item (Text)
The process of adding a sub-menu item is essentially the same as adding a main menu item, except that you will double-click on 
Add Sub-Menu Item in the Sub Menu f ield of the Fixed Menu Conf iguration dialog (FIG. 6). 

Refer to the Adding a Menu Item (Text) section on page 14 for details.

Adding a Sub-Menu Item (Unicode)
The process of adding a sub-menu item is essentially the same as adding a main menu item, except that you will double-click on 
Add Sub-Menu Item in the Sub Menu f ield of the Fixed Menu Conf iguration dialog (FIG. 6). 

Refer to the Adding a Menu Item (Unicode) section on page 15 for details.

Adding a Sub-Menu Item (Complex Script)
The process of adding a sub-menu item is essentially the same as adding a main menu item, except that you will double-click on 
Add Sub-Menu Item in the Sub Menu f ield of the Fixed Menu Conf iguration dialog (FIG. 6). 

Refer to the Adding a Sub-Menu Item (Complex Script) section on page 17 for details.

Arranging Menu and Sub Menu items
In both the Main and Sub Menu fields, the items are appear top to bottom as they do in the LCD.
To move an item:
1. Select the menu item from the list.
2. Click either Up or Down to move the item within the list.
To remove an item:
1. Select the menu item from the list.
2. Click Delete.
To undo the delete:

Select the deleted item from the list and click Delete again. 
If you click Close, save and exit; you will not be able to undelete.
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Complex-Script Glyphs
The Complex-Script Glyph configuration module allows you to create menu/sub-menu items using characters and fonts that could 
not otherwise be displayed. Selecting the Complex-script glyph launches the Add/Edit Keypad Glyphs dialog.

What is a Complex-Script Glyph?
A complex-script glyph is a rendering of a group of characters without an application dependency for font or language support. 
KeypadBuilder creates a graphic image from predefined text and then load the graphic to your device. This is useful for rendering 
conditional script languages, displaying proprietary fonts on devices and utilizing icon type. The only type limitations are what your 
computer already has; you cannot display a language you do not have loaded on your PC. Only the glyph and not the font is ever 
loaded on your device.
KeypadBuilder supports the creation of 256 glyphs per device project.

Creating Complex-Script Glyphs For Keypads
To create a glyph for use as a menu or sub-menu item:
1. With a KeypadBuilder project open, click Complex-Script Glyphs from the navigation pane. This invokes the Add/Edit Keypad 

Glyphs dialog (FIG. 11). 

The Add/Edit Keypad Glyphs dialog allows you to create, edit and manage your menu glyphs. The options in this dialog include:  

2. Click New Glyph to access the Create/Modify Glyphs dialog (FIG. 12). 
The options in this dialog allow you to generate graphic representatives for unique script languages and also enables the use 
of specialty fonts. The options in this dialog include:          

FIG. 11  Add and Edit Keypad Glyphs

• Glyph name The name associated with the glyph, this is useful for tracking icon glyphs and multiple language 
menu items.

• Glyph graphic A thumbnail rendering of the glyph as it displays in the menu.

• Glyph selection A list of available glyphs. Click on a glyph to select.

• Create new glyph Launches the Create/Modify Glyphs dialog to create new glyph entries.

• Edit existing glyph Launches the Create/Modify Glyphs dialog to edit existing glyph entries. You must have a glyph 
selected in order to edit it.

• Delete glyph Toggles a selected glyph from Deleted to not. If you delete a glyph and close the project, the glyph is 
gone permanently.

• Close Closes the Add/Edit Keypad Glyphs dialog and enacts changes.
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3. In the Create/Modify Glyphs dialog, click the format font selection button (...) to launch the Windows Font dialog. Select the 
family, format and size of the font, and click OK to close this dialog and return to the Create/Modify Glyphs dialog.

4. Place your cursor in the Text f ield and type what you wish to make a glyph. 
Glyphs can be no larger than 96x24 pixels. 
If you make a mistake click Clear to start fresh.

5. Click Create Glyph to render your glyph. The glyph will not create if you exceeded the maximum text dimensions.
6. In the field Glyph Name, type in name that will help you associate that glyph within your project.
7. Click OK to accept the glyph.

Editing Glyphs
To edit a glyph for use as a menu or sub-menu item:
1. With a KeypadBuilder project open, click Complex-Script Glyphs from the navigation pane.
2. Select from the list the glyph you intend to edit.
3. Click Edit Glyph in the Add/Edit Keypad Glyphs dialog.
Select from the following options to edit your glyph:

Change the font format or family - Click the format font selection button (...) to launch the Windows font format dialog. 
Select the family, format and size of the font and click OK.

Change the language character set - In the Character Select drop down list, select the language character set you wish to 
use. Your operating system must support this or you must use a keyboard language interface.

Change the characters in the glyph - Place your cursor in the Text field and type what you wish to make a glyph. This glyph 
cannot be larger than 96x24 pixels. If you make a mistake, click Clear to start fresh.

4. Click Create Glyph to render your glyph. The glyph will not be created if you exceeded the text dimensions.
5. If necessary, in the field Glyph Name, type in a name that will help you associate that glyph within your project.
6. Click OK to accept the glyph.

FIG. 12  Create/Modify Glyphs dialog

• Font type information This is a listing of the family and point size of the font you currently have selected.

• Format font Launches the Windows font format dialog. Select the family, format and size of the font.

• Character entry field Click in this field to place the cursor, this is where you type your glyph.

• Clear Clears all typed information in the character entry field, only the font information remains.

• Create Glyph Renders a glyph from the information typed in the character entry field based upon the font type 
and character set selection.

• Glyph attributes This is the number of characters your glyph occupies and the dimensions in pixels (WxH). The 
glyph can be no larger than 96x24.

• Rendered glyph The glyph after Create Glyph is selected. This is what will appear as a menu item.

• Glyph Name The name associated with the glyph image.

• Glyph ID An automatically assigned value (0-255) for index and application tracking purposes.

Format Font - Opens the Font dialog 

Character Entry field

Glyph attributes

Font type information

(set Font, Style and Size)
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Deleting Glyphs
To delete a glyph no longer in use as a menu or sub-menu item:
1. With a KeypadBuilder project open, click Complex-Script Glyphs from the navigation pane.
2. Select from the list the glyph you intend to delete.
3. Click Delete Glyph in the Add/Edit Keypad Glyphs dialog.
4. Click OK to accept the deletion of the glyph.

Mio Modero Attaché Projects
Overview
Use KeypadBuilder to create files (*.KPB) that allow you to get the most out of Mio Modero Attaché keypads and the devices they 
control. FIG. 13 shows the KeypadBuilder interface as it appears with an Attaché project active.

Creating A New Attaché Project
To create a new KeypadBuilder file, go to File > New Project > Mio Modero Keypad. 
Select Mio Modero Attache from Device Selection list in the Project Conf iguration dialog.

Attaché Project Navigation Pane
The KeypadBuilder Project Navigation Pane is open when an Attaché project file is active. This is the main area for accessing the 
configuration modules in creating an Attaché device file. 

Navigation Menu
Only available when a .KPB file is open, this menu is the crux of adding functionality to the keypad device. While viewing a graphic 
representation of your selected keypad device, you can do the following: 

FIG. 13  Project Navigation Pane - Attaché projects

Navigation Menu
Project Configuration Opens the Project Configuration dialog. This is topical Project Information, Device Selection and Device Setup 

Information.

Button Configuration Opens the Button Configuration dialog. Click to select buttons, and then assign button properties, Configuration 
Options and Display Options. The Channel Map can be accessed from this dialog.

Engraving... Opens the Engraving dialog. Click to select buttons and create either text or icon engraving instructions. The 
engraving dialog develops a .DXF file that must be provided to AMX to create your custom engraved buttons. 
Keypad display options and export options are also available in this dialog.

LCD Configuration... For keypad devices equipped with an LCD, the LCD Configuration dialog sets up Display Options, the presence of 
Dynamic Text, and Line Options.

Fixed Menu System... For keypad devices equipped with an LCD, the Fixed Menu Configuration dialog allows for the creation of Menu 
and one tier of sub-menus. The Main Menu can contain a maximum of 10 items. You can edit and add menu and 
sub-menu items.

Complex-Script Glyphs Launches the Add/Edit Keypad Glyphs dialog. Create glyph renderings of text and characters for menu/sub-menu 
items.
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Project Conf iguration
Click the Project Conf iguration button in the Navigation Menu to access the Project Configuration dialog (FIG. 2). The options in 
this dialog allow you to specify Project Information, information to make the file unique and Device Selection, the type of keypad 
device to be programmed.  

The Project Configuration dialog, and processes involved for Attaché projects is essentially the same as for Keypad projects. Refer 
to Project Conf iguration section on page 7 for details.

Button Conf iguration
Click the Button Conf iguration button in the Navigation Menu to access the Button Configuration dialog (FIG. 3). The options in 
this dialog allow you to set the keypad button properties. 

While the layout is different, to accommodate the button layout on the Attaché keypads, the Button Conf iguration dialog, and 
processes involved for Attaché projects is essentially the same as for Keypad projects. Refer to the Button Conf iguration section on 
page 8 for details.

FIG. 14  Project Configuration dialog (Attaché projects)

FIG. 15  Button Configuration dialog (Attaché projects)
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Engraving
Click the Engraving button in the Navigation Menu to access the Engraving dialog (FIG. 4). The options in this dialog allow you to 
create the .DXF file that AMX needs to create your device’s custom keypad. 

While the layout is different, to accommodate the button layout on the Attaché keypads, the Engraving dialog, and processes 
involved for Attaché projects is essentially the same as for Keypad projects. Refer to the Engraving section on page 9 for details.

LCD Conf iguration
Click the LCD Conf iguration button in the Navigation Menu to access the Conf igure LCD Keypad Display dialog. The options in this 
dialog control what menu items are shown and how they are displayed in devices equipped with an LCD. 
The Engraving dialog, and processes involved for Attaché projects is essentially the same as for Keypad projects. Refer to the LCD 
Conf iguration section on page 11 for details.

Fixed-Menu Conf iguration
Click the Fixed-Menu Conf iguration button in the Navigation Menu to access the Fixed-Menu Configuration dialog. The options in 
this dialog allow you to create the navigation hierarchy for your keypad device.
The Fixed-Menu Conf iguration dialog, and processes involved for Attaché projects is essentially the same as for Keypad projects. 
Refer to the Fixed-Menu Conf iguration section on page 12 for details.

Complex-Script Glyphs
The Complex-Script Glyph configuration module allows you to create menu/sub-menu items using characters and fonts that could 
not otherwise be displayed. Selecting the Complex-script glyph launches the Add/Edit Keypad Glyphs dialog.
Complex-Script Glyphs for Attaché projects work the same as for Keypad projects. Refer to the Complex-Script Glyphs section on 
page 18 for details.

FIG. 16  Engraving dialog (Attaché projects)
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Mio Modero Remote Projects
Overview
Use KeypadBuilder to create files (*.KPB) that allow you to get the most out of the Mio R-1, R-2 and R-3 remotes and the devices 
they control.

Creating A New Remote Project
To create a new KeypadBuilder file, go to File > New Project > Mio Modero Keypad. The device type that opens depends upon what 
is set in the Preferences menu.

Remote Project Navigation Pane
The KeypadBuilder Project Navigation Pane is open when a remote project file is active. This is the main area for accessing the 
configuration modules in creating a remote device file. 

Navigation Menu
Only available when a .KPB file is open, this menu is the crux of adding functionality to the remote keypad device. While viewing a 
graphic representation of your selected remote, you can do the following: 

FIG. 17  Project Navigation Pane - Remote projects

Navigation Menu
Project Configuration Opens the Project Configuration dialog. This is topical Project Information, Device Selection and Device Setup 

Information.

Display Configuration Opens the Display Configuration dialog. Click to select buttons, and then assign button properties, Configuration 
Options and Display Options. The Channel Map can be accessed from this dialog.

Engraving Opens the Engraving dialog. Click to select buttons and create either text or icon engraving instructions. The 
engraving dialog develops a .DXF file that must be provided to AMX to create your custom engraved buttons. 
Keypad display options and export options are also available in this dialog.

Navigation Menu
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Project Conf iguration
Click the Project Conf iguration button in the Navigation Menu to access the Project Configuration dialog (FIG. 18). The options in 
this dialog allow you to specify information to make the file unique and Device Selection, the type of remote device to be 
programmed.      

Setting the Remote Project Conf iguration
With a new KeypadBuilder project file open, click Project Properties in the Navigation Pane.
1. Enter information in to the Project Information section as necessary. 

2. Under the Device Selection section, establish the device that uses the remote project file. The Device Selection section 
contains a drop-down list of all remote devices capable of being programmed by KeypadBuilder. Select the remote device you 
wish to design for, and the device appears in the window below. If the remote device differs from the default file that opened, 
select the remote device from the drop down menu.

NOTE: Changing the device selection clears any previous unsaved work.

3. Select the color of your remote device from the Color Selection drop down list. The type of device selected dictates the colors 
available to choose from.

4. Click OK to confirm the changes or Cancel to exit and drop all changes.

FIG. 18  Project Properties dialog (Remote projects)

• Project Name The name of the keypad device project. This field is user defined and optional.

• Designer The designer name creating the KeypadBuilder file. This field is user defined and optional.

• Dealer Dealer name providing the keypad file. This field is user defined and optional.

• Purchase Order This name will populate the file name of the .DXF in the engraving section.

• Sales Order This name will populate the file name of the .DXF in the engraving section.

• Comments Any additional comments or clarifications for the file. This field is user defined and optional.

• Using Teletext Keypad Select this option if you are designing for a Teletext remote (default = disabled).
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Display Conf iguration
Click the Display Conf iguration button in the Navigation Menu to access the Display Conf iguration dialog (FIG. 19). The options in 
the Display Configuration dialog (for Mio Modero Remote projects) allow you to assign button properties, Configuration, Display 
font, type and justification, as well as create and edit glyph files for remote devices.    

NOTE: The title bar on this dialog indicates whether the 'Using Teletext Keypad' option is selected (in the Project Conf iguration 
dialog). For example, if the 'Using Teletext Keypad' option was selected, the title bar reads "Display Conf iguration - Teletext". 

Setting the Remote Display Conf iguration
1. With a new KeypadBuilder remote project file open, click Display Conf iguration in the Navigation Pane. This invokes the 

Display Conf iguration dialog.
2. Under Display Font Selections, select the character set you would like to use. 

There can be only one set.
This does not apply if you plan to utilize glyphs.

3. Under Display Type, click the radio button to select the type of display used in the LCD. The options are straight typed Text, 
Unicode format and rendered Complex Script glyphs.
If you will be using Complex Script display, click the Edit glyph button to launch the Add/Edit Keypad Glyphs dialog (FIG. 20). 
This option is only available if you selected Complex Script as the Display Type.
Refer to the Creating Complex-Script Glyphs For Keypads section on page 18 for additional details. 

FIG. 19  Display Configuration dialog

Display Conf iguration dialog
Display Font Selections The Available Fonts list indicates the fonts supported by KeypadBuilder. Click to select the language character 

set you want displayed in the LCD. 
Note: There can be only one set.

Display Type Select the type of display used in the LCD (Text, Unicode, or Complex Script ).

Edit glyph This option is only available if you selected Complex Script as the Display Type.
Click this button to launch the Add/Edit Keypad Glyphs dialog. 

Display Text A graphic representation of how your menu item displays upon button selection.

Button Property

Button Button is established by the device firmware and reflects what button you currently have selected. 
Note: Teletext remotes support one less device and one more macro than the standard version of the remote. 
Therefore, if the Using Teletext Keypad option is enabled for the project (in the Project Conf iguration dialog), 
when the middle button on the third row is selected, the Button f ield displays the text “Macro Button 4” (read-
only). Similarly, when the last button on the third row is selected, the Button f ield displays the text “Remote 
Button 5” (again, only if the Using Teletext Keypad option is enabled for the project). 

Text This is the field you enter what is to be displayed upon your selected button press.

Glyph... This button is only available if you selected Complex Script as the Display Type.
• Click Glyph to launch the Mio-R1 Add Edit Menu Item dialog. 
• Select Remove Glyph to remove a selected Glyph.

Update Adds your menu item to the project file display configuration.

Display Justification Click the radio button to align the menu item to the Left, Center, or Right
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4. Within the Display Text graphic, click on the button for which you want to create a display in the LCD.
For Text and Unicode users, type or paste your characters within the Text f ield.
Complex Script entries need to click the Glyph button to select the glyph you wish to use in the Add/Edit Menu Item dialog 

If you do not provide KeypadBuilder with an Item Name, it will use the Glyph ID to differentiate glyph items used. 

NOTE: For more information on using Complex-Script Glyphs, refer to the What is a Complex-Script Glyph? section on page 18.

5. Determine the justification of the information by clicking the radio button for:
Left
Center
Right

6. Click Update to confirm your changes to the file.
7. After you have set the options you need, click OK.

Removing a Glyph From a Button
1. In the Display Conf iguration dialog, select the button from which you wish to clear the glyph.
2. Click Remove Glyph.
3. Click Update to confirm your changes.

FIG. 20  Add and Edit Keypad Glyphs
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Engraving
Click the Engraving button in the Navigation Menu to access the Remote Engraving dialog (FIG. 21). The options in this dialog allow 
you to create the .DXF file that AMX needs to create your device’s custom keypad. 

NOTE: The title bar on this dialog indicates whether the 'Using Teletext Keypad' option is selected (in the Project Conf iguration 
dialog). For example, if the 'Using Teletext Keypad' option was selected, the title bar reads "Remote Engraving - Teletext"

Creating the Remote Engraving File
1. Click on a button in the Display Text area to select the button you wish to engrave.
2. In the Font Selection drop down menu, select between placing a symbol, AMX Icon 2, or text, Arial, Arial Narrow, or Arial 

Unicode MS. 
If you selected a text font, type the text you want displayed in the Text field.
If you select Icon in the font selection, you could use letters to get the associated icon but the Symbols drop down list is a 

simpler approach.
The Symbols drop down list is available when you select AMX Icon in the font selection list. The list is a collection of icons 
created by AMX. When you select an icon the corresponding letter is placed in the Text field. If you select more than one 
icon, it will not replace the previous icon, but rather add it and display all selected icons.

Buttons can have 1-10 characters.

NOTE: The KeypadBuilder Engraving module supports the engraving of its listed supported OS languages. You must have the 
language loaded on you OS and then use Unicode to render the text on the button.

3. You can only set the size of the symbol and text displayed on the button. Click on the Scale drop down menu and select in a 
range from 0.5 to 1.5. The larger the ratio, the more area of the button the text or icon fills.

NOTE: If your font selection or scale is greater than the area of the button that can be engraved, you will receive a warning in 
this f ield and KeypadBuilder will not create the .DXF f ile.

4. Click Update.
5. To preview the .DXF file as it appears to the engraver, click Engraving File Preview...
6. Click Export DXF File... to open the Export DXF File dialog (FIG. 22) to create the .DXF file necessary for engraving. 

FIG. 21  Remote Engraving dialog
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7. Within the Export DXF File dialog, set the destination directory for the file. Either type or click Browse to determine where to 
save the file.

8. Type a Description of the file in the field provided. The description aids in making a unique file name for the engraver. The File 
to Export field displays what the final file name is. For example:

C:\(Media Room)-S12-D0-SB0-DB0-CElite Taupe.DXF 

NOTE: KeypadBuilder will not create the DXF f ile if the information exceeds the bounding box.

See the Anatomy of A DXF File section on page 10 for additional details.
9. Click Export to confirm and create the DXF file.
10. Click Done to exit the dialog.
11. Click OK to save changes to the Engraving module and return to the Navigation Pane.

FIG. 22  Export DXF File dialog
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Mio Modero DMS Keypad Projects
Overview
Use KeypadBuilder to create files (*.KPB) that allow you to get the most out of Mio Modero DMS keypads and the devices they 
control. FIG. 23 shows the KeypadBuilder interface as it appears with a DMS Keypad project active. 

Workspace Navigator Window
The Workspace Navigator is typically located on the left side of the screen (although you may move it anywhere you like) and is 
used to open the pages / popup pages in the file, and to view/edit the function codes associated with each page. The Workspace 
Navigator contains two tabs (FIG. 24): 

Right-click within the Workspace Navigator - Pages Tab to launch the Workspace context menu.

 

FIG. 23  KeypadBuilder Work Area - DMS Projects

FIG. 24  Workspace Navigator Window

Workspace Window Design View Window

Button Information Window

Page Navigation Window

Workspace Navigator - Pages Tab Workspace Navigator - Function Maps Tab
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Pages Tab
Click the Pages tab at the bottom of the Workspace Navigator window to view the pages List-box tables contained within the open 
Project, in the Workspace Navigator (FIG. 24). Use the Workspace Navigator to view/open and rename keypad pages.

Note that the Project folder contains two folders: Pages and List-box Tables. Click the + symbol next to the folders, or 
double-click on the folders to view the pages and tables they contain.

Right-click anywhere within the Pages tab to access the Workspace Navigator context menu.
Edit Focus: A tiny arrow in the Workspace Navigator indicates which page or list-box tables is currently in focus (the one 

you are currently working on in the current Design View).

Function Maps Tab
Click the Function Maps tab at the bottom of the Workspace Navigator window to view the Function Code Map (FIG. 24).

Design View Window 
The Design View window is a graphic representation of either your currently selected page or list table. You can select a page or 
table in the Workspace Navigator - Pages Tab. You can select pages and List Box tables to edit or in the event it is associated, you 
can use the page flip.
Click within the scroll/button area or on the menu item to navigate and select within the Design View window.

Button Information Window
Below the button navigation list of the Page Navigation window is the text box, Button Information window (see FIG. 23).
The text area of the Button Information window provides which line is currently selected, if the button has a page flip attribute 
assigned, the port address of the button and the channel code for the button.
In the event you have created a keypad page that drills down without any means of navigating back out, this window will read Page 
Flip = NeedPageFlip. Allocate one of the buttons to return to another page with further navigation.

Page Navigation Window
The Page Navigation window provides helpful information and quick navigation for editing button features on selected pages. All 
pertinent page information is displayed in the visually appealing black boxes complemented with the yellow text. 
The text box at the top of the Page Navigation indicates which page you currently have selected an in view in the Design View 
Window. Below the page title is a button navigation list for selecting and editing buttons on the current page.
The button navigation list contains 8 button regions and 2 "hidden" buttons that serve as navigation for each keypad page. There 
are 4 possible button icon types found in the button navigation list (FIG. 25). 

Select any button and go to Project > Button Item Properties to edit or change any of the following button types. Right-click on 
any button to access the List Box Button Properties dialog. 

Workspace Context Menu
Add Page Launches the Add New Page dialog.

Delete Page Available when a page is right-clicked upon in the Workspace Navigator. After confirmation, deletes the selected 
keypad page.

Page Configuration Available when a page is right-clicked upon in the Workspace Navigator. Launches the Page Configuration dialog.

Edit Table Available when a table is right-clicked upon in the Workspace Navigator. Launches the Edit List-table dialog.

Delete Table Available when a table is right-clicked upon in the Workspace Navigator. After confirmation, deletes the selected List 
Box table.

FIG. 25  Page Navigation Window - Button Type icons

Page Navigation Window - Button Types
• General Button: The General buttons are the basic buttons in both the button select Mio Modero DMS and touch select Mio 

Modero DMS Pinnacle. General buttons can serve as page flips, List Box navigators and provide feedback. 
There can only be 8 general buttons per page.

• Page Navigation Button KeypadBuilder includes a scroll up and down navigation button with each keypad page. While the buttons 
are considered "hidden," some programming properties can be edited. If a List Box is present on the page, 
the Page Navigation buttons can be assigned to navigate them. Page Navigation buttons can also be 
assigned page flips. The Page Navigation buttons and General buttons 1 and 8 occupy the same buttons 
on Mio Modero DMS devices. The Page Navigation properties will override the General button properties in 
the event they differ.

General button

Page Navigation button

List Box button

List Box Navigation button
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The button information area of the Page Navigation window provides which line is currently selected, if the button has a page flip 
attribute assigned, the port address of the button and the channel code for the button.
Right-click within the Page Navigation Window to launch the Page Navigation context menu. 

Table Data Window
This window is viewable when a List Box is present in the project file and the table is selected in the Page Navigation window 
(FIG. 26).    

The title block indicates the name of the selected table and the Port and Address associated with the table. The list is comprised of 
each item in the List Box table, the Port, Channel, any page flip assigned, and current status changes of the item.
To edit table displayed in this window, click on any table item and go to the Project menu:

Select Edit Table... to launch the Edit List-table dialog.
Select Delete Table to launch the Confirm Delete List Table dialog.

Page Navigation Window - Button Types (Cont.)
• List Box Button KeypadBuilder makes use of the new format, List Box buttons. Both static and dynamic list boxes allow 

nearly limitless button options beyond the physical limitations of device's General buttons. A List Box 
button's display area is limited to the number of button lines allocated to via the Page Configuration 
dialog. A List Box button used in conjunction with a List Box Navigation button can display several devices 
or channels.

• List Box Navigation Button A List Box button just isn't as cool as it could be without its partner List Box Navigation button. List Box 
Navigation buttons have incremental options that are assigned in the Button Properties dialog. List Box 
Navigation buttons are necessary if your List Box exceeds the line viewing area, e.g., the List Box is 2 lines 
and you have 3 devices in your list.

Page Navigation Context Menu
• Properties Launches either the Button Properties dialog or the List Box Button Properties dialog.

• List Box Items Launches the Edit List Table dialog.

• Project Properties Launches the Project Properties dialog - Project Information Tab / Project Properties dialog - Setup 
Information Tab.

• Page Configuration Launches the Page Configuration dialog.

• Power Assign Codes Launches the Power Assignments dialog.

FIG. 26  Table Data Window
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Moving, Docking and Resizing Dockable Windows
To move the window, click on the title bar and drag and drop the window into place. Dockable windows automatically snap 

into place once they are positioned near an available docking area (along the edges of the application window, or along the 
edge of another dockable window.)

To dock the window, drag the window to reposition it next to any border or window frame and the window will automatically 
snap to the nearest border.

To stretch the window, click on any border and drag the border either vertically or horizontally.
To resize the window, click on the bottom-left corner of the window border in the area shaded with parallel diagonal lines 

and drag the corner in any direction.

Working With Dockable Windows
All windows in KeypadBuilder are fully dockable. Dockable windows can be re-arranged within the application window. They 
automatically snap to the top, bottom, right or left side of the application window, or along the edges of other docked windows. 
To dock/undock a window, double-click inside the window's title bar.

Project Menu
With a DMS Project open there is an additional item in the Menu Bar - The Project menu. The Project menu items are what allow you 
to make and edit pages, buttons and tables: 

Project Menu
• Add Page Launches the Add New Page dialog. The project opens with a default "Main Page" but you need to select 

Project > Add Page to create more keypad pages.

• Delete Page Deletes the page currently in view. Deletion of pages requires confirmation.

• Project Properties Launches the Project Properties dialog. This dialog allows you to set the Project Information, device selection 
and device color via the Project Information tab and the Start up and Inactivity pages via the Setup 
Information tab.

• Page Configuration Launches the Page Configuration dialog. This dialog allows you to edit page information and page layout for 
selected keypad page.

• Button Item Properties Depending upon what button type is selected in the page navigation window, launches either the Button 
Properties dialog (keypad button) or List Box Button Properties dialog (List Box button).

• Power Assign Codes Launches the Power Assignments dialog. KeypadBuilder can assign channel and address function types based 
on user parameters.

• Edit Table This feature is available if you have a table selected via the Workspace Navigator - Pages Tab. This menu item 
launches the Add/Edit List-box Items dialog

• Delete Table This feature is available if you have a table selected via the Workspace Navigator - Pages Tab. Deletes the page 
currently in view. Deletion of pages requires confirmation.

• List Box Items This feature is available if you have a table selected via the Workspace Navigator - Pages Tab. This menu item 
allows you to add and edit List Box items via the Add/Edit List-box Items dialog.
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Creating a New Mio Modero DMS Pinnacle Project File
1. Go to File > New Project > Mio Modero DMS Keypad.
2. Based on what is set in the KeypadBuilder preferences, the project file may already be a Mio Modero DMS Pinnacle (shown in 

the Design View Window).
3. If the project file is not a Mio Modero DMS Pinnacle, go to Project > Project Properties to launch the Project Properties dialog 

- Project Information Tab (FIG. 27). Use the options in the Project Information tab of the Project Properties dialog to view/edit 
project information associated with the active project file. 

The options in this tab include: 

Select OK to confirm or Cancel to exit without changes.
4. In Device Selection choose Mio Modero DMS Pinnacle Keypad from the drop down list.
5. Click OK.

Creating a New Mio Modero DMS Project File
With KeypadBuilder open:
1. Go to File > New Project > Mio Modero DMS Keypad.
2. Based on what is set in the KeypadBuilder preferences, the project file may already be a Mio Modero DMS (shown in the Design 

View Window).
3. If the project file is not a Mio Modero DMS, go to Project > Project Properties to launch the Project Properties dialog - Project 

Information Tab.
4. In Device Selection choose Mio Modero DMS Keypad from the drop down list.
5. Click OK.

FIG. 27  Project Properties dialog - Project Information Tab

Project Information

• Job Name This editable field displays the current Job Name associated with this project.

• Designer This editable field displays the current Designer associated with this project.

• Dealer This editable field displays the current Dealer associated with this project.

• Purchase Order This editable field displays the current Purchase Order (number) associated with this project.

• Sales Order This editable field displays the current Sales Order (number) associated with this project.

• Comments This editable field displays any comments that were added.

Device Selection

• Device Selection The drop down menu is a selection between the keypad devices supported by KeypadBuilder, select 
either Mio Modero DMS Keypad or Mio Modero DMS Pinnacle Keypad.

• Color Selection Select from the drop down menu the color of your DMS device.
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Maximum Text Sizes 

Mio Modero DMS projects support 35 font variations. Different sizes of the same typeface counts as a font variation. 
Font variations in excess of 35 will not appear on the pages once loaded.

Working with DMS Project Files
Setting a Start Up Page
Use the Start Up Page option in the Panel Setup Information tab of the Project Properties dialog to specify a particular page in your 
project to be displayed when the panel first boots up:
1. Select Project > Project Properties to open the Project Properties dialog.
2. Open the System Information tab (FIG. 28). The System Information tab dialog sets the startup and inactivity pages for the 

project file as well as designating port and channel allocation methods. 

The Start Up Page section is a listing of all pages currently in the active project file. Click on one of the pages to designate 
it as the startup page.

The Inactivity Page section is a listing of all page currently in the active project file. Click on one of the pages to designate 
it as the page the device reverts to after the set time-out.  

   

Maximum Text Sizes 
General Button Properties: • Button Name and Description - 128 chars

• Button State Text - 32 bytes*

List-box Button Properties: • Button Name and Description - 128 chars
• Table Name - 32 chars

New List-table dialog: • Table Name - 32 chars

List-Table Edit dialog: • Table Name - 32 chars

Add-Page dialog / Page Configuration dialog: • Page Name - 64 chars

Add/Edit List-box Item dialog: • Button State Text - 32 bytes*

* Since this control supports Unicode text, the max has to be specified in bytes, so Unicode 
text will be limited to 16 chars

FIG. 28  Project Properties dialog - Project Information Tab

Device Port Allocation: 

Automatically Calculate 
Port Allocation

Based on the port settings in the KeypadBuilder project file, ports are allocated to the device.

Specify Port Allocation Manually establish the number of ports to be allocated to the device, this feature is necessary with 
dynamic list boxes that utilize ports.

Ports A text field for typing in the number of ports to allocate.
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3. In the Setup Information tab, select the page that you want the keypad to load to when first launched.
4. Click OK to confirm or Cancel to exit without changes.

Setting an Inactive Page Flip
Use the Inactive Page Flip option in the Panel Setup Information tab of the Project Properties dialog to specify a particular page in 
your project to be displayed when the panel is inactive for a specified period of time:
1. Select Project > Project Properties to open the Project Properties dialog.
2. In the Setup Information tab, select the page that you want the keypad to flip to when the keypad is inactive.
3. Click OK to confirm or Cancel to exit without changes.

Working with Pages
Adding a Page
Both the Mio Modero DMS and Mio Modero DMS Pinnacle behave the same when it comes to adding new keypad pages to a project 
file. To launch the Add New Page dialog (FIG. 29), go to Project > Add Page... 

You can add as many page as you need for your project file and can track and navigate your keypad pages via the Workspace 
Navigator - Pages Tab. The options in this dialog include: 

Device Channel Allocation:

Automatically Calculate
Channel Allocation

Based on the channel settings in the KeypadBuilder project file, channels are allocated to the 
device.

Specify Channel 
Allocation

Manually establish the number of channels to be allocated to the device, this feature is necessary 
with dynamic list boxes that utilize channels.

Channels A text field for typing in the number of channels to allocate.

FIG. 29  Add New Page dialog

• Name By default KeypadBuilder names your new pages incrementally, e.g., Page 4, but it is a good idea 
for you to change them to unique names that will aid you in identifying the page's purpose in your 
project.

• Address and Channel
 Assignments

• Address Port
• Address Code
• Channel Port
• Channel Code
By default, KeypadBuilder sets every new page to Address Port: 1, Code: 0; Channel Port 1, Code:0. 
See Working With Function Codes for the importance of these function codes.
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Page Conf iguration
Both the Mio Modero DMS and Mio Modero DMS Pinnacle behave the same when it comes to editing the page configuration of 
keypad pages within a project file. To launch the Page Conf iguration dialog (FIG. 30), go to Project > Page Conf iguration... 

The options in this dialog include: 

• Page Layout The Page Layout is the graphic representation of the keypad page. A cross-hair cursor allows you 
to select button lines for editing purposes. To select, left-click on an of the Single Button lines.
• Add - Adds either a button line, a double button line or a List Box button via the Add Button 

dialog. At a minimum, there must be one button line removed from the keypad page. A double 
button line requires two adjoining buttons be removed and a List Box button will display within 
any number set but at least one button must be removed for Add to enable.

• Remove - Removes the line currently selected within the Page Layout area.
• Make Double - Allocates two button lines to one button. Click on any single button where the 

adjoining button has been removed to enable Make Double.
• Move Up - Moves the selected button line up the keypad page, over the button before it.
• Move Down - Moves the selected button line down the keypad page, below the button before it.

FIG. 30  Page Configuration dialog

• Name By default KeypadBuilder names your new pages incrementally, e.g., Page 4, but it is a good idea 
for you to change them to unique names that will aid you in identifying the page's purpose in your 
project.

• Address and Channel
Assignments

• Address Port
• Address Code
• Channel Port
• Channel Code
By default, KeypadBuilder sets every new page to Address Port: 1, Code: 0; Channel Port 1, Code:0. 
See Working With Function Codes for the importance of these function codes.

• Page Layout The Page Layout is the graphic representation of the keypad page. A cross-hair cursor allows you 
to select button lines for editing purposes. To select, left-click on an of the Single Button lines.

• Add Adds either a button line, a double button line or a List Box button via the Add Button dialog. At a 
minimum, there must be one button line removed from the keypad page. A double button line 
requires two adjoining buttons be removed and a List Box button will display within any number set 
but at least one button must be removed for Add to enable.

• Remove Removes the line currently selected within the Page Layout area.

• Make Double Allocates two button lines to one button. Click on any single button where the adjoining button has 
been removed to enable Make Double.

• Move Up Moves the selected button line up the keypad page, over the button before it.

• Move Down Moves the selected button line down the keypad page, below the button before it.
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Working With Buttons
Removing Buttons
1. In the Workspace tab, select the Page containing the Button(s) that you want to remove.
2. Go to Project > Page Conf iguration... to launch the Page Conf iguration dialog (FIG. 30).
3. Click to select a button.
4. Click Remove.

Adding Buttons
You can only add buttons to a page if there is at least open slot resulting from removing one or more buttons.
1. In the Workspace tab, select the Page to which you want to add a button.
2. Go to Project > Page Conf iguration... to launch the Page Conf iguration dialog (FIG. 30).
3. Click Add. This invokes the Add Button dialog (FIG. 31). 

The options in this dialog include: 

Setting Button Properties
1. Right-click on a single or double button in the Page Navigation Window to access the Page Navigation context menu.
2. Select Properties to access the Button Properties dialog - Programming tab (FIG. 32). 

The Button Properties dialog is the interface that allows for establishing the characteristics of the button. Included in this 
dialog are two tabs, Programming and States. It is through these two tabs that a naming convention, button description, and 
other characteristics are set.

FIG. 31  Add Button dialog

• Single Button Adds a single button to the selected keypad page.

• Double Button Adds a double button to the selected keypad page. A double button can only be added to a keypad page in 
the event there are two adjoining opens button lines.

• List Box Adds a List Box table button to the keypad page. By default, KeypadBuilder allocates the maximum open 
rows to the List Box button. To change the number of rows used by the List Box, click the drop down list 
and select the number of lines to be used by the button.
Refer to the Working with List Box Buttons section on page 40 for additional information.

FIG. 32  Button Properties dialog - Programming tab
37KeypadBuilder - Instruction Manual



Mio Modero DMS Keypad Projects
Button Programming Properties
The options in the Programming tab include: 

Button State Properties
The States tab is the text and how it is to be displayed on the keypad device for both the Off and On states. The options in the States 
tab include: 

Programming Properties

• Name This is the name of the button as it will appear in the Page Navigation Window. By default, 
KeypadBuilder names these buttons incrementally, e.g., Button 1. It is a good design practice to give 
your buttons names that apply to the function they serve.

• Description This text field is for describing the button in some detail. Providing information in this field is helpful 
not only to yourself but to anyone else that works with the project file at a later date.

• Page Flips A page flip causes the button to open a different page than the one containing the button. If a page 
flip has been set, the Page Flip Actions and target page are listed here. The browse (...) launches the 
Button Page Flip Actions dialog.

• Addressing The addressing for the selected button. Set the Port and Code for both the Address and Channel. If a 
List Box button is present on the selected keypad page, the checkbox List Box Navigation Button? is 
active.

• List Box Navigation 
Button?

If there is a List Box button on a keypad page it is imperative that a List Box Navigation button is 
added to the page. List Box buttons only display information within the allocated viewable area via 
the Page Configuration dialog and require a navigation to scroll up and down the list. If List Box 
Navigation Button? is checked you will only be able to set the Address Port and Code for the button. 
The navigation options are as follows:
• none - the List Box navigation does nothing when selected.
• single up - the List Box navigation moves up the list by an item increment of one.
• single down - the List Box navigation moves down the list by an item increment of one.
• page up - the List Box navigation moves up the list by an item increment of the total lines in the 

display area.
• page down - the List Box navigation moves down the list by an item increment of the total lines in 

the display area.
• goto top - the List Box navigation moves up to the first item in the list.
• goto bottom - the List Box navigation moves down to the last item in the list.

• Feedback Select the type of feedback to associate with this button (channel, inverted channel, always on, 
momentary, blink, or none).

State Properties

Off State:

• Text This text field box is the text to be displayed when the channel is in the Off state.

• Font The font is the currently selected font, style and point size. Clicking on the (...) launches the Choose 
Font dialog.

• Justification The text is displayed on the keypad device as either Left, Center or Right. Click the radio button next to 
the desired selection to select.

• Word Wrap When checked, the text will wrap to the next line. Be certain your display area supports your selected 
font attributes.
Word Wrap is generally useful with fonts sizes 8 pt. or less.

• Text Color The text can display black on white background or white on black background. Click the radio button 
next to the desired selection to select.

• Copy to On State When checked, all settings used for the Off sate are duplicated to the On state. This feature only works 
one way and any changes made to the On state will not be reflected in the Off state.

On State:

• Text This text field box is the text to be displayed when the channel is in the On state.

• Font The font is the currently selected font, style and point size. Clicking on the (...) launches the Choose 
Font dialog.

• Justification The text is displayed on the keypad device as either Left, Center or Right. Click the radio button next to 
the desired selection to select.

• Word Wrap When checked, the text will wrap to the next line. Be certain your display area supports your selected 
font attributes.

• Text Color The text can display black on white background or white on black background. Click the radio button 
next to the desired selection to select.
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Creating a Page Flip
A basic keypad page design concept is the Page Flip. A page flip is a button attribute that allows the user to press a button to "flip" 
through different keypad pages. A basic example would be a button labeled "DVD Player" on a main page that when touched, opens 
a DVD Player page, containing only buttons that control the DVD player. Typically you would set up a different control page for each 
piece of equipment. Organization of device controls is essential to good touch panel design, and page flips allow you to separate, 
organize and cross-link your control pages.
To create a page flip:
1. Select a (or create a new) button.
2. Go to Project > Button Item Properties.
3. Click the browse button (...) to open the Button Page Flip Actions dialog. The Button Page Flip Actions dialog (FIG. 33) allows 

you to set up page flips for any button type. A page flip causes the button to open a different page than the one containing the 
button. 

The two-column table lists all page flips that have been set for this button. The Action column indicates the page flip type, and 
the Target column indicates the target page for the flip.

4. Click the Add command button to create a new page flip for this button, and access a drop-down list of possible actions for 
the page flip (or Page Flip Action). The selected page flip action is represented in the Action column.

5. Specify the target page to open. Click the down arrow in the Target column to select the target of the selected Page Flip Action.
6. Repeat this process as desired to create multiple page flips on the button.
7. Use the Move Up/Move Down buttons to re-arrange the order of the page flips if necessary.

Page Flip Actions
With a button selected in a Page Navigation Window, go to Project > Button Item Properties to open the Button Page Flip Actions 
dialog, where you can set the type of page flip to apply to the selected button, and specify the target page.
Click the Add command button to access the Page Flip Actions drop-down list which allows you to select from a list of available 
page flip actions:

Standard Page - This selection populates the Target List Box with a list of standard pages in your project. Select a target 
page for the page flip.

Previous Page - This selection sets the page flip to go to the previous page (relative to the order of existing page flips) 
when the button is touched. 

Renaming Pages via the Workspace Navigator
You can rename a page or List Box table by single clicking on the page or List Box table name, then single clicking again. This will 
allow for in-place editing of the name value for the item.

FIG. 33  Button Page Flip Actions dialog
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Working with List Box Buttons
Setting List Button Properties
1. Select the List Box button in the Page Navigation Window.
2. Go to Project > Button Item Properties... to launch the List Box Button Properties dialog.
3. In the text field Button Name type a unique name for the List Box button. For the purpose of this example call it My Music 

ListBtn.
4. Use the Description f ield to further explain the function of the List Box. My Music Files
5. Set the Addressing Port and Code. 

See the Working With Function Codes section on page 48 for more information on Addresses.

6. In the List Item Text Properties section, click the (...) to launch the Choose Font dialog and set the font properties for the table. 
The Choose Font dialog is a listing of all fonts available on the PC where KeypadBuilder resides. Select font, style and size by 

clicking on them. Click OK to confirm changes or Cancel to exit without changes.
All font information set here is passed down to each entry that appears in the List Box tables.

7. Click the button next to Left in the Justif ication section to set all data in the table to Left.
8. In the List Box Data Source, select one of the following:

Create New Table (A Static List Box Table)
Use Existing Table (Only available when there is a preexisting static List Box table, in which case you can select from the list 

of available tables.)
Specify a Dynamic Table (A Dynamic List Box Table)
Next...
Create A Static List Box Table (see the A Static List Box Data Table section on page 42)
- or -
Create A Dynamic List Box Table (see the A Dynamic List Box Data Table section on page 42).

Creating a List Box Button
The first section to adding a List Box to a keypad page is allocating a spot on the page.
1. Go to Project > Add Page... to launch the Add New Page dialog. Provide all pertinent Page Information at this time but for the 

purposes of this topic we are going to address only the List Box criteria.
2. Within the Page Layout area select the first Single Button line from the top by clicking on it.
3. Click Remove.
4. Repeat steps 2 and 3 for the second and third Single Button lines.
5. Click Add to launch the Add Button dialog (FIG. 34). 

NOTE: You can only add a button line to a keypad page if there is an open area. 

The items in this dialog include: 

6. Click the radio button for List Box.
7. KeypadBuilder sets the default number of lines for the List Box to the maximum allowable. Leave the number of rows at 3 and 

click OK.
8. Click OK on the Add New Page dialog.
The first 3 button lines have now been allocated to a List Box. Note the List Box button icon in the Page Navigation Window.

FIG. 34  Add Button dialog

• Single Button Adds a single button to the selected keypad page.

• Double Button Adds a double button to the selected keypad page. A double button can only be added to a keypad page in 
the event there are two adjoining opens button lines.

• List Box Adds a List Box table button to the keypad page. By default, KeypadBuilder allocates the maximum open 
rows to the List Box button. To change the number of rows used by the List Box, click the drop down list 
and select the number of lines to be used by the button.
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Associating a Data Table With a List Box Button
After a page has been assigned a List Box button area, a table must be associated with the button.

NOTE: This dialog will only appear in the event a table has not already been assigned to the List Box button.

1. Right-click on a new List Box button in the Page Navigation Window to access the Page Navigation context menu.
2. Select List Box Items. Assuming that the selected List Box button has not yet been associated with a Data Table, the Associate 

Data Table dialog is displayed (FIG. 35). 

3. Click one of the following radio buttons:
Create New Table - Creates a new static table. New tables require a unique table name and table port and address. See the 

Working With Function Codes section on page 48 for more information on ports and addresses.
Use Existing Table - Uses one of the preexisting tables within the KeypadBuilder project file. Existing tables requires a 

selection from the list provided.
Specify a Dynamic Table - Assigns a dynamic table to display within the List Box button. Dynamic tables require the port 

and address for the dynamic table.

Creating a List Box Navigation Button
Select the General, Single Button just below the List Box button in the Page Navigation Window.
1. Go to Project > Button Item Properties... to launch the Button Properties dialog.
2. Open the Programming tab
3. In the text field Name type a unique name for the List Box navigation button. For the purpose of this example call it Single Up.
4. Use the Description f ield to further explain the function of the List Box button. Moves the list up by increments of 1.
5. There is no need to set a page flip for this button. In the Addressing section, place a check next to List Box Navigation Button?
6. Within the list now available, click on single up.
7. You can set a Feedback attribute for the button if you would like the button to provide a momentary or blink to show activity 

when the button is selected but it is not required for a List Box navigation button to function.
8. Open the States Tab
9. Place a check in the box next to Copy to On State. This will pass all settings made for the Off State to the On State.
10. In the Text f ield, type the text to display on the keypad, for this example Up.
11. Click the (...) within the Font section to launch the Choose Font dialog. The default font is set in the Preferences dialog.
12. Click the radio button next to Center in the Justif ication section.
13. Click the radio button next to White on Black in the Text Color section.
14. Since all the information passed through to the On State, click OK.
15. Repeat these steps for another single button within the Page Navigation window, but select single down on the Programming 

Tab. In the States Tab, provide the text Down.
Next...
Setting List Button Properties

Editing DMS Button Properties
With a project file open in KeypadBuilder:
1. Click on the button in the Page Navigation Window to select it.
2. Go to Project > Button Item Properties to launch the Button Properties dialog.
3. Once done making changes, click OK.

FIG. 35  Associate Data Table dialog
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Working With List Box Data Tables
List boxes provide flexibility to keypad pages once constrained by physical display areas. Both static and dynamic tables can display 
multiple devices and items when used with proper navigation tools.

A Static List Box Data Table
A static List Box populates button information based on data stored on the Mio Modero DMS. 
The device cannot display current state information provided by the master like A Dynamic List Box Table can. Conversely, the 
device will resume the last known static table event should power be cycled.

A Dynamic List Box Data Table
A dynamic List Box table populates button information base upon communications between the Mio Modero DMS and a master. 
Opposed to static tables, the information displayed on the device is passed through the master to the device. 
Dynamic tables are great for creating parameters for displaying changing options, i.e., date, time or temperature; however, if the 
device loses power it will not be able to display the last known states. 
After creating a dynamic table, specify port allocation (see the Specify Port Allocation section on page 49) and specify channel 
allocation (see the Specify Channel Allocation section on page 49).

Creating a List Box Data Table
Now that the List Box has been allocated for on the keypad page, navigation buttons have been set for the List Box and properties 
have been established for the List Box it is time to create a Static List Box Table.
1. Select the List Box button in the Page Navigation Window.
2. Go to Project > List Box Items... to launch the List Box Button Properties dialog (FIG. 36). This dialog sets and edits the 

properties for the List Box button. Any settings established in the List Box button properties populates down to each item 
contained in the List Box. 

Options in this dialog include: 

FIG. 36  List Box Button Properties dialog

• Button Name This is the name of the button as it will appear in the Page Navigation Window. By default, 
KeypadBuilder names these buttons incrementally, e.g., Button 1. It is a good design practice to 
give your buttons names that apply to the function they serve.

• Description This text field is for describing the button in some detail. Providing information in this field is helpful 
not only to yourself but to anyone else that works with the project file at a later date.

• Addressing The addressing for the selected button. Set the Port and Code for both the Address and Channel.

• Font The font is the currently selected font, style and point size. Clicking on the (...) launches the Choose 
Font dialog.

• Word Wrap When checked, the text will wrap to the next line. Be certain your display area supports your 
selected font attributes.
Word Wrap is generally useful with fonts sizes 8 pt. or less.

• Justification The text is displayed on the keypad device as either Left, Center or Right. Click the radio button next 
to the desired selection to select.
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NOTE: Feedback for List Box buttons is always "momentary."

3. Click the radio button next to Create New Table.
4. In the space provided, type a unique name for the table.
5. Assign a Port and Address for the table. See the Working With Function Codes section on page 48for more information on Ports 

and Addresses.
6. Click OK to confirm and launch the Create List Box Table dialog (FIG. 37). 

Items in this dialog include: 

• List Box Data Source • Create New Table - Creates a new static table. New tables require a unique table name and table 
port and address. See Working With Function Codes for more information on ports and 
addresses.

• Use Existing Table - Uses one of the preexisting tables within the KeypadBuilder project file. 
Existing tables requires a selection from the list provided.

• Specify a Dynamic Table - Assigns a dynamic table to display within the List Box button. Dynamic 
tables require the port and address for the dynamic table.

FIG. 37  Create List Box Table dialog

• Table The name of the table established in the Associate Data Table dialog. Type within this field to edit 
the table name.

• Port The current port setting for the selected table. Type within this field to change the port setting. 
See Working With Function Codes for more information.

• Address The current address setting for the selected table. Type within this field to change the address 
setting.

• Table Items List The list is comprised of each item in the List Box table, the Port, Channel, any page flip assigned, 
and current status changes of the item.

• New Add list items to the List Box table via the Add/Edit List-box Item dialog.

• Edit When List Box item is selected in the Table Items List, edit the information via the Add/Edit List-
box Item dialog.

• Delete Delete the List Box items selected in the Table Items List.

• Use Default Port 
for New Table Entries?

This option enables/disables the channel port/code auto-assignment options below.
• When disabled, the port value for new entries will default to the table port value, and the 

channel will default to zero, and the subsequent auto-assignment options are disabled.
• If this option is enabled, the Default Port for New Table Entries and Default Channel to Next 

Available options (below) will also be enabled.
• By default, this option is disabled. 

• Default Port for 
New Table Entries

Enter a numeric (integer) value for the default port to be assigned to new table entries. 
• This field is limited to 1 - 100. 
• The default value is 1.
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7. Click the New button to launch the Add/Edit List Box Table Items dialog (FIG. 38).  

The options in this dialog include: 

Note that the font information is fixed to what was set in the List Box Button Properties dialog.
8. Type the information to be displayed in the List Box table cell in the Caption field.
9. If you want to set the item in this cell as a page flip button, click the Page Flip drop-down menu. The drop down list is 

populated with pages already created in the project file.
10. Assign Port and Channel information as necessary. See the Working With Function Codes section on page 48 for more 

information.
11. Click OK
12. Repeat for as many items as needed.

Deleting List Table Items
Deleted list table items are marked as "deleted" and are not sent to the device if a transfer takes place nor saved to the project if the 
project is saved. Further, the channel codes associated with a deleted list table item are also be removed from the function map tree 
when the list table item is marked as "deleted", and restored to the Function Map tree if the item is restored ("delete" is toggled).
Deleted items are removed permanently from the project when the project is saved.

• Default Channel To
Next Available?

This option enables auto-assignment of channel codes for new entries.
When disabled, the default channel code associated with new entries will be zero.
If this option is enabled, the channel code for new entries will default to the highest channel code 
value found in the existing table entries that is associated with the default port, plus one. For 
example, if channel codes 1, 2, 3, and 6 have been assigned to existing entries in the table, the 
next code assigned will be 7.
• If this field is enabled, the Base Channel and Back-f ill Unused Channels? options will also be 

enabled.
• By default, this option is disabled. 

• Base Channel Enter a numeric (integer) value for the minimum channel code to be assigned to new table 
entries. This field only becomes enabled if the Default Channel to Next Available? option is 
enabled. Use this option in cases where you intend to skip a segment of channel codes - this 
value can be increased to the start of the new segment
• This field is limited to 1 - 4000. 
• The default value is 1.

• Back-fill Unused
Channels?

This option enables "back-filling" the default channel code with unused values in the sequence. 
For example, if channel codes 1, 2, 3, and 6 have been assigned to existing entries in the table, 
the next code assigned will be 4. 
• This field only becomes enabled if the Default Channel to Next Available? option is enabled.
• By default, this option is disabled. 

• Move Up Move the selected List Box item up one line.

• Move Down Move the selected List Box item down one line.

FIG. 38  Add/Edit List Box Table Items dialog

• Font The type face and point size as was established in the List Box Button Properties dialog.

• Caption Type the text to be displayed in the List Box table on the device.

• Page Flip A link to another page if necessary. The drop down list contains all other pages within the project file.

• Port Type the port assignment for the List Box item. See Working With Function Codes for more information.

• Channel Type the channel assignment for the List Box item.
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Deleting List Tables
In the event a table has been selected for deletion, Project > Delete Table, KeypadBuilder will seek confirmation via the Confirm 
Delete List Table dialog (FIG. 39). This dialog provides a list of every page view where the selected table occurs.

Dynamic List Box Table Example
The following is an example of a Dynamic List Box table as it appears in NetLinx code and how it corresponds to KeypadBuilder. See 
List Box Commands for more information on List Box commands. Dynamic List Box buttons require the same List Box navigation 
buttons as static tables do.
DEFINE_DEVICE
Keypad = 11001:1:4
Keypad2 = 11001:2:4
KeypadMusic = 11001:10:4
DEFINE_EVENT
BUTTON_EVENT[Keypad,5] 

{
  PUSH:
  {

    //Deletes any existing data list at address 1
    SEND_COMMAND Keypad, "'^LDD-1'"

    //Creates new 5-column data list at port 1, address 1 named "my music"
    SEND_COMMAND Keypad, "'^LDN-1,1,5,my music'" 

FIG. 39  Confirm Delete List Table dialog

FIG. 40  BUTTON_EVENT[Keypad,5] - KeypadBuilder location
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    //Specifies column types for the data list at address 1 starting at column 1
    SEND_COMMAND Keypad, "'^LDT-1,1,0,0,0,0,3'"

    //Adds rows to the data list at address 1
    SEND_COMMAND Keypad, "'^LDA-1,0,01,The Shins, Chutes, Lipless, "10,1"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,02,The Shins, Chutes, "High Horse", "10,2"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,03,The Shins, Chutes, So I, "10,3"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,04,The Shins, Chutes, Pilgrim, "10,4"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,05,The Shins, Chutes, Simon, "10,5"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,06,The Shins, Chutes, Fighting, "10,6"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,07,The Shins, Chutes, Bullets, "10,7"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,08,The Shins, Chutes, Square, "10,8"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,09,The Shins, Chutes, Gone, "10,9"'"
    SEND_COMMAND Keypad, "'^LDA-1,0,10,The Shins, Chutes, Come, "10,10"'"

    //Sets the column number (4) to display in the view with address 2
    SEND_COMMAND Keypad, "'^LVC-2,4'"

    //Updates the view at address 2
    SEND_COMMAND Keypad, "'^LVU-2'"
  }
}
//Sort the list by title instead of Track number
BUTTON_EVENT[Keypad,6] 

FIG. 41  Dynamic Table Properties ( Table Port 1, Table Address 1) - KeypadBuilder location

FIG. 42  Sort by title - KeypadBuilder location
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{
  PUSH:
  {
    //Set the sort order for view address 2. The 1 indicates forward sort.
    SEND_COMMAND Keypad, "'^LVO-2,1'"

    //Set the column of the list on which to base the sort of the data displayed
    //at view address 2 (in this case column 4 which contains titles)
    SEND_COMMAND Keypad, "'^LVS-2,4'"

    //Updates the view at address 2
    SEND_COMMAND Keypad, "'^LVU-2'"
  }
}

//Sort the list by Track number instead of title
BUTTON_EVENT[Keypad,7]

{
  PUSH:
  {
    //Set the sort order for view address 2. The 1 indicates forward sort.
    SEND_COMMAND Keypad, "'^LVO-2,1'"

    //Set the column of the list on which to base the sort of the data displayed
    //at view address 2 (in this case column 1 which contains track numbers)
    SEND_COMMAND Keypad, "'^LVS-2,1'"

    //Updates the view at address 2
    SEND_COMMAND Keypad, "'^LVU-2'"
  }
}
BUTTON_EVENT[KeypadMusic,1]
BUTTON_EVENT[KeypadMusic,2]
BUTTON_EVENT[KeypadMusic,3]
BUTTON_EVENT[KeypadMusic,4]
BUTTON_EVENT[KeypadMusic,5]
BUTTON_EVENT[KeypadMusic,6]
BUTTON_EVENT[KeypadMusic,7]
BUTTON_EVENT[KeypadMusic,8]
BUTTON_EVENT[KeypadMusic,9]
BUTTON_EVENT[KeypadMusic,10]
{
  PUSH:

FIG. 43  Sort by track number - KeypadBuilder location
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  {
    SEND_COMMAND Keypad2, "'^TXT-1,0,[Track ',itoa(BUTTON.INPUT.CHANNEL),']'" 

Working With Function Codes
In KeypadBuilder, the term Function Codes refers to two of the code types that can be assigned to buttons:

Channel Codes: The channel codes indicate the port number and the channel code associated with the button. The channel 
code represents communication out of the keypad to the master controller.

Address Codes: The address code represents communication from the master controller to the keypad, causing the keypad 
to do something (i.e. indicate feedback, display a text string, etc.).

Each function code is a two-part number separated by a colon: 
Port Number:Channel/Address/Level Number (depending on which function code you are looking at).

NOTE: The easiest way to handle function codes is to create and f inalize your pages, tables, and buttons (with function codes) before 
generating the supporting NetLinx program code. That way, in case you have to change any aspect of the project (i.e. add/remove 
controlled equipment, test strings, etc.), you can update the function code assignments in KeypadBuilder, rather than having to re-
write your code.

Function Code Map
Click the Function Maps tab (at the bottom of the Workspace Navigator window) to view the Function Code Map. 

The Function Code Map is a representation of the Channel codes, Address codes, Level codes, String Outputs and Command 
Outputs utilized in the keypad file, displayed in a hierarchical tree format in the Function Map tab of the Workspace Navigator 
window. This list is sorted by Port, and within Port by Code. 

FIG. 44  SEND_COMMAND Keypad2 - KeypadBuilder location

FIG. 45  Function Code Map
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You can use the Function Code Map to delete codes as well as drag and drop items from one port to another, within the 
primary folder the selected item belongs to (i.e. Channel Codes, Address Codes, Level Codes). For example, you cannot 
drag and drop an Address Code (regardless of the port folder that contains it) into any port folder contained in either the 
Channel or Level folders. 

NOTE: Neither String or Command Outputs support any type of drag and drop operations.

Selecting an item in the tree and then left clicking again will provide an in-place edit of the code value. 

NOTE: While you can (in-place) edit the Channel, Address and Level codes via these folders, you cannot edit String or Command 
Outputs the same way. These can only be edited via the General tab of the Properties Control window.

Specify Port Allocation
Since dynamic tables exist at the master, KeypadBuilder is blind to the port and channel needs a keypad project has. To allocate 
needed port allocation for the project file:
1. With the project file open, go to Project > Project Properties.
2. Select the Setup Information tab.
3. Click the radio button for Specify Port Allocation.
4. In the field ports type the number of ports to be allocated. A message below the port field confirms the number of ports to 

allocate.
5. Click OK

Specify Channel Allocation
Since dynamic tables exist at the master, KeypadBuilder is blind to the port and channel needs a keypad project has. To allocate 
needed channel allocation for the project file:
1. With the project file open, go to Project > Project Properties.
2. Select the Setup Information tab.
3. Click the radio button for Specify Channel Allocation.
4. In the field channels type the number of channels to be allocated. A message below the channel field confirms the number of 

channels to allocate.
5. Click OK

Using Power Assign
One of the big time-eating factors of creating a keypad is correctly setting up the channel, address and level function codes for any 
given button, and other properties that depend on button type. Use Power Assign to streamline this process. The Power Assign 
feature can operate on a single button, or on a group of selected buttons.
Select Button > Power Assign to open the Power Assign dialog.
Suppose you have a keypad file from a pre-existing job, and you like the pages. You can open the old file, save it as a new job. 
However, lets assume that they came through with the wrong channel codes. A good trick to use for this kind of operation is to 
Shift-select the buttons in the order you want the channel codes to occur before copying and pasting. Start with the button that will 
get the first channel code and click on it. Then hold down the Shift key, and Shift-click on the rest of the buttons you want to copy, 
in the order that the final channel codes will need to occur, adding them to the selection.
Clear Channels First: One powerful feature of Power Assign is the ability to clear the various function codes from the buttons. Since 
the buttons remain selected after the paste operation, all you need to do is bring up the Power Assign dialog, then:
1. Under Function Code Action, select Clear.
2. Under Function Code Type, select Channel, or Address.
3. Click Assign. 
It is good practice to clear the function codes before any Assign Codes operations. If you don’t clear the codes first, and any of the 
buttons in the group you are assigning already have codes assigned, they will show up as used when Power Assign does its’ checks. 
In some cases, this may be what you want to have happen, but usually you’ll want to clear them before assigning.
Assign Codes: Next assign new function codes:
1. Under Function Code Action, select Assign.
2. Under Function Code Type, select Channel, or Address.
3. Click Assign. 
To use take full advantage of Power Assign, you need to understand the nuances of some of the options involved:

Begin Assignment At (Power Assign)
Ensure Contiguous Code Assignment (Power Assign)
Wrap Within Port ID (Power Assign)

Begin Assignment At (Power Assign)
If you don’t check the Begin Assignment At option, the assign operation begins at the first available channel, just like the standard 
Auto Assign. When Begin Assignment At is selected you can specify the starting value of the channels. 
This is particularly useful for setting up things like numeric keypads, where you need the channels to begin at a specific value, since 
you might be using offset math in your code to process the button pushes.
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Wrap Within Port ID (Power Assign)
Since the keypads support more than one port, you’re no longer limited to 256 channels and address codes. However, things like 
SYSTEM_CALLS are based upon all the channels coming from a single device. And if the channels are split across ports the 
feedback part of the System Call won’t work. Another thing that comes into play with being able to use multiple ports is that you 
may need to confine certain ranges of channels to a single device to take advantage of the DEFINE_MUTUALLY_EXCLUSIVE channel 
grouping in the code. Since MUTUALLY EXCLUSIVE works on a particular port, ensure that the group of buttons is entirely within a 
single device. In either of these cases, check the Don’t Split option, which ensures that all channels assigned fall within a single port 
code.
When Power Assign is run with this option enabled, one of two things can happen, depending upon the setting of the Keep Checking 
option. If Keep Checking is not set, you get an error notice. If it is selected, Power Assign keeps looking until it either finds a valid 
range to assign the channels to, or there simply aren’t enough free channels to perform the operation, in which case you get 
another error message.
The easiest way to understand Keep Checking is to look at it from the standpoint of what you want to do. If it’s absolutely essential 
that Power Assign use exactly the range of channels you have in mind (i.e. the code is already written and it would be a fair amount 
of work to change it), turn off Keep Checking, and turn on Start At. If the requested channels are not available (i.e. they’ve been 
used elsewhere), you get an error message, telling you that Power Assign couldn’t assign the channels. This means that the 
channels in question have been used elsewhere. You can then use the channel map to verify which of the channels in the range you 
wanted were in use.
If it isn’t important that the channels end up exactly where you had specified, just that they are assigned as a group, you can select 
Keep Checking and Power Assign will do just that, subject to the Begin Assignment At, Ensure Contiguous Code Assignment, and 
Split Across Port IDs settings. 
One nice thing about the Power Assign palette is that it retains its settings after use, which is handy when you need both the push 
channels and address codes to have the same numeric values. 
First, use the Functions tab of the Workspace Navigator and click back and forth between the push channel and address options. 
Look for a clear range of channels large enough and make a note of the start channel. Next, open the Power Assign dialog.
Here’s the setup you would use: 
Check Begin Assignment At and Ensure Contiguous Code Assignment. Split Across Port IDs is optional based on whether these 
channels will be used for System Calls or need to have mutually exclusive feedback.
Then supply the device and channel values, click Channel under Function Code Type, and click Assign. Next, click Address under 
Function Code Type, and click Assign again. If you didn’t require both the push channel and address to match, you’re done. If they 
need to match, watch for an error in either of the assignment operations. If this is the case, clear both the push channels and 
address codes using the Clear Codes action settings. 
While initially somewhat confusing, an immense amount of power is available in the options under Function Code Action. Since the 
selection is retained after any operation, if you make a mistake, it’s easy to click Clear Codes and hit the assign button again. 
Remember that Power Assign processes the channel assignments based on the order in the selection so, if the order is important to 
you, make sure to create the selection using the Shift-Select technique.

Ensure Contiguous Code Assignment (Power Assign)
This is used when the channels have to be in order, with no breaks between them, as in a numeric keypad. In these cases, since the 
order is important, use the Shift-select technique to select the buttons in the order you want to assign the channels. 
If you don’t care what channels are assigned, uncheck this option, and KeypadBuilder will f ind the next available free channels, 
skipping used channels and continuing on until all available channels have been assigned. 
In this case the values will be subject to whether or not you’ve set the Begin Assignment At checkbox.
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Power Assignments dialog
Select Project > Power Assign Codes to open the Power Assignments dialog (FIG. 46), where you can set channel and address 
function code type parameters for one or more selected buttons. 

The options in this dialog include: 

Edit List-table dialog
The Edit List Table dialog is accessible when a List Box button is selected in the Page Navigation Window, then Project > List Box 
Items. This dialog creates and edits items contained within the List Box table.

Table - The name of the table established in the Associate Data Table dialog. Type within this field to edit the table name.
Port - The current port setting for the selected table. Type within this field to change the port setting. See Working With 

Function Codes for more information.
Address - The current address setting for the selected table. Type within this field to change the address setting.
Table Items List - The list is comprised of each item in the List Box table, the Port, Channel, any page flip assigned, and 

current status changes of the item.

FIG. 46  Power Assignments dialog

• Function Code Action • Clear: Clears the button group's channel or address setting based on the option you select in 
the Function Code Type area. Choose Channel to clear the channel numbers or Address to clear 
the address number.

• Assign: Sets the button group's channel or address setting based on the option you select in 
the Function Code Type area. Choose Channel to set the channel numbers or Address to set the 
address number.

• Function Code Type • Channel: Sets the button group's channel numbers (if you select the Function Code Action/
Assign option).

• Address: Sets the button group's address numbers (if you select the Function Code Action/
Assign option).

• Function Code 
Assignment Options

• Begin Assignment At (Power Assign): Sets the button group's starting device and channel 
numbers (if you select the Function Code Action/Assign option).

• Port: Sets the button group's port numbers (if you select the Function Code Action/Assign 
option).

• Function Code: Sets the button group's function codes (if you select the Function Code Action/
Assign option).

• Ensure Contiguous 
Code Assignment 
(Power Assign)

Sets the button group's device and channel number assignments to be contiguous (i.e. 1, 2, 3, 
etc.).

• Reuse Previously 
Assigned Codes

Sets the codes, starting at either port 1/channel 1 or what you specify in the Begin Assignment At 
field without regard to previously utilized codes.

• Code Assignments • Split Across Port IDs: Sets the program to create a different device number for each channel. For 
example, port 1/channel 255, and port 2/channel 1 are considered to be split across device IDs.

• Wrap Within Port ID (Power Assign): Sets the program to avoid creating two or more channels 
with different device numbers.
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New - Add list items to the List Box table via the Add/Edit List-box Item dialog.
Edit - When List Box item is selected in the Table Items List, edit the information via the Add/Edit List-box Item dialog.
Delete - Delete the List Box items selected in the Table Items List.
Move Up - Move the selected List Box item up one line.
Move Down - Move the selected List Box item down one line.
OK - Confirm changes and exit.
Cancel - Close window without making changes.

Send DMS Conf iguration Files dialog
The Send DMS Conf iguration Files dialog allows you to see the current settings for sending files, change and set the connection 
method and send the file. 

Communication Settings - The display field shows you the current communication setting for KeypadBuilder.
The Communication Settings... button launches the Communication Settings dialog.

Device ID - Type the Device ID number for the currently targeted device.
Send File Options - Click the box to include the information sent to the device.

Smart Transfer - Transfers only the files that have been changed or are new.
Send File - Click this button after the communications have been set to send the selected files to the targeted device.
Done - Click this button after you have received indication of a successful send in the Transfer Status f ield. Done closes the 

dialog.
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KeypadBuilder File Transfers
Sending A Conf iguration File to A Device
To send the final configuration file to you master:

NOTE: The Mio Attaché and Mio-R1 can only communicate via Serial.

1. Select Send to Device... in the Transfer menu. 
For Keypad and Remote Projects, this launches the Send Conf iguration Files dialog (FIG. 47). 

For DMS Projects, this launches the Send DMS Conf iguration Files dialog (FIG. 48). 

The Send (DMS) Conf iguration Files dialog allows you to see the current settings for sending files, change and set the 
connection method and send the file. 

2. Click Communication Settings... to confirm your settings are correct. This option invokes the Communication Settings dialog 
(FIG. 49). 

3. In the Send Conf iguration Files dialog, enter the Device ID number for the currently targeted device.
4. Under Send File Options, make sure Conf iguration File is checked. Select Smart Transfer to transfers only files that have been 

changed or are new.

NOTE: If you set the LCD Display Resolutions in the LCD Conf iguration module to CJK or Korean and Latin fonts and this is your 
f irst f ile send, make sure Font File is checked in the Send File Options.

5. Click Send File. The Transfer Status is displayed below.

FIG. 47  Send Configuration Files dialog

FIG. 48  Send DMS Configuration Files dialog

FIG. 49  Communication Settings dialog
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6. Upon successful transmission, click Done.

NOTE: Sending an inappropriate conf iguration f ile, i.e., a double-style sent to a single-style, to a device will result in an overwrite 
of any f ile currently residing on the device, but the device will not work.
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