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1. READ these instructions.
2. KEEP these instructions.
3. HEED all warnings.
4. FOLLOW all instructions.
5. DO NOT use this apparatus near water.
6. CLEAN ONLY with dry cloth.
7. DO NOT block any ventilation openings. Install in accordance with the manufacturer's instructions.
8. DO NOT install near any heat sources such as radiators, heat registers, stoves, or other apparatus (including amplifiers) that 

produce heat.
9. DO NOT defeat the safety purpose of the polarized or grounding type plug. A polarized plug has two blades with one wider than the 

other. A grounding type plug has two blades and a third grounding prong. The wider blade or the third prong are provided for your 
safety. If the provided plug does not fit into your outlet, consult an electrician for replacement of the obsolete outlet.

10. PROTECT the power cord from being walked on or pinched, particularly at plugs, convenience receptacles, and the point where 
they exit from the apparatus.

11. ONLY USE attachments/accessories specified by the manufacturer.

12. USE ONLY with a cart, stand, tripod, bracket, or table specified by the manufacturer, or sold with the apparatus. When a cart is 
used, use caution when moving the cart/apparatus combination to avoid injury from tip-over.

13. UNPLUG this apparatus during lightning storms or when unused for long periods of time.
14. REFER all servicing to qualified service personnel. Servicing is required when the apparatus has been damaged in any way, such as 

power-supply cord or plug is damaged, liquid has been spilled or objects have fallen into the apparatus, the apparatus has been 
exposed to rain or moisture, does not operate normally, or has been dropped.

15. DO NOT expose this apparatus to dripping or splashing and ensure that no objects filled with liquids, such as vases, are placed on 
the apparatus.

16. To completely disconnect this apparatus from the AC Mains, disconnect the power supply cord plug from the AC receptacle.
17. Where the mains plug or an appliance coupler is used as the disconnect device, the disconnect device shall remain readily operable. 
18. DO NOT overload wall outlets or extension cords beyond their rated capacity as this can cause electric shock or fire. 

The exclamation point, within an equilateral triangle, is intended to alert the user to the presence of important operating and maintenance 
(servicing) instructions in the literature accompanying the product.

The lightning flash with arrowhead symbol within an equilateral triangle is intended to alert the user to the presence of uninsulated "dangerous 
voltage" within the product's enclosure that may be of sufficient magnitude to constitute a risk of electrical shock to persons.

ESD Warning: The icon to the left indicates text regarding potential danger associated with the discharge of static electricity from an outside 
source (such as human hands) into an integrated circuit, often resulting in damage to the circuit.

WARNING: To reduce the risk of fire or electrical shock, do not expose this apparatus to rain or moisture.
WARNING: No naked flame sources - such as lighted candles - should be placed on the product.
WARNING: Equipment shall be connected to a MAINS socket outlet with a protective earthing connection.
WARNING: To reduce the risk of electric shock, grounding of the center pin of this plug must be maintained. 
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Overview
Overview
FileTransfer 2
The FileTransfer 2 application gives you the ability to queue a list of files to transfer to various NetLinx and Axcess devices, without 
launching NetLinx Studio.
FileTransfer 2 supports the following capabilities for file transfers:

Ability to select the Platform type (NetLinx or Axcess).
Ability to set the username and password for NetLinx masters that have security enabled.
Ability to send/receive via USB (for USB enabled) devices via a Virtual NetLinx Master (VNM) connection.
Ability to send/receive files via TCP/IP and RS232 protocols.

FileTransfer 2 recognizes the following file types for transfer:
APW (NetLinx Studio Workspace)
AXW (NetLinx Studio Export-to-Go)
FTL (File Transfer List)

System Requirements / Supported Files
Supported File Types
The following are the types of files this application can send to and receive from, various NetLinx and Axcess devices:

TOK Files
TKN Files (including compiled Duet TKN Files)
TP4 Files 
TPD Files
KPB Files (except for Mio DMS/DMS Pinnacle)
KPD Files
IRL/IRV Files
SRC Files 

Notes on supported f ile types:
The selection of available file types depends on the selected platform, Send/Receive selection and communication settings
All files must mapped to devices before they can be selected for transfer.
Source Code files cannot be sent until they have been successfully compiled.
While Touch Panel UI files are sent to the panels themselves, KPD files are sent to the master and not directly to the keypad. 

Before sending a KPD (KPDesign) file to the target keypad(s), be sure that you have successfully compiled the Source Code 
file that contains the keypad module, and sent it to the Master (see Configuring NetLinx Source Code for KPD Files).

Supported Operating Systems
Windows XP® 
Windows 2000®

NOTE: You must have Administrator rights to install and run all required System f iles.

PC Requirements/Recommendations
Pentium 233 MHZ processor (minimum requirement); 300 MHZ or faster recommended.
Windows-compatible CD-ROM drive.
Windows-compatible mouse (or other pointing device).

Tested Modems List
The following is a list of internal and external modems that have been tested with the program. 

INTERNAL MODEMS --- Windows Operating System ---

Manufacturer Model - Internal 95 98 ME NT 2000 XP

Diamond Supra 336i SP ASVD ? C ? ? ? ?

Diamond Supra 56i SP ? C ? ? ? ?

Lucent 56K LU PCI ? C ? C ? ?

US Robotics 56k Fax PCI #3CP5610A ? C ? C ? ?

US Robotics Sportster WinModem - #0467 ? X ? ? ? ?

Zoom Fax 28.8 v.341 #275 ? C ? ? ? ?

Note: Internal modes were tested only for calling capabilities.
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Overview
C = Call - means that the FileTransfer 2 program can get the modem to call another modem and establish communications.
A = Answer - means that the FileTransfer 2 program can get the modem to answer inbound calls and establish 

communications with the master controller.
X = Not supported.
< = Less 100% reliable.

EXTERNAL MODEMS --- Windows Operating System ---

Manufacturer Model - External 95 98 ME NT 2000 XP

Boca 14.4 V.32b #MV.34xx X X X X X X

Hayes Accura 56k #03328-A ? C C C C ?

Hayes Accura 144+Fax 144 #5300AM X X X C X X

MultiTech MultiModem 19.2k Data/Fax ? X ? A A ?

Practical Peripherals PM288MT II v.34 - 28K ? C< ? ? X ?

US Robotics 56k Fax v.90 #USR5686D ? CA ? CA CA ?

US Robotics Sportster56k Fax #USR5686-03 CA CA CA CA CA ?

US Robotics Sportster 33.6 - #0413 ? ? ? CA ? ?

US Robotics Sportster 14.4 Fax CJE-0235 ? ? ? ? ? ?

Zoom Fax 56kx Dualmode #2949L ? CA C CA C ?
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Using FileTransfer 2
Overview
The basic steps for using transferring files to and from system devices are:

Sending Files To System Devices:
Adding Files To The Files To Send Queue (see below)
Configuring Communications Settings for Transfers - see the Communication Settings section on page 12
Device Mapping - see the Device Mapping section on page 15
Transferring the Files - see the File Transfer Operations section on page 16

Receiving Files From System Devices:
Adding Files To The Files To Receive Queue (see below)
Configuring Communications Settings for Transfers - see the Communication Settings section on page 12
Device Mapping - see the Device Mapping section on page 15
Transferring the Files - see the File Transfer Operations section on page 16

Adding Files To The Transfer Queue
Before files can be sent to or received from system devices, they must first be added to the Transfer Queue in either the Send or 
Receive tab

Adding Files To The Files To Send Queue
There are several possible approaches to adding files to the Files To Send List (Send tab). 
1. Add some or all of the files contained in a Workspace file or a Workspace-To-Go file.
2. Add a set of files, defined in a File Transfer List file.
3. Add individual systems (see Supported File Types list).
Notes:
The f ile types that are available for selection depend on the selected Platform (Axcess or NetLinx), Send/Receive selection and 
Communication settings.
All f iles must mapped to devices before they can be selected for transfer. You can edit the f ile's mapping information via the Edit menu 
(Device Mapping option), but without any mapping information associated with the f ile, it cannot be selected.
Source Code f iles cannot be sent until they have been successfully compiled.
While Touch Panel UI f iles are sent to the panels themselves, KPD f iles are sent to the master and not directly to the keypad. Before 
sending a KPD (KPDesign) f ile to the target keypad(s), be sure that you have successfully compiled the Source Code f ile that contains 
the keypad module, and sent it to the Master.

Adding All Files Contained In an APW or AXW File
In the Send tab:
1. Select File > Open Workspace/AXW/FTL File or click the Load Workspace command button to open the Open File dialog. 
2. Select either NetLinx Studio Files (*.apw) or Export-To-Go Files (*axw) from the File of Type drop-down menu (depending on 

which type of file contains the system files that you want to transfer).
This dialog contains two tabs: Existing and Recent. 
Use the Existing tab to locate and select the desired file, with the ability to navigate through all available local and network 

drives.
The Recent tab contains a listing of the most recently used files (of all types).

3. Locate and select the Workspace file that you want to add, and click Open. This opens the Quick Load dialog.
4. In the Selection Options section, select Entire Workspace.
5. Click Select All to add every file type in the Workspace, and enable the Remove Duplicates when Loading option.
6. Click OK to close the Quick Load dialog and add the files to the Files To Send queue.

Adding Files From a Specif ic Project/System
In the Send tab:
1. Select File > Load Workspace/AXW/FTL File or click the Load Workspace command button to open the Open File dialog. 
2. Set the File of Type drop-down to NetLinx Studio Files (*.apw).

This dialog contains two tabs: Existing and Recent. 
Use the Existing tab to locate and select the desired file, with the ability to navigate through all available local and network 

drives.
The Recent tab contains a listing of the most recently used files (of all types).
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Using FileTransfer 2
3. Locate and select the Workspace file that contains the Project/System with the file(s) you want to add, and click Open. This 
opens the Quick Load dialog.

4. In the Selection Options section:
Select Active System to add files from the active System in the open Workspace.
Select a Project-System to add files from a specific Project/System in the open Workspace.

5. Click in the checkboxes to specify which file types in the selected System to add.
6. Click OK to close the Quick Load dialog and add the files to the Files To Send queue.

Adding Individual System Files From the Open Workspace f ile
With a Workspace (or Workspace To-Go) file open, use the Add command button (in the Send tab) to select individual System files 
to add to the Files To Send queue:
1. Click the Add command button to open the Select Files For File Transfer dialog.
2. Open the Current Workspace tab.

This tab consists of a display of the (compiled) Source Code (.AXS), Token (.TKN), User-Interface (.TPD/.TP4) and IR (.IRL) 
files contained in the currently open Workspace.

Use the options in the Current Workspace tab to locate and select file(s) for transfer to the Master or System devices on the 
bus. Use this tab if the file(s) you want to transfer are included in the open Workspace. 

3. Click OK to add the selected file(s).

Adding Orphan Files
In the Send tab:
1. Click the Add command button to open the Select Files For File Transfer dialog.
2. Open the Other tab. Use this tab if the file(s) you want to transfer are not included in the open Workspace. This tab consists of 

a display of the different types of files that can be transferred to the Master or System devices on the bus:
IR Codes (*.IRL/*.IRV)
NetLinx Source Code (*.SRC)
Compiled NetLinx Source Code (*.TKN)
Compiled Axcess Source Code (*.TOK)
Touch Panel Design File (*.TPD)
TP4 Touch Panel (*.TP4)
KPD Keypad Touch File (*.KPD)

3. Select the type of file that you want to add to the Transfer List.
4. Click the Add button. This invokes the Open dialog, with the Files of Type selection already set to the selected file type.
5. In the Open dialog, locate and select the file that you want to add.
6. Click Open to add the selected file to the Files To Send queue.

Adding Files To The Files To Receive Queue
To add files to the Files To Receive queue:
1. Open the Receive tab.
2. Click the Add command button to open the Select Files For Transfer dialog.
3. Select the type of file you want to receive from the system device (IRL/IRV, TPD, SRC, AXS or TP4), and click Add (opens the 

Save As dialog).

NOTE: The f ile types that are available for selection depend on the selected Platform (Axcess or NetLinx), Send/Receive selection 
and Communication settings.

4. In the Save As dialog, specify a name and target directory for the retrieved file. Click Save to close this dialog and open the 
Enter Device Mapping Information dialog.

5. Enter the Device, Port and System numbers for the source device, and click OK to close the dialog and add the to the File list at 
the bottom of the Select Files To Transfer dialog.

6. Click Settings in the Communication Settings section at the bottom of the dialog to open the Communication Settings dialog 
and specify the communication settings for the source device.
Note that in the Select Files For File Transfer dialog, communication settings apply to every file in the File list (since in this 
case the communication settings are relating to a system device that is the source for files you are receiving, not to individual 
files that may be sent to any of several devices in the system).

7. Click OK to close the Select Files For File Transfer dialog. The files you added should now appear in the Files To Receive queue 
of the Receive tab.

8. Repeat steps 2 - 7 to add files to retrieve from different system devices to the Files To Receive queue.
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File Transfer List (*.FTL) Files
File Transfer List (FTL) files are created in FileTransfer 2, and allow you to save a list of files as they appear in either the Files To 
Send or Files To Receive queues (with communications settings and device mapping information).
Once saved as an FTL file, the file transfer list can be quickly reloaded without having to open and configure each file.

Creating an File Transfer List (FTL) File
To create a FTL file:
1. Add a list of files to the Files To Send or Files To Receive queues (in either the Send or Receive tab).
2. Click the Save List command button. This opens the Save As dialog, with File Transfer List Files (*.ftl) pre-selected as the Save 

as type selection.
3. Click Save to save the FTL file.

Opening File Transfer List (FTL) Files
To open a FTL file:
1. Click the Load List command button (in either the Send or Receive tab) to open the Open dialog, with File Transfer List Files 

(*.ftl) pre-selected as the Files of type selection.
2. Locate and select the desired FTL file, and click Open to add the files defined in the FTL list to the Files to Send or Receive 

queue.

Workspace Files (*.APW)
Workspace Files (*.APW) are created in NetLinx Studio 2, and allow you to work with multiple projects/files simultaneously. While 
the FileTransfer 2 application supports reading NetLinx Studio Workspace Files, Workspace Files can only be created, edited (and 
optionally exported as (*.AXW) "To Go" files) using NetLinx Studio 2. 
Refer to the NetLinx Studio on-line help for details on creating, editing and saving Workspace Files and Workspace To Go files.
A Workspace File represents at least one Project (containing at least one System), however a Workspace can contain multiple 
Projects. Each Project in turn can contain multiple Systems. At any time, you can create a Workspace file (via the File > Save 
Workspace option in NetLinx Studio). Once created, you can re-open that Workspace file to recall the NetLinx Studio workspace, 
exactly as it was when the Workspace file was created.
All Workspace information is saved in an XML-formatted file with the .APW file extension.

NOTE: The File > Save Workspace command only saves the Workspace (APW) f ile itself, and does not save changes made to the 
System f iles contained in the Workspace. Use the File > Save All command to save the Workspace f ile and all of the System f iles it 
contains.

One advantage of the Workspace file is that it serves as a time-saver: Once you have saved a Workspace file in NetLinx Studio, 
(containing a particular set of Projects, Systems and System Files), the next time you open the application, you can simply open the 
single Workspace file (File > Open Workspace) to load the Projects/Systems it contains. This way you bypass the need to open each 
Project, System and System File individually.
All Projects and associated Systems and System files are linked to the Workspace, so that you can add and remove Projects and 
Systems without having to make copies of the files. NetLinx Studio also allows you to copy and paste Projects within the 
Workspace; in the case that you need to create several similar Projects you can quickly generate multiple Projects and modify each 
one as necessary.
Since all System files are linked to the Workspace, when you open a file for editing, you are opening and editing the actual file, not 
a local copy. It is important to understand that in the event that the file is linked to multiple Systems, any changes made to the file 
will be reflected in every instance that the file is used (not just the System that you were in when the changes were made). Even if 
you don't have multiple links to the same file, you should still be careful about altering the file. If you are linking to a file that other 
people might use, they will be affected by the changes you make to the file. So, if you intend to make changes to a System file, and 
you want those changes to be specific to only one System in the Workspace, you should make a copy of the original file (under a 
different name), make your changes, then remove the original file from the System and link the new file to the System.
Workspace files also allow you to build (compile) multiple Projects/Systems. The Build Workspace command (in NetLinx Studio) 
compiles every file contained in the Workspace.
It is important to note that in NetLinx Studio (v2.0 and later), there is no concept of Projects outside the context of a Workspace. A 
Project can only be opened by adding it to a Workspace. This is to support the file linking aspect of the program. 
Other features of the Workspace file include:

You can import other Project or Systems folders from previously saved Workspace files.
You can copy and paste existing Projects and Systems within a Workspace.
You can edit the identifier that is used to display the workspace name in the tree display along with the description for the 

Workspace file via the Workspace Properties dialog.
You can export all the files associated with the Workspace (including the Workspace file) into a .ZIP file.

Workspace-To-Go Files (*.AXW)
The Export Workspace Files To Go option (in NetLinx Studio 2's Project menu) allows you to export the currently open Workspace 
for distribution as a Workspace-To-Go (*.AXW) file. 
AXW files preserve all relative file path information for the Projects, Systems and System files contained in the Workspace, making 
them ideal for distribution to remote sites.
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As is indicated in the Export Workspace Files To Go dialog (in NetLinx Studio 2), there are three major points to understand when 
exporting your Workspace files:

All files will reside in the same directory as the APW file upon extraction of the AXW file.
No directory/path information is required for the "To Go" APW File Name.
You may enter non-existing folders - NetLinx Studio will create them for you.

NetLinx Master Security
NetLinx Studio supports secure communication with NetLinx Masters, via the Authentication Required option in the Communication 
Settings dialog.
Before you can enable/disable NetLinx security on a Master through NetLinx Studio, you must verify the following:

The target Master has been loaded with firmware that supports security. This means that the Master must have Master 
Firmware version 304 (or higher) to support this functionality. If your master does not have firmware loaded that supports 
security, the Master will not be secured (although it might appear to be in NetLinx Studio).

Security has been enabled on the target Master (via options in the Security tab of the Master's built-in interface). Refer to 
the Master's documentation for details on enabling/disabling security.

With security enabled, users will be required to provide the correct User Name and Password in order to establish communication 
with the Master. 
The User Name and Password are case-sensitive.
If the correct User Name and Password are not entered, NetLinx Studio will display an "Authentication Failure" message, and the 
connection to the Master will be denied.

NOTE: This security option is not available for Axcess masters, or for NetLinx Virtual Master connections.

Enabling Security on NetLinx Masters
Security for NetLinx Master is controlled via options in the NetLinx Studio application. 
Before you can enable/disable security on a NetLinx Master through NetLinx Studio, you must:
Have loaded firmware in the target Master that supports security. This means that the Master must have NetLinx Master Firmware 
version 304 or higher to support this functionality. If your master does not have firmware loaded that supports security, the Master 
will not be secured (although it might appear to be in NetLinx Studio).
Have security enabled on the target Master (via options in the Security tab of the Master's built-in interface). Refer to the NetLinx 
Master's documentation for details on enabling/disabling security.
You must first establish communication with the NetLinx Master in order to apply security (see Connecting to a NetLinx Master).
1. Once you are connected to the Master that you want to apply security to, select Settings > Master Communication Settings to 

access the Master Communication Settings dialog.

NOTE: You can apply a default User Name and Password to the No active System - Default Settings option, so that as you create 
new NetLinx systems they will always require that User Name/Password combination.

2. Verify that you have connected to the desired Master by checking the information in displayed in the Conf iguration window.
3. Click the Communication Settings command button to access the Communication Settings dialog.
4. Click to select the Authentication Required option. This enables the User Name and Password command button.
5. Click the User Name and Password button to access the Master Controller User Name and Password dialog.
6. Enter the User Name and Password that will be required to establish communication with this Master (as long as the 

Authentication Required option is selected).
The User Name and Password must each be between 4 and 20 characters long.

7. Click OK to save your changes and return to the Communication Settings dialog.
8. Click OK to save your changes and return to the Master Communication Settings dialog.
Now that security has been applied to the Master, note that the Master Security Status icon in the Status Bar changes to indicate 
that the Master is "locked".

Connecting to a Secured NetLinx Master
When connecting to a NetLinx Master that has security enabled, you will be required to enter a User Name and Password before you 
can connect.
To establish a connection to a secured master,
1. Select Communication Settings from the Edit menu (or the File Transfer context menu) to open the Communication Settings 

dialog and select NetLinx as the platform, and select a Transport Connection type.
2. Click Edit Settings to configure the selected transport type. 
3. Click OK to save the TCP/IP, Serial or Modem settings (depending on the transport type selected).
4. Click the Authentication Required checkbox. This enables the User Name and Password button.
5. Click on User Name and Password to enter the User Name and Password that are set for this NetLinx Master (in the Master 

Controller User Name and Password dialog). These are case sensitive.
6. Click OK to close the Master Controller User Name and Password dialog.
7. Click OK to close the Communication Settings dialog.
10FileTransfer2 - Instruction Manual



Using FileTransfer 2
At this point you should be able to connect to the secured Master.

If you don't connect:
Verify that the master is set for ICSP Connectivity, with Require Encryption enabled (via the Master's built-in interface). 
Refer to the Master's documentation for details on enabling/disabling security.

Applying Security To Individual File Transfers
In addition to the security for NetLinx Masters that can be enabled per system, NetLinx Studio (v 2.3 or higher) also allows you to 
apply security to individual file transfers via options in the Communication Settings dialog. 
With security enabled on a file transfer operation, users will be required to provide the correct User Name and Password in order to 
transfer the file to/from the Master.

NOTE: When you apply security to an individual f ile transfer operation (as described below), the individual f ile's security settings will 
be overridden by the security set for the target Master. For example, if the target Master already has security enabled (via the 
Authentication Required option in the Communication Settings for that Master), the user will have to provide the correct User Name 
and Password set for that Master, even if the File also requires a User Name and Password to successfully transfer to/from the Master.

Before you can enable/disable NetLinx security on a File Transfer operation, you must verify the following:
The target Master has been loaded with firmware that supports security. This means that the Master must have Master 

Firmware version 304 (or higher) to support this functionality. If your master does not have firmware loaded that supports 
security, the Master will not be secured (although it might appear to be in NetLinx Studio).

Security has been enabled on the target Master (via options in the Security tab of the Master's built-in interface). Refer to 
the Master's documentation for details on enabling/disabling security.

To Apply Security To an Individual File Transfer Operation:
1. In the File Transfer dialog, click to select a file transfer from the list of files in the File Transfer List.
2. Click the Edit button and select Communication Settings from the Edit menu to open the Communication Settings dialog. The 

settings you specify here are applied only to the selected File Transfer operation.
3. Click to select the Authentication Required option.
4. Click the User Name and Password button to open the Master Controller User Name and Password dialog, and enter the User 

Name and Password combination that the program will require in order to start this file transfer.
Once security is applied, if the correct User Name and Password are not entered when prompted, NetLinx Studio will display an 
"Authentication Failure" message in the Error column of the Transfer Status window, and the transfer will not complete.

NOTE: This security option is not available for Axcess masters, or for NetLinx Virtual Master connections.
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Communication Settings
Overview
Communication settings for each file is established and saved with the files when they are created in NetLinx Studio, but can be 
overwritten in FileTransfer 2, via options in the Communication Settings dialog (accessible via the Edit menu).

Files can be transferred to/from a NetLinx master via TCP/IP, Serial-RS232, Modem or Virtual NetLinx Master connection.
Files can be transferred to/from a Axcess master via Serial-RS232 or Modem connection.

Listening for NetLinx Masters
Click the Listen button in either the TCP/IP Settings dialog to listen for "blink" (UDP) messages from NetLinx Masters on the 
subnet, in the Listen For Masters dialog. 
As NetLinx Masters are detected on the subnet, they are displayed in the Listen For Master dialog, with the option of adding them to 
the List of Addresses in the TCP/IP Settings dialog:
1. Select a file in either the Send or Receive tab.
2. Select Communication Settings from either the File Transfer context menu or the Edit menu to open the Communication 

Settings dialog.
3. Select TCP/IP as the Transport Connection Option.
4. Click Edit Settings to open the TCP/IP Settings dialog.
5. Click Listen to open the Listen For Masters dialog.
6. Click Start Listening to begin "listening" for UDP messages from active NetLinx Masters on the subnet.
7. Click Stop Listening to stop listening for UDP packets.
All Masters that were detected on the subnet are listed by TCP.IP URL address in this dialog.

To Add NetLinx Masters to the List of Addresses in the TCP/IP Settings dialog
1. Select one or more (Ctrl + click to multi-select) of the Masters in the List of Active NetLinx Master Controllers (Listen For 

Masters dialog) that you want to add to the List of Address in the TCP/IP Settings dialog.
2. Click Select To Add to open the New TCP/IP Setting dialog, where you can add a description (optional) and specify whether to 

automatically ping the Master Controller to ensure availability.
3. Click OK to save the new TCP/IP settings, close the dialog and add the new connection to the List of Addresses. Note that if 

you selected multiple Masters (in the Listen for Masters dialog), the New TCP/IP Settings dialog opens for each file individually 
to allow you to configure (or verify) every Master connection.

Virtual NetLinx Master
FileTransfer 2 supports direct connection to G4 panels via TCP/IP and USB, for situations where the target panel is not connected 
to a NetLinx Master. In this situation, you can use your PC's Ethernet or USB connectors to connect directly to the panel, using your 
PC as a Virtual NetLinx Master. 

Virtual NetLinx Master connections support both TCP/IP and USB.
Virtual NetLinx Master connections can be used to transfer TPDesign4 panel (.TP4) file, NetLinx Firmware (.KIT) files, or IR 

Files directly to G4 touch panels.
USB direct transfers require that you configure the Master Connection setting on the panel itself to USB prior to attempting 

the transfer.
TCP/IP direct transfers require that you configure the Master Connection setting on the panel itself to TCP/IP prior to 

attempting the transfer.

Conf iguring Communications Settings
FileTransfer 2 allows you to specify and maintain separate communications settings for each file in the Files To Send and Files To 
Receive queues:
1. Select a file (Send or Receive tabs).
2. Click the Edit command button and select Communication Settings from the Edit menu to open the Communication Settings 

dialog.
Select a Platform for this transfer (Axcess or NetLinx).
Select a Transport Connection Option (TCP/IP, Serial, Modem or Virtual NetLinx Master).

NOTE: The TCP/IP and Virtual NetLinx Master options are only available if NetLinx is selected as the platform.

3. Click Edit Settings to specify the communication settings for the selected connection option (see list of topics below).
4. Click OK to close the Communication Settings dialog.
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Conf iguring TCP/IP Communication Settings (NetLinx only)
With a Transfer selected in the Transfer List:
1. Click the Edit command button, and select Communication Settings to open the Communication Settings dialog.
2. Select NetLinx Master as the Platform Selection.
3. Select TCP/IP as the Transport Connection Option.
4. Click Edit Settings to open the TCP/IP Settings dialog.
5. Enter the TCP/IP Address of the master:

a.  Click New to open the New TCP/IP Setting dialog.
b.  Enter the new TCP/IP Address and (optional) Description in the text fields provided.
c.  By default, the program is set to automatically ping the master controller to ensure availability. De-select this option if 

desired.

NOTE: The Port should always be set to 1319 (default setting). Do not change the Port assignment.

d.  Click OK to return to the Communication Settings dialog.
6. Click OK to save the new TCP/IP communication settings with the selected file.

Conf iguring Serial Communication Settings
With a Transfer selected in the Transfer List:
1. Click the Edit command button, and select Communication Settings to open the Communication Settings dialog.
2. Specify the Platform Selection (NetLinx Master or Axcess Master).
3. Select Serial as the Transport Connection Option.
4. Click Edit Settings to open the Serial Settings dialog.
5. Select a COM port and specify the communication settings for serial port communications. The default settings are:

Comm Port — COM1
Baud Rate — 38400
Data Bits — 8
Parity — None
Stop Bits — 1
Flow Control — None

6. Click OK to return to the Communication Settings dialog.
7. Click OK to save the new Serial communication settings with the selected file.

Conf iguring Modem Communication Settings
With a Transfer selected in the Transfer List:
1. Click the Edit command button, and select Communication Settings to open the Communication Settings dialog.
2. Specify the Platform Selection (NetLinx Master or Axcess Master).
3. Select Modem as the Transport Connection Option.
4. Click Edit Settings to open the Modem Settings dialog.
5. Select a COM port and specify the communication settings for modem communications. The default settings are:

Comm Port — COM1
Baud Rate — 38400
Data Bits — 8
Parity — None
Stop Bits — 1
Flow Control — None
Phone Number — Enter the telephone number of the master. 

6. Click OK to return to the Communication Settings dialog.
7. Click OK to save the new Modem communication settings with the selected file.

Conf iguring Virtual NetLinx Master Communication Settings (NetLinx only)
1. Click the Edit command button, and select Communication Settings to open the Communication Settings dialog.
2. Select NetLinx Master as the Platform Selection.
3. Select Virtual NetLinx Master as the Transport Connection Option.
4. Click Edit Settings to access the Virtual NetLinx Master Settings dialog, which displays the System number (and IP address) of 

the Virtual NetLinx Master (default = 1) .
Assuming that the actual NetLinx Master is set to 0 (via the System Properties dialog - System ID field), this default setting will 
work. However, if you have designated any other number as the System ID, be sure to set this System Number to a different 
number than the System ID, to avoid a conflict with the actual NetLinx Master (range = 1-65535).
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NOTE: As indicated in the Virtual NetLinx Master dialog, changes made to the system number f ield will not take effect until all 
communications are stopped and restarted.

5. Click OK to return to the Communication Settings dialog.
6. Click OK to save the new VNM communication settings with the selected file.

Conf iguring the Touch Panel for Virtual NetLinx Master USB Transfers
If it is not already powered up and connected, apply power to the G4 panel and verify that it is connected to the PC running NetLinx 
Studio via the USB connector on the rear (or side) of the panel.

Connecting the Panel to your PC via USB:
1. Apply power to the panel by plugging in the power supply.
2. Wait for the splash screen to disappear, then use a (Type A) USB cable to connect the panel to an available USB port on your 

PC. Plug the USB cable into the panel first, then connect to the PC.

Conf iguring the Panel For Virtual NetLinx Master Transfers Via USB
1. Press and hold the gray Front Setup Access button (below the touch screen) for 3 seconds to access the Setup page.
2. Press the Protected Setup button to access the Protected Setup page.
3. Use the on-screen keyboard to enter the password (the default password is 1988).
4. Press the System Connection button to access the System Connection Setup page.
5. Select USB as the Master Connection.
6. Press the Back button to return to the Protected Setup page and press the Reboot button to reboot the panel.

Conf iguring the Touch Panel for Virtual NetLinx Master TCP/IP Transfers
If it is not already powered up and connected, apply power to the G4 panel and verify that it is connected to the LAN via the TCP/IP 
connector on the rear (or side) of the panel.
1. Press and hold the gray Front Setup Access button (below the touch screen) for 3 seconds to access the Setup page.
2. Press the Protected Setup button to access the Protected Setup page.
3. Use the on-screen keyboard to enter the password (the default password is 1988).
4. Press the System Connection button to access the System Connection Setup page.
5. Select Ethernet as the Master Connection.
6. Set the System Number to 0 (zero).
7. Select the Master URL / IP input box and enter the IP address of your PC.

NOTE: To get your PC's IP address, select Start > Run and type cmd to open a DOS window. Then, enter ipconf ig to display the IP 
address of your PC. 

8. Press the Back button to return to the Protected Setup page and press the Reboot button to reboot the panel.

Changing Communication Settings for Multiple Files
FileTransfer2 v1.4 or higher supports changing communication settings for multiple selected files in the Send and Receive tabs.
1. Ctrl + click any number of files in the Files To Send (Send tab) or Files To Receive (Receive tab) queues to select multiple files.
2. Click the Edit button to access the Edit menu.
3. Select Communication Settings to invoke the Communication Settings dialog. Use the options in this dialog to specify 

communication settings. These settings will be applied to all selected files.
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Setting Device-File Mapping Information
Every time you select a file (to send or receive) via the Select Files For File Transfer dialog (Other tab), the program prompts you to 
enter (or verify) its device mapping information, in the Enter Device Mapping Information dialog.
Use this dialog to define the Device:Port:System (D:P:S) address assignment for a target device.

Editing Device Mapping Information
Device-file mapping information for each file (which associates a device address with each file) is established and saved with the 
files when they are created in NetLinx Studio, but can be overwritten in FileTransfer 2, via the Device Mapping options (accessible 
via the Edit menu):
1. Select a file in the Transfer List (Send or Receive tab).
2. Click Edit to open the Edit menu, and select Device Mapping. This opens the Enter DPS dialog.
3. Enter the Device:Port:System (D:P:S) information for the selected file.
4. Click OK to save the D:P:S assignment and close the dialog.

Device:Port:System (D:P:S)
A device is any hardware component that can be connected to the NetLinx bus. Each device must be assigned a unique number to 
locate that device on the bus. The Axcess language allows physical device numbers in the range 0-255. The NetLinx language 
allows numbers in the range 0-32767. Device 0 refers to the master; numbers above 32767 are reserved for internal use. 
NetLinx requires a Device:Port:System (D:P:S) specification where Axcess expected only a device number. This D:P:S triplet can be 
expressed as series of constants, variables separated by colons, or as a DEV structure, to explicitly represent a device number, port 
and system. 
Here’s the syntax:
DEVICE:PORT:SYSTEM

where:
Device: 16-bit integer representing the device number
Port: 16-bit integer representing the port number (in the range 1 through the number of ports on the device)
System: 16-bit integer representing the system number (0 = this system) that the device belongs to.
For example, 128:1:0 represents the first port on device 128 on this system.

DEV structure example:
STRUCTURE DEV
{
   INTEGER Number      // device number
   INTEGER Port        // port on device
   INTEGER System      // system device belongs to
}

NOTE: In Axcess, Master Source Code f iles are always mapped to the Master Controller (device = 0), and cannot be mapped to any 
other device. This does not apply to NetLinx Master Source Code f iles.
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File Transfer Operations
Overview
FileTransfer 2 supports asynchronous communications, which allows you send and receive to and from the bus on all available 
communications ports. You can send and receive both Axcess and NetLinx Source Code files to and from the appropriate Master 
Controller or bus device.

Axcess or NetLinx Source Code files (.AXS) can be sent to the Master Controller, or other control devices on the bus. Source 
code files must be successfully compiled before they can be sent.

Touch Panel UI files created in TPDesign3 (.TPD) are sent directly to wired Touch Panels on the bus via an AxLink/serial 
connection where the Device ID = 0.

Touch Panel UI files created in TPDesign4 (.TP4) are sent to the Master, either serially or over TCP/IP. G4 panels are 
connected to the Masters via TCP/IP and cannot be sent over AxLink. You can choose to include buttons and pages only, or 
include fonts, bitmaps and/or icons in the transfer.

KeyPad UI files (.KPD) are sent to a NetLinx Master.
IR library files (.IRL/.IRV) are sent to IR-controlled devices on the bus, or directly to a System device (i.e. Touch Panels).
The Virtual NetLinx Master option allows you to transfer files directly to G4 devices, without the need for an intermediate 

NetLinx Master.

File Transfer Status Information
Once you have started a file transfer operation, the status of each transfer item in the Files to Send or Receive queue is indicated in 
the Transfer Status Window.

Transfer Errors and Def initions
The following table describe the most common error messages that might be displayed in the Error column of the Transfer Status 
Window. 

Transfer Errors and Def initions
Error String Meaning

Failure generic/unclassified failure.

Success generic success.

File does not exist the file supplied on the cmdline doesn't exist.

Failed to create temporary file couldn't create a required temporary file.

Failed to connect with 
FileTransfer application

console app couldn't connect to running instance of FileTransfer 2 application.

Invalid phone number supplied console parameter is invalid.

Invalid flow control supplied console parameter is invalid.

Invalid stopbits supplied console parameter is invalid.

Invalid parity supplied console parameter is invalid.

Invalid databits supplied console parameter is invalid.

Invalid baudrate supplied console parameter is invalid.

Invalid communications port supplied console parameter is invalid.

Invalid VNM settings supplied console parameter is invalid.

Invalid TCP/IP settings supplied console parameter is invalid.

Invalid file type the file supplied on the cmdline is an unknown file type.

Unknown Error generic/unknown error.

Not enough arguments not enough console parameters supplied to do anything.

Unable to install handler! Ctrl+C, Break console handler couldn't be installed.

Invalid Option! Expected -
U=<user>:<password>

console security option is incorrect.

<option> is an invalid option! invalid/unknown option passed to console.

<option> is not a valid device 
mapping or option!

console expected a device mapping or an option but found something else.

File: <filename> does not exist 
and cannot be transferred!

file does not exist at location specified.
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Sending Files To System Devices
Once you have:

Added the desired file(s) to the File To Send Queue,
Configured the communication settings for the files in the list, and
Specified the device-file mapping information for the files in the list,

you are ready to begin transferring the file(s) to devices in the system:
1. Click the Send command button. This initiates the transfer of every file listed in the Transfer (Send) List, in the order in which 

they are listed (top to bottom).
2. The progress and status of each file transfer is indicated in the Transfer Status Window.

Receiving Files From System Devices
Once you have:

Added the desired file(s) to the File To Receive Queue,
Configured the communication settings for the files in the list, and
Specified the device-file mapping information for the files in the list,

you are ready to begin receiving the file(s) from devices in the system:
1. Click the Receive command button. This initiates the transfer of every file listed in the Files To Send List, in the order in which 

they are listed (top to bottom).
2. The progress and status of each file transfer is indicated in the Transfer Status Window.

Virtual NetLinx Master Transfers
File Transfer2 supports direct connection to G4 panels via TCP/IP and USB, for situations where the target panel is not connected 
to a NetLinx Master. In this situation, you can use your PC's Ethernet or USB connectors to connect directly to the panel, using your 
PC as a Virtual NetLinx Master. 

Virtual NetLinx Master supports both TCP/IP and USB connections.
Virtual NetLinx Master can be used to transfer TPDesign4 panel (.TP4) file, NetLinx Firmware (.KIT) files, or IR Files directly 

to G4 touch panels.
G4 touch panels that support USB connection include the MVP-8400i, MVP-8400, MVP-7500, NXD-700Vi and NXD/T-CV7.
USB direct transfers require that you configure the Master Connection setting on the panel itself to USB prior to attempting 

the transfer.
TCP/IP direct transfers require that you configure the Master Connection setting on the panel itself to TCP/IP prior to 

attempting the transfer.

AMX USB Driver Information for USB Enabled G4 Panels
The AMX USB driver (required to connect to USB-enabled G4 panels via USB) is included with the NetLinx Studio (as well as 
TPDesign4) installation programs. Once you have installed the latest version of either NetLinx Studio (v2.4 or higher) or TPD4 (v2.4 
or higher), you should have the required USB driver.
After having installed NetLinx Studio 2 (or TPDesign4), follow the steps below to ensure a valid USB connection to the G4 panels:
1. Power up the Panel without the USB cable connected to the panel.
2. Plug in the USB cable into the G4 panel.
3. You should see an USB icon show up in the System Tray.
4. Double click on the icon to bring up the list of USB devices (you should see the "AMX USB LAN LINK"" device in the list).
5. If the "Install Driver" dialog doesn't appear automatically, select the Properties button and then the Update Driver button.
6. When the Install Driver dialog does appear, click on the Next buttons, accepting all the default prompts.
7. The OS will complain about the fact that the driver you are installing/updating does not have a digital signature. This is 

acceptable, so select to continue the installation.
8. After installation is complete, you are ready to connect to the USB port of the G4 panel. 

Transfer Errors and Def initions (Cont.)
Error String Meaning

File: <filename> is currently opened
by another application and cannot
be transferred!

this can happen if another application has an exclusive lock on a file.

Nothing to transfer! 
[Project Identifier invalid?] 
[System Identifier invalid?]

After processing all supplied parameters and options, there was nothing to transfer. That is, no 
files could be found or nothing was specified for transfer. Additionally, if you specified a project 
identifier and/or a system identifier, you may have inadvertently requested an empty or 
nonexistent set of files.

Failed to open workspace! Failed to open workspace!

No APW file AXW file does not contain an APW.
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a.  Open the Communication Settings dialog (select a file in the Transfer List and select Edit > Communication Settings).
b.  Select Virtual NetLinx Master as the Transport Connection Option.
c.  Click OK to close this dialog.

Virtual NetLinx Master Transfers via USB or TCP/IP Connection
To use Virtual NetLinx Master to transfer TPDesign4 panel (.TP4) files, NetLinx Firmware (.KIT) files or IR files directly to a MVP-
8400i, MVP-8400, MVP-7500, NXD-700Vi and NXD/T-CV7 panel:
1. In the Send tab, click the Add button to open the Select Files for File Transfer dialog.
2. Click the Other tab, and select the type of file you want to transfer (only IRL/IRV, TP4 or IRN files can be transferred via USB 

connection).
3. Click the Add button. This invokes the Open dialog, where you can locate and select the file you want to transfer. 
4. Select the desired file and click OK to close this dialog and invoke the Enter Device Mapping Information dialog.
5. Review the mapping information, and click OK to return to the Select Files for File Transfer dialog.
6. Click OK to return to the Send tab, where the new file should appear in the Files to Send queue.
7. Click inside the checkbox to the left of the file you just added. 

Keep in mind that any files with a checkmark will be included in this transfer.
Note that the Connection column indicates that the file you just added is using Virtual NetLinx Master.

8. Click the Send button to begin the transfer.

NOTE: The procedure for Virtual NetLinx Master transfers via TCP/IP connection is identical.

Virtual NetLinx Master TCP/IP Transfers
FileTransfer 2 supports direct connection to G4 panels via TCP/IP (and USB), for situations where the target panel is not connected 
to a NetLinx Master. In this situation, you can use your PC's Ethernet connection to connect directly to the panel, using your PC as 
a Virtual NetLinx Master. There are three basic steps to Virtual NetLinx Master TCP/IP file transfers (see page 14):
1. Configuring the Touch Panel for Virtual NetLinx Master TCP/IP Transfers
2. Configuring FileTransfer 2 for Virtual NetLinx Master TCP/IP Transfers
3. Transferring Files Using a Virtual NetLinx Master TCP/IP Connection

Conf iguring FileTransfer 2 for Virtual NetLinx Master TCP/IP Transfers
1. Click Edit and select Communication Settings to open the Communication Settings dialog.
2. Select Virtual NetLinx Master as the Transport Connection Option.
3. Click the Edit Settings button to access the Virtual NetLinx Master Settings dialog, which displays the System number of the 

Virtual NetLinx Master (default = 1).
Assuming that the actual NetLinx Master is set to 0 (via the System Properties dialog - System ID field), this default setting will 
work. However, if you have designated any other number as the System ID, be sure to set this System Number to a different 
number than the System ID, to avoid a conflict with the actual NetLinx Master (range = 1-65535).

NOTE: As indicated in the Virtual NetLinx Master dialog, changes made to the system number f ield will not take effect until all 
communications are stopped and restarted.

4. Click OK to close the Virtual NetLinx Master Settings dialog.
5. Click OK to close the Communication Settings dialog.

Transferring Files Using a Virtual NetLinx Master TCP/IP Connection
NOTE: Verify that Virtual NetLinx Master is selected as the Transport Connection Option in the Communication Settings dialog.

To use Virtual NetLinx Master to transfer TPDesign4 panel (.TP4) files or IR files directly to a MVP-series, V-Series Modero, VG-
Series Modero, NXD-CV5, or NXD/T-CV7/10 panel via TCP/IP:
1. Click the Add button to open the Select Files for File Transfer dialog.
2. Click the Other tab, and select the type of file you want to transfer (only IRL/IRV, TP4 or IRN files can be transferred via a 

Virtual NetLinx Master connection).
3. Click the Add button. This invokes the Open dialog, where you can locate and select the file you want to transfer. 
4. Select the desired file and click OK to close this dialog and invoke the Enter Device Mapping Information dialog.
5. Review the mapping information, and click OK to return to the Select Files for File Transfer dialog.
6. Click OK to return to the Send tab, where the new file should appear in the Files to Send queue.
7. Click inside the checkbox to the left of the file you just added. Keep in mind that any files with a checkmark will be included in 

this transfer.
Note that the Connection column indicates that the file you just added is using Virtual NetLinx Master.

8. Click the Send button to begin the transfer.
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Virtual NetLinx Master USB Transfers
FileTransfer 2 supports direct connection to G4 panels via USB (and TCP/IP), for situations where the target panel is not connected 
to a NetLinx Master. In this situation, you can use your PC's USB connection to connect directly to the panel, using your PC as a 
Virtual NetLinx Master.
There are three basic steps to Virtual NetLinx Master USB file transfers:
1. Configuring the Touch Panel for Virtual NetLinx Master USB Transfers (see page 14)
2. Configuring FileTransfer 2 for Virtual NetLinx Master USB Transfers 
3. Transferring Files Using a Virtual NetLinx Master USB Connection

Conf iguring FileTransfer 2 for Virtual NetLinx Master USB Transfers
1. Click Edit and select Communication Settings to open the Communication Settings dialog.
2. Select Virtual NetLinx Master as the Transport Connection Option.
3. Click the Edit Settings button to access the Virtual NetLinx Master Settings dialog, which displays the System number of the 

Virtual NetLinx Master (default = 1).
Assuming that the actual NetLinx Master is set to 0 (via the System Properties dialog - System ID field), this default setting will 
work. However, if you have designated any other number as the System ID, be sure to set this System Number to a different 
number than the System ID, to avoid a conflict with the actual NetLinx Master (range = 1-65535).

NOTE: As indicated in the Virtual NetLinx Master Settings dialog, changes made to the system number f ield will not take effect 
until all communications are stopped and restarted.

4. Click OK to close the Virtual NetLinx Master Settings dialog.
5. Click OK to close the Communication Settings dialog.

Transferring Files Using a Virtual NetLinx Master USB Connection
NOTE: Verify that Virtual NetLinx Master is selected as the Transport Connection Option in the Communication Settings dialog.

To use Virtual NetLinx Master to transfer TPDesign4 panel (.TP4) files or IR files directly to an MVP-7500, MVP-8400,V-Series 
Modero, VG-Series Modero, NXD-CV5, or NXD/T-CV7/10 panel via USB:
1. Click the Add button to open the Select Files for File Transfer dialog.
2. Click the Other tab, and select the type of file you want to transfer (only IRL/IRV, TP4 or IRN files can be transferred via a 

Virtual NetLinx Master connection).
3. Click the Add button. This invokes the Open dialog, where you can locate and select the file you want to transfer. 
4. Select the desired file and click OK to close this dialog and invoke the Enter Device Mapping Information dialog.
5. Review the mapping information, and click OK to return to the Select Files for File Transfer dialog.
6. Click OK to return to the Send tab, where the new file should appear in the Files to Send queue.
7. Click inside the checkbox to the left of the file you just added. Keep in mind that any files with a checkmark will be included in 

this transfer.
Note that the Connection column indicates that the file you just added is using Virtual NetLinx Master.

8. Click the Send button to begin the transfer.

Using the FTCon Console Program
The FTCon.exe ("FTCon") program is provided with FileTransfer 2 so that transfers may be made from a normal windows console 
(DOS box). Command line arguments supplied to FTCon.exe are passed along to the FileTransfer 2 program which then runs from 
the system tray.

NOTE: FTCon is intended for use only by advanced programmers. 

FTCon Command-line Arguments:
APW File Transfer Arguments - see page 20
AXW File Transfer Arguments - see page 20
FTL File Transfer Arguments - see page 20
Single File Transfer Arguments - see page 20

How to read the command line argument descriptions:
"text" Quoted text indicates a double quoted argument.

[ ] Brackets indicate the item is optional.

-option, --option Options start with a dash or double-dash (GNU style).
• The emboldened letter is the acceptable abbreviated form.
• Case is not relevant.
• Options are always optional so they are not bracketed (see above).
• If the option takes an argument, then the keyword is immediately followed by an equals sign (`=') and 

the argument's value.
• A pipe ( | )between two or more options indicates a boolean OR relationship.
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APW File Transfer Arguments
The following arguments specify how to launch the FTCon program with an APW file:
"FileName" ["Project Id"] [“System Id”]

"FileName" - Fully qualified file name of the APW within quotes.
"Project Id" – If not supplied, all files in the workspace are transferred. Otherwise, this must be the identifier of a project. 

The first matching project is transferred.
"System Id" - If not supplied, all systems in the project are transferred. Otherwise, this must be the identifier of a system. 

The first matching system is transferred.
Examples:
ftcon.exe "test.apw"    Send the entire workspace contained in test.apw.
ftcon.exe "test.apw" "proj1"    Sends the project named "proj1" contained in test.apw.
ftcon.exe "test.apw" “proj1” "sys1"   Sends the system named "sys1" within “proj1” 

AXW File Transfer Arguments
The following arguments specify how to launch the FTCon program with an AXW file:
"FileName" ["Project Id"] [“System Id”]

"Project Id" – If not supplied, all files in the workspace are transferred. Otherwise, this must be the identifier of a project. 
The first matching project is transferred.

"System Id" - If not supplied, all systems in the project are transferred. Otherwise, this must be the identifier of a system. 
The first matching system is transferred.

FTL File Transfer Arguments
The following arguments specify how to launch the FTCon program with an FTL file:
"FileName" –Send | -Receive

"FileName" - Fully qualified file name of the FTL within quotes.
-Send |-Receive Indicates whether to load the specified FTL into the send or receive queue. Send is assumed by default.

Single File Transfer Arguments
The following arguments specify how to launch the FTCon program with a single file. All arguments must be present on the 
command line, except where noted, for the specified file or the file will not transfer. The order of the arguments is important and 
will need to follow the order listed below.
"FileName" CommSettings [DeviceMapping] –Send|Receive -Boot 
               -Axcess -Optimize -Direct –Tpd=BIF –User="username:password"

"FileName" - Fully qualified file name of the file to transfer within quotes.
CommSettings - Specifies the communication protocol and settings used for transferring the file. 

For a TCP/IP transfer, the command would be:
ip/url:[port]:[ping-before-connect]

The IP/URL address can be either the IP address or an URL and the port specifies the port on the master. 
An example for a TCP/IP transfer would be:
192.168.221.3:1319:1   

-or-
amx.boardroom.net:1319:0 

The port is optional and defaults to 1319. Ping-before-connect is optional and the default is 1(enabled).
For serial transfer, the command would be:
commport,baud,[databits],[parity],[stopbits],[flow] 

commport = specifies the comm. port for transfer (i.e. COM2).
baud = specifies baud rate (i.e. 9600 or 57600).
databits = specifies the number of data bits. This should be set to 8.
parity = specifies the parity. This should be set to N for no. Other values are O for odd, E for even, M for mark and S for 

space.
stopbits = specifies stop bit value. This should be set to 1.
flow = specifies flow control. This should be set to N for none. Other values are D for DTR-DSR, X for XON-XOFF, and R 

for RTS-CTS.
An example of a serial transfer over COM3 port would be:
COM3,57600,8,N,1,N

For VNM/USB transfers, the command would be:
VNM=systemNumber

where V specifies the VNM and the systemNumber is the system number of the master that the device is connected to. 
An example for a VNM transfer would be:
VNM=1

For modem transfers, the command would be:
COM3,57600,8,N,1,N,555-123-4567
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File Transfer Operations
DeviceMapping - For NetLinx masters, the device mapping will be in the D:P:S form:
128:1:3455

For Axcess masters, the device mapping argument will contain a single device value:
128

NOTE: For NetLinx masters, the default DPS is 0:1:0. For Axcess masters there is no default and a device number (even zero) 
must be specif ied. This is because a single device number is used to differentiate an Axcess transfer from a NetLinx transfer.

Send - This flag indicates that the specified file is to be sent to the device.
Receive - This flag indicates that the specified file is to be received from the device.
Axcess - This flag indicates that the specified transfer is an Axcess transfer
Boot - This flag indicates that the master should be rebooted after all transfers on the connection are finished.
User - For NetLinx masters that have security enabled, the argument will need to contain the username and password 

separated by a colon:
–User="fieldtech:mypassword"

Optimize - For TP4 transfers, this enables Smart Transfer. Smart Transfer automatically optimizes the download by 
identifying the various components (fonts, bitmaps, sound files, even pages and popup pages) of the panel file you have 
specified for download, and comparing them to the elements already present on the target panel. Any shared 
components are not downloaded, resulting in a much faster transfer (assuming that there are shared components).

Direct - Indicates a "Direct To Device" connection. Any device mapping is ignored, and this method is only valid for 
single-file transfers.

Tpd - For TPD transfers, this indicates whether to send bitmaps, icons, and fonts.
To not send bitmaps, icons, or fonts, do not specify the equal "=" sign.
-t=B|I|F

B = Send bitmaps within the TPD file.
I = Send icons within the TPD file.
F = Send fonts within the TPD file.

You many use any combination. For example:
-t do not send bitmaps, fonts, or icons.
-t=B send bitmaps only.
-t=BI send bitmaps and icons only.
-t=BF send bitmaps and fonts only.
-t=BIF send bitmaps, icons, and fonts.
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