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RPMLoader - Quick Start
RPMLoader - Quick Start
Overview
RPMLoader is a companion program to the RPM (Rapid Project Maker) web application that transfers RPM-generated files to the 
Master Controller and System Devices.

NOTE: Rapid Project Maker (NSS-RPM) is a cloud-based conf iguration tool that allows entry level AV technicians or IT professionals 
with limited technical prof iciency to easily conf igure an AMX system by using a step-by-step wizard-based approach. See RPM on 
www.amx.com for details and additional product documentation.

When you click on the Generate button in RPM (on the Summary page), RPM generates an RPMLoader project f ile (*.rpmx). 

An RPMLoader project file (*.rpmx) is a package of the files required to support the RPM-generated system, including the Master 
file (*.TKN), Touch Panel files (*.TP4), and any other system files required to support a RPM-generated project. 
RPMLoader extracts the files and transfers them to their target system devices, based on information that was defined in RPM. 
Since RPMLoader Project Files already contain connection information for the Master Controller as well as device mapping 
information for the other files in the project, it is simple to use RPMLoader to transfer the files to the appropriate devices.

Three Simple Steps
For RPM-Generated projects, there are just three simple steps to transferring RPMLoader project files:
1. Open an RPMLoader project file (*.rpmx).
2. Select the START FILE TRANSFERS button to transfer the files to the Master Controller (FIG. 2): 

3. Wait for the Master to reboot after all the files have been transferred.

NOTE: RPMLoader generates several Reports based on the project. See Reports  on page 31 for details.

RPMLoader provides many powerful tools for communications and file transfers - see the Tasks window and related help topics for 
more information. Some of main options within the program are described in further detail in the sections below:

Connecting to a Master Controller - page 11
Zero-Configuration Networking - page 20
Device Mapping - page 22
Device Binding - page 24
Adding and Removing Files From the File Transfer List - page 29

If you have any problems, visit the Troubleshooting section on page 42 for additional assistance. Also, RPMLoader provides an 
option to Package Files for Tech Support - this option allows you to create a ZIP file containing several key files in the current 
RPMLoader project, and e-mail the ZIP file to AMX Technical Support. See Package Files for Tech Support  on page 43 for details.

Opening an RPMLoader Project File
There are several ways to open an RPMLoader project file (*.rpmx) in RPMLoader:

Via the Download Project Command in RPM
1. In the RPM Web Application, click the Download Project button (FIG. 3): 

FIG. 1  RPM Web Application (Summary Page) - Generate command button

FIG. 2  RPMLoader - START FILE TRANSFERS button

FIG. 3  RPM Web Application (Summary Page ) - Download Project command button
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RPMLoader - Quick Start
2. When the application prompts you to open or save the file, click Open (FIG. 4): 

3. The RPMLoader project file opens in RPMLoader.

Via Windows Explorer
Double-click on an RPMLoader project file (*.rpmx) in Windows Explorer to open the file in RPMLoader. 
By default, downloaded RPMLoader Project Files are saved to the following directory:

"C:\DOCUME~1\<username>\LOCALS~1\Temp\"

Via RPMLoader (Start Tasks Window)
In the RPMLoader application Start Tasks window, select Open a RPM Project File (FIG. 5): 

Via RPMLoader (Open Command)
Select Open in the File menu or the Toolbar.

Once an RPMLoader project file has been opened in RPMLoader, the files indicated in the Project can be transferred to a 
target Master Controller.

After making changes to your RPMX file, select Save in the File menu to update all of your changes.

Connecting to a Master Controller
RPMLoader supports two types of connection to the Master Controller for file transfers: Network (TCP/IP) and Serial (RS-232). 
Communication Settings are configured in the Communication Settings dialog (FIG. 6): 

Refer to the following sections for detailed instructions:
See the Connecting to a Master Controller via Network Connection section on page 11
See the Connecting to a Master Controller via Serial Connection section on page 14

FIG. 4  File Download dialog

FIG. 5  RPMLoader Tasks window: Start > Open RPM Project File

FIG. 6  Communication Settings dialog
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RPMLoader - Quick Start
Transferring the Project Files
When you are connected to the Master Controller (indicated in the status bar), you can transfer the files contained in the 
RPMLoader Project to the Master. RPM-generated projects already include connection information for the target Master (as set in 
the RPM Web Application). Typically there is no need to re-configure the connection settings for the Project. In this case, the 
communication settings for the target Master are indicated in the Master Connection f ield (FIG. 7): 

Verify the File Transfer List and click Start File Transfers.
If the program detects that your project includes unbound devices when the Start File Transfer button is clicked, the 

Binding/File Transfer Options dialog is invoked. As indicated in this dialog, you might have unpredictable results with your 
System if you do not bind all of your Devices. Select an option and click OK: See the Device Binding section on page 24 for 
more information.

The status bars indicate each file's progress during the transfer operation. The status of the transfer operation is also 
displayed in the Output Status Bar, with details on files were transferred and any problems or errors that occurred during 
the transfer.

Refer to the Transferring the Project Files section on page 28 for more information.

Reports
RPMLoader provides several report functions, accessible via the Reports section of the Tasks window, or via the Reports menu. 
Refer to the Reports section on pages 31 for details.

FIG. 7  RPMLoader Project Window - Master Connection information
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RPMLoader Project Files (*.rpmx)
RPMLoader Project Files (*.rpmx)
Overview
RPMLoader Project Files (*.rpmx) are created by the RPM web application, and consist of a listing of the Master (*.TKN), Touch Panel 
files (*.TP4), as well as IR Library files (*.IRL) and any other files required to support a RPM-generated project. 
RPMLoader transfers the files contained in the RPMLoader Project to their designated AMX devices. RPMLoader Project Files also 
contain connection information for the Master Controller as well as device mapping information for device files.
In the Basic view (see page 44), the Project Name, Description and Master Connection information are indicated in the RPMLoader 
Project Window: 

In the Advanced view (see page 45), the Project Name, Description and Master Connection information are indicated in the 
RPMLoader Project Window. Additionally, the File Transfer List indicates all of the files that are included in the current project, and 
the Online Device Tree indicates the current device tree as reported by the connected AMX Controller (FIG. 9): 

FIG. 8  RPMLoader Project Information (Basic View)

FIG. 9  RPMLoader Project Information (Advanced View)
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RPMLoader Project Files (*.rpmx)
Opening an RPMLoader Project File
There are several ways to open an RPMLoader project file (*.rpmx) in RPMLoader (see page 6 for details):
1. In the RPM Web Application, click the Download Project button. When the application prompts you to open or save the file, 

click Open (see FIG. 3 on page 6). The RPMLoader project file opens in RPMLoader.
2. Double-click on an RPMLoader project file (*.rpmx) in Windows Explorer to open the file in RPMLoader.
3. In the RPMLoader application Start Tasks window, select Open a RPM Project File (see page 7 for details).
4. Select Open in the RPM Loader File menu or Toolbar.
Once an RPMLoader project file has been opened in RPMLoader, the files indicated in the Project can be transferred to a target 
Master Controller.
After making changes to your RPMX file, select Save in the File menu to update all of your changes.

Saving an RPMLoader Project File
To save changes made to an RPMLoader project file (*.rpmx):

Select File > Save (or click the toolbar button) to save changes to the file, using the same filename and location.
Select File > Save As to save changes to the file, using a different filename and/or location.
10RPMLoader Instruction Manual
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Connecting to a Master Controller
Overview
RPMLoader supports two types of connection to the Master Controller for file transfers: Network (TCP/IP) and Serial (RS-232). 
Communication Settings are configured in the Communication Settings dialog (FIG. 10): 

Connecting to a Master Controller via Network Connection
RPM-generated projects typically already have the NetLinx Master’s IP information, based on the IP address entered in the RPM UI 
(Project Details page - FIG. 11): 

However, RPM does not require that an IP address is entered in order to generate a project. Therefore, it is possible to open a RPMX 
project that does not have an IP address defined. Additionally, you may need to change the IP address that was entered in RPM. Use 
the Communication Settings dialog in RPMLoader to enter or edit the AMX Controller’s IP information:
1. Select Communication Settings in the Start Tasks window to open the Communication Settings dialog. Alternatively, this 

dialog can be opened via the Options Menu and the Toolbar.
2. Under Connection To Master, select Network Connection (FIG. 12): 

If the desired target NetLinx Master is listed in the List of Masters window, select it and click the Select button to populate the 
Network Connection f ields with it's IP Address and Description,
If the target Master is online, but is not indicated in the List of Masters window, click on Listen For Masters to search the 

network for online NetLinx Masters in the Listen For Masters dialog. See Listening for Masters on the Subnet (below) for 
details.

To enter TCP/IP information for a Master that is not indicated in the List of Masters window, click New to open the IP/URL 
Properties dialog. Use this dialog to manually specify a new TCP/IP connection. Enter a valid TCP/IP address, and fill in the 
Description. Enter a valid Username and Password if the target Master is secured. See Adding a new Network Connection  on 
page 13 for details.

NOTE: Do not change the Port number - it should remain set to 1319.

If the target Master is indicated in the List of Masters window, it's TCP/IP settings can be edited via the IP/URL Properties 
dialog (click the Edit command button to open). See Editing a Network Connection  on page 13 for details.

FIG. 10  Communication Settings dialog

FIG. 11  RPM User Interface - AMX Controller’s IP information (on the Project Details page)

FIG. 12  Communication Settings dialog - Network Connection option
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Connecting to a Master Controller
3. Once the Network Connection f ields indicate the correct IP information and Master Description, click OK to save the current 
configuration and close the Communication Settings dialog.
If the connection is successful, the Online Tree will be populated with the Master's Device Tree, and the Master Description 

name is displayed in the Header bar of the Online Tree Bar.
If the connection fails, the Connection Failed dialog is invoked, providing the options to either Retry or Cancel the 

connection attempt.

Listening for Masters on the Subnet
If the target Master Controller is online, but is not indicated in the List of Masters window in the Communication Settings dialog, 
search the network for online Masters via the Listen For Masters dialog.
1. Select Communication Settings in the Start Tasks window to open the Communication Settings dialog (see FIG. 10 on 

page 11). Alternatively, this dialog can be opened via the Communication Settings icon in the Project Window, or the Options 
Menu, or the Toolbar.

2. Click Listen For Masters to open the Listen For Masters dialog.
3. Click Start Listening to begin listening for "blink" (UDP) messages from Masters on the subnet.

Click Stop Listening at any time to stop listening for blink messages.
As Masters are detected on the subnet, they are displayed in the List of Active NetLinx Master Controllers.

4. Select one or more Masters from the List of Active NetLinx Master Controllers, and click Select To Add (FIG. 13): 

5. The New TCP/IP Setting dialog is presented, to provide an opportunity to enter User Names and Passwords for each (only 
necessary if the target Master is secured):

NOTE: If you have selected multiple Masters, then multiple New TCP/IP Setting dialogs will be presented serially, in the order that 
the Masters were selected. Fill in the f ields as necessary and click OK to save changes and proceed to the next New TCP/IP 
Setting dialog. This process will continue until each new Master has been added to the Communication Settings dialog (List of 
Masters).

6. Fill in the fields in this dialog and click OK to close the dialog and add the new Master to the List of Masters in the 
Communication Settings dialog (FIG. 15): 

FIG. 13  Listen For Masters dialog

FIG. 14  New TCP/IP Setting dialog
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Connecting to a Master Controller
NOTE: Do not change the Port number - it should remain set to 1319.

Adding a new Network Connection
1. Select Communication Settings in the Start Tasks window to open the Communication Settings dialog. Alternatively, this 

dialog can be opened via the Options Menu and the Toolbar.
2. Under Connection To Master, select Network Connection.
3. Click New to open the New TCP/IP Setting dialog (see FIG. 14 on page 12). 
4. Enter a valid IP/URL Address.
5. Enter a descriptive name for the Master Controller in the Description f ield.

NOTE: Do not change the Port number - it should remain set to 1319.

6. Enter a valid Username and Password if the target Master is secured. 
7. Click OK to save changes and close the New TCP/IP Setting dialog.
The new network connection is indicated in the List of Masters window in the Communication Settings dialog.

Editing a Network Connection
1. Select Communication Settings in the Start Tasks window to open the Communication Settings dialog. Alternatively, this 

dialog can be opened via the Options Menu and the Toolbar.
2. Select Network Connection.
3. Select the network connection to edit, in the List of Masters window.
4. Click the Edit command button to open the Edit TCP/IP Setting dialog (FIG. 16): 

5. Edit the fields in this dialog as necessary.
6. Click OK to save changes.

NOTE: RPMLoader v2.4 or higher supports IP Address List Files. IP Address List Files provide the option of managing a list of IP 
Addresses as a separate f ile (CSV or TXT) that can be imported into RPMLoader, to quickly add target devices for f ile transfer 
operations. The Import IP Address List File and Export IP Addresses options are provided in the Communication Settings dialog. See 
the IP Address List Files section on page 36 for details.

FIG. 15  Communication Settings dialog (indicating a new NetLinx Master)

FIG. 16  Edit TCP/IP Setting dialog 
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Connecting to a Master Controller
Connecting to a Master Controller via Serial Connection
To establish a Serial Connection with the target Master Controller:
1. Select Communication Settings in the Start Tasks window to open the Communication Settings dialog. Alternatively, this 

dialog can be opened via the Options Menu and the Toolbar.
2. Under Connection To Master, select Serial Connection (FIG. 17): 

3. Click and hold the COM<X> command button (FIG. 18) to select the port (COM 1 or COM 3) to use for Serial communication 
(default = COM 1): 

4. Click and hold the Baud command button (FIG. 19) to select the baud rate (9600, 38400, 57600 or 115200) for Serial 
communication (default = 38400): 

5. Click on the DIP Switch Settings command button (FIG. 20) to open the DIP Switch Settings dialog. 

Use this dialog to view the DIP switch settings required on the NetLinx Master for each Baud Rate (FIG. 21): 

These settings are for the "CONFIGURATION" DIP Switch on the Master Controller. Verify that the "CONFIGURATION" DIP 
Switch on the Master matches the appropriate diagram in this dialog.

6. Enter a valid Username and Password if the target Master is secured (FIG. 22): 

FIG. 17  Communication Settings dialog - Serial Connection option

FIG. 18  Serial Connection option - COM <X> button

FIG. 19  Serial Connection option - Baud button

FIG. 20  Serial Connection option - DIP Switch Settings button

FIG. 21  DIP Switch Settings dialog
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Connecting to a Master Controller
7. Click OK to close the Communication Settings dialog.
If the connection is successful, the Online Tree will be populated with the Master's Device Tree, and the Master Description 

name is displayed in the Header bar of the Online Tree Bar.
If the connection fails, the Connection Failed dialog is invoked, providing the options to either Retry or Cancel the 

connection attempt.

Viewing Online Devices
The Online Tree Bar (FIG. 23) displays a list of devices detected to be currently online by the Master Controller to which RPMLoader 
is currently connected, providing the device number, port count and firmware version for each. 
Click View The Online Tree in the Start Tasks window, the View Menu or the Toolbar to hide/show the Online Tree Bar.

NOTE: Initially, the only entry in the Online Tree is <Empty Device Tree>. Since the connection information for the target NetLinx 
Master is included in the RPMX Project f ile, you can simply click Refresh System Online Tree to connect to the Master and populate the 
online tree. If the connection fails, select Options > Communications Settings (or click the toolbar button) to conf igure the 
communication settings and establish a connection with the target Master via the Communication Settings dialog. See Connecting to 
a Master Controller  on page 11 for details. 

Right-click inside the Online Tree Bar context menu and select Refresh System Online Tree, or Refresh Network Online Tree to 
populate the online device tree.

Select Reports > View Online Tree Report to open the a summary listing of all devices in the online tree, in TXT format. This 
option is also available via the Online Tree Bar context menu.

The online devices are organized according to the System to which they belong.
Double-click any System folder to display a list of System devices (and their firmware version) that are currently online.
Double-click any online device in the list to display the ports and sub-devices associated with the device. Sub-devices are 

hardware components contained within a parent device, which may require their own firmware. For example, and NXI 
Master Controller contains three components, each of which require firmware.

The Unbound NDP Devices folder in the Online Tree Bar indicates all devices in the system that are not currently bound to a 
Master. See Device Binding  on page 24 for details.

NOTE: The Online Tree Bar is only a snap shot and is not updated in real time as devices come on/off line. Select Refresh System 
Online Tree or Refresh Network Online Tree from the Online Tree Bar context menu to update the Online Tree.

FIG. 22  Serial Connection option - Username and Password

FIG. 23  Online Tree Bar 
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Connecting to a Master Controller
Other Master Controller Tasks
Opening the Master Controller's Conf iguration Page
Master Controllers feature an on-board Web Console which allows you to connect to the Controller via a web browser and make 
various configuration and security settings. 
Select Launch Conf iguration Page from the Master Controller Tasks window, or select Launch Master Conf iguration Page from the 
Options Menu to open the connected Master's Configuration Page (in it’s own browser window). An example is shown below 
(FIG. 24): 

NOTE: The Web Console is described in the NI & DVX Central Controllers WebConsole & Programming Guide.

FIG. 24  Example Master Configuration Page
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Connecting to a Master Controller
Opening the RPM Conf iguration Manager
Once a RPM project has been loaded on an AMX Controller, the RPM Conf iguration Manager WebConsole is available via the Launch 
RPM Conf iguration Manager option in the Options menu and Tasks Bar. Use the RPM Conf iguration Manager to view information on 
the project currently on the Master.
Select Launch RPM Conf iguration Manager from the Master Controller Tasks window, or select Launch RPM Conf iguration 
Manager from the Options Menu to open the connected Master's RPM Configuration Manager WebConsole (in it’s own browser 
window).
The Home page (initial view) provides basic (read-only) summary information on the current project (FIG. 25). 

The Settings and Environment menus provide options to configure some basic settings on various devices in the system. The 
options presented in these menus will depend n the devices in the system.
For example, select Settings > Displays to access a Display configuration page similar to the one shown in FIG. 26: 

In this example, the Warm Up Time and Cool Down Time values can be edited as desired. Click Accept to save changes.

FIG. 25  Example RPM Configuration Manager (Home page)

FIG. 26  Example RPM Configuration Manager (sample Display configuration page))
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Connecting to a Master Controller
Opening a Telnet Window
Select Launch Telnet Window from the Master Controller Tasks window, or select Launch Master Telnet Window from the Options 
Menu to open a Telnet session with the connected Master. 

The default Telnet program is TELNET.EXE and can be changed by the user via the Preferences dialog.
In your terminal program, type "Help" or a question mark ("?") and <Enter> to access the Help Menu, and display a list of 

the supported commands.

NOTE: Telnet Commands are described in the NI & DVX Central Controllers WebConsole & Programming Guide.

An example Telnet window is shown below (FIG. 27): 

Rebooting the Master Controller
1. Select Reboot Master from the Master Controller Tasks window, or select Reboot Master from the Online Tree Bar Context 

Menu to reboot the connected Master Controller.
2. RPMLoader will prompt you to verify this action (FIG. 28): 

3. Click Yes to proceed. The application will alert you that the Master has been rebooted, and reminds you to give it a little time to 
get back online (click OK to close this dialog - FIG. 29): 

NOTE: To re-establish communication with the Master after a reboot, select Refresh System Online Tree or Refresh Network Online 
Tree from the Online Tree Bar Context Menu.

FIG. 27  Example Telnet window

FIG. 28  Reboot Master Controller - Verify

FIG. 29  Master has been rebooted
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Connecting to a Master Controller
Checking and Setting the Master Controller's Date and Time
Use the options in the Set Date and Time dialog to view and set the date/time information on the connected Master Controller:
1. Select Check Master's Date/Time in the Master Controller Tasks window to open the Set Date and Time dialog (FIG. 30). Note 

that this command is also available via the Options Menu. 

The read-only Master’s Current Date/Time f ield indicates the current date/time information for the Master. 
2. To change the Date setting, click the Edit icon in the Set Date/Time f ield to open a calendar and select the desired date 

(FIG. 31): 

3. To adjust the Time setting, select the Hour, Minute or Second display in the Time f ield and click the up and down arrow buttons 
as desired (FIG. 32): 

NOTE: Click Get Current Time to refresh the Time f ield with the current time.

4. Click Done to save changes and close this dialog.

FIG. 30  Set Date and Time dialog

FIG. 31  Set Date and Time dialog - Calendar

FIG. 32  Set Date and Time dialog - Time Settings
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Connecting to a Master Controller
Changing the Master Controller's Network Address Information
Use the options in the Master Controller's Network Address dialog to change the network settings for the connected Master:
1. Select Change Master's Network Address in the Master Controller Tasks window to open the Master Controller's Network 

Address dialog (FIG. 33). Note that this command is also available via the Options Menu. The IP and DNS information in this 
dialog represents the current network address information for the Master. 

2. Edit the IP Address f ields as necessary.
3. Click Set IP Information to set the new IP address information on the connected Master. 

NOTE: The program will prompt you that the Master Controller will be rebooted when this button is pressed (click OK to 
proceed).

4. Edit the DNS Address fields as necessary.
5. Click Set DNS Information to set the new IP address information on the connected Master.

NOTE: It is not necessary to reboot the Master if only the DNS Address information is changed.

6. Click Done to close this dialog.

Zero-Conf iguration Networking
Zero-Configuration networking provides the ability to automatically discover devices that are present on the LAN. The Zero 
Configuration Bar provides Zero-Configuration networking functionality within RPMLoader. 
Click View > Zero Conf iguration Bar to open this view, listing all Masters on the LAN to which the PC running RPMLoader is 
connected (FIG. 34): 

To populate the network device list, right-click anywhere within this tab, and click Refresh Zero Conf ig List in the Zero-
Configuration Window Context Menu.
Double-click on any entry in the Network Device List to open it's Web Configuration page.

NOTE: By default, Web Conf iguration pages are opened in your default browser. To open Web Conf iguration pages within RPMLoader, 
right-click anywhere within this tab to open the Context Menu, and de-select Launch Via Default Browser.

Generating a List of Network Devices
Right-click inside the Zero Configuration Bar, and select Refresh Zero Conf ig List to generate an initial listing of all Zero-Config 
devices detected.

FIG. 33  Master Controller's Network Address dialog

FIG. 34  Zero Configuration Bar 
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Conf iguring Devices via Zero-Conf ig Networking
Once you have generated a listing of devices of Zero-Config devices on the network, you can access any device in the list simply by 
double-clicking on it's entry - the selected device's Web Console (HTML) is displayed in your default browser.

Use the Web Console pages to configure the device as desired.
Refer to the device's Operation/Reference Guide for detailed configuration instructions and descriptions of settings.

Valid Subnet Masks
The following table lists valid Subnet Masks and the maximum number of IP Hosts allowed for each: 

Subnet Masks Max IP Hosts Subnet Masks Max IP Hosts

255.255.255.255 1 255.255.0.0 65536
255.255.255.254 2 255.254.0.0 131072
255.255.255.252 4 255.252.0.0 262144
255.255.255.248 8 255.248.0.0 524288
255.255.255.240 16 255.240.0.0 1048576
255.255.255.224 32 255.224.0.0 2097152
255.255.255.192 64 255.192.0.0 4194304
255.255.255.128 128 255.128.0.0 8388608
255.255.255.0 256 255.0.0.0 16777216
255.255.254.0 512
255.255.252.0 1024
255.255.248.0 2048
255.255.240.0 4096
255.255.224.0 8192
255.255.192.0 16384
255.255.128.0 32768
21RPMLoader Instruction Manual



Device Mapping
Device Mapping
Overview
In order to transfer the system files to the correct devices, each file must have correct device mapping information. NetLinx 
requires a Device:Port:System (D:P:S) specification for each file. If you are working with an RPMLoader Project Files (*.rpmx) that 
was generated by the RPM web application, then the device mapping is already established for each file that is indicated in the 
RPMX file, and is displayed in the Mapping column of the File Transfer List Bar.
However, If you have added/imported files to the transfer list, or if you have created a new RPMLoader Project, then it will be 
necessary to define device mapping information for each file indicated in the File Transfer List Bar. To define device mapping for 
files indicated in an RPMLoader Project:
1. Right-click on a file in the File Transfer List Bar (FIG. 35): 

2. Select Device Mapping from the File Transfer List Bar Context Menu to open the Device Mapping dialog (FIG. 36): 

3. Use the fields in this dialog to specify the target device for the selected file:
Device Number: 16-bit integer representing the device number (0 = NetLinx Master; numbers above 32767 are reserved 

for internal use).
Port Number: 16-bit integer representing the port number (range = 1 through the number of ports on the device).
System Number: 16-bit integer representing the system number that the device belongs to (0 = this system).

4. Click OK to save the mapping information and close the Device Mapping dialog.

FIG. 35  File Transfer List Bar

FIG. 36  Device Mapping dialog
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Device:Port:System (D:P:S)
A Device is any hardware component that can be connected to the NetLinx bus. Each Device must be assigned a unique number to 
locate that Device on the bus. The NetLinx language allows numbers in the range 0-32767.
Device 0 refers to the master; numbers above 32767 are reserved for internal use.
NetLinx requires a Device:Port:System (D:P:S) specification. This D:P:S triplet can be expressed as series of constants, variables 
separated by colons, or as a DEV structure, to explicitly represent a device number, port and system. Here's the syntax:
DEVICE:PORT:SYSTEM

where:
Device: 16-bit integer representing the device number
Port: 16-bit integer representing the port number (in the range 1 through the number of ports on the device)
System: 16-bit integer representing the system number (0 = this system) that the device belongs to.

For example, 128:1:0 represents the first port on device 128 on this system.
DEV structure example:
STRUCTURE DEV
{
   INTEGER Number    // device number
   INTEGER Port      // port on device
   INTEGER System    // system device belongs to
}
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Device Binding
Overview
A Bound device is one which has established communication with a specific Master. The devices listed beneath the top System 
folder in the Online Device Tree are Bound to the Master.
An Unbound device is an NDP-capable device which has not yet been assigned (bound) to communicate with a specific Master. 
These are "orphan" devices, until they are assigned to communicate to a specific Master.
The Unbound NDP Devices folder in the Online Tree Bar indicates all devices in the system that are not currently bound to a Master 
(FIG. 37): 

Unbound devices can be associated (bound) to a Master for communications either via the AMX Device Binding Wizard dialog 
(based on the Manifest file), or manually via the Bind/Unbind Devices dialog.

Using the AMX Device Binding Wizard
DXLink/ICSLan Device Binding is the process of pairing the assorted DXLink and/or ICSLan devices that were selected during your 
RPM project configuration. The options in the AMX Device Binding Wizard dialog allow you to bind DXLink/ICSLan devices (FIG. 38): 

To open this dialog, select AMX Device Binding Wizard from the Start Tasks window, or select AMX Device Binding Wizard from the 
Options menu.

NOTE: This option is only available if there are DXLink/ICSLan devices associated with your RPM project.

IMPORTANT: You must bind your DXLink/ICSLan devices BEFORE you transfer your conf iguration f iles to the devices.
The AMX Device Binding Wizard provides two main windows: AMX Devices To Bind and Network Device Listing.

FIG. 37  Online Tree Bar - Unbound NDP Devices folder

FIG. 38  AMX Device Binding Wizard dialog
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1. In the AMX Devices To Bind window, click on an Unbound device. Note that devices that are eligible to be bound are pre-
selected for binding.

2. In the Binding Device column, click on the <Click to Select a Device> entry to activate the Device Selection drop-down menu 
for the selected device (FIG. 39): 

3. Click the down arrow to access the drop-down listing of Network Devices that are compatible and available to bind with the 
selected device. Select the device to which the selected AMX device will be bound (FIG. 40): 

4. The selected device is indicated in the Binding Device column (FIG. 41): 

5. Repeat this process for all Unbound devices in the AMX Devices To Bind window. Note that the Status column still indicates 
Unbound for these devices, since the Binding Process has not yet been started.
Bind all devices in the AMX Devices To Bind window. You might have unpredictable results with your System if you do not 

bind all of your Devices. The program will prompt you bind any Unbound devices before transferring project files.
To unbind a Bound Device, right-click on a device and select Unbind Device.

6. When all devices have been paired for binding, click the Start Binding Process button to begin binding the devices according 
to the Binding Device selections (FIG. 42):   

7. As the Binding Process is performed, the message in the Status column changes from "Unbound" to "Attempting To Bind 
Device", then to "Device Has Been Bound", then to "Setting Description", then "Changing Device ID", and finally to "Rebooting 
Device". Also, the Binding icon indicates that the process is active (FIG. 43): 

8. When the Binding Process is complete, the Binding Wizard Log file (RPMBindingLog.TXT) is opened. providing a summary of the 
binding process (FIG. 44): 

FIG. 39  AMX Device Binding Wizard dialog - Device Selection drop-down menu

FIG. 40  AMX Device Binding Wizard dialog - Selecting a Device

FIG. 41  AMX Device Binding Wizard dialog - Device Selected

FIG. 42  AMX Device Binding Wizard dialog - Start Binding Process

FIG. 43  AMX Device Binding Wizard dialog - Status Column 
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9. Close the Binding Wizard Log file and click Done to close this dialog.
Once you have bound all the devices to your Master controller, the devices will have the appropriate "Device ID" assigned to them 
along with their description and location information. You can view this information in the Online Tree Report.

Manually Binding/Unbinding Devices
The Unbound NDP Devices folder in the Online Tree Bar indicates all devices in the system that are not currently bound to a Master 
Controller (FIG. 45): 

To manually Bind or Unbind NDP Devices to the Master, use the Bind/Unbind Devices dialog (FIG. 46): 

1. Select an unbound device in the Online Tree Bar (Unbound NDP Devices folder).

FIG. 44  Example Binding Wizard Log file (RPMBindingLog.TXT)

FIG. 45  Online Tree Bar - Unbound NDP Devices folder

FIG. 46  Bind/Unbind Devices dialog
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2. Right-click to open the context menu and select Bind/Unbind Device to open the Bind/Unbind Devices dialog.
3. The selected device is indicated in the Device To Bind/Unbind f ield at the top of the dialog. To select a different device, click the 

down arrow to select from a listing of all unbound devices in the current system.
4. The NetLinx Master associated with the System is indicated in the Master Binding list. 

If there are multiple Master indicated here, place a checkmark next to the Master to which the selected device will be bound.
Note that a Device can only be bound to one Master.

5. Select the device(s) to be bound to this Master Controller. Devices that have a check will be bound, those without a check will 
be unbound devices.

6. Click OK to save the changes and close the Bind/Unbind Devices dialog.
7. Refresh the Online Tree to see the new device binding:

Right-click inside the Online Tree Bar to open the context menu and select Refresh System Online Tree to refresh the online 
tree at the System level.

Right-click inside the Online Tree Bar to open the context menu and select Refresh Network Online Tree to refresh the 
online tree at the Network level (including all Systems on the network)
If a device was selected to be unbound then it will have moved from the System folder into the Unbound NDP Devices 

folder;
If an unbound device was bound to the Master, then it will have moved out of the Unbound NDP Devices folder into the 

System folder.
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Transferring the Project Files
Overview
When you are connected to the Master Controller (indicated in the status bar), you can transfer the files contained in the 
RPMLoader Project to the Master. The status bar indicates the current connection status (FIG. 47): 

RPM-generated projects already include connection information for the target Master (as set in the RPM Web Application). Typically 
there is no need to re-configure the connection settings for the Project. In this case, the communication settings for the target 
Master are indicated in the Master Connection f ield (FIG. 48): 

1. Verify the File Transfer List and click Start File Transfers.
If the RPMLoader project does not have connection information, then the Start File Transfers button is disabled, and the 
Master Connection field indicates that no communication settings have been selected for this project (FIG. 49): 

In this case, it is necessary to configure communications settings to establish a connection with the target Master via the 
Communication Setting dialog. See the Connecting to a Master Controller section on page 11 for details.Once communications 
have been configured, the Start File Transfers button is enabled. 

2. At this point, verify the File Transfer List and click Start File Transfers.
The status bars indicate each file's progress during the transfer operation (FIG. 50): 

FIG. 47  RPMLoader Status Bar - Connected / Not Connected

FIG. 48  RPMLoader Project Window - Master Connection information

FIG. 49  RPMLoader Project Window - Start File Transfers button disabled

FIG. 50  RPMLoader Project Window - Status Bars

Connected to Master Controller
Note Connected to Master Controller
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If the program detects that your project includes unbound devices when the Start File Transfer button is clicked, the Binding/
File Transfer Options dialog is invoked. As indicated in this dialog, you might have unpredictable results with your System if you 
do not bind all of your Devices. Select an option and click OK:
You can Start the Binding Wizard to Bind your Devices - click to open the AMX Device Binding Wizard. See the Device 

Binding section on pages 24 for information.
You can Skip the Binding Wizard and Start the File Transfer Process - click to begin the file transfer when you click OK. 

The status of each file in the transfer operation is displayed in the Output Status Bar, with details on files were transferred and any 
problems or errors that occurred during the transfer (FIG. 51). 

Once you start to transfer files, you can cancel the transfer operation via the STOP FILE TRANSFERS button (FIG. 52): 

Adding and Removing Files From the File Transfer List
The list of files contained in the RPMLoader Project are indicated in the File Transfer List Bar. 

Adding Files To the File Transfer List
1. Select Add/Import Local File To Transfer from the Options Menu or the File Transfer List Bar Context Menu to open the Add/

Import File To Transfer dialog (FIG. 53). Use the options in this dialog to either Add or Import a file to the transfer list. 

By default, the Import the File into the .RPMX File option is de-selected. In this case, the file will be added by reference to the 
File Transfer list (but not saved in the RPMLoader project file). Select this option to import the selected file into the current 
RPMLoader Project. In this case, the file will be added to the RPMLoader Project.

2. Click the Browse button in the File field to invoke the Open dialog. Note that the Open dialog includes a File Type drop-down 
menu (lower-left corner). By default, only TPDesign4 (*.TP4) files are listed, until a different file type is selected:
TPDesign4 Files (.TP4) - default selection
IR Library Files (*.IRL)
Master Files (*.TKN)
JAR Files (*.JAR)
Driver Design Files (.XDD)
All Files (*.*)

FIG. 51  Output Status Bar - Example File Transfer Status Information

FIG. 52  RPMLoader Project Window - STOP FILE TRANSFERS

FIG. 53  Add/Import File To Transfer dialog
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NOTE: Driver Design Files (.XDD) are created in the Driver Design plug-in for AMX Design Suite integrated development 
environment. See www.amx.com for details.

3. Select a file and click Open. This closes the Open dialog and returns to the Add/Import File To Transfer dialog.
4. The selected file name is indicated in the File f ield.
5. Enter a Description and Master Directory.
6. In the Device Address f ields (Device, Port and System), specify the (D:P:S) device-file mapping information required to 

associate this file with a target device.
7. Click OK to save changes and close the Add/Import File To Transfer dialog.
The selected file is now indicated in the File Transfer Status window, at the bottom of the file list (FIG. 54). 

By default, all newly added files are mapped to "0:1:0".
All newly added files are selected for inclusion in the file transfer (as indicated by the checkmark in the File column of the 

File Transfer List window). To exclude a file from the transfer operation, de-select this checkmark.

Removing Files From the File Transfer List
De-select (uncheck) any files that you do not want to include in the transfer. 
To remove a file from the list entirely, highlight the file and select Remove Item From List from the File Transfer List context menu.

Smart Transfer (TP4/TP5 f iles)
The Smart Transfer feature reduces the transfer time by only replacing those panel files that have been updated (relative to the files 
already loaded in the panel). Any bitmaps, sound files and fonts that all already resident on the target panel, or in your panel file on 
your PC (for uploads) are not included in the transfer.
By default, Smart Transfer is enabled in RPMLoader. This feature can be disabled via the Enable "Smart Transfer" for all TP4 Files 
and Enable "Smart Transfer" for all TP5 Files options in the Preferences dialog (FIG. 55): 

FIG. 54  File Transfer Status window - LOCAL and IMPORTED Files

FIG. 55  Preferences dialog - Enable "Smart Transfer" for all TP4 and TP5 Files options
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Reports
Overview
RPMLoader provides several report functions, accessible via the Reports section of the Tasks window, or via the Reports menu 
(FIG. 56): 

RPM Project (Conf iguration) Report
Select View RPM Project Report from the Reports Tasks window, or select Reports > View Project Report to open the RPM Project 
(Configuration) Report (FIG. 57). 

This report is in the form of an PDF document ("RPM_Report.pdf"), and opens in your default PDF viewer. It provides a full summary 
of the current RPM Project, organized to follow the flow presented by the RPM web interface:

Project Information
Controller Information
Device Count Listing
Device Configuration Information
<AMX Controller Type> Control Connections
Direct Connections to Display Devices
A/V Connections
Macro Touch Panel Summary
Macro Definitions
Enzo Device - Enzo
Sensor Diagrams
Touch Panel - Touch Panel (including Logo Image Uploaded)
Cable Diagrams
Equipment List

FIG. 56  Reports Tasks Window

FIG. 57  Example RPM Project Report (sample page one)
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Online Tree Report
Select View Online Tree Report from the Reports Tasks window, or select Reports > View Online Tree Report to open the Online 
Tree report (FIG. 58): 

This report provides a summary of the online device tree for this RPM Project, in the form of a TXT file:

Last File Transfer Log
Select View Last File Transfer Log from the Reports Tasks window, or select Reports > View Last File Transfer Log to open the File 
Transfer Log (FIG. 59): 

The File Transfer Log file ("RPMLoaderLog.txt) is a summary of all transfers that were included in the most recent file transfer 
operation, in the form of a text file.

FIG. 58  Example Online Tree Report

FIG. 59  Example Last File Transfer Log
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Firmware File Transfers
Master Controllers use Kit files for firmware upgrades. A Kit file (.KIT) is a package of several files, all of which are required to 
upgrade the firmware, and are available online via www.amx.com.

The Online Tree Bar displays information about each online device, including the current firmware version.
Before attempting to upgrade the firmware to a Master, you must have the appropriate Kit file for your Master.

Warning! If for any reason your Kit file transfer should fail, continue to retry the transfer until you are successful. DO NOT reboot 
the Master, or change connections until the transfer is complete. Failure to complete this operation successfully may result in a 
factory repair of the Master.
Use the Send To NetLinx Device dialog to update the firmware in Master Controllers or System devices (FIG. 60): 

1. Choose Options > Advanced > Firmware File Transfer to open the Send To NetLinx Device dialog.
2. Under Location, click the Browse button to locate and select the Firmware Directory that contains the desired KIT file, via the 

Browse For Folder dialog. 

3. The Files window lists all of the KIT files that are in the selected Firmware Directory with each file's last modified date/time and 
file size. Select the appropriate .KIT file from the list.

4. Under Target, set the Device and System number of the device that is the target for this firmware transfer. If the Kit file is 
determined to be specifically for the target Master, the Device number is forced to zero. If the Kit file is for an unspecified 
device, you must enter the correct Device ID number (FIG. 62): 

FIG. 60  Send To NetLinx Device dialog

FIG. 61  Send To NetLinx Device dialog - Location
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Use the Online Tree to determine the device's assigned ID.
Port is preset to 1 and cannot be edited.
If your PC has more than one NIC Card, use the NIC IP Address(es) for HTTP Transfer option to select which NIC card to 

use for this transfer.
HTTP Port: Specify which port to use for HTTP transfers. In most cases, the default setting of 80 should work.
Use Legacy ICSP Firmware Transfer: Check this option to use ICSP (rather than HTTP) for this transfer.

5. Review the File, Connection, Address, and Target Device information before you send.
6. Click Send to send the selected KIT file to the specified device. The progress of the transfer is indicated in the Kit File Transfer 

progress bars.
7. Allow 20-30 seconds for Masters to reboot. When the Master has rebooted, the Status LED on the front panel blinks once a 

second to indicate that it is functioning properly. Once it has rebooted, click OK.
8. When the transfer is finished, and the reboot is complete, press Close.

G5 Panel Firmware KIT File Transfers
RPMLoader (v2.0 or higher) will activate a stand-alone web server to transfer G5 Firmware KIT files via HTTP. 
For G5 Panels, the Send To NetLinx Device dialog will automatically transfer the KIT file using the stand-alone web server that is 
started by the program.
The Firmware KIT file for these G5 panels contains a token within the description to signify to the program that a web server f ile 
transfer can take place, as indicated in the description section of the dialog (FIG. 63): 

If an error occurs during this type of transfer, the HTTP Server Transfer Error dialog is presented. This dialog provides options for 
completing the download.

FIG. 62  Send To NetLinx Device dialog - Target fields

FIG. 63  Send To NetLinx Device dialog - indicating G5 (HTTP File Transfer Capable) KIT file
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Controlling a Device
To send strings and/or commands to a device connected to the Master Controller. Note that you must be connected to a Master to 
use this function.
1. Select Control a Device in the Options > Advanced sub-menu to open the Control a Device dialog (FIG. 64): 

2. Enter the target device's D:P:S values in the Device To Control fields.
3. Enter the desired Channel and Level information for the target device.
4. In the Message(s) To Send f ield, enter the string or command to send to the specified device.
5. Click Send To Device.
Note the results are indicated in the Output Status Bar. For example, the entry highlighted below shows that the string "message to 
send" was sent to the device with D:P:S values of [10001:3:0]: 

FIG. 64  Control a Device dialog

FIG. 65  Output Status Bar Indicating Message Sent
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IP Address List Files
IP Address List Files provide the option of managing a list of IP Addresses as a separate file (CSV or TXT) that can be imported into 
RPMLoader, to quickly add target devices for file transfer operations. The Import IP Address List File and Export IP Addresses 
options are provided in the Communication Settings dialog (FIG. 66): 

Importing an IP Address List File
1. In the Communication Setting dialog, click on Import IP Address List File. This selection opens the Import IP Address List File 

dialog (FIG. 67): 

2. Select an Import Option:
Remove ALL Network History prior to Import (default selection): Select this option to clear all entries from the IP address 

list (of the Communication Settings dialog) before adding the contents of the imported IP Address List File. With this option 
selected, only the IP Addresses in the imported file will be indicated.

Add to Network History: Select this option to add the addresses in the IP Address List File to the existing list of IP addresses 
(in the Communication Settings dialog).

3. Click the Browse button (see FIG. 67) to locate and select the desired .TXT or .CSV file (via the Open dialog). Alternatively, type 
the path and filename directly in the File Name to Import field.

NOTE: This f ile must contain one or more IP addresses formatted according to the rules described in the IP Address Import File 
Information section on page 37. These rules are also indicated in the Import IP Address List File dialog.

4. Click Import Fie Layout to open the IP Address Import File Layout Information dialog (FIG. 68): 

FIG. 66  Communication Settings dialog

FIG. 67  Import IP Address List File dialog

Browse button
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This dialog describes the layout required by RPMLoader to utilize IP Address Import Files (see IP Address Import File 
Information  on page 37).

5. Click Import File to import the selected .TXT or .CSV file.
6. Click OK to close the Import IP Address List File dialog and return to the Communication Settings dialog. The contents of the 

imported file are indicated in the List of Masters in the Communication Settings dialog.

IP Address Import File Information
Your IP Address data must be delimited by commas (",") or pipes ("|"). 
You can have either a "#" or ";" in column one of your text file to designate comment lines. They will be ignored during the import 
process.
The order of the data must be as follows:
IP Address,Description,Port,Ping Host Flag

If no Port is specified, then the default is 1319.
For the Ping Host Flag value, please specify either 1 for TRUE or 0 for FALSE. If no Ping Host Flag is specified, then the 

default is TRUE.
Example File 1:
;----------------------------------
;  North Campus Meeting Rooms
;----------------------------------
10.24.94.24,First Floor-Ben Hogan Room,1319,1
10.24.94.37,Second Floor-Arnold Palmer Room,1319,1
10.24.94.44,Third Floor-Board Room,1319,1

Example File 2:
#----------------------------------
#  South Campus Meeting Rooms
#----------------------------------
10.24.94.24|First Floor-Ben Hogan Room|1319|1
10.24.94.37|Second Floor-Arnold Palmer Room|1319
10.24.94.33|Third Floor-Board Room|1319|1

FIG. 68  IP Address Import File Layout dialog
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Exporting an IP Address List File
1. In the Communication Settings dialog, click on Export IP Address List File. This selection opens the Export IP Address List File 

dialog (FIG. 69): 

2. In the File Name to Export field, enter a name for the exported file.
3. Optionally, enter any comments that might prove helpful in the Comments to Add to the File f ield.
4. Select either Comma or Pipe "|" as the delimiter to use in the exported file (default = Comma).
5. Click the Browse button to specify the target directory for the exported file, in the Save As dialog.
6. Also in the Save As dialog, select either TXT or CSV as the desired file type for the exported file (default = CSV File).
7. Click Save to close the Save As dialog and return to the Export IP Address List File dialog. Note that the file path, file name and 

file type for the exported file are indicated in the File Name to Export f ield.
8. Click Export File to export the List of IP Addresses File according to the options selected. Click Done to close the Export IP 

Address List File dialog without exporting the file.
9. Click OK to close this dialog.
Once the file has been exported, it is available to be imported via the Import IP Address List File option in the Communication Setting 
dialog.

Setting Program Preferences
Select Options > Preferences to open the Preferences dialog (FIG. 70). Use the options in this dialog to set various program-level 
preferences for RPMLoader: 

The options in the Preferences dialog include:

FIG. 69  Export IP Address List File dialog

FIG. 70  Preferences dialog

Browse button
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Online and Zero Conf iguration Trees
These options set the fonts and colors used in both the Online Tree Bar and the Zero-Configuration Bar:

Font: Click the Browse button (...) next to the Font window to select a Font, Font Style and Size to use (via the Font dialog).
Foreground Color: Click the arrow button to select the color for the Foreground (text) color.
Background Color: Click the arrow button to select the color for the Background color.
Collapse the Bound, Unbound, Searching and Lost Device branches of the Online Tree upon Refresh: This option is 

enabled by default, to prevent the constant display of potentially large numbers of NDP devices, as may be the case on 
some networks.

Output Status Bar
These options set the fonts and colors used in the Output Status Bar:

Font: Click the Browse button (...) next to the Font window to select a Font, Font Style and Size to use (via the Font dialog).
Foreground Color: Click the arrow button to select the color for the Foreground (text) color.
Background Color: Click the arrow button to select the color for the Background color.

TELNET Program to Launch
Use this option to specify a Telnet program to launch for use with Serial File Transfers in RPMLoader (default = telnet.exe). To select 
a different program, click the Browse button to invoke the Open dialog. Locate and select the desired .EXE and click Close to close 
the dialog and save your changes.

File Transfer Options
These options control whether to use Smart Transfer for TP4 (TPDesign4) and TP5 (TPDesign5) files. Smart Transfer reduces the 
transfer time by only replacing those panel files that have been updated (relative to the files already loaded in the panel). Any 
bitmaps, sound files and fonts that all already resident on the target panel are not included in the transfer.

Click Enable Smart Transfers for all TP4 Files to enable or disable the Smart Transfer feature for TPD4 files (default = 
enabled).

Click Enable Smart Transfers for all TP5 Files to enable or disable the Smart Transfer feature for TPD5 files (default = 
enabled)

PC Network Adapter for Scanning HiQnet Devices
Use this option to select which NIC to use when scanning for HiQnet devices (only if your PC has multiple NICs).
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Using the BSS Conf iguration Wizard
Overview
When you build a project with a BSS BLU-102 or BLU-103 device, the BSS Conf iguration Wizard option is displayed in the 
RPMLoader Tasks Bar, under Start (FIG. 71): 

Click this option to open the BSS Conf iguration Wizard dialog. Use the options in this dialog to configure BSS BLU-102/103 
device(s) in the RPM project:
1. Select BSS Conf iguration Wizard to open the BSS Device Conf iguration Wizard dialog (FIG. 72): 

2. In the BSS Devices Available section, select a BLU-102/103 device to configure. Note that the selected device is indicated in 
the BSS Device To Conf igure f ield.
If you plug in your BSS device after this dialog is opened, select Rescan Network to search for new devices that have come 

online. To view or edit the PC Network Adapter that is used to scan HiQnet devices, see the Preferences dialog (see 
page 38).

If multiple PC Network Adapters (NICs) are detected on your PC, use the NIC IP Addresses to Select option to select which 
NIC to use when scanning for HiQnet devices (FIG. 73). If your PC only uses one NIC, then this option is not displayed. 

3. Click Start Conf iguration Process. This initiates a series of file transfers to the BLU-102/103 device, resets the device's Node 
ID, and configures the device to work with RPM.
This process should take 5-10 seconds to complete. Progress is indicated in the Conf iguration Status window.
The BSS Conf iguration Report will automatically be displayed afterwards. This report provides a summary of the 

configuration settings on the BLU-102/103 device.

FIG. 71  RPMLoader Tasks Bar - BSS Configuration Wizard

FIG. 72  BSS Configuration Wizard dialog

FIG. 73  BSS Configuration Wizard dialog - NIC IP Addresses to Select option

Click to open the BSS Conf iguration Wizard dialog
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Using the BSS Configuration Wizard
4. After you exit the wizard, the Online Tree will refresh automatically to indicate the BLU-102/103 device that was configured, 
under the heading HiQNet Devices (FIG. 74): 

NOTE: It may be necessary to refresh the Online Tree again to see the BLU-10x device show up after it has rebooted.

Rescan the Network
Click to scan the network for BLU-102/103 devices. If a BSS device is plugged in after the BSS Device Configuration Wizard dialog 
is opened, click Rescan Network to search for any devices that may have come online.

Show Last Conf iguration Log
Click to display the most recent Configuration Log (.txt) file (FIG. 75): 

FIG. 74  RPMLoader Online Tree indicating a BLU-102 (HiQNet device)

FIG. 75  Sample Configuration Log file

BLU-102
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Troubleshooting
Troubleshooting
Overview
This section outlines common troubleshooting tasks that can be performed in case you have trouble using RPMLoader.

Cannot Communicate with the Master Controller
RPMLoader Project Files that are generated by the RPM Web Application file come with the communications setting already defined. 
However, if you need to select a different network address for your control system, use the options in the Communication Settings 
dialog. Refer to the Connecting to a Master Controller section on page 11.

Error During a File Transfer - Invalid Device Mapping
A file may not transfer to a device if the device mapping is invalid. Device mapping information (D:P:S) consists of a Device number, 
a Port number and a System number (see Device:Port:System (D:P:S)  on page 23). To change the D:P:S:
1. Select the device within the File Transfer List Bar (see FIG. 54 on page 30).
2. Right-click to open the context menu, and select Device Mapping. This opens the Enter DPS dialog (FIG. 36 on page 22).
3. Enter the correct D:P:S and click OK.
4. After changing the device mapping, deselect all the files that did transfer successfully and make sure the problem file is 

selected on the File Transfer List.
5. Start the file transfer process again to send the file to the device.
If you are not sure of the correct device number, select View the Online Tree in the Start Tasks window. The Online Tree Bar will list 
the devices that are online with the Master Controller. From there, you can see which device number is correct for the device in 
question. Refer to the Device Mapping section on page 22.

Error During a File Transfer - Device is Offline
If a device is "offline" with a Master Controller and a file will not transfer:
1. Select the View the Online Tree option in the Start Tasks window. 
2. The Online Tree Bar will appear on the right and you will see all the devices that are online with the Master Controller.

Need to Change a Conf iguration Parameter on a Master
If there is a need to further investigate the configuration of a Master Controller, select the Launch Conf iguration Page option in 
the Master Controller Tasks window. This will open the Web Configuration page of the connected NetLinx Master within your default 
browser. See Opening the Master Controller's Conf iguration Page  on page 16.
You may also launch a Telnet window for the Master Controller: select the Launch Telnet Window option in the Master Controller 
Tasks window. This will launch a telnet session with the Master Controller. See Opening a Telnet Window  on page 18 for details.

Need to Change a Conf iguration Parameter on a Device
When the Online Device Tree is displayed, you can launch a user-defined Telnet window using the IP address of the selected device. 
Right-click on the device in the Online Device Tree to open the context menu, and select Launch Telnet Window. See Opening a 
Telnet Window  on page 18 for details.

Need Detailed Information on a Device
Within the Online Tree Bar, right-click to open the context menu, and select Device Properties. This will display a "balloon window" 
that provides detailed properties for the selected device (FIG. 76): 

You can also generate a full report of all the devices (see Online Tree Report section on page 32).

FIG. 76  Example Device Detailed Properties Display
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Package Files for Tech Support
In the case that the RPMLoader project fails to work, select Package Files for Tech Support from the Help Tasks window to access 
the Package Files for Tech Support dialog. Note that this command is also available via the Help Menu (FIG. 77): 

Use the options in this dialog to create a ZIP file containing several key files in the current RPMLoader project, and 
e-mail the ZIP file to AMX Technical Support. The resulting ZIP file will contain the following:

Online Tree Report
RPM Project Report
Last File Transfer Log

Packaging Options: These options are enabled only if this Project includes at least one local file in the File Transfer list:
Include Local files that were ADDED to the Project.
Include Local files that were IMPORTED into the Project.
See Adding Files To the File Transfer List  on page 29 for details.

When the OK button is pressed a ZIP file is generated, and an e-mail document is automatically generated, with descriptive text 
loaded into the body of the e-mail. Attach the ZIP file to the e-mail, and send to AMX Technical Support.

FIG. 77  Package Files for Tech Support dialog
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RPMLoader - Program Reference
RPMLoader - Program Reference
Supported OS/Languages and PC Requirements
Supported Operating Systems (OS)'

Windows 8.1 (32/64 bit)
Windows 10 (32/64 bit)

NOTE: You must have Power User (or Administrator) rights to install and run all required System f iles.

Supported Languages
English
German
Spanish
French
Russian

PC Requirements/Recommendations
1.00 GHz Processor (minimum requirement); 1.5GHz or faster recommended.
100 MB Free Disk Space
1 GB RAM

NOTE: RPMLoader requires that the computer on which it is installed have internet connectivity for the purpose of application 
updates, and local network connectivity for the purpose of transferring system f iles to the control systems.

RPMLoader - Basic View (Default Setting)
The RPMLoader UI features two tabs: Basic and Advanced. By default, RPMLoader opens to the Basic view, shown in FIG. 78: 

The Basic view provides access to all of the basic functionality of the RPMLoader application. If you are simply transferring a RPM 
Project to a target AMX Controller, you should only need to work in the Basic view.

FIG. 78  RPMLoader (Basic View)
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RPMLoader - Program Reference
RPMLoader - Advanced View
FIG. 79 represents the RPMLoader Advanced View, which shows the File Transfer List and Online Tree bars (in addition to the Project 
Window, which is available via the Basic view). Use the Basic View and Advanced View tabs in the Project Window to switch views. 
Additionally, use the options in the View menu to show the Output Status and Zero-Configuration bars if desired. 

FIG. 79  RPMLoader (Advanced View)
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