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1. INTRODUCTION TO CPi2000 GUI 

Homepage of CPi2000 GUI

The CPi2000 Cinema Processor comes with a tailor-designed graphic user interface (or GUI) software, and can be controlled 
remotely through either Ethernet. 

The GUI software includes all the functions you may need for setting up and tuning your cinema sound system in an intuitive 
platform, and requires minimum operation training. 

The GUI is comprised of five function pages, namely Overview, Basic Setting, Input Setting, Output Setting and Log Page, where 
functions necessary to set up and monitor a cinema sound system are available. 

Through the GUI software, you can select built-in JBL speaker presets or edit speakers settings, synchronize the time with the 
Internet, reset the device to factory default settings, modify IP settings, and export to or import from a USB device the device 
setting files. 

2. GET CONNECTED TO GUI

2.1 System Requirement

To run the GUI software, you will need a computer running with Windows 7, Windows 10 or Windows XP. 

2.2 Run the GUI 

The GUI software requires no installation. To obtain and run the GUI software:

1.	 Download the latest GUI software from www.jblpro.com. 
1)	 Search for "CPi2000" on the website homepage.
2)	 Download the GUI application file (named as cpi2000_version number) from the product page.

2.	 After downloading, double click to run cpi2000_x.x.x.x. You will be directed to the home page, i.e. the 
Overview page. 

3.	 Select the desired language (Chinese or English) on the upper right corner of the GUI. 

2.3 Connect CPi2000

To control your CPi2000 through GUI, please connect your computer and CPi2000 to the same network. 

cpi2000_x.x.x.x

http://www.jblpro.com
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1.	 Connect your computer and CPi2000 to the same network (or Ethernet switch).

2.	 Configure your computer's IP address to DHCP. 

NOTE: CPi2000 default IP setting: DHCP.

3.	 Power on CPi2000 hardware device and wait till its LCD homescreen shows a solid IP address instead of “Getting IP...”.

4.	 Go to GUI, click "Offline" ( ), then the system will scan for available devices. 

5.	 Click to select the target device from the result list, then click "Connect".

6.	 When the device is connected, the "Offline" button turns to be "Connected" ( ). Now you can set up and control the 
selected device through the GUI software. 
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3. OPERATE GUI

3.1 Overview

After successful launch of the GUI software, you will be directed to the Overview page where you can make quick selection of 
the input source, mute/unmute output channels, obtain or edit general information of the device, and edit output speakers and 
amplifiers.

Input Source & 
Mute/Unmute

Speakers & 
Amplifiers

Apply

Cinema Hall 
Information

Device IP 
Address 

Information

Input Source & Mute Selection Buttons: Click the buttons to choose the input source or mute/unmute.  

•	 Analog Input ( )

•	 Mic Input (
CPi2000  

)

•	 Digital Input ( ) 

•	 Music/Non-Sycn Input ( )

•	 Mute/Unmute (
Rs LFE

)  

Cinema Hall Information: Input cinema hall information.

•	 Theater: Enter the name of the theater. 

•	 Hall: Enter the name of the cinema hall.

NOTE: The Hall name can only contain the capitals (A-Z), digital numbers (0-9), "-" and "_".  

Device IP Address Information: Show IP settings of the device. 

•	 DHCP: Shows the DHCP status (Enabled / Disabled) of the device.  
•	 IP Address: Shows the IP address of the device. 
•	 Subnet Mask: Shows the subnet mask of the device. 
•	 Default Gateway: Shows the gateway of the device. 
•	 Server: Enter the name of the server. 
•	 Projector: Enter the name of the film projector. 

•	 CPi2000 S/N: Shows the serial number of the device. 

Speakers & Amplifiers: Click the drop-down menu to select the speaker model and enter the amplifier name for each channel. 

Apply: Click to confirm and save current configuration. 
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3.2 Basic Setting

From the Basic Setting page, you can define the global output volume, mute/unmute output, set up the surround delay, activate 
amplifier and speaker fault detection, and select 5.1/7.1 audio setting for your sound system. 

Master Volume

•	 Master Volume Fader: Drag the fader or enter a specific value in the textfield (step: 0.1) underneath. The recommended master volume 
is 7.

•	 Sync to Preset: Tick to set the current volume as benchmark. The device will always resume the last benchmark master volume in its 
next reboot. 

•	 Mute: Click to mute ( ) or unmute ( ) the output. 

•	 Fade In / Fade Out: Use the textfields or the up/down arrows to define the fade-in and/or fade-out value for the mute button. Time range: 
0-10 sec. 

Surround Delay

•	 Feet / Meters: Choose a unit of measure. 
•	 Average distance from screen to rear wall of the theater: Enter a value between 0-100 meters (or 0-328.1 feet).
•	 Average distance between left and right surround speakers: Enter a value between 0-100 meters (or 0-328.1 feet).

•	 Apply ( ): After keying the distance values, click this button to calculate the Delay Time. 

Tip: After clicking the Apply (  ) button, Delay Time can be fine tuned using the up/down arrow (  ). 

Fault Detection

•	 Fault Detection Channels: Tick to choose the channels to be monitored.

NOTE: Fault Detection messages will be shown through the front panel LCD of the hardware device. 

NOTE: Only Crown XLC2500 and XLC2800 support Fault Detection. 

Main Audio Setting

•	 5.1 System / 7.1 System: Select the input source processing. The default value is 5.1 System. 

NOTE: When 5.1 System is selected, BLS and BRS will copy audio signals from LS and RS respectively.
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3.3 Input Setting

From the Input Setting page, you can configure settings for the selected input source: Digital, Analog, Mic or Music (Non-Sync). 

Digital Input Setting

Assign each individual input channel throug their drop-down menus

Channel 
assignment 
presets

•	 Input Gain: Drag the fader or enter a specific value in the textfield underneath.

•	 Mute: Click to mute ( ) or unmute ( ) the digital input.

•	 Channel Assignment: You can use the trapezoid to assign input channels or click one of the three presets (L/R C/Sw Ls/Rs, L/C R/Ls Rs/
Sw, L/Ls C/Rs R/Sw)on the right upper corner. 

•	 Global Audio Delay:  Click the "Enable" button to " ", then set the delay time in the textfiled or using the up/down arrows. Delay 
time range: 0-100 ms.

•	 Undo: Click to undo current configuration.

•	 Apply: Click to apply current configuration.
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Analog Input Setting

Channel 
assignment 
presets

Assign each individual input channel throug their drop-down menus

•	 Input Gain: Drag the fader or enter a specific value in the textfield underneath.

•	 Mute: Click to mute ( ) or unmute ( ) the analog input.

•	 Channel Assignment: You can use the trapezoid to assign input channels or click one of the three presets (L/R C/Sw Ls/Rs, L/C R/Ls Rs/
Sw, L/Ls C/Rs R/Sw)on the right upper corner. 

•	 Global Audio Delay:  Click the "Enable" button to " ", then set the delay time in the textfiled or using the up/down arrows. Delay 
time range: 0-100 ms.

•	 Undo: Click to undo current configuration.

•	 Apply: Click to apply current configuration.

Mic Input Setting

•	 Input Gain: Drag the fader or enter a specific value in the textfield underneath.

•	 Mute: Click to mute ( ) or unmute ( ) the microphone input.

•	 Channel Assignment: Click to choose assign the microphone input to either Center or Surround channels. 

•	 Phantom Power: Click to turn on ( ) or off ( ) the phantom power (+12V). 

•	 Global Audio Delay:  Click the "Enable" button to " ", then set the delay time in the textfiled or using the up/down arrows. Delay 
time range: 0-100 ms.

Music (Non-Sync) Input Setting

•	 Input Gain: Drag the fader or enter a specific value in the textfield underneath.
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•	 Mute: Click to mute ( ) or unmute ( ) the music (non-sync) input.

•	 Channel Assignment: Click to choose assign the music (non-sync) input to the desired channels. 

•	 Global Audio Delay:  Click the "Enable" button to " ", then set the delay time in the textfiled or using the up/down arrows. Delay 
time range: 0-100 ms.
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3.4 Output Setting

Output Setting is where you can align and tune the speakers and contains two tabs: Room Level and EQ Tuning. Room Level is 
where you can set up and balance the global output level among all channels. EQ Tuning is useful to make fine tuning and equali-
zation of each channel.   

Prior to tuning, please:  

1)	 Ensure all the speakers and devices in your audio system are firmly and correctly connected. 

2)	 Check for any distortion, overload, or reversed polarity. 

3)	 Aim the speakers to the auditorium and avoid any obstructions of the sound throw. 

Step 1: Place RTA Microphone & SPL Meter

1)	 Connect your RTA microphone to Mic Input connector at the rear panel of CPi2000. 

2)	 Position the microphone 2/3 of distance from the front to rear speakers and slightly off the centerline. 
1.
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3)	 Tilt the microphone 45°upward towards the screen. 
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4)	 Place the SPL meter close to the RTA microphone and point it towards the screen.
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5)	 According to your RTA microphone, choose to turn on ( ) or off ( ) the Phantom Power. 

For instance: if you are using a 
condenser RTA microphone, the 
Phantom Power needs to be "ON".

Step 2: Calibrate Internal SPL Meter

Prior to output channel alignment, internal SPL must be calibrated: 

1)	 Set amplifiers to reasonable gain levels (maximum at most of the time).

2)	 Select "Pink Noise" from Signal Mode drop-down menu. 

3)	 Click "Center" in the Output Channel Level. Then the Pink Noise signal will be sent to the Center channel speaker. 

4)	 Adjust the Center channel fader if necessary until the microphone level constantly reaches the "Target Mic Level". 

          

NOTE: The Mic Gain (at the rear panel of CPi2000) can be adjusted to help the RTA microphone reach the target level. 
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5)	 Measure the room level using the SPL meter. Enter the value to the "Measured Value" textfiled and press Enter.

                   

6)	 Wait for the system to calibrate the room level. When calibration is done, "(target 85 dBc)" appears under the Target Mic 
Level.

Step 3: EQ Tuning of Center Channel

After room level calibration, click the "EQ Tuning" tab to equalize the Center channel. 

"C" reference

Active Channel 
Level

Full / X-Curve

EQ Assist

Low Shelf Filter
High Shelf Filter

1)	 Select "Pink Noise" from the Signal Mode. 

2)	 Click "Full" 1/3 Octave Graphic EQ. 

3)	 Slightly move the "Active Channel Level" till the frequency bands roughly meets the "C" reference line. 

4)	 Switch to "X-Curve" for fine tuning of each frequency band. 

5)	 Use "EQ Assist", "Low Shelf Filter", "High Shelf Filter" and/or the 27-Band GEQ to tune a specific band if necessary. 

6)	 When equalization is done, the frequency curve should roughtly match the "C" reference line.

Step 4: EQ Tuning of Non-Sw Channels

1)	 Select the output channel in Room Level and set its global output level to "Target Mic Level".
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NOTE: The global output channel level should always reach the "Target Mic Level" or the green area. 

2)	 Repeat the Center Channel EQ tuning steps to equalize the selected channel till its frequency bands meet its "C" line.

Step 5: EQ Tuning of Subwoofer Channel

1)	 Select the Subwoofer channel in Room Level and set its global output level to "Target Mic Level".

2)	 Switch to EQ Tuning tab and use "Active Channel Level", "PEQ1&2" and "Full/X-Curve" to tune low frequency bands. 
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NOTE: The 27-Band GEQ is not operatable for Subwoofer EQ Tuning. 

3)	 When equalization is done, the low frequency curve should roughtly match the green reference line.

Step 6: Rotate Output Channels

When EQ tuning of all output channels is completed:

1)	 Click "Rotate" in the Room Level page to go through global output level of each channel. 

2)	 Adjust the channel fader to meet the target its dBc level if necessary.

NOTE: The measured value of L,R,C and Sw channels should register 85 dBc.  Ls, Rs, Bls, BRs should reach 82 dBc.  
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3.5 Log Page

The Log Page displays Operation Information, Warning, Error or Critical events occured to CPi2000. You may tick or untick the 
message types you would like to show through the Log Page. 

•	 Refresh Log: Click to refresh the log page.
•	 Save Log: Click to save the log file to a known place.
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4. FUNCTION TABS

4.1 File

The File tab is useful to load a device setting file to GUI and save current setting to an offline place, or exit the GUI software. 

                  

4.2 Tools

The Tools tab is where you can add/editor speakers, calibrate device time, upgrade firmware, restore to factory settings and 
configure IP settings. 

4.2.1 Speaker Editor 

Speaker Editor is where you can add new speakers and edit speaker settings.

A. Add New Speaker

1)	 Tick the "New Speaker" in the window below. 

2)	 Name the new speaker in the textfield of "Speaker name".

3)	 Select the correct "Speaker type". 

4)	 Choose the "Apply channel" for the new speaker.

5)	 Click the "New" button to equalize the speaker. 
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B. Modify/Delete Speaker EQ Setting

1)	 Select the desired speaker from the "Speaker List". 

2)	 Click the "Delete" button to remove the speaker from the Speaker List. Or

3)	 Click the "Modify" button to change the speaker EQ settings. 

C. Speaker EQ Settings 

Clicking the "New" or "Modify" button will navigate to the speaker EQ setting page to configure speaker parameters.

Choose signal options: 100 Hz, 1 kHz, 10 kHz, Pink Noise

Click to assign 
signal to desired 
channel. 

Set Gain, Delay 
and Polarity.

Set Output 
Limiter

Frequency Range 
(available only to 
two-/three-way 
speakers)

Double click to 
enable Crossover EQ 

(  to ) 

Choose the 
filter type.

Set parameters of 
Band Pass Filter 

Equalizer.

Double click to 
enable PEQ 
(  to ) 

Set PEQ 
parameters 

Click to apply 
current settings. 

Load setting files. Save setting files.

Use FIR under HPF and/or LPF must meet these requirements:
•	 The Speaker Type is "Full", "Two-way" or "Three-way";
•	 The Frequency of either HPF or LPF is no lower than 400 Hz. 
•	 The Tab sum of HPF and LPF is no more than 384.
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                         Speaker Type
Parameters Full-Range Two-Way Three-Way Surround Subwoofer

Signal Generator 100 Hz, 1 kHz, 10 kHz, Pink Noise

Assign to L, R Ls, Rs, Bls, Brs Sw

Frequency Range (N/A) LF, HF LF, MF, HF (N/A) (N/A)

Crosso-
ver EQ

Type HPF, LPF, FIR HPF, LPF

BPF EQ IIR, FIR (≥400 Hz) IIR

Slope
Bessel 6, Bessel 12, Bessel 18, Bessel 24, Bessel 30, Bessel 36, Bessel 42, Bessel 48, Butter-worth 6, Butter-worth 12, 
Butter-worth 18, Butter-worth 24, Butter-worth 30, Butter-worth 36, Butter-worth 42, Butter-worth 48, Linkwitz-Riley 
12, Linkwitz-Riley 24, Linkwitz-Riley 36, Linkwitz-Riley 48. 

Tab (FIR only) 50 - 384

Frequency 20 - 20 kHz

PEQ

Band 1 to 8

Type Bell, Low shelf, High shelf

Slope (Low-/High-
Shelf only) 3 - 15 dB/Oct

Gain -20 to 20 dB

Frequency 20 - 20 kHz

Q (Bell only) 0.1 - 16

General 
Setting

Gain -120 to 20 dB

Delay 0 - 20 ms

Polarity Positive (+), Negative (-)

Output 
Limiter

Auto ON, OFF

Threshold -60 - 0 dB

Attack 0.1 - 200 ms

Release 5 - 360 dB/s

Hold 0 - 500 ms

4.2.2 Calibrate Time

Click "Sync Time" will synchronize the time of CPi2000 and the PC Host. 

4.2.3 Upgrade Firmware

1)	 Download the latest firmware file from www.jblpro.com and save it to your PC. 

2)	 Click "Tools" > "Upgrade Firmware".

3)	 Follow the screen pop-ups and click "Yes" to start upgrading. 

http://www.jblpro.com
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4.2.4 Restore Factory Settings

1)	 Click "Tools" > "Restore Factory Settings". 

2)	 Click "Yes" to restore the device settings to factory settings. 

3)	 When upgrading is completed, the CPi2000 will start rebooting. Then reconnect the CPi2000 to its GUI. 

NOTE:  Restoring factory settings will erase all user data. We suggest you save all user settings before this operation. 
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4.2.5 Set IP Address

Configure IP address settings of CPi2000 through DHCP or manually. Default IP address setting: DHCP.

•	 DHCP: Enable (Default), Disable
•	 IP Address: Shows the IP address of the device or can be assigned manually when DHCP is disabled. 
•	 Subnet Mask: Shows the subnet mask of the device or can be assigned manually when DHCP is disabled.

•	 Gateway:Shows the gateway of the device or can be assigned manually when DHCP is disabled.

4.3 About

The About tab shows the following information of CPi2000:

•	 Application Version
•	 Device Firmware Version
•	 DSP Firmware Version
•	 A5 Firmware Version
•	 A5 Software Version
•	 Front Panel Firmware Version

•	 Build Time
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